]> git.pld-linux.org Git - packages/serd.git/blob - serd.spec
- updated to 0.32.2
[packages/serd.git] / serd.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs # API documentation
4
5 Summary:        Lightweight C library for RDF syntax
6 Summary(pl.UTF-8):      Lekka biblioteka C do składni RDF
7 Name:           serd
8 Version:        0.32.2
9 Release:        1
10 License:        ISC
11 Group:          Libraries
12 Source0:        http://download.drobilla.net/%{name}-%{version}.tar.xz
13 # Source0-md5:  3af4135454f7d07458584520dfd3f656
14 URL:            http://drobilla.net/software/serd/
15 BuildRequires:  meson >= 0.56.0
16 BuildRequires:  ninja >= 1.5
17 BuildRequires:  pkgconfig
18 BuildRequires:  rpmbuild(macros) >= 1.736
19 BuildRequires:  tar >= 1:1.22
20 BuildRequires:  xz
21 %if %{with apidocs}
22 BuildRequires:  doxygen
23 BuildRequires:  mandoc
24 BuildRequires:  sphinx-pdg >= 2
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Serd is a lightweight C library for RDF syntax which supports reading
30 and writing Turtle and NTriples.
31
32 Serd is not intended to be a swiss-army knife of RDF syntax, but
33 rather is suited to resource limited or performance critical
34 applications (e.g. converting many gigabytes of NTriples to Turtle),
35 or situations where a simple reader/writer with minimal dependencies
36 is ideal (e.g. in LV2 implementations or embedded applications).
37
38 %description -l pl.UTF-8
39 Serd to lekka biblioteka C do obsługi składni RDF, obsługująca odczyt
40 i zapis formatów Turtle i NTriples.
41
42 Serd nie ma na celu obsługi wszystkich aspektów składni RDF, jest
43 przeznaczony raczej do zastosowań z ograniczonymi zasobami lub
44 krytycznych pod względem wydajności (np. konwersji wielu gigabajtów z
45 formatu NTriples do Turtle), albo w sytuacjach, gdzie ideałem jest
46 prosty program czytający/zapisujący o minimalnych zależnościach (np. w
47 implementacjach LV2 lub środowiskach wbudowanych).
48
49 %package devel
50 Summary:        Header files for serd library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki serd
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description devel
56 Header files for serd library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki serd.
60
61 %prep
62 %setup -q
63
64 %build
65 %meson build \
66         --default-library=shared \
67         %{!?with_apidocs:-Ddocs=disabled}
68
69 %ninja_build -C build
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %ninja_install -C build
75
76 %if %{without apidocs}
77 # -Ddocs=disabled disables man page installation
78 install -d $RPM_BUILD_ROOT%{_mandir}/man1
79 cp -p doc/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
80 %endif
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS COPYING NEWS README.md
91 %attr(755,root,root) %{_bindir}/serdi
92 %attr(755,root,root) %{_libdir}/libserd-0.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libserd-0.so.0
94 %{_mandir}/man1/serdi.1*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libserd-0.so
99 %{_includedir}/serd-0
100 %{_pkgconfigdir}/serd-0.pc
This page took 0.108342 seconds and 3 git commands to generate.