]> git.pld-linux.org Git - packages/seed.git/blob - seed.spec
- release 2 (rebuild with mpfr-3.0.x)
[packages/seed.git] / seed.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 #
5 Summary:        JavaScript interpreter
6 Summary(pl.UTF-8):      Interpreter JavaScript
7 Name:           seed
8 Version:        2.30.0
9 Release:        2
10 License:        LGPL v3
11 Group:          Applications
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/seed/2.30/%{name}-%{version}.tar.bz2
13 # Source0-md5:  dd09d22c6a06b4bbef7320bb6a715c0f
14 URL:            http://live.gnome.org/Seed
15 BuildRequires:  autoconf >= 2.59
16 BuildRequires:  automake >= 1:1.7
17 BuildRequires:  dbus-glib-devel
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  gettext-devel
20 BuildRequires:  gnome-js-common
21 BuildRequires:  gobject-introspection-devel >= 0.6.3
22 BuildRequires:  gtk+2-devel
23 BuildRequires:  gtk-doc >= 1.9
24 BuildRequires:  gtk-webkit-devel
25 BuildRequires:  intltool >= 0.35.0
26 BuildRequires:  libffi-devel
27 BuildRequires:  libtool
28 BuildRequires:  libxml2-devel
29 BuildRequires:  mpfr-devel
30 BuildRequires:  pkgconfig
31 BuildRequires:  readline-devel
32 BuildRequires:  sqlite3-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Seed is a library and interpreter, dynamically bridging (through
37 GObjectIntrospection) the WebKit JavaScriptCore engine, with the GNOME
38 platform. Seed serves as something which enables you to write
39 standalone applications in JavaScript, or easily enable your
40 application to be extensible in JavaScript.
41
42 %description -l pl.UTF-8
43 Seed jest biblioteką i interpreterem, dynamicznie łączącym (poprzez
44 GObjectIntrospection) silnik WebKit JavaScriptCore z GNOME. Seed
45 umożliwia pisanie samodzielnych aplikacji w JavaScript, jak również
46 łatwe ich rozszerzanie w JavaScript.
47
48 %package devel
49 Summary:        Header files for seed library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki seed
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       glib2-devel
54 Requires:       gobject-introspection-devel
55 Requires:       gtk-webkit-devel
56
57 %description devel
58 Header files for seed library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki seed.
62
63 %package static
64 Summary:        Static seed library
65 Summary(pl.UTF-8):      Statyczna biblioteka seed
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static seed library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka seed.
74
75 %package apidocs
76 Summary:        seed library API documentation
77 Summary(pl.UTF-8):      Dokumentacja API biblioteki seed
78 Group:          Documentation
79 Requires:       gtk-doc-common
80
81 %description apidocs
82 API documentation for seed library.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API biblioteki seed.
86
87 %prep
88 %setup -q
89
90 %build
91 %{__intltoolize}
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         --disable-silent-rules \
99         %{__enable_disable apidocs gtk-doc} \
100         --with-html-dir=%{_gtkdocdir}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 mv -f $RPM_BUILD_ROOT%{_docdir}/seed{,-%{version}}
110
111 rm -f $RPM_BUILD_ROOT%{_libdir}/seed/libseed*.{a,la}
112
113 %if %{without apidocs}
114 rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}
115 %endif
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc %{_docdir}/seed-%{version}
126 %attr(755,root,root) %{_bindir}/seed
127 %attr(755,root,root) %{_libdir}/libseed.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libseed.so.0
129 %dir %{_libdir}/seed
130 %attr(755,root,root) %{_libdir}/seed/libseed_cairo.so
131 %attr(755,root,root) %{_libdir}/seed/libseed_canvas.so
132 %attr(755,root,root) %{_libdir}/seed/libseed_dbusnative.so
133 %attr(755,root,root) %{_libdir}/seed/libseed_example.so
134 %attr(755,root,root) %{_libdir}/seed/libseed_ffi.so
135 %attr(755,root,root) %{_libdir}/seed/libseed_gettext.so
136 %attr(755,root,root) %{_libdir}/seed/libseed_gtkbuilder.so
137 %attr(755,root,root) %{_libdir}/seed/libseed_libxml.so
138 %attr(755,root,root) %{_libdir}/seed/libseed_mpfr.so
139 %attr(755,root,root) %{_libdir}/seed/libseed_multiprocessing.so
140 %attr(755,root,root) %{_libdir}/seed/libseed_os.so
141 %attr(755,root,root) %{_libdir}/seed/libseed_readline.so
142 %attr(755,root,root) %{_libdir}/seed/libseed_sandbox.so
143 %attr(755,root,root) %{_libdir}/seed/libseed_sqlite.so
144 %{_datadir}/seed
145 %{_mandir}/man1/seed.1*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libseed.so
150 %{_libdir}/libseed.la
151 %{_includedir}/seed
152 %{_pkgconfigdir}/seed.pc
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libseed.a
157
158 %if %{with apidocs}
159 %files apidocs
160 %defattr(644,root,root,755)
161 %{_gtkdocdir}/seed
162 %endif
This page took 0.037067 seconds and 4 git commands to generate.