]> git.pld-linux.org Git - packages/seed.git/blob - seed.spec
- release 4
[packages/seed.git] / seed.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 #
5 Summary:        JavaScript interpreter
6 Summary(pl.UTF-8):      Interpreter JavaScript
7 Name:           seed
8 Version:        2.30.0
9 Release:        4
10 License:        LGPL v3
11 Group:          Applications
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/seed/2.30/%{name}-%{version}.tar.bz2
13 # Source0-md5:  dd09d22c6a06b4bbef7320bb6a715c0f
14 Patch0:         gobject-introspection.patch
15 URL:            http://live.gnome.org/Seed
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.7
18 BuildRequires:  dbus-glib-devel
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gettext-devel
21 BuildRequires:  gnome-js-common
22 BuildRequires:  gobject-introspection-devel >= 0.6.3
23 BuildRequires:  gtk+2-devel
24 BuildRequires:  gtk-doc >= 1.9
25 BuildRequires:  gtk-webkit-devel
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libffi-devel
28 BuildRequires:  libtool
29 BuildRequires:  libxml2-devel
30 BuildRequires:  mpfr-devel
31 BuildRequires:  pkgconfig
32 BuildRequires:  readline-devel
33 BuildRequires:  sqlite3-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Seed is a library and interpreter, dynamically bridging (through
38 GObjectIntrospection) the WebKit JavaScriptCore engine, with the GNOME
39 platform. Seed serves as something which enables you to write
40 standalone applications in JavaScript, or easily enable your
41 application to be extensible in JavaScript.
42
43 %description -l pl.UTF-8
44 Seed jest biblioteką i interpreterem, dynamicznie łączącym (poprzez
45 GObjectIntrospection) silnik WebKit JavaScriptCore z GNOME. Seed
46 umożliwia pisanie samodzielnych aplikacji w JavaScript, jak również
47 łatwe ich rozszerzanie w JavaScript.
48
49 %package devel
50 Summary:        Header files for seed library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki seed
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       glib2-devel
55 Requires:       gobject-introspection-devel
56 Requires:       gtk-webkit-devel
57
58 %description devel
59 Header files for seed library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki seed.
63
64 %package static
65 Summary:        Static seed library
66 Summary(pl.UTF-8):      Statyczna biblioteka seed
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static seed library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka seed.
75
76 %package apidocs
77 Summary:        seed library API documentation
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki seed
79 Group:          Documentation
80 Requires:       gtk-doc-common
81
82 %description apidocs
83 API documentation for seed library.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API biblioteki seed.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %{__intltoolize}
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         --disable-silent-rules \
101         %{__enable_disable apidocs gtk-doc} \
102         --with-html-dir=%{_gtkdocdir}
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 mv -f $RPM_BUILD_ROOT%{_docdir}/seed{,-%{version}}
112
113 rm -f $RPM_BUILD_ROOT%{_libdir}/seed/libseed*.{a,la}
114
115 %if %{without apidocs}
116 rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}
117 %endif
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc %{_docdir}/seed-%{version}
128 %attr(755,root,root) %{_bindir}/seed
129 %attr(755,root,root) %{_libdir}/libseed.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libseed.so.0
131 %dir %{_libdir}/seed
132 %attr(755,root,root) %{_libdir}/seed/libseed_cairo.so
133 %attr(755,root,root) %{_libdir}/seed/libseed_canvas.so
134 %attr(755,root,root) %{_libdir}/seed/libseed_dbusnative.so
135 %attr(755,root,root) %{_libdir}/seed/libseed_example.so
136 %attr(755,root,root) %{_libdir}/seed/libseed_ffi.so
137 %attr(755,root,root) %{_libdir}/seed/libseed_gettext.so
138 %attr(755,root,root) %{_libdir}/seed/libseed_gtkbuilder.so
139 %attr(755,root,root) %{_libdir}/seed/libseed_libxml.so
140 %attr(755,root,root) %{_libdir}/seed/libseed_mpfr.so
141 %attr(755,root,root) %{_libdir}/seed/libseed_multiprocessing.so
142 %attr(755,root,root) %{_libdir}/seed/libseed_os.so
143 %attr(755,root,root) %{_libdir}/seed/libseed_readline.so
144 %attr(755,root,root) %{_libdir}/seed/libseed_sandbox.so
145 %attr(755,root,root) %{_libdir}/seed/libseed_sqlite.so
146 %{_datadir}/seed
147 %{_mandir}/man1/seed.1*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libseed.so
152 %{_libdir}/libseed.la
153 %{_includedir}/seed
154 %{_pkgconfigdir}/seed.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libseed.a
159
160 %if %{with apidocs}
161 %files apidocs
162 %defattr(644,root,root,755)
163 %{_gtkdocdir}/seed
164 %endif
This page took 0.057307 seconds and 3 git commands to generate.