]> git.pld-linux.org Git - packages/scummvm.git/blob - scummvm.spec
- no asm on !x86
[packages/scummvm.git] / scummvm.spec
1 %define         version_tools   0.7.0
2 Summary:        SCUMM graphic adventure game interpreter
3 Summary(pl):    Interpreter przygodówek opartych na SCUMM
4 Name:           scummvm
5 Version:        0.7.0
6 Release:        2
7 License:        GPL
8 Group:          X11/Applications/Games
9 Source0:        http://dl.sourceforge.net/scummvm/%{name}-%{version}.tar.bz2
10 # Source0-md5:  7e2f9bc1bc54aa78285f7f3189ee8a7c
11 Source1:        http://dl.sourceforge.net/scummvm/%{name}-tools-%{version_tools}.tar.bz2
12 # Source1-md5:  eeebbd4e309a8564dd911d5c26fed2f0
13 Source2:        %{name}.desktop
14 Source3:        %{name}.png
15 URL:            http://scummvm.sourceforge.net/
16 BuildRequires:  SDL-devel >= 1.2.2
17 BuildRequires:  libmad-devel
18 BuildRequires:  libvorbis-devel
19 BuildRequires:  mpeg2dec-devel
20 %ifarch %{ix86}
21 BuildRequires:  nasm
22 %endif
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 ScummVM is a collection of interpreters, capable of emulating several
28 adventure game engines. ScummVM mainly supports games created using
29 SCUMM (Script Creation Utility for Maniac Mansion), used in various
30 LucasArts games such as Monkey Island, Day of the Tentacle, and
31 others.
32
33 ScummVM also contains interpreters for several non-SCUMM games.
34 Currently these are Beneath a Steel Sky, Broken Sword 1 & 2, Flight of
35 the Amazon Queen and Simon the Sorcerer 1 & 2.
36
37 At this time ScummVM should be considered beta software, and is still
38 under heavy development. Be aware that whilst we attempt to make sure
39 that many games can be completed with few major bugs, crashes can
40 happen.
41
42 %description -l pl
43 ScummVM jest zbiorem interpreterów zdolnych do emulacji kilku silników
44 gier przygodowych. ScummVM g³ównie wspiera gry stworzone z u¿yciem
45 silnika SCUMM (Script Creation Utility for Maniac Mansion), u¿ywanego
46 przez takie tytu³y stworzone przez Lucas Arts jak Monkey Island, Day
47 of the Tentacle.
48
49 ScummVM potrafi równie¿ interpretowaæ kilka gier nie opartych na
50 SCUMM. W chwili obecnej s± to Beneath a Steel Sky, Broken Sword 1 i 2,
51 Flight of the Amazon Queen oraz Simon the Sorcerer 1 i 2.
52
53 ScummVM jest ca³y czas intensywnie rozwijany i powinien byæ traktowany
54 jako program w stanie beta. Wiele gier powinno daæ siê skoñczyæ bez
55 wiêkszych b³êdów, nale¿y byæ jednak ¶wiadomym, ¿e program mo¿e siê
56 czasem wysypaæ.
57
58 %package tools
59 Summary:        ScummVM tools
60 Summary(pl):    Narzêdzia zwi±zane ze ScummVM
61 Group:          X11/Applications/Games
62
63 %description tools
64 Collection of various tools that may be useful to use in conjunction
65 with ScummVM.
66
67 %description tools -l pl
68 Zestaw narzêdzi mog±cych byæ u¿ytecznymi w po³±czeniu ze ScummVM.
69
70 %prep
71 %setup -q -a 1
72
73 %build
74 ./configure \
75         --disable-debug \
76 %ifnarch %{ix86}
77         --disable-nasm \
78 %endif
79         --enable-kyra
80
81 %{__make} \
82         CXX="%{__cxx}" \
83         CXXFLAGS="%{rpmcflags}" \
84         LDFLAGS="%{rpmldflags}"
85
86 cd %{name}-tools-%{version_tools}
87 %{__make} \
88         CC="%{__cc}" \
89         CFLAGS="%{rpmcflags}" \
90         LDFLAGS="%{rpmldflags}"
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man6,%{_pixmapsdir},%{_desktopdir}}
95
96 install scummvm $RPM_BUILD_ROOT%{_bindir}
97 install scummvm.6 $RPM_BUILD_ROOT%{_mandir}/man6
98
99 cd %{name}-tools-%{version_tools}
100 install compress_san    $RPM_BUILD_ROOT%{_bindir}
101 install convbdf         $RPM_BUILD_ROOT%{_bindir}
102 install dekyra          $RPM_BUILD_ROOT%{_bindir}
103 install descumm         $RPM_BUILD_ROOT%{_bindir}
104 install desword2        $RPM_BUILD_ROOT%{_bindir}
105 install extract         $RPM_BUILD_ROOT%{_bindir}/extract-scummvm
106 install kyra_unpak      $RPM_BUILD_ROOT%{_bindir}
107 install loom_tg16_extract       $RPM_BUILD_ROOT%{_bindir}
108 install mm_nes_extract  $RPM_BUILD_ROOT%{_bindir}
109 install queenrebuild    $RPM_BUILD_ROOT%{_bindir}
110 install rescumm         $RPM_BUILD_ROOT%{_bindir}
111 install saga2mp3        $RPM_BUILD_ROOT%{_bindir}
112 install simon1decr      $RPM_BUILD_ROOT%{_bindir}
113 install simon2mp3       $RPM_BUILD_ROOT%{_bindir}
114 install sword1mp3       $RPM_BUILD_ROOT%{_bindir}
115 install sword2mp3       $RPM_BUILD_ROOT%{_bindir}
116 cd -
117
118 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
119 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc NEWS README TODO
127 %attr(755,root,root) %{_bindir}/scummvm
128 %{_mandir}/man6/*
129 %{_pixmapsdir}/*
130 %{_desktopdir}/*
131
132 %files tools
133 %defattr(644,root,root,755)
134 %doc %{name}-tools-%{version_tools}/README
135 %attr(755,root,root) %{_bindir}/*
136 %exclude %{_bindir}/scummvm
This page took 0.447226 seconds and 4 git commands to generate.