]> git.pld-linux.org Git - packages/sawfish.git/blob - sawfish.spec
added missing requires for gnome subpackage (rep-gtk-gnome, rep-gtk-libglade)
[packages/sawfish.git] / sawfish.spec
1 Summary:        A highly configurable and extensible X11 window manager
2 Name:           sawfish
3 Version:        0.35
4 Release:        2
5 Epoch:          1
6 License:        GPL
7 Group:          X11/Window Managers
8 Group(de):      X11/Fenstermanager
9 Group(es):      X11/Administraadores De Ventanas
10 Group(fr):      X11/Gestionnaires De Fenêtres
11 Group(pl):      X11/Zarz±dcy Okien
12 Source0:        ftp://download.sourceforge.net/pub/sourceforge/sawmill/%{name}-%{version}.tar.gz
13 Patch0:         %{name}-info.patch
14 Patch1:         %{name}-no_version.patch
15 Patch2:         %{name}-no_libnsl.spec
16 URL:            http://sawmill.sourceforge.net
17 Requires:       rep-gtk >= 0.14-3
18 BuildRequires:  autoconf
19 BuildRequires:  esound-devel
20 BuildRequires:  control-center-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  gnome-libs-devel
23 BuildRequires:  gtk+-devel >= 1.2.0
24 BuildRequires:  imlib-devel >= 1.8.2
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng >= 1.0.8
27 BuildRequires:  librep-devel >= 0.13.2-2
28 BuildRequires:  libtiff-devel
29 BuildRequires:  libungif-devel
30 BuildRequires:  ncurses-devel
31 BuildRequires:  readline-devel
32 BuildRequires:  gmp-devel
33 BuildRequires:  rep-gtk >= 0.14-3
34 BuildRequires:  rep-gtk-gnome >= 0.14-3
35 BuildRequires:  rep-gtk-libglade >= 0.14-3
36 Obsoletes:      sawmill
37 Obsoletes:      sawmill-gnome
38 Obsoletes:      sawmill-themer
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _prefix         /usr/X11R6
42 %define         _infodir        /usr/share/info
43
44 %description
45 This is an extensible window manager using a LISP-based scripting
46 language--all window decorations are configurable, the basic idea is
47 to have as much user-interface policy as possible controlled through
48 the Lisp language. All configuration may be performed through a GTK
49 interface; sawmill is mostly-GNOME compliant.
50
51 %package gnome
52 Summary:        GNOME support for sawmill
53 Group:          X11/Window Managers
54 Group(de):      X11/Fenstermanager
55 Group(es):      X11/Administraadores De Ventanas
56 Group(fr):      X11/Gestionnaires De Fenêtres
57 Group(pl):      X11/Zarz±dcy Okien
58 Requires:       %{name} = %{version}
59 Requires:       rep-gtk-gnome >= 0.14-3
60 Requires:       rep-gtk-libglade >= 0.14-3
61
62 %description gnome
63 Optional GNOME support for sawmill. Includes a wm-entries spec, and a
64 control center applet.
65
66 %package themer
67 Summary:        GUI for creating sawmill themes
68 Group:          X11/Window Managers
69 Group(de):      X11/Fenstermanager
70 Group(es):      X11/Administraadores De Ventanas
71 Group(fr):      X11/Gestionnaires De Fenêtres
72 Group(pl):      X11/Zarz±dcy Okien
73 Requires:       %{name} = %{version}
74
75 %description themer
76 Optional theme builder for sawmill. Allows static window themes to be
77 created/edited in a graphical environment.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84
85 %build
86 gettextize --copy --force
87 autoconf
88 %configure \
89         --disable-static \
90         --enable-capplet \
91         --with-readline \
92         --with-esd \
93         --with-audiofile \
94         --without-static
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT \
103         G_MENU_DIR=%{_applnkdir}/Settings/GNOME
104
105 gzip -9nf README NEWS FAQ TODO
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
114
115 %postun
116 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc *.gz
121 %attr(755,root,root) %{_bindir}/sawfish
122 %attr(755,root,root) %{_bindir}/sawfish-client
123 %attr(755,root,root) %{_bindir}/sawfish-ui
124 %{_datadir}/sawfish
125
126 %dir %{_libexecdir}/sawfish
127 %dir %{_libexecdir}/sawfish/%{_host}
128
129 %{_libexecdir}/sawfish/%{_host}/DOC
130 %{_libexecdir}/sawfish/%{_host}/sawfish
131 /usr/libexec/rep/%{_host}/sawfish
132
133 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/*.so
134 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/*.la
135 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/gtk-style
136 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/sawfish-menu
137 %{_infodir}/sawfish*
138
139 %files gnome
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/sawfish-capplet
142 %{_datadir}/control-center/Sawfish
143 %{_datadir}/gnome/wm-properties/Sawfish.desktop
144
145 %files themer
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/sawfish-themer
148 %{_datadir}/sawfish/themer.glade
This page took 0.03602 seconds and 4 git commands to generate.