]> git.pld-linux.org Git - packages/sawfish.git/blob - sawfish.spec
- merged from DEVEL
[packages/sawfish.git] / sawfish.spec
1 Summary:        A highly configurable and extensible X11 window manager
2 Summary(pl):    Window Manad¿er dla X11 o du¿ych mo¿liwo¶ciach konfiguracyjnych i skalowalno¶ci
3 Name:           sawfish
4 Version:        2.0
5 Release:        2
6 Epoch:          2
7 License:        GPL
8 Group:          X11/Window Managers
9 Source0:        http://ftp.gnome.org/pub/gnome/sources/sawfish/2.0/%{name}-%{version}.tar.bz2
10 Patch0:         %{name}-applnk.patch
11 URL:            http://sawmill.sourceforge.net/
12 Icon:           sawfish.xpm
13 BuildRequires:  autoconf                
14 BuildRequires:  automake
15 BuildRequires:  esound-devel >= 0.2.27
16 BuildRequires:  gettext-devel
17 BuildRequires:  librep-devel >= 0.16
18 BuildRequires:  gtk+2-devel >= 2.0.3
19 BuildRequires:  libtool
20 BuildRequires:  ncurses-devel
21 BuildRequires:  readline-devel
22 BuildRequires:  rep-gtk >= 0.16
23 BuildRequires:  rep-gtk-gnome >= 0.16
24 BuildRequires:  rep-gtk-libglade >= 0.16
25 BuildRequires:  texinfo
26 %define         repexecdir      %(rep-config --execdir || echo "Install_librep-devel_and_rebuild_this_package")
27 Requires:       rep-gtk >= 0.16
28 Requires:       %{repexecdir}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30 Obsoletes:      sawmill
31 Obsoletes:      sawmill-gnome
32 Obsoletes:      sawmill-themer
33
34 %define         _prefix         /usr/X11R6
35 %define         _libexecdir     %{_libdir}
36 %define         _wmpropsdir     %{_datadir}/wm-properties
37
38 %description
39 This is an extensible window manager using a LISP-based scripting
40 language--all window decorations are configurable, the basic idea is
41 to have as much user-interface policy as possible controlled through
42 the Lisp language. All configuration may be performed through a GTK
43 interface; sawmill is mostly-GNOME compliant.
44
45 %description -l pl
46 Window manad¿er o du¿ych mo¿liwo¶ciach rozszerzania, u¿ywaj±cy
47 bazowanego na LISP-ie jêzyka skryptowego, dziêki czemu wszystkie
48 dodatki do okien s± configurowalne. Ogóln± ide± jest, aby daæ jak
49 najwiêksz± kontrolê w rêce u¿ytkownika poprzez graficzny interfejs
50 dziêki w³a¶nie LISP-owi. Sawmill jest najbardziej zgodny z GNOME-m.
51
52 %package gnome
53 Summary:        GNOME support for sawmill
54 Summary(pl):    Support GNOME'a dla sawmilla
55 Group:          X11/Window Managers
56 Requires:       %{name} = %{version}
57 Requires:       rep-gtk-gnome >= 0.14-3
58 Requires:       rep-gtk-libglade >= 0.14-3
59
60 %description gnome
61 Optional GNOME support for sawmill. Includes a wm-entries spec, and a
62 control center applet.
63
64 %description gnome -l pl
65 Opcjonalny support GNOME'a dla sawmilla. Zawiera aplet dla
66 control-center oraz wm-entries spec.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 %{__gettextize}
74 %{__libtoolize}
75 aclocal
76 %{__autoconf}
77 %{__automake} || :
78 %configure \
79         --disable-static \
80         --enable-capplet \
81         --enable-themer \
82         --enable-gnome-widgets \
83         --with-readline \
84         --with-esd \
85         --with-audiofile \
86         --with-gnu-ld
87 %{__make} host_type=%{_host}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_wmpropsdir}
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT \
95         G_MENU_DIR=%{_applnkdir}/Settings/GNOME \
96         host_type=%{_host}
97
98 install Sawfish.desktop $RPM_BUILD_ROOT%{_wmpropsdir}
99
100 gzip -9nf README NEWS FAQ TODO
101
102 %find_lang %{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
109
110 %postun
111 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
112
113 %files -f %{name}.lang
114 %defattr(644,root,root,755)
115 %doc *.gz
116 %attr(755,root,root) %{_bindir}/*
117 %{_datadir}/sawfish
118 %{_pixmapsdir}/*
119
120 %dir %{_libexecdir}/sawfish
121 %dir %{_libexecdir}/sawfish/%{version}
122 %dir %{_libexecdir}/sawfish/%{version}/%{_host}
123 %attr(755,root,root) %{_libexecdir}/sawfish/%{version}/%{_host}/*.so
124 %attr(755,root,root) %{_libexecdir}/sawfish/%{version}/%{_host}/*.la
125 %attr(755,root,root) %{_libexecdir}/sawfish/%{version}/%{_host}/gtk-style
126 %attr(755,root,root) %{_libexecdir}/sawfish/%{version}/%{_host}/sawfish-menu
127 %attr(755,root,root) %{_libexecdir}/sawfish/%{version}/%{_host}/sawfish-about
128 %dir %{_libexecdir}/sawfish/%{version}/%{_host}/sawfish
129 %dir %{_libexecdir}/sawfish/%{version}/%{_host}/sawfish/wm
130 %dir %{_libexecdir}/sawfish/%{version}/%{_host}/sawfish/wm/util
131 %attr(755,root,root) %{_libexecdir}/sawfish/%{version}/%{_host}/sawfish/wm/util/*.so
132 %attr(755,root,root) %{_libexecdir}/sawfish/%{version}/%{_host}/sawfish/wm/util/*.la
133 %{_libexecdir}/sawfish/%{version}/%{_host}/DOC
134
135 %dir %{repexecdir}/sawfish
136 %attr(755,root,root) %{repexecdir}/sawfish/*.so
137 %attr(755,root,root) %{repexecdir}/sawfish/*.la
138 %{_infodir}/sawfish*
139
140 %files gnome
141 %defattr(644,root,root,755)
142 %{_datadir}/control-center-2.0/capplets/*
143 %{_wmpropsdir}/Sawfish.desktop
This page took 0.348799 seconds and 4 git commands to generate.