]> git.pld-linux.org Git - packages/samba.git/blob - samba.spec
bug fixes
[packages/samba.git] / samba.spec
1 Summary:        SMB client and server
2 Summary(pl):    Klient i serwer SMB
3 Name:           samba
4 Version:        2.0.2
5 Release:        3d
6 Copyright:      GPL
7 Group:          Daemons
8 Group(pl):      Serwery
9 Source0:        ftp://samba.anu.edu.au/pub/samba/%{name}-%{version}.tar.gz
10 Source1:        %{name}.PLD.tar.bz2
11 Patch0:         %{name}.%{version}.patch
12 Patch1:         %{name}-config.patch
13 Patch2:         %{name}-cap.patch
14 Prereq:         /sbin/chkconfig 
15 Prereq:         fileutils
16 Requires:       pam >= 0.66 
17 Requires:       krb5-lib >= 1.0.5
18 BuildRoot:      /tmp/%{name}-%{version}-root
19
20 %description
21 Samba provides an SMB server which can be used to provide
22 network services to SMB (sometimes called "Lan Manager")
23 clients, including various versions of MS Windows, OS/2,
24 and other Linux machines. Samba also provides some SMB
25 clients, which complement the built-in SMB filesystem
26 in Linux. Samba uses NetBIOS over TCP/IP (NetBT) protocols
27 and does NOT need NetBEUI (Microsoft Raw NetBIOS frame)
28 protocol.
29
30 This release is known as the "Locking Update" and has full
31 support for Opportunistic File Locking. In addition this update
32 includes native support for Microsoft encrypted passwords,
33 improved browse list and WINS database management.
34
35 Please refer to the WHATSNEW.txt document for fixup information.
36 This binary release includes encrypted password support.
37 Please read the smb.conf file and ENCRYPTION.txt in the
38 docs directory for implementation details.
39
40 WARNING! This version is designed for using with Kerberos V
41
42 %description -l pl
43 Samba udostêpnia serwer SMB, który mo¿e byæ u¿yty w celu 
44 dostarczenia us³ug sieciowych (potocznie zwanych "Lan Manager"),
45 dla klientów takich jak M$ Windows, OS/2 a tak¿e maszyn linuxowych. 
46 W pakiecie znajduje siê równie¿ oprogramowanie klienckie. Samba u¿ywa 
47 protoko³u NetBIOS po TCP/IP (NetBT) i nie wymaga ¶miesznego protoko³u 
48 NetBEUI. Ta wersja ma pe³ne wsparcie dla blokowania plików, a tak¿e 
49 wsparcie dla kodowania hase³ w standardzie M$ i zarzadzania komiczn± 
50 baz± WINS.
51
52 UWAGA! Ta wersja jest przeznaczona dla maszyn wyposa¿onych w Kerberos'a V
53
54 %prep
55 %setup -q -a1
56 %patch0 -p1
57 %patch1 -p1
58 %patch2 -p1
59
60 %build
61 cd source
62 autoconf
63 CFLAGS=$RPM_OPT_FLAGS LDFLAGS=-s \
64     ./configure \
65         --sysconfdir=/etc/samba \
66         --with-krb5=/usr \
67         --with-smbmount \
68         --with-smb-wrapper \
69         --with-quotas \
70         --prefix=/usr \
71         --with-privatedir=/etc/samba \
72         --libdir=/etc/samba \
73         --localstatedir=/var \
74         --sbindir=/usr/sbin \
75         --bindir=/usr/bin \
76         --with-swatdir=/usr/share/swat
77         
78 make all smbwrapper
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 install -d $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT/etc/samba/codepages/src
85 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,pam.d}
86 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
87 install -d $RPM_BUILD_ROOT/home/samba
88 install -d $RPM_BUILD_ROOT/lib/security
89 install -d $RPM_BUILD_ROOT/usr/{bin,sbin}
90 install -d $RPM_BUILD_ROOT/usr/man/{man1,man5,man7,man8}
91 install -d $RPM_BUILD_ROOT/var/lock/samba
92 install -d $RPM_BUILD_ROOT/var/log/samba
93 install -d $RPM_BUILD_ROOT/var/spool/samba
94 install -d $RPM_BUILD_ROOT/usr/share/swat/{include,images,help}
95
96 ( cd source;
97 make prefix=$RPM_BUILD_ROOT/usr \
98     BASEDIR=$RPM_BUILD_ROOT/usr \
99     BINDIR=$RPM_BUILD_ROOT/usr/bin \
100     SBINDIR=$RPM_BUILD_ROOT/usr/sbin \
101     LIBDIR=$RPM_BUILD_ROOT/etc/samba \
102     PRIVATEDIR=$RPM_BUILD_ROOT/etc/samba \
103     SWATDIR=$RPM_BUILD_ROOT/usr/share/swat \
104     VARDIR=$RPM_BUILD_ROOT/var \
105     install
106 )
107
108 install  source/codepages/codepage_def.* \
109     $RPM_BUILD_ROOT/etc/samba/codepages/src
110
111 install  docs/manpages/*.1 $RPM_BUILD_ROOT/usr/man/man1
112 install  docs/manpages/*.5 $RPM_BUILD_ROOT/usr/man/man5
113 install  docs/manpages/*.7 $RPM_BUILD_ROOT/usr/man/man7
114 install  docs/manpages/*.8 $RPM_BUILD_ROOT/usr/man/man8
115
116 install  packaging/PLD/smb.conf         $RPM_BUILD_ROOT/etc/samba
117 install  packaging/PLD/smbusers         $RPM_BUILD_ROOT/etc/samba
118 install  packaging/PLD/smbprint         $RPM_BUILD_ROOT/usr/bin
119 install  packaging/PLD/smbadduser       $RPM_BUILD_ROOT/usr/bin
120 install  packaging/PLD/findsmb          $RPM_BUILD_ROOT/usr/bin
121 install  packaging/PLD/smb.init         $RPM_BUILD_ROOT/etc/rc.d/init.d/smb
122 install  packaging/PLD/samba.pam        $RPM_BUILD_ROOT/etc/pam.d/samba
123 install  packaging/PLD/samba.log        $RPM_BUILD_ROOT/etc/logrotate.d/samba
124
125 install swat/help/*.html docs/htmldocs/*.html \
126     $RPM_BUILD_ROOT/usr/share/swat/help
127 install swat/images/*.gif $RPM_BUILD_ROOT/usr/share/swat/images
128 install swat/include/*.html $RPM_BUILD_ROOT/usr/share/swat/include
129
130 mv swat/README swat/README.swat
131
132 install -s source/bin/*.so $RPM_BUILD_ROOT/lib/security
133
134 touch $RPM_BUILD_ROOT/var/lock/samba/{STATUS..LCK,wins.dat,browse.dat}
135
136 echo 127.0.0.1 > $RPM_BUILD_ROOT/etc/samba/lmhosts
137
138 for i in 437 737 850 852 861 866 932 949 950 936; do
139 $RPM_BUILD_ROOT/usr/bin/make_smbcodepage c $i \
140 $RPM_BUILD_ROOT/etc/samba/codepages/src/codepage_def.$i \
141 $RPM_BUILD_ROOT/etc/samba/codepages/codepage.$i; done
142
143 gzip -9fn $RPM_BUILD_ROOT/usr/man/man[1578]/*
144 bzip2 -9  README Manifest WHATSNEW.txt Roadmap docs/*.reg swat/README.swat
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 /sbin/chkconfig --add smb
151
152 # Not for PLD
153 #if !( grep ^[:space:]*swat /etc/services > /dev/null ) then
154 #echo 'swat     901/tcp         # Swat service used via inetd' >> /etc/services
155 #fi
156
157 # Not for PLD 
158 #if !( grep ^[:space:]*swat /etc/inetd.conf > /dev/null ) then
159 #echo 'swat     stream  tcp     nowait.400      root    /usr/sbin/swat swat' >> /etc/inetd.conf
160 #killall -HUP inetd >&2
161 #fi
162
163 %preun
164 if [ $1 = 0 ]; then
165     /etc/rc.d/init.d/smb stop >&2
166     /sbin/chkconfig --del smb
167 fi
168 # Not for PLD 
169 #    cd /etc
170 #    tmpfile=/etc/tmp.$$
171 #    sed -e '/^[:space:]*swat.*$/d' /etc/inetd.conf > $tmpfile
172 #    mv $tmpfile inetd.conf
173 #    sed -e '/^[:space:]*swat.*$/d' /etc/services > $tmpfile
174 #    mv $tmpfile services
175 #fi
176
177 %files
178 %defattr(644,root,root,755)
179 %doc README.bz2 Manifest.bz2 WHATSNEW.txt.bz2 swat/README.swat.bz2
180 %doc Roadmap.bz2 docs/faq/*.html docs/*.reg.bz2 
181
182 %attr(755,root,root) /usr/bin/*
183 %attr(755,root,root) /usr/sbin/*
184
185 %dir /etc/samba
186 %config(noreplace) %verify(not size mtime md5) /etc/samba/smb.conf
187 %attr(600,root,root) %config %verify(not size mtime md5) /etc/samba/smbusers
188 %attr(640,root,root) %config %verify(not size mtime md5) /etc/samba/lmhosts
189
190 %attr(750,root,root) %config /etc/rc.d/init.d/smb
191 %attr(640,root,root) /etc/logrotate.d/samba
192 %attr(640,root,root) /etc/pam.d/samba
193
194 %attr(755,root,root) /lib/security/*.so
195
196 %attr(644,root, man) /usr/man/man[1578]/*
197
198 %dir /home/samba
199 %dir /etc/samba/codepages
200 /etc/samba/codepages/*
201
202 %dir /usr/share/swat
203
204 %dir /usr/share/swat/help
205 /usr/share/swat/help/*.html
206
207 %dir /usr/share/swat/include
208 /usr/share/swat/include/*.html
209
210 %dir /usr/share/swat/images
211 /usr/share/swat/images/*.gif
212
213 %attr(750,root,root) %dir /var/lock/samba
214 %attr(640,root,root) /var/lock/samba/*
215
216 %attr(0750,root, root) %dir /var/log/samba
217 %attr(1777,root, root) %dir /var/spool/samba
218
219 %changelog
220 * Tue Jan 26 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
221   [2.2.0-1d]
222 - updated to new version,
223 - added Group(pl),
224 - added patch against GNU libc-2.1 -- prepared by Paul Laufer
225   http://www.cspupomona.edu/~pelaufer/samba,
226 - some other changes ...
227
228 * Wed Aug 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
229   [1.9.18p8-1d]
230 - build against glibc-2.1,
231   patch prepared by Paul Laufer <PELaufer@csupomona.edu>
232   http://www.netcom.com/~mlaufer/samba,
233 - translation modified for pl,
234 - build with Kerberos V support,
235 - moved %changelog at the end of spec,
236 - build from non root's acccount,
237 - changed permisions of binaries to 755,
238 - moved config files to /etc/samba instead /etc,
239 - added a sticky bit on /var/spool/samba,
240 - minor modifications of spec.
241
242 * Sat Jul 4 1998 John H Terpstra <jht@samba.anu.edu.au>
243   - changed classification of codepage source files
244   - altered installation of samba system files
245   - modified doc handling (removed attribute setting parameters)
246
247 * Sat Jun 13 1998 John H Terpstra <jht@samba.anu.edu.au>
248   - Added code pages 737 and 861 to files section
249   - Added auto-generation of empty /etc/lmhosts file if not exist
250   - Always zap and create empty /var/lock/samba/STATUS..LCK file
251
252 * Wed Jun 10 1998 John H Terpstra <jht@samba.anu.edu.au>
253   - Updated version info for 1.9.18p8 release
254   - updated codepage support for pages 737 861
255
256 * Sun Apr 26 1998 John H Terpstra <jht@samba.anu.edu.au>
257   - minor tidy up in preparation for release of 1.9.18p5
258   - added findsmb utility from SGI package
259
260 * Wed Mar 18 1998 John H Terpstra <jht@samba.anu.edu.au>
261   - Updated version and codepage info.
262   - Release to test name resolve order
263
264 * Sat Jan 24 1998 John H Terpstra <jht@samba.anu.edu.au>
265  - Many optimisations (some suggested by Manoj Kasichainula <manojk@io.com>
266   - Use of chkconfig in place of individual symlinks to /etc/rc.d/init/smb
267   - Compounded make line
268   - Updated smb.init restart mechanism
269   - Use compound mkdir -p line instead of individual calls to mkdir
270   - Fixed smb.conf file path for log files
271   - Fixed smb.conf file path for incoming smb print spool directory
272   - Added a number of options to smb.conf file
273   - Added smbadduser command (missed from all previous RPMs) - Doooh!
274   - Added smbuser file and smb.conf file updates for username map
This page took 0.051487 seconds and 4 git commands to generate.