]> git.pld-linux.org Git - packages/samba.git/blob - samba.spec
Samba i howto...
[packages/samba.git] / samba.spec
1 Summary:        SMB client and server
2 Summary(pl):    Klient i serwer SMB
3 Name:           samba
4 Version:        2.0.3
5 Release:        1
6 Copyright:      GPL
7 Group:          Daemons
8 Group(pl):      Serwery
9 Source0:        ftp://samba.anu.edu.au/pub/samba/%{name}-%{version}.tar.gz
10 Source1:        %{name}-PLD.tar.gz
11 Patch0:         %{name}-glibc2.1.patch
12 Patch1:         %{name}-config.patch
13 Patch2:         %{name}-cap.patch
14 Prereq:         /sbin/chkconfig 
15 Prereq:         fileutils
16 Requires:       pam >= 0.66 
17 #Requires:      krb5-lib >= 1.0.5
18 BuildRoot:      /tmp/%{name}-%{version}-root
19
20 %description
21 Samba provides an SMB server which can be used to provide
22 network services to SMB (sometimes called "Lan Manager")
23 clients, including various versions of MS Windows, OS/2,
24 and other Linux machines. Samba also provides some SMB
25 clients, which complement the built-in SMB filesystem
26 in Linux. Samba uses NetBIOS over TCP/IP (NetBT) protocols
27 and does NOT need NetBEUI (Microsoft Raw NetBIOS frame)
28 protocol.
29
30 This release is known as the "Locking Update" and has full
31 support for Opportunistic File Locking. In addition this update
32 includes native support for Microsoft encrypted passwords,
33 improved browse list and WINS database management.
34
35 Please refer to the WHATSNEW.txt document for fixup information.
36 This binary release includes encrypted password support.
37 Please read the smb.conf file and ENCRYPTION.txt in the
38 docs directory for implementation details.
39
40 %description -l pl
41 Samba udostêpnia serwer SMB, który mo¿e byæ u¿yty w celu dostarczenia
42 us³ug sieciowych (potocznie zwanych "Lan Manager"), dla klientów takich
43 jak MS Windows, OS/2 a tak¿e maszyn linuxowych.  W pakiecie znajduje siê
44 równie¿ oprogramowanie klienckie. Samba u¿ywa protoko³u NetBIOS po TCP/IP
45 (NetBT) i nie wymaga protoko³u NetBEUI. Ta wersja ma pe³ne wsparcie dla
46 blokowania plików, a tak¿e wsparcie dla kodowania hase³ w standardzie
47 MS i zarzadzania baz± WINS.
48
49 UWAGA: w przeciwieñstwie do wersji 2.0.2 aktualnie samba pozbawiona jest
50 mozliwo¶ci kontrolowania domeny NT.
51
52 %prep
53 %setup -q -a1
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57
58 %build
59 cd source
60 autoconf
61 CFLAGS=$RPM_OPT_FLAGS LDFLAGS=-s \
62     ./configure \
63         %{buildarch}-`echo %{buildos} | tr A-Z a-z` \
64         --sysconfdir=/etc/samba \
65         --with-smbmount \
66         --with-smb-wrapper \
67         --with-quotas \
68         --prefix=/usr \
69         --with-privatedir=/etc/samba \
70         --libdir=/etc/samba \
71         --localstatedir=/var \
72         --sbindir=/usr/sbin \
73         --bindir=/usr/bin \
74         --with-swatdir=/usr/share/swat
75 #       --with-krb5=/usr \
76         
77 make all smbwrapper
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 install -d $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT/etc/samba/codepages/src
84 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,pam.d}
85 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
86 install -d $RPM_BUILD_ROOT/home/samba
87 install -d $RPM_BUILD_ROOT/lib/security
88 install -d $RPM_BUILD_ROOT/usr/{bin,sbin}
89 install -d $RPM_BUILD_ROOT/usr/man/{man1,man5,man7,man8}
90 install -d $RPM_BUILD_ROOT/var/lock/samba
91 install -d $RPM_BUILD_ROOT/var/log/samba
92 install -d $RPM_BUILD_ROOT/var/spool/samba
93 install -d $RPM_BUILD_ROOT/usr/share/swat/{include,images,help}
94
95 ( cd source;
96 make prefix=$RPM_BUILD_ROOT/usr \
97     BASEDIR=$RPM_BUILD_ROOT/usr \
98     BINDIR=$RPM_BUILD_ROOT/usr/bin \
99     SBINDIR=$RPM_BUILD_ROOT/usr/sbin \
100     LIBDIR=$RPM_BUILD_ROOT/etc/samba \
101     PRIVATEDIR=$RPM_BUILD_ROOT/etc/samba \
102     SWATDIR=$RPM_BUILD_ROOT/usr/share/swat \
103     VARDIR=$RPM_BUILD_ROOT/var \
104     install
105 )
106
107 install  source/codepages/codepage_def.* \
108     $RPM_BUILD_ROOT/etc/samba/codepages/src
109
110 install  docs/manpages/*.1 $RPM_BUILD_ROOT/usr/man/man1
111 install  docs/manpages/*.5 $RPM_BUILD_ROOT/usr/man/man5
112 install  docs/manpages/*.7 $RPM_BUILD_ROOT/usr/man/man7
113 install  docs/manpages/*.8 $RPM_BUILD_ROOT/usr/man/man8
114
115 install  packaging/PLD/smb.conf         $RPM_BUILD_ROOT/etc/samba
116 install  packaging/PLD/smbusers         $RPM_BUILD_ROOT/etc/samba
117 install  packaging/PLD/smbprint         $RPM_BUILD_ROOT/usr/bin
118 install  packaging/PLD/smbadduser       $RPM_BUILD_ROOT/usr/bin
119 install  packaging/PLD/findsmb          $RPM_BUILD_ROOT/usr/bin
120 install  packaging/PLD/smb.init         $RPM_BUILD_ROOT/etc/rc.d/init.d/smb
121 install  packaging/PLD/samba.pam        $RPM_BUILD_ROOT/etc/pam.d/samba
122 install  packaging/PLD/samba.log        $RPM_BUILD_ROOT/etc/logrotate.d/samba
123
124 install swat/help/*.html docs/htmldocs/*.html \
125     $RPM_BUILD_ROOT/usr/share/swat/help
126 install swat/images/*.gif $RPM_BUILD_ROOT/usr/share/swat/images
127 install swat/include/*.html $RPM_BUILD_ROOT/usr/share/swat/include
128
129 mv swat/README swat/README.swat
130
131 install -s source/bin/*.so $RPM_BUILD_ROOT/lib/security
132 install -s source/bin/smbsh $RPM_BUILD_ROOT/usr/bin
133
134 touch $RPM_BUILD_ROOT/var/lock/samba/{STATUS..LCK,wins.dat,browse.dat}
135
136 echo 127.0.0.1 > $RPM_BUILD_ROOT/etc/samba/lmhosts
137
138 for i in 437 737 850 852 861 866 932 949 950 936; do
139 $RPM_BUILD_ROOT/usr/bin/make_smbcodepage c $i \
140 $RPM_BUILD_ROOT/etc/samba/codepages/src/codepage_def.$i \
141 $RPM_BUILD_ROOT/etc/samba/codepages/codepage.$i; done
142
143 gzip -9fn $RPM_BUILD_ROOT/usr/man/man[1578]/*
144 gzip -9  README Manifest WHATSNEW.txt Roadmap docs/*.reg swat/README.swat
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 /sbin/chkconfig --add smb
151
152 # Not for PLD
153 #if !( grep ^[:space:]*swat /etc/services > /dev/null ) then
154 #echo 'swat     901/tcp         # Swat service used via inetd' >> /etc/services
155 #fi
156
157 # Not for PLD 
158 #if !( grep ^[:space:]*swat /etc/inetd.conf > /dev/null ) then
159 #echo 'swat     stream  tcp     nowait.400      root    /usr/sbin/swat swat' >> /etc/inetd.conf
160 #killall -HUP inetd >&2
161 #fi
162
163 %preun
164 if [ $1 = 0 ]; then
165     /etc/rc.d/init.d/smb stop >&2
166     /sbin/chkconfig --del smb
167 fi
168 # Not for PLD 
169 #    cd /etc
170 #    tmpfile=/etc/tmp.$$
171 #    sed -e '/^[:space:]*swat.*$/d' /etc/inetd.conf > $tmpfile
172 #    mv $tmpfile inetd.conf
173 #    sed -e '/^[:space:]*swat.*$/d' /etc/services > $tmpfile
174 #    mv $tmpfile services
175 #fi
176
177 %files
178 %defattr(644,root,root,755)
179 %doc README.gz Manifest.gz WHATSNEW.txt.gz swat/README.swat.gz
180 %doc Roadmap.gz docs/faq/*.html docs/*.reg.gz 
181
182 %attr(755,root,root) /usr/bin/*
183 %attr(755,root,root) /usr/sbin/*
184
185 %dir /etc/samba
186 %config(noreplace) %verify(not size mtime md5) /etc/samba/smb.conf
187 %attr(600,root,root) %config %verify(not size mtime md5) /etc/samba/smbusers
188 %attr(640,root,root) %config %verify(not size mtime md5) /etc/samba/lmhosts
189
190 %attr(750,root,root) %config /etc/rc.d/init.d/smb
191 %attr(640,root,root) /etc/logrotate.d/samba
192 %attr(640,root,root) /etc/pam.d/samba
193
194 %attr(755,root,root) /lib/security/*.so
195
196 %attr(644,root, man) /usr/man/man[1578]/*
197
198 %dir /home/samba
199 %dir /etc/samba/codepages
200 /etc/samba/codepages/*
201
202 %dir /usr/share/swat
203
204 %dir /usr/share/swat/help
205 /usr/share/swat/help/*.html
206
207 %dir /usr/share/swat/include
208 /usr/share/swat/include/*.html
209
210 %dir /usr/share/swat/images
211 /usr/share/swat/images/*.gif
212
213 %attr(750,root,root) %dir /var/lock/samba
214 %attr(640,root,root) /var/lock/samba/*
215
216 %attr(0750,root, root) %dir /var/log/samba
217 %attr(1777,root, root) %dir /var/spool/samba
218
219 %changelog
220 * Sun Mar 28 1999 Ziemek Borowski <zmb@ziembor.waw.pl>
221 [2.0.3] 
222 - updated to 2.0.3 (change in samba.2.0.3.patch file)
223 - removed kerberos support
224
225 * Tue Jan 26 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
226   [2.2.0-1d]
227 - updated to new version,
228 - added Group(pl),
229 - added patch against GNU libc-2.1 -- prepared by Paul Laufer
230   http://www.cspupomona.edu/~pelaufer/samba,
231 - some other changes ...
232
233 * Wed Aug 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
234   [1.9.18p8-1d]
235 - build against glibc-2.1,
236   patch prepared by Paul Laufer <PELaufer@csupomona.edu>
237   http://www.netcom.com/~mlaufer/samba,
238 - translation modified for pl,
239 - build with Kerberos V support,
240 - moved %changelog at the end of spec,
241 - build from non root's acccount,
242 - changed permisions of binaries to 755,
243 - moved config files to /etc/samba instead /etc,
244 - added a sticky bit on /var/spool/samba,
245 - minor modifications of spec.
246
247 * Sat Jul 4 1998 John H Terpstra <jht@samba.anu.edu.au>
248   - changed classification of codepage source files
249   - altered installation of samba system files
250   - modified doc handling (removed attribute setting parameters)
251
252 * Sat Jun 13 1998 John H Terpstra <jht@samba.anu.edu.au>
253   - Added code pages 737 and 861 to files section
254   - Added auto-generation of empty /etc/lmhosts file if not exist
255   - Always zap and create empty /var/lock/samba/STATUS..LCK file
256
257 * Wed Jun 10 1998 John H Terpstra <jht@samba.anu.edu.au>
258   - Updated version info for 1.9.18p8 release
259   - updated codepage support for pages 737 861
260
261 * Sun Apr 26 1998 John H Terpstra <jht@samba.anu.edu.au>
262   - minor tidy up in preparation for release of 1.9.18p5
263   - added findsmb utility from SGI package
264
265 * Wed Mar 18 1998 John H Terpstra <jht@samba.anu.edu.au>
266   - Updated version and codepage info.
267   - Release to test name resolve order
268
269 * Sat Jan 24 1998 John H Terpstra <jht@samba.anu.edu.au>
270  - Many optimisations (some suggested by Manoj Kasichainula <manojk@io.com>
271   - Use of chkconfig in place of individual symlinks to /etc/rc.d/init/smb
272   - Compounded make line
273   - Updated smb.init restart mechanism
274   - Use compound mkdir -p line instead of individual calls to mkdir
275   - Fixed smb.conf file path for log files
276   - Fixed smb.conf file path for incoming smb print spool directory
277   - Added a number of options to smb.conf file
278   - Added smbadduser command (missed from all previous RPMs) - Doooh!
279   - Added smbuser file and smb.conf file updates for username map
This page took 0.050606 seconds and 4 git commands to generate.