]> git.pld-linux.org Git - packages/s3ql.git/blob - s3ql.spec
- initial
[packages/s3ql.git] / s3ql.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 Summary:        Filesystem that stores data in Google Storage, Amazon S3 etc
6 Name:           s3ql
7 Version:        2.8.1
8 Release:        1
9 License:        GPL v3
10 Group:          Applications/System
11 Source0:        https://bitbucket.org/nikratio/s3ql/downloads/%{name}-%{version}.tar.bz2
12 # Source0-md5:  b0c173fa97a0b4b77caa3fd66022f228
13 URL:            https://bitbucket.org/nikratio/s3ql/
14 BuildRequires:  python3-Crypto
15 BuildRequires:  python3-apsw
16 BuildRequires:  python3-devel
17 BuildRequires:  python3-distribute
18 BuildRequires:  python3-dugong
19 BuildRequires:  python3-modules
20 BuildRequires:  rpm-pythonprov
21 Requires:       python3-Crypto
22 Requires:       python3-apsw
23 Requires:       python3-dugong
24 Requires:       python3-llfuse
25 Requires:       python3-modules
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 S3QL is a file system that stores all its data online using storage
30 services like Google Storage, Amazon S3, or OpenStack. S3QL
31 effectively provides a hard disk of dynamic, infinite capacity that
32 can be accessed from any computer with internet access running Linux,
33 FreeBSD or OS-X.
34
35 %prep
36 %setup -q
37
38 %build
39 CC="%{__cc}" \
40 CFLAGS="%{rpmcflags}" \
41 %{__python3} setup.py build --build-base build-3 %{?with_tests:test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__python3} setup.py \
47         build --build-base build-3 \
48         install --skip-build \
49         --optimize=2 \
50         --root=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc CREDITS.txt Changes.txt INSTALL.txt README.rst
58 %attr(755,root,root) %{_bindir}/fsck.s3ql
59 %attr(755,root,root) %{_bindir}/mkfs.s3ql
60 %attr(755,root,root) %{_bindir}/mount.s3ql
61 %attr(755,root,root) %{_bindir}/s3ql*
62 %attr(755,root,root) %{_bindir}/umount.s3ql
63 %{py3_sitedir}/s3ql
64 %{py3_sitedir}/s3ql-%{version}-py*.egg-info
65 %{_mandir}/man1/*.1*
This page took 0.073304 seconds and 3 git commands to generate.