]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
up to 1.71.0
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.json
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.70.0
25 %define         bootstrap_cargo %{bootstrap_rust}
26 %define         bootstrap_date  2023-06-01
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.71.0
40 Release:        1
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  81ae525767680c1680bad985ecc35bff
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  afabe6d2054187af74998fd42c516717
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  2d4b19e6e0994fea57c837460612f8d7
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  329cfb044bff54ac749983285bf4819a
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  ba90a8fd5f8af3dd73599434e9f5083f
54 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
55 # Source5-md5:  e8a4cf787e2d82b2ba7b2e63800a1d1a
56 Patch0:         lint_docs_libs.patch
57 Patch1:         bash_comp_location.patch
58 URL:            https://www.rust-lang.org/
59 # for src/compiler-rt
60 BuildRequires:  cmake >= 3.4.3
61 BuildRequires:  curl
62 %ifarch %{arm} %{mips32} %{ppc}
63 BuildRequires:  libatomic-devel
64 %endif
65 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
66 BuildRequires:  procps
67 BuildRequires:  python3
68 BuildRequires:  python3-modules
69 BuildRequires:  rpm-build >= 4.6
70 BuildRequires:  rpmbuild(macros) >= 1.752
71 %if %{without cross}
72 BuildRequires:  curl-devel
73 BuildRequires:  libgit2-devel >= 1.4.0
74 BuildRequires:  libstdc++-devel
75 %if %{with system_llvm}
76 BuildRequires:  llvm >= 14.0
77 BuildRequires:  llvm-devel >= 14.0
78 %endif
79 BuildRequires:  openssl-devel >= 1.0.1
80 BuildRequires:  tar >= 1:1.22
81 BuildRequires:  xz
82 BuildRequires:  xz-devel
83 BuildRequires:  zlib-devel
84 %endif
85 %if %{without bootstrap}
86 BuildRequires:  %{name} >= %{bootstrap_rust}
87 BuildRequires:  cargo >= %{bootstrap_cargo}
88 BuildConflicts: %{name} > %{version}
89 %endif
90 %ifarch x32
91 BuildRequires:  glibc-devel(x86-64)
92 BuildRequires:  glibc-devel(x86-x32)
93 %if "%{_host_cpu}" == "x86_64"
94 # building on x86_64 host with --target x32-pld-linux
95 BuildRequires:  curl-devel
96 BuildRequires:  gcc-multilib-x32
97 BuildRequires:  libgit2-devel >= 1.4.0
98 BuildRequires:  libstdc++-devel
99 %{?with_system_llvm:BuildRequires:      llvm-devel >= 14.0}
100 BuildRequires:  openssl-devel >= 1.0.1
101 BuildRequires:  xz-devel
102 BuildRequires:  zlib-devel
103 %else
104 # building x86_64-hosted crosscompiler on x32 host
105 BuildRequires:  curl-devel(x86-64)
106 BuildRequires:  curl-devel(x86-x32)
107 BuildRequires:  gcc-multilib-64
108 BuildRequires:  libgit2-devel(x86-64) >= 1.4.0
109 BuildRequires:  libgit2-devel(x86-x32) >= 1.4.0
110 BuildRequires:  libstdc++-multilib-64-devel
111 %if %{with system_llvm}
112 BuildRequires:  llvm-devel(x86-64) >= 14.0
113 BuildRequires:  llvm-devel(x86-x32) >= 14.0
114 %endif
115 BuildRequires:  openssl-devel(x86-64)
116 BuildRequires:  openssl-devel(x86-x32)
117 BuildRequires:  xz-devel(x86-64)
118 BuildRequires:  xz-devel(x86-x32)
119 BuildRequires:  zlib-devel(x86-64)
120 BuildRequires:  zlib-devel(x86-x32)
121 %endif
122 %endif
123 # The C compiler is needed at runtime just for linking.  Someday rustc might
124 # invoke the linker directly, and then we'll only need binutils.
125 # https://github.com/rust-lang/rust/issues/11937
126 Requires:       gcc
127 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
128 %ifarch x32
129 Requires:       %{name}-std(x86-64) = %{version}-%{release}
130 Requires:       gcc-multilib-64
131 %endif
132 Obsoletes:      rust-analysis < 1.69.0
133 # Only x86_64 and i686 are Tier 1 platforms at this time.
134 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
135 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
136 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
137 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
138
139 %ifarch x32
140 %define         rust_triple             x86_64-unknown-linux-gnux32
141 %define         rust_host_triple        x86_64-unknown-linux-gnu
142 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
143 # libs in _libdir are x86_64 64bit
144 %define         _lib                    lib64
145 %define         _libdir                 %{_prefix}/lib64
146 %else
147 %ifarch armv6hl
148 %define         rust_triple             arm-unknown-linux-gnueabihf
149 %define         rust_host_triple        %{rust_triple}
150 %define         rust_bootstrap_triple   %{rust_triple}
151 %else
152 %ifarch armv7hl armv7hnl
153 %define         rust_triple             armv7-unknown-linux-gnueabihf
154 %define         rust_host_triple        %{rust_triple}
155 %define         rust_bootstrap_triple   %{rust_triple}
156 %define         rust_suppl_targets      thumbv7neon-unknown-linux-gnueabihf
157 %else
158 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
159 %define         rust_host_triple        %{rust_triple}
160 %define         rust_bootstrap_triple   %{rust_triple}
161 %endif
162 %endif
163 %endif
164
165 %define         rust_targets            %rust_triple %{?rust_suppl_targets}
166
167 %if %{without bootstrap}
168 %define         local_rust_root %{_prefix}
169 %else
170 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
171 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
172 %endif
173
174 # We're going to override --libdir when configuring to get rustlib into a
175 # common path, but we'll fix the shared libraries during install.
176 # Without this ugly hack, rust would not be able to build itself
177 # for non-bootstrap build, lib64 is just too complicated for it.
178 %define         common_libdir   %{_prefix}/lib
179 %define         rustlibdir      %{common_libdir}/rustlib
180
181 # once_call/once_callable non-function libstdc++ symbols
182 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
183
184 # ALL Rust libraries are private, because they don't keep an ABI.
185 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
186 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
187
188 %define         x_py { \
189         x_py() { \
190                 local cmd="$1"; \
191                 shift; \
192                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
193         }; x_py }
194
195
196 %description
197 Rust is a systems programming language that runs blazingly fast,
198 prevents segfaults, and guarantees thread safety.
199
200 This package includes the Rust compiler, standard library, and
201 documentation generator.
202
203 %description -l pl.UTF-8
204 Rust to systemowy język programowania działający bardzo szybko,
205 zapobiegający naruszeniom ochrony pamięci i gwarantujący
206 bezpieczną wielowątkowość.
207
208 %package std
209 Summary:        Standard library for Rust
210 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
211 Group:          Development/Tools
212 Requires:       %{name} = %{version}-%{release}
213
214 %description std
215 Standard library for Rust.
216
217 %description std -l pl.UTF-8
218 Standardowa biblioteka Rusta.
219
220 %package analyzer
221 Summary:        Implementation of Language Server Protocol for Rust
222 Summary(pl.UTF-8):      Implementacja Language Server Protocol dla Rusta
223 Group:          Development/Tools
224 Requires:       %{name} = %{version}-%{release}
225 Obsoletes:      rust-rls < 1.65.0
226
227 %description analyzer
228 Implementation of Language Server Protocol for Rust.
229
230 %description analyzer -l pl.UTF-8
231 Implementacja Language Server Protocol dla Rusta.
232
233 %package debugger-common
234 Summary:        Common debugger pretty printers for Rust
235 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
236 Group:          Development/Debuggers
237 BuildArch:      noarch
238
239 %description debugger-common
240 This package includes the common functionality for rust-gdb and
241 rust-lldb.
242
243 %description debugger-common -l pl.UTF-8
244 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
245
246 %package gdb
247 Summary:        GDB pretty printers for Rust
248 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
249 Group:          Development/Debuggers
250 Requires:       %{name}-debugger-common = %{version}-%{release}
251 Requires:       gdb
252 BuildArch:      noarch
253
254 %description gdb
255 This package includes the rust-gdb script, which allows easier
256 debugging of Rust programs.
257
258 %description gdb -l pl.UTF-8
259 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
260 odpluskwianie programów w języku Rust.
261
262 %package lldb
263 Summary:        LLDB pretty printers for Rust
264 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
265 Group:          Development/Debuggers
266 Requires:       %{name}-debugger-common = %{version}-%{release}
267 Requires:       lldb
268 BuildArch:      noarch
269
270 %description lldb
271 This package includes the rust-lldb script, which allows easier
272 debugging of Rust programs.
273
274 %description lldb -l pl.UTF-8
275 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
276 odpluskwianie programów w języku Rust.
277
278 %package doc
279 Summary:        Documentation for Rust
280 Summary(pl.UTF-8):      Dokumentacja do Rusta
281 Group:          Documentation
282 BuildArch:      noarch
283
284 %description doc
285 This package includes HTML documentation for the Rust programming
286 language and its standard library.
287
288 %description doc -l pl.UTF-8
289 Ten pakiet zawiera dokumentację w formacie HTML do języka
290 programowania Rust i jego biblioteki standardowej.
291
292 %package -n cargo
293 Summary:        Rust's package manager and build tool
294 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
295 Group:          Development/Tools
296 Requires:       %{name}%{?_isa}
297
298 %description -n cargo
299 Cargo is a tool that allows Rust projects to declare their various
300 dependencies and ensure that you'll always get a repeatable build.
301
302 %description -n cargo -l pl.UTF-8
303 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
304 zależności i zapewniające powtarzalność procesu budowania.
305
306 %package -n bash-completion-cargo
307 Summary:        Bash completion for cargo command
308 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
309 Group:          Applications/Shells
310 Requires:       %{name} = %{version}-%{release}
311 Requires:       bash-completion
312 BuildArch:      noarch
313
314 %description -n bash-completion-cargo
315 Bash completion for cargo command.
316
317 %description -n bash-completion-cargo -l pl.UTF-8
318 Bashowe dopełnianie parametrów polecenia cargo.
319
320 %package -n zsh-completion-cargo
321 Summary:        Zsh completion for cargo command
322 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
323 Group:          Applications/Shells
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       zsh
326 BuildArch:      noarch
327
328 %description -n zsh-completion-cargo
329 Zsh completion for cargo command.
330
331 %description -n zsh-completion-cargo -l pl.UTF-8
332 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
333
334 %prep
335 %setup -q -n %{rustc_package}
336 %patch0 -p1
337 %patch1 -p1
338
339 %if %{with bootstrap}
340 %ifarch %{x8664} x32
341 tar xf %{SOURCE1}
342 %endif
343 %ifarch %{ix86}
344 tar xf %{SOURCE2}
345 %endif
346 %ifarch aarch64
347 tar xf %{SOURCE3}
348 %endif
349 %ifarch armv6hl
350 tar xf %{SOURCE4}
351 %endif
352 %ifarch armv7hl armv7hnl
353 tar xf %{SOURCE5}
354 %endif
355 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
356 %{bootstrap_root}-root/install.sh \
357         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
358         --prefix=%{local_rust_root} \
359         --disable-ldconfig
360 test -f %{local_rust_root}/bin/cargo
361 test -f %{local_rust_root}/bin/rustc
362 %endif
363
364 # unbundle
365 # We're disabling jemalloc, but rust-src still wants it.
366 #%{__rm} -r src/jemalloc
367 %if %{with system_llvm}
368 %{__rm} -r src/llvm-project
369 mkdir -p src/llvm-project/libunwind
370 %endif
371
372 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
373 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
374         src/etc/rust-gdb
375
376 # cargo has hardcoded libexec path - honour rpm _libexecdir
377 %if "%{_libexecdir}" != "%{_prefix}/libexec"
378 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
379 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
380         src/bootstrap/dist.rs \
381         src/tools/cargo/src/cargo/util/auth.rs
382 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
383 %endif
384
385 # The configure macro will modify some autoconf-related files, which upsets
386 # cargo when it tries to verify checksums in those files.  If we just truncate
387 # that file list, cargo won't have anything to complain about.
388 find vendor -name .cargo-checksum.json \
389         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
390
391 %build
392 export CC="%{__cc}"
393 export CXX="%{__cxx}"
394 export AR="%{__ar}"
395 %configure \
396         --build=%{rust_bootstrap_triple} \
397         --host=%{rust_host_triple} \
398         --target="%(echo %rust_targets | tr ' ' ,)" \
399         --libdir=%{common_libdir} \
400         --disable-codegen-tests \
401         --disable-debuginfo-lines \
402 %if %{with full_debuginfo}
403         --disable-debuginfo-only-std \
404         --enable-debuginfo \
405 %else
406         --enable-debuginfo-only-std \
407         --disable-debuginfo \
408 %endif
409         --disable-jemalloc \
410         --disable-option-checking \
411         --disable-rpath \
412         --enable-extended \
413         --enable-llvm-link-shared \
414         --enable-vendor \
415         --local-rust-root=%{local_rust_root} \
416         --llvm-root=%{_prefix} \
417         --release-channel=%{channel} \
418         --set=llvm.static-libstdcpp=false
419
420 export RUST_BACKTRACE=full
421 %x_py dist --verbose
422
423 %{?with_tests:%x_py test}
424
425 %install
426 rm -rf $RPM_BUILD_ROOT
427
428 export CC="%{__cc}"
429 export CXX="%{__cxx}"
430 export AR="%{__ar}"
431 export DESTDIR=$RPM_BUILD_ROOT
432 %x_py install
433
434 # Make sure the shared libraries are in the proper libdir
435 %if "%{_libdir}" != "%{common_libdir}"
436 mkdir -p %{buildroot}%{_libdir}
437 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
438         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
439 %endif
440
441 # The shared libraries should be executable for debuginfo extraction.
442 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
443
444 # The libdir libraries are identical to those under rustlib/.  It's easier on
445 # library loading if we keep them in libdir, but we do need them in rustlib/
446 # to support dynamic linking for compiler plugins, so we'll symlink.
447 for rust_target in %rust_targets; do
448         for l in libstd libtest ; do
449                 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
450                 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
451                 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
452                         ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
453                 fi
454         done
455 done
456
457 # Remove installer artifacts (manifests, uninstall scripts, etc.)
458 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
459
460 # FIXME: __os_install_post will strip the rlibs
461 # -- should we find a way to preserve debuginfo?
462
463 # Remove unwanted documentation files (we already package them)
464 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
465 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
466 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
467 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
468
469 # Sanitize the HTML documentation
470 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
471 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
472
473 # Move rust-gdb's python scripts so they're noarch
474 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
475 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
476
477 # We don't need stdlib source
478 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
479
480 # Create the path for crate-devel packages
481 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
482
483 %clean
484 rm -rf $RPM_BUILD_ROOT
485
486 %post   -p /sbin/ldconfig
487 %postun -p /sbin/ldconfig
488
489 %files
490 %defattr(644,root,root,755)
491 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
492 %attr(755,root,root) %{_bindir}/rust-demangler
493 %attr(755,root,root) %{_bindir}/rustc
494 %attr(755,root,root) %{_bindir}/rustdoc
495 %attr(755,root,root) %{_bindir}/rustfmt
496 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
497 %attr(755,root,root) %{_libdir}/libstd-*.so
498 %attr(755,root,root) %{_libdir}/libtest-*.so
499 %{_mandir}/man1/rustc.1*
500 %{_mandir}/man1/rustdoc.1*
501 %dir %{rustlibdir}
502
503 %files std
504 %defattr(644,root,root,755)
505 %(for rust_target in %rust_targets; do
506 cat <<EOF
507 %dir %{rustlibdir}/$rust_target
508 %dir %{rustlibdir}/$rust_target/lib
509 %attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
510 %{rustlibdir}/$rust_target/lib/*.rlib
511 EOF
512 done
513 )
514
515 %files analyzer
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_bindir}/rust-analyzer
518 %attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
519
520 %files debugger-common
521 %defattr(644,root,root,755)
522 %dir %{_datadir}/%{name}
523 %dir %{_datadir}/%{name}/etc
524 %{_datadir}/%{name}/etc/lldb_commands
525 %{_datadir}/%{name}/etc/rust_types.py
526
527 %files lldb
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_bindir}/rust-lldb
530 %{_datadir}/%{name}/etc/lldb_*.py*
531
532 %files gdb
533 %defattr(644,root,root,755)
534 %attr(755,root,root) %{_bindir}/rust-gdb
535 %attr(755,root,root) %{_bindir}/rust-gdbgui
536 %{_datadir}/%{name}/etc/gdb_*.py*
537
538 %files doc
539 %defattr(644,root,root,755)
540 %dir %{_docdir}/%{name}
541 %doc %{_docdir}/%{name}/html
542
543 %files -n cargo
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_bindir}/cargo
546 %attr(755,root,root) %{_bindir}/cargo-clippy
547 %attr(755,root,root) %{_bindir}/cargo-fmt
548 %attr(755,root,root) %{_bindir}/clippy-driver
549 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
550 %{_mandir}/man1/cargo*.1*
551 %dir %{_datadir}/cargo
552 %dir %{_datadir}/cargo/registry
553
554 %files -n bash-completion-cargo
555 %defattr(644,root,root,755)
556 %{_sysconfdir}/bash_completion.d/cargo
557
558 %files -n zsh-completion-cargo
559 %defattr(644,root,root,755)
560 %{zsh_compdir}/_cargo
This page took 0.114638 seconds and 4 git commands to generate.