]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
- versioned obsoletes (rather approximate)
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json or rake
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      392
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 %define         bigdecimal_ver  1.1.0
25 %define         io_console_ver  0.3
26 Summary:        Ruby - interpreted scripting language
27 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
28 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
29 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
30 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
31 Name:           ruby
32 Version:        %{basever}.%{patchlevel}
33 # NOTE: do not decrease Release, when updating Version,
34 # unless rdoc_ver, rubygems_ver *both* are increased as well
35 Release:        8
36 Epoch:          1
37 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
38 License:        (Ruby or BSD) and Public Domain
39 Group:          Development/Languages
40 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{ruby_version}/%{name}-%{basever}-p%{patchlevel}.tar.bz2
41 # Source0-md5:  a810d64e2255179d2f334eb61fb8519c
42 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
43 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
44 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
45 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
46 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
47 # Source3-md5:  1892aadde51d36106c513bced2193dff
48 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
49 # Source100-md5:        50a49edb787211598d08e756e733e42e
50 Source4:        rdoc.1
51 Source5:        testrb.1
52 Patch0:         %{name}-lib64.patch
53 Patch1:         %{name}-ffs.patch
54 Patch2:         fix-bison-invocation.patch
55 # http://redmine.ruby-lang.org/issues/5231
56 Patch3:         disable-versioned-paths.patch
57 # TODO: Should be submitted upstream?
58 Patch4:         arch-specific-dir.patch
59 # http://redmine.ruby-lang.org/issues/5281
60 Patch5:         site-and-vendor-arch-flags.patch
61 # Make mkmf verbose by default
62 Patch6:         mkmf-verbose.patch
63 URL:            http://www.ruby-lang.org/
64 BuildRequires:  autoconf >= 2.60
65 BuildRequires:  automake
66 BuildRequires:  bison
67 BuildRequires:  db-devel
68 BuildRequires:  gdbm-devel >= 1.8.3
69 BuildRequires:  libffi-devel
70 BuildRequires:  ncurses-devel
71 BuildRequires:  openssl-devel
72 BuildRequires:  pkgconfig
73 BuildRequires:  readline-devel >= 4.2
74 BuildRequires:  rpm-build >= 5.4.10-49
75 # boostrap needs ruby binary, erb module
76 %{!?with_bootstrap:BuildRequires:       ruby-modules}
77 %{!?with_bootstrap:BuildRequires:       ruby}
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  yaml-devel
80 %if %{with tk}
81 BuildRequires:  tk-devel
82 %endif
83 Requires(post,postun):  /sbin/ldconfig
84 Provides:       ruby(ver) = %{ruby_version}
85 Obsoletes:      ruby-REXML <= 2.4.0-2
86 Obsoletes:      ruby-doc < 1.8.4
87 Obsoletes:      ruby-fastthread <= 0.6.3
88 %if %{with batteries}
89 Provides:       json = %{json_ver}
90 Provides:       rake = %{rake_ver}
91 Provides:       ruby-json = %{json_ver}
92 Provides:       ruby-rake = %{rake_ver}
93 Obsoletes:      ruby-json <= 1.5.4
94 Obsoletes:      ruby-rake <= 0.9.2.2
95 %endif
96 Conflicts:      ruby-activesupport < 2.3.11-2
97 Conflicts:      ruby-activesupport2 < 2.3.11-2
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
101 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
102
103 # The RubyGems library has to stay out of Ruby directory three, since the
104 # RubyGems should be share by all Ruby implementations.
105 %define rubygems_dir            %{_datadir}/rubygems
106
107 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
108 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
109
110 # This is the local lib/arch and should not be used for packaging.
111 %define sitedir                 site_ruby
112 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
113 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
114 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
115
116 # This is the general location for libs/archs compatible with all
117 # or most of the Ruby versions available in the PLD repositories.
118 %define vendordir               vendor_ruby
119 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
120 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
121 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
122
123 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
124 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
125 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
126 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
127 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
128 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
129 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
130 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
131 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
132
133 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
134 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
135 %define legacy_loadpath         %{legacy_archdir}
136 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
137
138 # bleh, some nasty (gcc or ruby) bug still not fixed
139 # (SEGV or "unexpected break" on miniruby run during build)
140 %define         specflags_ia64  -O0
141
142 # ruby needs frame pointers for correct exception handling
143 %define         specflags_ia32  -fno-omit-frame-pointer
144
145 %description
146 Ruby is the interpreted scripting language for quick and easy
147 object-oriented programming. It has many features to process text
148 files and to do system management tasks (as in Perl). It is simple,
149 straight-forward, extensible, and portable.
150
151 This package contains only shared library and ruby interpreter. To get
152 full-functional ruby environment install ruby-modules package.
153
154 %description -l ja.UTF-8
155 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
156 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
157 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
158
159 %description -l pl.UTF-8
160 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
161 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
162 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
163 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
164 rozszerzalny i przenośny.
165
166 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
167 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
168 funkcjonalnego środowiska ruby.
169
170 %description -l pt_BR.UTF-8
171 Ruby é uma linguagem de script interpretada de programação orientada a
172 objeto. Possui diversas características para processamento de texto. É
173 simples, extensível e direta.
174
175 %package modules
176 Summary:        Ruby standard modules and utilities
177 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
178 Group:          Development/Languages
179 Requires:       %{name} = %{epoch}:%{version}-%{release}
180 Suggests:       ruby-rubygems
181 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
182 Provides:       ruby-io-console = %{io_console_ver}
183 Provides:       ruby-json = %{json_ver}
184 Provides:       ruby-minitest = %{minitest_ver}
185 Provides:       ruby-rake = %{rake_ver}
186 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
187 Provides:       ruby-modules(ver) = %{ruby_version}
188 Obsoletes:      ruby-minitest <= 1.5.0
189
190 %description modules
191 Ruby standard modules and utilities:
192 - erb - Tiny eRuby
193 - irb - interactive Ruby
194 - testrb - automatic runner for Test::Unit of Ruby
195
196 %description modules -l pl.UTF-8
197 Standardowe moduły i narzędzia Ruby:
198 - erb - mały eRuby
199 - irb - interaktywny Ruby
200 - testrb - automatyczny runner dla Ruby Test::Unit
201
202 %package tk
203 Summary:        Ruby/Tk bindings
204 Summary(pl.UTF-8):      Wiązania Ruby/Tk
205 Group:          Development/Languages
206 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
207
208 %description tk
209 This pachage contains Ruby/Tk bindings.
210
211 %description tk -l pl.UTF-8
212 Ten pakiet zawiera wiązania Ruby/Tk.
213
214 %package devel
215 Summary:        Ruby development libraries
216 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
217 Group:          Development/Languages
218 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
219 Requires:       pkgconfig
220
221 %description devel
222 Ruby development libraries.
223
224 %description devel -l pl.UTF-8
225 Biblioteki programistyczne interpretera języka Ruby.
226
227 %package static
228 Summary:        Ruby static libraries
229 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
230 Group:          Development/Languages
231 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
232
233 %description static
234 Ruby static libraries.
235
236 %description static -l pl.UTF-8
237 Biblioteki statyczne Ruby.
238
239 %package doc
240 Summary:        Ruby HTML documentation
241 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
242 Group:          Documentation
243
244 %description doc
245 Ruby HTML documentation: FAQ, guide, core and standard library.
246
247 %description doc -l pl.UTF-8
248 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
249 stdlib.
250
251 %package doc-ri
252 Summary:        Ruby ri documentation
253 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
254 Group:          Documentation
255 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
256
257 %description doc-ri
258 Ruby ri documentation.
259
260 %description doc-ri -l pl.UTF-8
261 Dokumentacja Ruby w formacie ri.
262
263 %package examples
264 Summary:        Ruby examples
265 Summary(pl.UTF-8):      Przykłady dla języka Ruby
266 Group:          Development/Languages
267
268 %description examples
269 Ruby examples.
270
271 %description examples -l pl.UTF-8
272 Przykłady programów w języku Ruby.
273
274 # IMPORTANT: keep this as last package, as we reset Epoch
275 %package rdoc
276 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
277 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
278 Version:        %{rdoc_ver}
279 Epoch:          0
280 License:        GPL v2 and Ruby and MIT
281 Group:          Development/Libraries
282 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
283 Obsoletes:      rdoc <= 0.9.0
284
285 %description rdoc
286 RDoc produces HTML and command-line documentation for Ruby projects.
287 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
288 online documentation.
289
290 %description rdoc -l pl.UTF-8
291 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
292 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
293 wyświetlania dokumentacji online.
294
295 %package rubygems
296 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
297 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
298 Version:        %{rubygems_ver}
299 Epoch:          0
300 License:        Ruby or MIT
301 Group:          Development/Libraries
302 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
303 Requires:       %{name}-rdoc >= %{rdoc_ver}
304 Provides:       rubygems = %{rubygems_ver}
305 %if "%{_rpmversion}" >= "5"
306 BuildArch:      noarch
307 %endif
308
309 %description rubygems
310 RubyGems is the Ruby standard for publishing and managing third party
311 libraries.
312
313 %description rubygems -l pl.UTF-8
314 RubyGems to standardowe narzędzie języka Ruby do publikowania i
315 zarządzania zewnętrznymi bibliotekami.
316
317 %prep
318 %if %{with bootstrap}
319 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
320 %else
321 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
322 %endif
323 %patch0 -p1
324 %patch1 -p1
325 %patch2 -p1
326 %patch3 -p1
327 %patch4 -p1
328 %patch5 -p1
329
330 # must be regenerated with new bison
331 %{__rm} parse.{c,h}
332
333 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
334
335 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
336         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
337         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
338
339 %build
340 cp -f /usr/share/automake/config.sub .
341
342 # build ruby-1.8.7 first
343 %if %{with bootstrap}
344 cd %{name}-1.8.7-p330
345 %configure
346 %{__make}
347 cd ..
348 %endif
349
350 %{__autoconf}
351 %configure \
352         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
353         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
354         --with-archdir=%{ruby_archdir} \
355         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
356         --with-sitearchdir=%{ruby_sitearchdir} \
357         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
358         --with-vendorarchdir=%{ruby_vendorarchdir} \
359         --with-rubygemsdir=%{rubygems_dir} \
360         --with-search-path="%{legacy_loadpaths}" \
361         --enable-shared \
362         --enable-pthread \
363         --disable-rubygems \
364         --disable-install-doc \
365         --with-ruby-version=minor
366
367 %{__make} -j1 main \
368         COPY="cp -p" Q= \
369         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
370
371 %if %{with doc}
372 %{__make} -j1 rdoc
373 %endif
374
375 %install
376 rm -rf $RPM_BUILD_ROOT
377 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
378         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
379         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
380         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
381
382 %{__make} install %{?with_doc:install-doc} \
383         DESTDIR=$RPM_BUILD_ROOT
384
385 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
386 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
387 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
388
389 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
390
391 %if %{without batteries}
392 # packaged separately
393 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json}
394 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
395 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
396 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
397 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
398 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON
399 %endif
400
401 %if %{with doc}
402 # too much .ri
403 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
404 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
405 %endif
406
407 %clean
408 rm -rf $RPM_BUILD_ROOT
409
410 %post   -p /sbin/ldconfig
411 %postun -p /sbin/ldconfig
412
413 %files
414 %defattr(644,root,root,755)
415 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
416 %attr(755,root,root) %{_bindir}/ruby
417 %if %{with batteries}
418 %attr(755,root,root) %{_bindir}/rake
419 %endif
420 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
422 %{_mandir}/man1/ruby.1*
423 %if %{with batteries}
424 %{_mandir}/man1/rake.1*
425 %endif
426
427 %dir %{_libdir}/%{name}
428 %dir %{_libdir}/%{name}/%{vendordir}
429 %dir %{_datadir}/%{name}
430 %dir %{_datadir}/%{name}/%{vendordir}
431
432 %dir %{ruby_libdir}
433 %dir %{ruby_archdir}
434 %dir %{ruby_vendorlibdir}
435 %dir %{ruby_vendorarchdir}
436
437 %dir %{_datadir}/ri
438 %dir %{_datadir}/ri/%{ruby_version}
439 %dir %{ruby_ridir}
440
441 %dir %{ruby_rdocdir}
442
443 # common dirs for ruby vendor modules
444 %dir %{ruby_vendorlibdir}/net
445
446 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
447 %dir %{legacy_archdir}
448 %dir %{legacy_sitedir}
449 %dir %{legacy_sitelibdir}
450 %dir %{legacy_sitearchdir}
451 %dir %{legacy_vendorarchdir}
452 %dir %{legacy_libdir}/tasks
453 %dir %{legacy_archdir}/racc
454
455 %files devel
456 %defattr(644,root,root,755)
457 %attr(755,root,root) %{_libdir}/libruby.so
458 %{_includedir}/%{name}-%{ruby_version}
459 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
460 %{ruby_libdir}/mkmf.rb
461
462 %files static
463 %defattr(644,root,root,755)
464 %{_libdir}/libruby-static.a
465
466 %if %{with tk}
467 %files tk
468 %defattr(644,root,root,755)
469 %{ruby_libdir}/tcltk.rb
470 %{ruby_libdir}/tk*.rb
471 %{ruby_libdir}/tk
472 %{ruby_libdir}/tkextlib
473 %attr(755,root,root) %{ruby_archdir}/t*.so
474 %endif
475
476 %files rdoc
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_bindir}/rdoc
479 %attr(755,root,root) %{_bindir}/ri
480 %{_mandir}/man1/rdoc.1*
481 %{ruby_libdir}/rdoc
482 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
483 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
484 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
485 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
486 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
487
488 %if %{with batteries}
489 %files rubygems
490 %defattr(644,root,root,755)
491 %attr(755,root,root) %{_bindir}/gem
492 %{ruby_libdir}/rubygems
493 %{ruby_libdir}/rubygems.rb
494 %{ruby_libdir}/ubygems.rb
495
496 %if %{with batteries}
497 %dir %{gem_dir}/gems/rake-%{rake_ver}
498 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
499 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
500 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
501 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
502 %{gem_dir}/specifications/json-%{json_ver}.gemspec
503 %endif
504 %endif
505
506 %files modules
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_bindir}/erb
509 %attr(755,root,root) %{_bindir}/irb
510 %attr(755,root,root) %{_bindir}/testrb
511 %{ruby_libdir}/bigdecimal
512 %{ruby_libdir}/cgi
513 %{ruby_libdir}/date
514 %{ruby_libdir}/digest
515 %{ruby_libdir}/dl
516 %{ruby_libdir}/drb
517 %{ruby_libdir}/fiddle
518 %{ruby_libdir}/io
519 %{ruby_libdir}/irb
520 %{ruby_libdir}/matrix
521 %{ruby_libdir}/minitest
522 %{ruby_libdir}/net
523 %{ruby_libdir}/openssl
524 %{ruby_libdir}/optparse
525 %if %{with batteries}
526 %{ruby_libdir}/json
527 %{ruby_libdir}/rake
528 %endif
529 %{ruby_libdir}/psych
530 %{ruby_libdir}/racc
531 %{ruby_libdir}/rbconfig
532 %{ruby_libdir}/rexml
533 %{ruby_libdir}/rinda
534 %{ruby_libdir}/ripper
535 %{ruby_libdir}/rss
536 %{ruby_libdir}/shell
537 %{ruby_libdir}/syck
538 %{ruby_libdir}/test
539 %{ruby_libdir}/uri
540 %{ruby_libdir}/webrick
541 %{ruby_libdir}/xmlrpc
542 %{ruby_libdir}/yaml
543 %{ruby_libdir}/[A-Za-s]*.rb
544 %{ruby_libdir}/tempfile.rb
545 %{ruby_libdir}/thread.rb
546 %{ruby_libdir}/thwait.rb
547 %{ruby_libdir}/time.rb
548 %{ruby_libdir}/timeout.rb
549 %{ruby_libdir}/tmpdir.rb
550 %{ruby_libdir}/tracer.rb
551 %{ruby_libdir}/tsort.rb
552 %{ruby_libdir}/[u-z]*.rb
553 %exclude %{ruby_libdir}/rubygems.rb
554 %exclude %{ruby_libdir}/ubygems.rb
555 %exclude %{ruby_libdir}/mkmf.rb
556 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
557 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
558 %dir %{ruby_archdir}/digest
559 %attr(755,root,root) %{ruby_archdir}/digest/*.so
560 %dir %{ruby_archdir}/dl
561 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
562 %dir %{ruby_archdir}/enc
563 %attr(755,root,root) %{ruby_archdir}/enc/*.so
564 %dir %{ruby_archdir}/enc/trans
565 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
566 %dir %{ruby_archdir}/io
567 %attr(755,root,root) %{ruby_archdir}/io/*.so
568 %if %{with batteries}
569 %dir %{ruby_archdir}/json
570 %dir %{ruby_archdir}/json/ext
571 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
572 %endif
573 %dir %{ruby_archdir}/mathn
574 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
575 %dir %{ruby_archdir}/racc
576 %attr(755,root,root) %{ruby_archdir}/racc/*.so
577 %{ruby_archdir}/rbconfig.rb
578
579 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
580 %{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
581
582 # parents of gem_dir
583 %dir %{_datadir}/%{name}/gems
584 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
585 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
586
587 %dir %{gem_dir}
588 %dir %{gem_dir}/specifications
589 %{_mandir}/man1/erb.1*
590 %{_mandir}/man1/irb.1*
591 %{_mandir}/man1/ri.1*
592 %{_mandir}/man1/testrb.1*
593
594 %files doc
595 %defattr(644,root,root,755)
596 %doc ruby-doc-bundle/*
597 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
598 %{?with_doc:%doc ruby_%{doc_version}_core}
599
600 %if %{with doc}
601 %files doc-ri
602 %defattr(644,root,root,755)
603 %{ruby_ridir}/*
604 %endif
605
606 %files examples
607 %defattr(644,root,root,755)
608 %{_examplesdir}/%{name}-%{version}
This page took 0.109316 seconds and 4 git commands to generate.