]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
up to 1.9.3-484 (2013-11-22)
[packages/ruby.git] / ruby.spec
1 # TODO:
2 #       - include ext/ in docs
3 #       - replace ri with fastri
4 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
5 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
6 #   - custom-rubygems-location.patch
7 #
8 # Conditional build:
9 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
10 %bcond_without  tk              # skip building package with Tk bindings
11 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
12 %bcond_with     bootstrap       # build bootstrap version
13
14 %define         rel             1
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      484
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 # when increasing rubygems_ver, please remove "11." prefix in rubygems package release
22 %define         rubygems_ver    1.8.11
23 %define         minitest_ver    2.5.1
24 # when increasing rdoc_ver, please remove "11." prefix in rdoc package release
25 %define         rdoc_ver        3.9.5
26 %define         irb_ver         0.9.6
27 %define         bigdecimal_ver  1.1.0
28 %define         io_console_ver  0.3
29 Summary:        Ruby - interpreted scripting language
30 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
31 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
32 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
33 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
34 Name:           ruby
35 Version:        %{basever}.%{patchlevel}
36 Release:        %{rel}
37 Epoch:          1
38 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
39 License:        (Ruby or BSD) and Public Domain
40 Group:          Development/Languages
41 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/1.9/%{name}-%{basever}-p%{patchlevel}.tar.bz2
42 # Source0-md5:  03f5b08804927ceabe5122cb90f5d0a9
43 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
44 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
45 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
46 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
47 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
48 # Source3-md5:  1892aadde51d36106c513bced2193dff
49 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
50 # Source100-md5:        50a49edb787211598d08e756e733e42e
51 Source4:        rdoc.1
52 Source5:        testrb.1
53 Patch0:         %{name}-lib64.patch
54 Patch1:         %{name}-ffs.patch
55 Patch2:         fix-bison-invocation.patch
56 # http://redmine.ruby-lang.org/issues/5231
57 Patch3:         disable-versioned-paths.patch
58 # TODO: Should be submitted upstream?
59 Patch4:         arch-specific-dir.patch
60 # http://redmine.ruby-lang.org/issues/5281
61 Patch5:         site-and-vendor-arch-flags.patch
62 # Make mkmf verbose by default
63 Patch6:         mkmf-verbose.patch
64 Patch7:         strip-ccache.patch
65 URL:            http://www.ruby-lang.org/
66 BuildRequires:  autoconf >= 2.60
67 BuildRequires:  automake
68 BuildRequires:  bison >= 1.875
69 BuildRequires:  db-devel
70 BuildRequires:  gdbm-devel >= 1.8.3
71 BuildRequires:  libffi-devel
72 BuildRequires:  ncurses-devel
73 BuildRequires:  openssl-devel
74 BuildRequires:  pkgconfig
75 BuildRequires:  readline-devel >= 4.2
76 BuildRequires:  rpm-build >= 5.4.10-49
77 # boostrap needs ruby binary, erb module
78 %{!?with_bootstrap:BuildRequires:       ruby-modules}
79 %{!?with_bootstrap:BuildRequires:       ruby}
80 BuildRequires:  sed >= 4.0
81 BuildRequires:  yaml-devel
82 %if %{with tk}
83 BuildRequires:  tk-devel
84 %endif
85 Requires(post,postun):  /sbin/ldconfig
86 Provides:       ruby(ver) = %{ruby_version}
87 Obsoletes:      ruby-REXML <= 2.4.0-2
88 Obsoletes:      ruby-doc < 1.8.4
89 Obsoletes:      ruby-fastthread <= 0.6.3
90 Conflicts:      ruby-activesupport < 2.3.11-2
91 Conflicts:      ruby-activesupport2 < 2.3.11-2
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
95 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
96
97 # The RubyGems library has to stay out of Ruby directory three, since the
98 # RubyGems should be share by all Ruby implementations.
99 %define rubygems_dir            %{_datadir}/rubygems
100
101 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
102 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
103
104 # This is the local lib/arch and should not be used for packaging.
105 %define sitedir                 site_ruby
106 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
107 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
108 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
109
110 # This is the general location for libs/archs compatible with all
111 # or most of the Ruby versions available in the PLD repositories.
112 %define vendordir               vendor_ruby
113 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
114 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
115 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
116
117 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
118 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
119 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
120 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
121 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
122 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
123 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
124 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
125 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
126
127 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
128 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
129 %define legacy_loadpath         %{legacy_archdir}
130 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
131
132 # bleh, some nasty (gcc or ruby) bug still not fixed
133 # (SEGV or "unexpected break" on miniruby run during build)
134 %define         specflags_ia64  -O0
135
136 # ruby needs frame pointers for correct exception handling
137 %define         specflags_ia32  -fno-omit-frame-pointer
138
139 %description
140 Ruby is the interpreted scripting language for quick and easy
141 object-oriented programming. It has many features to process text
142 files and to do system management tasks (as in Perl). It is simple,
143 straight-forward, extensible, and portable.
144
145 This package contains only shared library and ruby interpreter. To get
146 full-functional ruby environment install ruby-modules package.
147
148 %description -l ja.UTF-8
149 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
150 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
151 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
152
153 %description -l pl.UTF-8
154 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
155 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
156 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
157 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
158 rozszerzalny i przenośny.
159
160 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
161 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
162 funkcjonalnego środowiska ruby.
163
164 %description -l pt_BR.UTF-8
165 Ruby é uma linguagem de script interpretada de programação orientada a
166 objeto. Possui diversas características para processamento de texto. É
167 simples, extensível e direta.
168
169 %package modules
170 Summary:        Ruby standard modules and utilities
171 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
172 Group:          Development/Languages
173 Requires:       %{name} = %{epoch}:%{version}-%{release}
174 Suggests:       ruby-rubygems
175 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
176 Provides:       ruby-io-console = %{io_console_ver}
177 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
178 Provides:       ruby-modules(ver) = %{ruby_version}
179 %if %{with batteries}
180 Provides:       ruby-minitest = %{minitest_ver}
181 Obsoletes:      ruby-minitest <= 1.5.0
182 %endif
183
184 %description modules
185 Ruby standard modules and utilities:
186 - erb - Tiny eRuby
187 - testrb - automatic runner for Test::Unit of Ruby
188
189 %description modules -l pl.UTF-8
190 Standardowe moduły i narzędzia Ruby:
191 - erb - mały eRuby
192 - testrb - automatyczny runner dla Ruby Test::Unit
193
194 %package tk
195 Summary:        Ruby/Tk bindings
196 Summary(pl.UTF-8):      Wiązania Ruby/Tk
197 Group:          Development/Languages
198 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
199
200 %description tk
201 This pachage contains Ruby/Tk bindings.
202
203 %description tk -l pl.UTF-8
204 Ten pakiet zawiera wiązania Ruby/Tk.
205
206 %package devel
207 Summary:        Ruby development libraries
208 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
209 Group:          Development/Languages
210 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
211 Requires:       gcc
212 Requires:       glibc-devel
213 Requires:       pkgconfig
214
215 %description devel
216 Ruby development libraries.
217
218 %description devel -l pl.UTF-8
219 Biblioteki programistyczne interpretera języka Ruby.
220
221 %package static
222 Summary:        Ruby static libraries
223 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
224 Group:          Development/Languages
225 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
226
227 %description static
228 Ruby static libraries.
229
230 %description static -l pl.UTF-8
231 Biblioteki statyczne Ruby.
232
233 %package doc
234 Summary:        Ruby HTML documentation
235 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
236 Group:          Documentation
237 %if "%{_rpmversion}" >= "5"
238 BuildArch:      noarch
239 %endif
240
241 %description doc
242 Ruby HTML documentation: FAQ, guide, core and standard library.
243
244 %description doc -l pl.UTF-8
245 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
246 stdlib.
247
248 %package doc-ri
249 Summary:        Ruby ri documentation
250 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
251 Group:          Documentation
252 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
253 %if "%{_rpmversion}" >= "5"
254 BuildArch:      noarch
255 %endif
256
257 %description doc-ri
258 Ruby ri documentation.
259
260 %description doc-ri -l pl.UTF-8
261 Dokumentacja Ruby w formacie ri.
262
263 %package examples
264 Summary:        Ruby examples
265 Summary(pl.UTF-8):      Przykłady dla języka Ruby
266 Group:          Development/Languages
267 %if "%{_rpmversion}" >= "5"
268 BuildArch:      noarch
269 %endif
270
271 %description examples
272 Ruby examples.
273
274 %description examples -l pl.UTF-8
275 Przykłady programów w języku Ruby.
276
277 # IMPORTANT: keep irb, rdoc, rubygems, rake, json as last packages as we reset epoch/version/release
278 # and %{version},%{release} macros may not be used directly as they take last
279 # subpackage value not main package one what you intend to use
280
281 %package irb
282 Summary:        The Interactive Ruby
283 Version:        %{irb_ver}
284 Group:          Development/Languages
285 Release:        %{basever}.%{patchlevel}.%{rel}
286 Epoch:          0
287 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
288 Provides:       irb = %{version}-%{release}
289 Provides:       ruby(irb) = %{version}-%{release}
290 %if "%{_rpmversion}" >= "5"
291 BuildArch:      noarch
292 %endif
293
294 %description irb
295 The irb is acronym for Interactive Ruby. It evaluates ruby expression
296 from the terminal.
297
298 %package rdoc
299 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
300 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
301 Version:        %{rdoc_ver}
302 # remove "11." when rdoc_ver is increased
303 Release:        11.%{basever}.%{patchlevel}.%{rel}
304 Epoch:          0
305 License:        GPL v2 and Ruby and MIT
306 Group:          Development/Libraries
307 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
308 Obsoletes:      rdoc <= 0.9.0
309 %if "%{_rpmversion}" >= "5"
310 BuildArch:      noarch
311 %endif
312
313 %description rdoc
314 RDoc produces HTML and command-line documentation for Ruby projects.
315 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
316 online documentation.
317
318 %description rdoc -l pl.UTF-8
319 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
320 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
321 wyświetlania dokumentacji online.
322
323 %package rubygems
324 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
325 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
326 Version:        %{rubygems_ver}
327 # remove "11." when rubygems_ver is increased
328 Release:        11.%{basever}.%{patchlevel}.%{rel}
329 Epoch:          0
330 License:        Ruby or MIT
331 Group:          Development/Libraries
332 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
333 Requires:       %{name}-rdoc >= %{rdoc_ver}
334 Suggests:       %{name}-devel
335 Provides:       rubygems = %{rubygems_ver}
336 %if "%{_rpmversion}" >= "5"
337 BuildArch:      noarch
338 %endif
339
340 %description rubygems
341 RubyGems is the Ruby standard for publishing and managing third party
342 libraries.
343
344 %description rubygems -l pl.UTF-8
345 RubyGems to standardowe narzędzie języka Ruby do publikowania i
346 zarządzania zewnętrznymi bibliotekami.
347
348 %package rake
349 Summary:        Rake is a Make-like program implemented in Ruby
350 Summary(pl.UTF-8):      Program typu Make dla języka Ruby
351 Version:        %{rake_ver}
352 Release:        %{basever}.%{patchlevel}.%{rel}
353 Epoch:          0
354 License:        MIT
355 Group:          Development/Languages
356 Provides:       rake = %{rake_ver}
357 Conflicts:      ruby-modules < 1:1.9.3.429-2
358 %if "%{_rpmversion}" >= "5"
359 BuildArch:      noarch
360 %endif
361
362 %description rake
363 Rake is a simple Ruby build program with capabilities similar to make.
364
365 It has the following features:
366 - Rakefiles (rake's version of Makefiles) are completely defined in
367   standard Ruby syntax. No XML files to edit. No quirky Makefile syntax
368   to worry about (is that a tab or a space?)
369 - Users can specify tasks with prerequisites.
370 - Rake supports rule patterns to synthesize implicit tasks.
371 - Rake is lightweight. It can be distributed with other projects as a
372   single file. Projects that depend upon rake do not require that rake
373   be installed on target systems.
374
375 %description rake -l pl.UTF-8
376 Rake to prosty program do budowania w języku Ruby o możliwościach
377 podobnych do make.
378
379 Ma następujące cechy:
380 - Pliki Rakefile (rake'owa odmiana plików Makefile) są definiowane
381   całkowicie w standardowej składni języka Ruby. Nie trzeba modyfikować
382   plików XML. Nie trzeba martwić się kaprysami składni Makefile (czy to
383   tabulacja czy spacja?).
384 - Użytkownicy mogą określać zadania z ich zależnościami.
385 - Rake obsługuje wzorce reguł do tworzenia z nich wynikowych zadań.
386 - Rake jest lekki. Może być rozpowszechniany z innymi projektami jako
387   pojedynczy plik. Projekty używające rake'a nie wymagają go
388   zainstalowanego na systemach docelowych.
389
390 %package json
391 Summary:        JSON library for Ruby
392 Summary(pl.UTF-8):      Biblioteka JSON dla języka Ruby
393 Version:        %{json_ver}
394 Release:        %{basever}.%{patchlevel}.%{rel}
395 Epoch:          0
396 License:        MIT
397 Group:          Development/Languages
398 Obsoletes:      ruby-json-rubyforge
399 Conflicts:      ruby-modules < 1:1.9.3.429-3
400
401 %description json
402 This is a JSON implementation as a Ruby extension in C.
403
404 %description json -l pl.UTF-8
405 Biblioteka JSON dla języka Ruby.
406
407 %prep
408 %if %{with bootstrap}
409 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
410 %else
411 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
412 %endif
413 %patch0 -p1
414 %patch1 -p1
415 %patch2 -p1
416 %patch3 -p1
417 %patch4 -p1
418 %patch5 -p1
419 %patch6 -p1
420 %patch7 -p1
421
422 # must be regenerated with new bison
423 %{__rm} parse.{c,h}
424
425 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
426
427 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
428         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
429         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
430
431 %build
432 cp -f /usr/share/automake/config.sub .
433
434 # build ruby-1.8.7 first
435 %if %{with bootstrap}
436 cd %{name}-1.8.7-p330
437 %configure
438 %{__make}
439 cd ..
440 %endif
441
442 %{__autoconf}
443 %configure \
444         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
445         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
446         --with-archdir=%{ruby_archdir} \
447         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
448         --with-sitearchdir=%{ruby_sitearchdir} \
449         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
450         --with-vendorarchdir=%{ruby_vendorarchdir} \
451         --with-rubygemsdir=%{rubygems_dir} \
452         --with-search-path="%{legacy_loadpaths}" \
453         --enable-shared \
454         --enable-pthread \
455         --disable-rubygems \
456         --disable-install-doc \
457         --with-ruby-version=minor
458
459 %{__make} -j1 main \
460         COPY="cp -p" Q= \
461         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
462
463 %if %{with doc}
464 %{__make} -j1 rdoc
465 %endif
466
467 %install
468 rm -rf $RPM_BUILD_ROOT
469 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
470         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
471         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
472         $RPM_BUILD_ROOT%{ruby_vendordir}/data \
473         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
474
475 %{__make} install %{?with_doc:install-doc} \
476         DESTDIR=$RPM_BUILD_ROOT
477
478 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
479 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
480 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
481
482 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
483
484 ln -sf %{gem_dir}/gems/rake-%{rake_ver}/bin/rake $RPM_BUILD_ROOT%{_bindir}/rake
485
486 %if %{without batteries}
487 # packaged separately
488 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
489 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
490 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
491 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
492 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
493 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
494 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/{json,minitest,rake}-*.gemspec
495 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
496 %endif
497
498 %if %{with doc}
499 # too much .ri
500 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
501 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
502 %endif
503
504 %clean
505 rm -rf $RPM_BUILD_ROOT
506
507 %post   -p /sbin/ldconfig
508 %postun -p /sbin/ldconfig
509
510 %files
511 %defattr(644,root,root,755)
512 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
513 %attr(755,root,root) %{_bindir}/ruby
514 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
515 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
516 %{_mandir}/man1/ruby.1*
517
518 %dir %{_libdir}/%{name}
519 %dir %{_libdir}/%{name}/%{vendordir}
520 %dir %{_datadir}/%{name}
521
522 %dir %{ruby_libdir}
523 %dir %{ruby_archdir}
524 %dir %{ruby_vendordir}
525 %dir %{ruby_vendordir}/data
526 %dir %{ruby_vendorlibdir}
527 %dir %{ruby_vendorarchdir}
528
529 %dir %{_datadir}/ri
530 %dir %{_datadir}/ri/%{ruby_version}
531 %dir %{ruby_ridir}
532
533 %dir %{ruby_rdocdir}
534
535 # common dirs for ruby vendor modules
536 %dir %{ruby_vendorlibdir}/net
537
538 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
539 %dir %{legacy_archdir}
540 %dir %{legacy_sitedir}
541 %dir %{legacy_sitelibdir}
542 %dir %{legacy_sitearchdir}
543 %dir %{legacy_vendorarchdir}
544 %dir %{legacy_libdir}/tasks
545 %dir %{legacy_archdir}/racc
546
547 %files devel
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/libruby.so
550 %{_includedir}/%{name}-%{ruby_version}
551 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
552 %{ruby_libdir}/mkmf.rb
553
554 %files static
555 %defattr(644,root,root,755)
556 %{_libdir}/libruby-static.a
557
558 %if %{with tk}
559 %files tk
560 %defattr(644,root,root,755)
561 %{ruby_libdir}/tcltk.rb
562 %{ruby_libdir}/tk*.rb
563 %{ruby_libdir}/tk
564 %{ruby_libdir}/tkextlib
565 %attr(755,root,root) %{ruby_archdir}/t*.so
566 %endif
567
568 %files irb
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_bindir}/irb
571 %{ruby_libdir}/irb.rb
572 %{ruby_libdir}/irb
573 %{_mandir}/man1/irb.1*
574
575 %files rdoc
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_bindir}/rdoc
578 %attr(755,root,root) %{_bindir}/ri
579 %{_mandir}/man1/rdoc.1*
580 %{ruby_libdir}/rdoc
581 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
582 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
583 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
584 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
585 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
586
587 %if %{with batteries}
588 %files rubygems
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_bindir}/gem
591 %{ruby_libdir}/rubygems
592 %{ruby_libdir}/rubygems.rb
593 %{ruby_libdir}/ubygems.rb
594
595 %files rake
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_bindir}/rake
598 %{_mandir}/man1/rake.1*
599 %{ruby_libdir}/rake
600 %dir %{gem_dir}/gems/rake-%{rake_ver}
601 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
602 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
603 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
604
605 %files json
606 %defattr(644,root,root,755)
607 %{ruby_libdir}/json
608 %dir %{ruby_archdir}/json
609 %dir %{ruby_archdir}/json/ext
610 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
611 %{gem_dir}/specifications/json-%{json_ver}.gemspec
612 %endif
613
614 %files modules
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/erb
617 %attr(755,root,root) %{_bindir}/testrb
618 %{ruby_libdir}/bigdecimal
619 %{ruby_libdir}/cgi
620 %{ruby_libdir}/date
621 %{ruby_libdir}/digest
622 %{ruby_libdir}/dl
623 %{ruby_libdir}/drb
624 %{ruby_libdir}/fiddle
625 %{ruby_libdir}/io
626 %{ruby_libdir}/matrix
627 %{ruby_libdir}/net
628 %{ruby_libdir}/openssl
629 %{ruby_libdir}/optparse
630 %{ruby_libdir}/psych
631 %{ruby_libdir}/racc
632 %{ruby_libdir}/rbconfig
633 %{ruby_libdir}/rexml
634 %{ruby_libdir}/rinda
635 %{ruby_libdir}/ripper
636 %{ruby_libdir}/rss
637 %{ruby_libdir}/shell
638 %{ruby_libdir}/syck
639 %{ruby_libdir}/test
640 %{ruby_libdir}/uri
641 %{ruby_libdir}/webrick
642 %{ruby_libdir}/xmlrpc
643 %{ruby_libdir}/yaml
644 %{ruby_libdir}/[A-Za-s]*.rb
645 %{ruby_libdir}/tempfile.rb
646 %{ruby_libdir}/thread.rb
647 %{ruby_libdir}/thwait.rb
648 %{ruby_libdir}/time.rb
649 %{ruby_libdir}/timeout.rb
650 %{ruby_libdir}/tmpdir.rb
651 %{ruby_libdir}/tracer.rb
652 %{ruby_libdir}/tsort.rb
653 %{ruby_libdir}/[u-z]*.rb
654 %if %{with batteries}
655 %exclude %{ruby_libdir}/rubygems.rb
656 %exclude %{ruby_libdir}/ubygems.rb
657 %endif
658 %exclude %{ruby_libdir}/irb.rb
659 %exclude %{ruby_libdir}/mkmf.rb
660 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
661 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
662 %dir %{ruby_archdir}/digest
663 %attr(755,root,root) %{ruby_archdir}/digest/*.so
664 %dir %{ruby_archdir}/dl
665 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
666 %dir %{ruby_archdir}/enc
667 %attr(755,root,root) %{ruby_archdir}/enc/*.so
668 %dir %{ruby_archdir}/enc/trans
669 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
670 %dir %{ruby_archdir}/io
671 %attr(755,root,root) %{ruby_archdir}/io/*.so
672 %dir %{ruby_archdir}/mathn
673 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
674 %dir %{ruby_archdir}/racc
675 %attr(755,root,root) %{ruby_archdir}/racc/*.so
676 %{ruby_archdir}/rbconfig.rb
677
678 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
679 %{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
680
681 %if %{with batteries}
682 # minitest
683 %{ruby_libdir}/minitest
684 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
685 %endif
686
687 # parents of gem_dir
688 %dir %{_datadir}/%{name}/gems
689 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
690 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
691
692 %dir %{gem_dir}
693 %dir %{gem_dir}/specifications
694 %{_mandir}/man1/erb.1*
695 %{_mandir}/man1/ri.1*
696 %{_mandir}/man1/testrb.1*
697
698 %files doc
699 %defattr(644,root,root,755)
700 %doc ruby-doc-bundle/*
701 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
702 %{?with_doc:%doc ruby_%{doc_version}_core}
703
704 %if %{with doc}
705 %files doc-ri
706 %defattr(644,root,root,755)
707 %{ruby_ridir}/*
708 %endif
709
710 %files examples
711 %defattr(644,root,root,755)
712 %{_examplesdir}/%{name}-%{version}
This page took 0.112457 seconds and 4 git commands to generate.