]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
%ruby_mod_ver_requires_eq macro todo
[packages/ruby.git] / ruby.spec
1 # TODO:
2 #       - include ext/ in docs
3 #       - replace ri with fastri
4 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
5 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
6 # - fix requires/provides 'ruby(abi) = '
7 # - nil this macro: %ruby_mod_ver_requires_eq "Requires: ruby-modules(ver) = "
8 # - fix tk build
9 #
10 # Conditional build:
11 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
12 %bcond_without  tk              # skip building package with Tk bindings
13 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
14 %bcond_without  default_ruby    # use this Ruby as default system Ruby
15 %bcond_with     bootstrap       # build bootstrap version
16
17 %define         rel             0.5
18 %define         ruby_version    2.0
19 %define         basever         2.0.0
20 %define         patchlevel      451
21
22 %define         ruby_suffix %{!?with_default_ruby:%{ruby_version}}
23 %define         doc_version     2_0_0
24
25 %define         bigdecimal_ver  1.2.0
26 %define         io_console_ver  0.4.2
27 %define         irb_ver         0.9.6
28 %define         json_ver        1.7.7
29 %define         minitest_ver    4.3.2
30 %define         psych_ver       2.0.0
31 %define         rake_ver        0.9.6
32 %define         rdoc_ver        4.0.0
33 %define         rubygems_ver    2.0.14
34 %define         test_unit_ver   2.0.0.0
35
36 %define         oname   ruby
37 Summary:        Ruby - interpreted scripting language
38 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
39 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
40 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
41 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
42 Name:           ruby%{ruby_suffix}
43 Version:        %{basever}.%{patchlevel}
44 Release:        %{rel}
45 Epoch:          1
46 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
47 License:        (Ruby or BSD) and Public Domain
48 Group:          Development/Languages
49 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/2.0/%{oname}-%{basever}-p%{patchlevel}.tar.bz2
50 # Source0-md5:  908e4d1dbfe7362b15892f16af05adf8
51 Source1:        http://www.ruby-doc.org/download/%{oname}-doc-bundle.tar.gz
52 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
53 Source2:        http://www.ruby-doc.org/downloads/%{oname}_%{doc_version}_stdlib_rdocs.tgz
54 # Source2-md5:  e93307804295a43512cafbf660a4cbe0
55 Source3:        http://www.ruby-doc.org/downloads/%{oname}_%{doc_version}_core_rdocs.tgz
56 # Source3-md5:  900186f317b51edfbb2f5317f8855719
57 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{oname}-1.8.7-p330.tar.gz
58 # Source100-md5:        50a49edb787211598d08e756e733e42e
59 Source4:        rdoc.1
60 Source5:        testrb.1
61 Patch0:         %{oname}-lib64.patch
62 Patch1:         %{oname}-ffs.patch
63 Patch2:         fix-bison-invocation.patch
64 # http://redmine.ruby-lang.org/issues/5231
65 #Patch3:                disable-versioned-paths.patch
66 # TODO: Should be submitted upstream?
67 #Patch4:                arch-specific-dir.patch
68 # http://redmine.ruby-lang.org/issues/5281
69 #Patch5:                site-and-vendor-arch-flags.patch
70 # Make mkmf verbose by default
71 Patch6:         mkmf-verbose.patch
72 Patch7:         strip-ccache.patch
73 Patch8:         duplicated-paths.patch
74 Patch9:         DESTDIR.patch
75 Patch10:        empty-ruby-version.patch
76 Patch11:        rubygems-2.0.0-binary-extensions.patch
77 Patch12:        custom-rubygems-location.patch
78 Patch13:        readline-6.3.patch
79 URL:            http://www.ruby-lang.org/
80 BuildRequires:  autoconf >= 2.60
81 BuildRequires:  automake
82 BuildRequires:  bison >= 1.875
83 BuildRequires:  db-devel
84 BuildRequires:  gdbm-devel >= 1.8.3
85 BuildRequires:  libffi-devel
86 BuildRequires:  ncurses-devel
87 BuildRequires:  openssl-devel
88 BuildRequires:  pkgconfig
89 BuildRequires:  readline-devel >= 4.2
90 BuildRequires:  rpm-build >= 5.4.10-49
91 # boostrap needs ruby binary, erb module
92 %{!?with_bootstrap:BuildRequires:       rpm-rubyprov}
93 %{!?with_bootstrap:BuildRequires:       ruby-modules}
94 %{!?with_bootstrap:BuildRequires:       ruby}
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  yaml-devel
97 %if %{with tk}
98 BuildRequires:  tk-devel
99 %endif
100 Requires(post,postun):  /sbin/ldconfig
101 Provides:       ruby(ver) = %{ruby_version}
102 Obsoletes:      ruby-REXML <= 2.4.0-2
103 Obsoletes:      ruby-doc < 1.8.4
104 Obsoletes:      ruby-fastthread <= 0.6.3
105 Conflicts:      rpm-build-macros < 1.692
106 Conflicts:      ruby-activesupport < 2.3.11-2
107 Conflicts:      ruby-activesupport2 < 2.3.11-2
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
111 #%define        gem_dir                 %{_datadir}/gems
112 #%define        gem_dir                 %{_datadir}/%{oname}/gems/%{ruby_version}
113 %define gem_dir                 %{_datadir}/%{oname}/%{ruby_version}/gems
114
115 # location where rubygems is installed
116 %define rubygems_dir            %{ruby_libdir}
117
118 %define ruby_archdir            %{_libdir}/%{oname}/%{ruby_version}
119 %define ruby_libarchdir         %{_libdir}/%{oname}/%{ruby_version}
120 %define ruby_libdir             %{_datadir}/%{oname}/%{ruby_version}
121
122 # This is the local lib/arch and should not be used for packaging.
123 %define sitedir                 site_ruby
124 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{oname}/%{sitedir}/%{ruby_version}
125 %define ruby_sitelibdir         %{_prefix}/local/share/%{oname}/%{sitedir}
126
127 # This is the general location for libs/archs compatible with all
128 # or most of the Ruby versions available in the PLD repositories.
129 %define vendordir               vendor_ruby
130 %define ruby_vendorarchdir      %{_libdir}/%{oname}/%{vendordir}/%{ruby_version}
131 %define ruby_vendorlibdir       %{_datadir}/%{oname}/%{vendordir}
132
133 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
134 %define legacy_libdir           %{_libdir}/%{oname}/%{ruby_version}
135 %define legacy_archdir          %{_libdir}/%{oname}/%{ruby_version}/%{_target_cpu}-linux
136 %define legacy_sitedir          %{_libdir}/%{oname}/%{sitedir}
137 %define legacy_sitelibdir       %{_libdir}/%{oname}/%{sitedir}/%{ruby_version}
138 %define legacy_sitearchdir      %{_libdir}/%{oname}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
139 %define legacy_vendordir        %{_libdir}/%{oname}/%{vendordir}
140 %define legacy_vendorlibdir     %{_libdir}/%{oname}/%{vendordir}/%{ruby_version}
141 %define legacy_vendorarchdir    %{_libdir}/%{oname}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
142
143 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
144 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
145 %define legacy_loadpath         %{legacy_archdir}
146 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
147
148 # bleh, some nasty (gcc or ruby) bug still not fixed
149 # (SEGV or "unexpected break" on miniruby run during build)
150 %define         specflags_ia64  -O0
151
152 # ruby needs frame pointers for correct exception handling
153 %define         specflags_ia32  -fno-omit-frame-pointer
154
155 %description
156 Ruby is the interpreted scripting language for quick and easy
157 object-oriented programming. It has many features to process text
158 files and to do system management tasks (as in Perl). It is simple,
159 straight-forward, extensible, and portable.
160
161 This package contains only shared library and ruby interpreter. To get
162 full-functional ruby environment install ruby-modules package.
163
164 %description -l ja.UTF-8
165 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
166 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
167 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
168
169 %description -l pl.UTF-8
170 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
171 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
172 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
173 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
174 rozszerzalny i przenośny.
175
176 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
177 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
178 funkcjonalnego środowiska ruby.
179
180 %description -l pt_BR.UTF-8
181 Ruby é uma linguagem de script interpretada de programação orientada a
182 objeto. Possui diversas características para processamento de texto. É
183 simples, extensível e direta.
184
185 %package modules
186 Summary:        Ruby standard modules and utilities
187 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
188 Group:          Development/Languages
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190 Suggests:       ruby-rubygems
191 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
192 Provides:       ruby-io-console = %{io_console_ver}
193 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
194 Provides:       ruby-modules(ver) = %{ruby_version}
195 %if %{with batteries}
196 Provides:       ruby-minitest = %{minitest_ver}
197 Obsoletes:      ruby-minitest <= 1.5.0
198 %endif
199 # FIXME later
200 Provides:       ruby(abi) = %{ruby_version}
201
202 %description modules
203 Ruby standard modules and utilities:
204 - erb - Tiny eRuby
205 - testrb - automatic runner for Test::Unit of Ruby
206
207 %description modules -l pl.UTF-8
208 Standardowe moduły i narzędzia Ruby:
209 - erb - mały eRuby
210 - testrb - automatyczny runner dla Ruby Test::Unit
211
212 %package tk
213 Summary:        Ruby/Tk bindings
214 Summary(pl.UTF-8):      Wiązania Ruby/Tk
215 Group:          Development/Languages
216 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
217
218 %description tk
219 This package contains Ruby/Tk bindings.
220
221 %description tk -l pl.UTF-8
222 Ten pakiet zawiera wiązania Ruby/Tk.
223
224 %package devel
225 Summary:        Ruby development libraries
226 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
227 Group:          Development/Languages
228 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
229 Requires:       gcc
230 Requires:       glibc-devel
231 Requires:       pkgconfig
232
233 %description devel
234 Ruby development libraries.
235
236 %description devel -l pl.UTF-8
237 Biblioteki programistyczne interpretera języka Ruby.
238
239 %package static
240 Summary:        Ruby static libraries
241 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
242 Group:          Development/Languages
243 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
244
245 %description static
246 Ruby static libraries.
247
248 %description static -l pl.UTF-8
249 Biblioteki statyczne Ruby.
250
251 %package doc
252 Summary:        Ruby HTML documentation
253 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
254 Group:          Documentation
255 %if "%{_rpmversion}" >= "5"
256 BuildArch:      noarch
257 %endif
258
259 %description doc
260 Ruby HTML documentation: FAQ, guide, core and standard library.
261
262 %description doc -l pl.UTF-8
263 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
264 stdlib.
265
266 %package doc-ri
267 Summary:        Ruby ri documentation
268 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
269 Group:          Documentation
270 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
271 %if "%{_rpmversion}" >= "5"
272 BuildArch:      noarch
273 %endif
274
275 %description doc-ri
276 Ruby ri documentation.
277
278 %description doc-ri -l pl.UTF-8
279 Dokumentacja Ruby w formacie ri.
280
281 %package examples
282 Summary:        Ruby examples
283 Summary(pl.UTF-8):      Przykłady dla języka Ruby
284 Group:          Development/Languages
285 %if "%{_rpmversion}" >= "5"
286 BuildArch:      noarch
287 %endif
288
289 %description examples
290 Ruby examples.
291
292 %description examples -l pl.UTF-8
293 Przykłady programów w języku Ruby.
294
295 # IMPORTANT: keep irb, rdoc, rubygems, rake, json as last packages as we reset epoch/version/release
296 # and %{version},%{release} macros may not be used directly as they take last
297 # subpackage value not main package one what you intend to use
298
299 %package irb
300 Summary:        The Interactive Ruby
301 Version:        %{irb_ver}
302 Release:        %{basever}.%{patchlevel}.%{rel}
303 Epoch:          0
304 Group:          Development/Languages
305 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
306 Provides:       irb = %{version}-%{release}
307 Provides:       ruby(irb) = %{version}-%{release}
308 %if "%{_rpmversion}" >= "5"
309 BuildArch:      noarch
310 %endif
311
312 %description irb
313 The irb is acronym for Interactive Ruby. It evaluates ruby expression
314 from the terminal.
315
316 %package rdoc
317 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
318 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
319 Version:        %{rdoc_ver}
320 Release:        %{basever}.%{patchlevel}.%{rel}
321 Epoch:          0
322 License:        GPL v2 and Ruby and MIT
323 Group:          Development/Libraries
324 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
325 Obsoletes:      rdoc <= 0.9.0
326 %if "%{_rpmversion}" >= "5"
327 BuildArch:      noarch
328 %endif
329
330 %description rdoc
331 RDoc produces HTML and command-line documentation for Ruby projects.
332 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
333 online documentation.
334
335 %description rdoc -l pl.UTF-8
336 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
337 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
338 wyświetlania dokumentacji online.
339
340 %package rubygems
341 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
342 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
343 Version:        %{rubygems_ver}
344 Release:        %{basever}.%{patchlevel}.%{rel}
345 Epoch:          0
346 License:        Ruby or MIT
347 Group:          Development/Libraries
348 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
349 Requires:       %{name}-rdoc >= %{rdoc_ver}
350 Suggests:       %{name}-devel
351 Provides:       rubygems = %{rubygems_ver}
352 %if "%{_rpmversion}" >= "5"
353 BuildArch:      noarch
354 %endif
355
356 %description rubygems
357 RubyGems is the Ruby standard for publishing and managing third party
358 libraries.
359
360 %description rubygems -l pl.UTF-8
361 RubyGems to standardowe narzędzie języka Ruby do publikowania i
362 zarządzania zewnętrznymi bibliotekami.
363
364 %package rake
365 Summary:        Rake is a Make-like program implemented in Ruby
366 Summary(pl.UTF-8):      Program typu Make dla języka Ruby
367 Version:        %{rake_ver}
368 Release:        %{basever}.%{patchlevel}.%{rel}
369 Epoch:          0
370 License:        MIT
371 Group:          Development/Languages
372 Provides:       rake = %{rake_ver}
373 Conflicts:      ruby-modules < 1:1.9.3.429-2
374 %if "%{_rpmversion}" >= "5"
375 BuildArch:      noarch
376 %endif
377
378 %description rake
379 Rake is a simple Ruby build program with capabilities similar to make.
380
381 It has the following features:
382 - Rakefiles (rake's version of Makefiles) are completely defined in
383   standard Ruby syntax. No XML files to edit. No quirky Makefile syntax
384   to worry about (is that a tab or a space?)
385 - Users can specify tasks with prerequisites.
386 - Rake supports rule patterns to synthesize implicit tasks.
387 - Rake is lightweight. It can be distributed with other projects as a
388   single file. Projects that depend upon rake do not require that rake
389   be installed on target systems.
390
391 %description rake -l pl.UTF-8
392 Rake to prosty program do budowania w języku Ruby o możliwościach
393 podobnych do make.
394
395 Ma następujące cechy:
396 - Pliki Rakefile (rake'owa odmiana plików Makefile) są definiowane
397   całkowicie w standardowej składni języka Ruby. Nie trzeba modyfikować
398   plików XML. Nie trzeba martwić się kaprysami składni Makefile (czy to
399   tabulacja czy spacja?).
400 - Użytkownicy mogą określać zadania z ich zależnościami.
401 - Rake obsługuje wzorce reguł do tworzenia z nich wynikowych zadań.
402 - Rake jest lekki. Może być rozpowszechniany z innymi projektami jako
403   pojedynczy plik. Projekty używające rake'a nie wymagają go
404   zainstalowanego na systemach docelowych.
405
406 %package json
407 Summary:        JSON library for Ruby
408 Summary(pl.UTF-8):      Biblioteka JSON dla języka Ruby
409 Version:        %{json_ver}
410 Release:        %{basever}.%{patchlevel}.%{rel}
411 Epoch:          0
412 License:        MIT
413 Group:          Development/Languages
414 Obsoletes:      ruby-json-rubyforge
415 Conflicts:      ruby-modules < 1:1.9.3.429-3
416
417 %description json
418 This is a JSON implementation as a Ruby extension in C.
419
420 %description json -l pl.UTF-8
421 Biblioteka JSON dla języka Ruby.
422
423 %prep
424 %if %{with bootstrap}
425 %setup -q -n %{oname}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
426 %else
427 %setup -q -n %{oname}-%{basever}-p%{patchlevel} -a1 -a2 -a3
428 %endif
429 %patch0 -p1
430 %patch1 -p1
431 %patch2 -p1
432 #%patch3 -p1
433 #%patch4 -p1
434 #%patch5 -p1
435 %patch6 -p1
436 %patch7 -p1
437 %patch8 -p1
438 %patch9 -p1
439 %patch10 -p1
440 %patch11 -p1
441 %patch12 -p1
442 %patch13 -p1
443
444 # must be regenerated with new bison
445 %{__rm} parse.{c,h}
446
447 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
448
449 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
450         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
451         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
452
453 %build
454 rubygems_ver=$(awk '/VERSION =/ && $1 == "VERSION" {print $3}' lib/rubygems.rb | xargs)
455 if [ $rubygems_ver != %{rubygems_ver} ]; then
456         echo "Set %%define rubygems_ver to $rubygems_ver and re-run."
457         exit 1
458 fi
459 rdoc_ver=$(awk '/VERSION =/ && $1 == "VERSION" {print $3}' lib/rdoc.rb | xargs)
460 if [ $rdoc_ver != %{rdoc_ver} ]; then
461         echo "Set %%define rdoc_ver to $rdoc_ver and re-run."
462         exit 1
463 fi
464
465 cp -f /usr/share/automake/config.sub .
466
467 # build ruby-1.8.7 first
468 %if %{with bootstrap}
469 cd %{oname}-1.8.7-p330
470 %configure
471 %{__make}
472 cd ..
473 %endif
474
475 %{__autoconf}
476 %configure \
477         %{?with_bootstrap:--with-baseruby=%{oname}-1.8.7-p330/miniruby} \
478         --program-suffix=%{ruby_suffix} \
479         --with-rubygemsdir=%{rubygems_dir} \
480         --with-rubylibprefix=%{ruby_libdir} \
481         --with-rubyarchprefix=%{ruby_archdir} \
482         --with-sitedir=%{ruby_sitelibdir} \
483         --with-sitearchdir=%{ruby_sitearchdir} \
484         --with-vendordir=%{ruby_vendorlibdir} \
485         --with-vendorarchdir=%{ruby_vendorarchdir} \
486         --with-rubyhdrdir=%{_includedir}/%{oname}-%{ruby_version} \
487         --with-rubyarchhdrdir=%{_includedir}/%{oname}-%{ruby_version} \
488         --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
489         --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
490         --enable-shared \
491         --enable-pthread \
492         --enable-multiarch \
493         --disable-rubygems \
494         --disable-install-doc \
495         --with-ruby-version=''
496
497 %{__make} -j1 main \
498         COPY="cp -p" Q= \
499         %{?with_bootstrap:BASERUBY="%{oname}-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
500
501 %if %{with doc}
502 %{__make} -j1 rdoc
503 %endif
504
505 %install
506 rm -rf $RPM_BUILD_ROOT
507 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{ruby_ridir}} \
508         $RPM_BUILD_ROOT%{ruby_vendorarchdir} \
509         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
510         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/data \
511
512 %{__make} install %{?with_doc:install-doc} \
513         DESTDIR=$RPM_BUILD_ROOT
514
515 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{oname}-%{basever}.%{patchlevel}
516 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{oname}-%{basever}.%{patchlevel}
517 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1/rdoc%{ruby_suffix}.1
518 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/testrb%{ruby_suffix}.1
519
520 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
521
522 ln -sf %{gem_dir}/gems/rake-%{rake_ver}/bin/rake $RPM_BUILD_ROOT%{_bindir}/rake%{ruby_suffix}
523
524 %if %{without batteries}
525 # packaged separately
526 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
527 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
528 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
529 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
530 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
531 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
532 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/default/{json,minitest,rake}-*.gemspec
533 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
534 %endif
535
536 %if %{with doc}
537 # too much .ri
538 #%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
539 #%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
540 %endif
541
542 %clean
543 rm -rf $RPM_BUILD_ROOT
544
545 %post   -p /sbin/ldconfig
546 %postun -p /sbin/ldconfig
547
548 %files
549 %defattr(644,root,root,755)
550 %doc NEWS LEGAL README README.EXT ChangeLog
551 %attr(755,root,root) %{_bindir}/ruby%{ruby_suffix}
552 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
553 %attr(755,root,root) %ghost %{_libdir}/libruby.so.%{ruby_version}
554 %{_mandir}/man1/ruby%{ruby_suffix}.1*
555
556 %dir %{_libdir}/%{oname}
557 %dir %{_libdir}/%{oname}/%{vendordir}
558 %dir %{_datadir}/%{oname}
559
560 %dir %{ruby_libdir}
561 %dir %{ruby_archdir}
562 %dir %{ruby_vendorlibdir}
563 %dir %{ruby_vendorarchdir}
564
565 %dir %{_datadir}/ri
566 %dir %{_datadir}/ri/%{ruby_version}
567 %dir %{ruby_ridir}
568
569 #%dir %{ruby_rdocdir}
570
571 # common dirs for ruby vendor modules
572 %dir %{ruby_vendorlibdir}/data
573 %dir %{ruby_vendorlibdir}/net
574
575 %if 0
576 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
577 %dir %{legacy_archdir}
578 %dir %{legacy_sitedir}
579 %dir %{legacy_sitelibdir}
580 %dir %{legacy_sitearchdir}
581 %dir %{legacy_vendorarchdir}
582 %dir %{legacy_libdir}/tasks
583 %dir %{legacy_archdir}/racc
584 %endif
585
586 %files devel
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/libruby.so
589 %{_includedir}/%{oname}-%{ruby_version}
590 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
591 %{ruby_libdir}/mkmf.rb
592
593 %files static
594 %defattr(644,root,root,755)
595 %{_libdir}/libruby-static.a
596
597 %if %{with tk}
598 %files tk
599 %defattr(644,root,root,755)
600 %{ruby_libdir}/tcltk.rb
601 %{ruby_libdir}/tk*.rb
602 %{ruby_libdir}/tk
603 %{ruby_libdir}/tkextlib
604 %attr(755,root,root) %{ruby_archdir}/t*.so
605 %endif
606
607 %files irb
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_bindir}/irb%{ruby_suffix}
610 %{ruby_libdir}/irb.rb
611 %{ruby_libdir}/irb
612 %{_mandir}/man1/irb%{ruby_suffix}.1*
613
614 %files rdoc
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/rdoc%{ruby_suffix}
617 %attr(755,root,root) %{_bindir}/ri%{ruby_suffix}
618 %{_mandir}/man1/rdoc%{ruby_suffix}.1*
619 %{ruby_libdir}/rdoc
620 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
621 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
622 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
623 %{gem_dir}/specifications/default/rdoc-%{rdoc_ver}.gemspec
624 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
625
626 %if %{with batteries}
627 %files rubygems
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/gem%{ruby_suffix}
630 %dir %{rubygems_dir}
631 %{rubygems_dir}/rubygems
632 %{rubygems_dir}/rubygems.rb
633 %{rubygems_dir}/ubygems.rb
634 %{rubygems_dir}/rbconfig
635
636 %files rake
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_bindir}/rake%{ruby_suffix}
639 %{_mandir}/man1/rake%{ruby_suffix}.1*
640 %{ruby_libdir}/rake
641 %dir %{gem_dir}/gems/rake-%{rake_ver}
642 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
643 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
644 %{gem_dir}/specifications/default/rake-%{rake_ver}.gemspec
645
646 %files json
647 %defattr(644,root,root,755)
648 %{ruby_libdir}/json
649 %dir %{ruby_archdir}/json
650 %dir %{ruby_archdir}/json/ext
651 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
652 %{gem_dir}/specifications/default/json-%{json_ver}.gemspec
653 %endif
654
655 %files modules
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_bindir}/erb%{ruby_suffix}
658 %attr(755,root,root) %{_bindir}/testrb%{ruby_suffix}
659 %{ruby_libdir}/bigdecimal
660 %{ruby_libdir}/cgi
661 %{ruby_libdir}/date
662 %{ruby_libdir}/digest
663 %{ruby_libdir}/dl
664 %{ruby_libdir}/drb
665 %{ruby_libdir}/fiddle
666 %{ruby_libdir}/io
667 %{ruby_libdir}/matrix
668 %{ruby_libdir}/net
669 %{ruby_libdir}/openssl
670 %{ruby_libdir}/optparse
671 %{ruby_libdir}/psych
672 %{ruby_libdir}/racc
673 %{ruby_libdir}/rbconfig
674 %{ruby_libdir}/rexml
675 %{ruby_libdir}/rinda
676 %{ruby_libdir}/ripper
677 %{ruby_libdir}/rss
678 %{ruby_libdir}/shell
679 #%{ruby_libdir}/syck
680 %{ruby_libdir}/syslog
681 %{ruby_libdir}/test
682 %{ruby_libdir}/uri
683 %{ruby_libdir}/webrick
684 %{ruby_libdir}/xmlrpc
685 %{ruby_libdir}/yaml
686 %{ruby_libdir}/[A-Za-s]*.rb
687 %{ruby_libdir}/tempfile.rb
688 %{ruby_libdir}/thread.rb
689 %{ruby_libdir}/thwait.rb
690 %{ruby_libdir}/time.rb
691 %{ruby_libdir}/timeout.rb
692 %{ruby_libdir}/tmpdir.rb
693 %{ruby_libdir}/tracer.rb
694 %{ruby_libdir}/tsort.rb
695 %{ruby_libdir}/[u-z]*.rb
696 %if %{with batteries}
697 %exclude %{ruby_libdir}/rubygems.rb
698 %exclude %{ruby_libdir}/ubygems.rb
699 %exclude %{ruby_libdir}/rbconfig/datadir.rb
700 %exclude %{ruby_libdir}/rbconfig/obsolete.rb
701 %endif
702 %exclude %{ruby_libdir}/irb.rb
703 %exclude %{ruby_libdir}/mkmf.rb
704 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
705 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
706 %dir %{ruby_archdir}/digest
707 %attr(755,root,root) %{ruby_archdir}/digest/*.so
708 %dir %{ruby_archdir}/dl
709 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
710 %dir %{ruby_archdir}/enc
711 %attr(755,root,root) %{ruby_archdir}/enc/*.so
712 %dir %{ruby_archdir}/enc/trans
713 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
714 %dir %{ruby_archdir}/io
715 %attr(755,root,root) %{ruby_archdir}/io/*.so
716 %dir %{ruby_archdir}/mathn
717 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
718 %dir %{ruby_archdir}/racc
719 %attr(755,root,root) %{ruby_archdir}/racc/*.so
720 %{ruby_archdir}/rbconfig.rb
721
722 %{gem_dir}/specifications/default/bigdecimal-%{bigdecimal_ver}.gemspec
723 %{gem_dir}/specifications/default/io-console-%{io_console_ver}.gemspec
724
725 %if %{with batteries}
726 # minitest
727 %{ruby_libdir}/minitest
728 %{gem_dir}/specifications/default/minitest-%{minitest_ver}.gemspec
729 %endif
730
731 %{gem_dir}/specifications/default/psych-%{psych_ver}.gemspec
732
733 # test-unit
734 %{gem_dir}/specifications/default/test-unit-%{test_unit_ver}.gemspec
735 %dir %{gem_dir}/gems/test-unit-%{test_unit_ver}
736 %dir %{gem_dir}/gems/test-unit-%{test_unit_ver}/bin
737 %attr(755,root,root) %{gem_dir}/gems/test-unit-%{test_unit_ver}/bin/testrb
738
739 # parents of gem_dir
740 #%dir %{_datadir}/%{oname}/gems
741 #%dir %{_datadir}/%{oname}/gems/%{ruby_version}
742 #%dir %{_datadir}/%{oname}/gems/%{ruby_version}/gems
743
744 %dir %{_datadir}/%{oname}/%{ruby_version}/gems/gems
745
746 %dir %{gem_dir}
747 %dir %{gem_dir}/specifications
748 %dir %{gem_dir}/specifications/default
749 %{_mandir}/man1/erb%{ruby_suffix}.1*
750 %{_mandir}/man1/ri%{ruby_suffix}.1*
751 %{_mandir}/man1/testrb%{ruby_suffix}.1*
752
753 %files doc
754 %defattr(644,root,root,755)
755 %doc ruby-doc-bundle/*
756 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
757 %{?with_doc:%doc ruby_%{doc_version}_core}
758
759 %if %{with doc}
760 %files doc-ri
761 %defattr(644,root,root,755)
762 %{ruby_ridir}/*
763 %endif
764
765 %files examples
766 %defattr(644,root,root,755)
767 %{_examplesdir}/%{oname}-*
This page took 0.20664 seconds and 4 git commands to generate.