]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
fix packaging --without batteries
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      392
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 %define         bigdecimal_ver  1.1.0
25 %define         io_console_ver  0.3
26 Summary:        Ruby - interpreted scripting language
27 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
28 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
29 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
30 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
31 Name:           ruby
32 Version:        %{basever}.%{patchlevel}
33 # NOTE: do not decrease Release, when updating Version,
34 # unless rdoc_ver, rubygems_ver *both* are increased as well
35 Release:        9
36 Epoch:          1
37 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
38 License:        (Ruby or BSD) and Public Domain
39 Group:          Development/Languages
40 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{ruby_version}/%{name}-%{basever}-p%{patchlevel}.tar.bz2
41 # Source0-md5:  a810d64e2255179d2f334eb61fb8519c
42 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
43 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
44 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
45 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
46 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
47 # Source3-md5:  1892aadde51d36106c513bced2193dff
48 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
49 # Source100-md5:        50a49edb787211598d08e756e733e42e
50 Source4:        rdoc.1
51 Source5:        testrb.1
52 Patch0:         %{name}-lib64.patch
53 Patch1:         %{name}-ffs.patch
54 Patch2:         fix-bison-invocation.patch
55 # http://redmine.ruby-lang.org/issues/5231
56 Patch3:         disable-versioned-paths.patch
57 # TODO: Should be submitted upstream?
58 Patch4:         arch-specific-dir.patch
59 # http://redmine.ruby-lang.org/issues/5281
60 Patch5:         site-and-vendor-arch-flags.patch
61 # Make mkmf verbose by default
62 Patch6:         mkmf-verbose.patch
63 URL:            http://www.ruby-lang.org/
64 BuildRequires:  autoconf >= 2.60
65 BuildRequires:  automake
66 BuildRequires:  bison
67 BuildRequires:  db-devel
68 BuildRequires:  gdbm-devel >= 1.8.3
69 BuildRequires:  libffi-devel
70 BuildRequires:  ncurses-devel
71 BuildRequires:  openssl-devel
72 BuildRequires:  pkgconfig
73 BuildRequires:  readline-devel >= 4.2
74 BuildRequires:  rpm-build >= 5.4.10-49
75 # boostrap needs ruby binary, erb module
76 %{!?with_bootstrap:BuildRequires:       ruby-modules}
77 %{!?with_bootstrap:BuildRequires:       ruby}
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  yaml-devel
80 %if %{with tk}
81 BuildRequires:  tk-devel
82 %endif
83 Requires(post,postun):  /sbin/ldconfig
84 Provides:       ruby(ver) = %{ruby_version}
85 Obsoletes:      ruby-REXML <= 2.4.0-2
86 Obsoletes:      ruby-doc < 1.8.4
87 Obsoletes:      ruby-fastthread <= 0.6.3
88 Conflicts:      ruby-activesupport < 2.3.11-2
89 Conflicts:      ruby-activesupport2 < 2.3.11-2
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
93 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
94
95 # The RubyGems library has to stay out of Ruby directory three, since the
96 # RubyGems should be share by all Ruby implementations.
97 %define rubygems_dir            %{_datadir}/rubygems
98
99 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
100 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
101
102 # This is the local lib/arch and should not be used for packaging.
103 %define sitedir                 site_ruby
104 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
105 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
106 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
107
108 # This is the general location for libs/archs compatible with all
109 # or most of the Ruby versions available in the PLD repositories.
110 %define vendordir               vendor_ruby
111 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
112 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
113 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
114
115 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
116 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
117 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
118 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
119 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
120 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
121 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
122 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
123 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
124
125 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
126 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
127 %define legacy_loadpath         %{legacy_archdir}
128 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
129
130 # bleh, some nasty (gcc or ruby) bug still not fixed
131 # (SEGV or "unexpected break" on miniruby run during build)
132 %define         specflags_ia64  -O0
133
134 # ruby needs frame pointers for correct exception handling
135 %define         specflags_ia32  -fno-omit-frame-pointer
136
137 %description
138 Ruby is the interpreted scripting language for quick and easy
139 object-oriented programming. It has many features to process text
140 files and to do system management tasks (as in Perl). It is simple,
141 straight-forward, extensible, and portable.
142
143 This package contains only shared library and ruby interpreter. To get
144 full-functional ruby environment install ruby-modules package.
145
146 %description -l ja.UTF-8
147 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
148 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
149 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
150
151 %description -l pl.UTF-8
152 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
153 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
154 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
155 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
156 rozszerzalny i przenośny.
157
158 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
159 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
160 funkcjonalnego środowiska ruby.
161
162 %description -l pt_BR.UTF-8
163 Ruby é uma linguagem de script interpretada de programação orientada a
164 objeto. Possui diversas características para processamento de texto. É
165 simples, extensível e direta.
166
167 %package modules
168 Summary:        Ruby standard modules and utilities
169 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
170 Group:          Development/Languages
171 Requires:       %{name} = %{epoch}:%{version}-%{release}
172 Suggests:       ruby-rubygems
173 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
174 Provides:       ruby-io-console = %{io_console_ver}
175 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
176 Provides:       ruby-modules(ver) = %{ruby_version}
177 %if %{with batteries}
178 Provides:       rake = %{rake_ver}
179 Provides:       ruby-json = %{json_ver}
180 Provides:       ruby-minitest = %{minitest_ver}
181 Provides:       ruby-rake = %{rake_ver}
182 Obsoletes:      ruby-json <= 1.5.4
183 Obsoletes:      ruby-minitest <= 1.5.0
184 Obsoletes:      ruby-rake < 0.9.2.2
185 %endif
186
187 %description modules
188 Ruby standard modules and utilities:
189 - erb - Tiny eRuby
190 - irb - interactive Ruby
191 - testrb - automatic runner for Test::Unit of Ruby
192
193 %description modules -l pl.UTF-8
194 Standardowe moduły i narzędzia Ruby:
195 - erb - mały eRuby
196 - irb - interaktywny Ruby
197 - testrb - automatyczny runner dla Ruby Test::Unit
198
199 %package tk
200 Summary:        Ruby/Tk bindings
201 Summary(pl.UTF-8):      Wiązania Ruby/Tk
202 Group:          Development/Languages
203 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
204
205 %description tk
206 This pachage contains Ruby/Tk bindings.
207
208 %description tk -l pl.UTF-8
209 Ten pakiet zawiera wiązania Ruby/Tk.
210
211 %package devel
212 Summary:        Ruby development libraries
213 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
214 Group:          Development/Languages
215 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
216 Requires:       pkgconfig
217
218 %description devel
219 Ruby development libraries.
220
221 %description devel -l pl.UTF-8
222 Biblioteki programistyczne interpretera języka Ruby.
223
224 %package static
225 Summary:        Ruby static libraries
226 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
227 Group:          Development/Languages
228 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
229
230 %description static
231 Ruby static libraries.
232
233 %description static -l pl.UTF-8
234 Biblioteki statyczne Ruby.
235
236 %package doc
237 Summary:        Ruby HTML documentation
238 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
239 Group:          Documentation
240
241 %description doc
242 Ruby HTML documentation: FAQ, guide, core and standard library.
243
244 %description doc -l pl.UTF-8
245 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
246 stdlib.
247
248 %package doc-ri
249 Summary:        Ruby ri documentation
250 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
251 Group:          Documentation
252 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
253
254 %description doc-ri
255 Ruby ri documentation.
256
257 %description doc-ri -l pl.UTF-8
258 Dokumentacja Ruby w formacie ri.
259
260 %package examples
261 Summary:        Ruby examples
262 Summary(pl.UTF-8):      Przykłady dla języka Ruby
263 Group:          Development/Languages
264
265 %description examples
266 Ruby examples.
267
268 %description examples -l pl.UTF-8
269 Przykłady programów w języku Ruby.
270
271 # IMPORTANT: keep this as last package, as we reset Epoch
272 %package rdoc
273 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
274 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
275 Version:        %{rdoc_ver}
276 Epoch:          0
277 License:        GPL v2 and Ruby and MIT
278 Group:          Development/Libraries
279 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
280 Obsoletes:      rdoc <= 0.9.0
281
282 %description rdoc
283 RDoc produces HTML and command-line documentation for Ruby projects.
284 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
285 online documentation.
286
287 %description rdoc -l pl.UTF-8
288 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
289 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
290 wyświetlania dokumentacji online.
291
292 %package rubygems
293 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
294 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
295 Version:        %{rubygems_ver}
296 Epoch:          0
297 License:        Ruby or MIT
298 Group:          Development/Libraries
299 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
300 Requires:       %{name}-rdoc >= %{rdoc_ver}
301 Provides:       rubygems = %{rubygems_ver}
302 %if "%{_rpmversion}" >= "5"
303 BuildArch:      noarch
304 %endif
305
306 %description rubygems
307 RubyGems is the Ruby standard for publishing and managing third party
308 libraries.
309
310 %description rubygems -l pl.UTF-8
311 RubyGems to standardowe narzędzie języka Ruby do publikowania i
312 zarządzania zewnętrznymi bibliotekami.
313
314 %prep
315 %if %{with bootstrap}
316 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
317 %else
318 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
319 %endif
320 %patch0 -p1
321 %patch1 -p1
322 %patch2 -p1
323 %patch3 -p1
324 %patch4 -p1
325 %patch5 -p1
326
327 # must be regenerated with new bison
328 %{__rm} parse.{c,h}
329
330 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
331
332 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
333         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
334         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
335
336 %build
337 cp -f /usr/share/automake/config.sub .
338
339 # build ruby-1.8.7 first
340 %if %{with bootstrap}
341 cd %{name}-1.8.7-p330
342 %configure
343 %{__make}
344 cd ..
345 %endif
346
347 %{__autoconf}
348 %configure \
349         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
350         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
351         --with-archdir=%{ruby_archdir} \
352         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
353         --with-sitearchdir=%{ruby_sitearchdir} \
354         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
355         --with-vendorarchdir=%{ruby_vendorarchdir} \
356         --with-rubygemsdir=%{rubygems_dir} \
357         --with-search-path="%{legacy_loadpaths}" \
358         --enable-shared \
359         --enable-pthread \
360         --disable-rubygems \
361         --disable-install-doc \
362         --with-ruby-version=minor
363
364 %{__make} -j1 main \
365         COPY="cp -p" Q= \
366         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
367
368 %if %{with doc}
369 %{__make} -j1 rdoc
370 %endif
371
372 %install
373 rm -rf $RPM_BUILD_ROOT
374 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
375         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
376         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
377         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
378
379 %{__make} install %{?with_doc:install-doc} \
380         DESTDIR=$RPM_BUILD_ROOT
381
382 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
383 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
384 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
385
386 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
387
388 %if %{without batteries}
389 # packaged separately
390 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
391 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
392 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
393 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
394 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
395 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
396 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/{json,minitest,rake}-*.gemspec
397 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
398 %endif
399
400 %if %{with doc}
401 # too much .ri
402 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
403 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
404 %endif
405
406 %clean
407 rm -rf $RPM_BUILD_ROOT
408
409 %post   -p /sbin/ldconfig
410 %postun -p /sbin/ldconfig
411
412 %files
413 %defattr(644,root,root,755)
414 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
415 %attr(755,root,root) %{_bindir}/ruby
416 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
417 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
418 %{_mandir}/man1/ruby.1*
419
420 %if %{with batteries}
421 # rake
422 %attr(755,root,root) %{_bindir}/rake
423 %{_mandir}/man1/rake.1*
424 %endif
425
426 %dir %{_libdir}/%{name}
427 %dir %{_libdir}/%{name}/%{vendordir}
428 %dir %{_datadir}/%{name}
429 %dir %{_datadir}/%{name}/%{vendordir}
430
431 %dir %{ruby_libdir}
432 %dir %{ruby_archdir}
433 %dir %{ruby_vendorlibdir}
434 %dir %{ruby_vendorarchdir}
435
436 %dir %{_datadir}/ri
437 %dir %{_datadir}/ri/%{ruby_version}
438 %dir %{ruby_ridir}
439
440 %dir %{ruby_rdocdir}
441
442 # common dirs for ruby vendor modules
443 %dir %{ruby_vendorlibdir}/net
444
445 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
446 %dir %{legacy_archdir}
447 %dir %{legacy_sitedir}
448 %dir %{legacy_sitelibdir}
449 %dir %{legacy_sitearchdir}
450 %dir %{legacy_vendorarchdir}
451 %dir %{legacy_libdir}/tasks
452 %dir %{legacy_archdir}/racc
453
454 %files devel
455 %defattr(644,root,root,755)
456 %attr(755,root,root) %{_libdir}/libruby.so
457 %{_includedir}/%{name}-%{ruby_version}
458 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
459 %{ruby_libdir}/mkmf.rb
460
461 %files static
462 %defattr(644,root,root,755)
463 %{_libdir}/libruby-static.a
464
465 %if %{with tk}
466 %files tk
467 %defattr(644,root,root,755)
468 %{ruby_libdir}/tcltk.rb
469 %{ruby_libdir}/tk*.rb
470 %{ruby_libdir}/tk
471 %{ruby_libdir}/tkextlib
472 %attr(755,root,root) %{ruby_archdir}/t*.so
473 %endif
474
475 %files rdoc
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_bindir}/rdoc
478 %attr(755,root,root) %{_bindir}/ri
479 %{_mandir}/man1/rdoc.1*
480 %{ruby_libdir}/rdoc
481 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
482 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
483 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
484 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
485 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
486
487 %if %{with batteries}
488 %files rubygems
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_bindir}/gem
491 %{ruby_libdir}/rubygems
492 %{ruby_libdir}/rubygems.rb
493 %{ruby_libdir}/ubygems.rb
494 %endif
495
496 %files modules
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{_bindir}/erb
499 %attr(755,root,root) %{_bindir}/irb
500 %attr(755,root,root) %{_bindir}/testrb
501 %{ruby_libdir}/bigdecimal
502 %{ruby_libdir}/cgi
503 %{ruby_libdir}/date
504 %{ruby_libdir}/digest
505 %{ruby_libdir}/dl
506 %{ruby_libdir}/drb
507 %{ruby_libdir}/fiddle
508 %{ruby_libdir}/io
509 %{ruby_libdir}/irb
510 %{ruby_libdir}/matrix
511 %{ruby_libdir}/net
512 %{ruby_libdir}/openssl
513 %{ruby_libdir}/optparse
514 %{ruby_libdir}/psych
515 %{ruby_libdir}/racc
516 %{ruby_libdir}/rbconfig
517 %{ruby_libdir}/rexml
518 %{ruby_libdir}/rinda
519 %{ruby_libdir}/ripper
520 %{ruby_libdir}/rss
521 %{ruby_libdir}/shell
522 %{ruby_libdir}/syck
523 %{ruby_libdir}/test
524 %{ruby_libdir}/uri
525 %{ruby_libdir}/webrick
526 %{ruby_libdir}/xmlrpc
527 %{ruby_libdir}/yaml
528 %{ruby_libdir}/[A-Za-s]*.rb
529 %{ruby_libdir}/tempfile.rb
530 %{ruby_libdir}/thread.rb
531 %{ruby_libdir}/thwait.rb
532 %{ruby_libdir}/time.rb
533 %{ruby_libdir}/timeout.rb
534 %{ruby_libdir}/tmpdir.rb
535 %{ruby_libdir}/tracer.rb
536 %{ruby_libdir}/tsort.rb
537 %{ruby_libdir}/[u-z]*.rb
538 %if %{with batteries}
539 %exclude %{ruby_libdir}/rubygems.rb
540 %exclude %{ruby_libdir}/ubygems.rb
541 %endif
542 %exclude %{ruby_libdir}/mkmf.rb
543 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
544 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
545 %dir %{ruby_archdir}/digest
546 %attr(755,root,root) %{ruby_archdir}/digest/*.so
547 %dir %{ruby_archdir}/dl
548 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
549 %dir %{ruby_archdir}/enc
550 %attr(755,root,root) %{ruby_archdir}/enc/*.so
551 %dir %{ruby_archdir}/enc/trans
552 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
553 %dir %{ruby_archdir}/io
554 %attr(755,root,root) %{ruby_archdir}/io/*.so
555 %dir %{ruby_archdir}/mathn
556 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
557 %dir %{ruby_archdir}/racc
558 %attr(755,root,root) %{ruby_archdir}/racc/*.so
559 %{ruby_archdir}/rbconfig.rb
560
561 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
562 %{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
563
564 %if %{with batteries}
565 # json
566 %{ruby_libdir}/json
567 %dir %{ruby_archdir}/json
568 %dir %{ruby_archdir}/json/ext
569 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
570 %{gem_dir}/specifications/json-%{json_ver}.gemspec
571
572 # minitest
573 %{ruby_libdir}/minitest
574 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
575
576 # rake
577 %{ruby_libdir}/rake
578 %dir %{gem_dir}/gems/rake-%{rake_ver}
579 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
580 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
581 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
582 %endif
583
584 # parents of gem_dir
585 %dir %{_datadir}/%{name}/gems
586 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
587 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
588
589 %dir %{gem_dir}
590 %dir %{gem_dir}/specifications
591 %{_mandir}/man1/erb.1*
592 %{_mandir}/man1/irb.1*
593 %{_mandir}/man1/ri.1*
594 %{_mandir}/man1/testrb.1*
595
596 %files doc
597 %defattr(644,root,root,755)
598 %doc ruby-doc-bundle/*
599 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
600 %{?with_doc:%doc ruby_%{doc_version}_core}
601
602 %if %{with doc}
603 %files doc-ri
604 %defattr(644,root,root,755)
605 %{ruby_ridir}/*
606 %endif
607
608 %files examples
609 %defattr(644,root,root,755)
610 %{_examplesdir}/%{name}-%{version}
This page took 0.157138 seconds and 4 git commands to generate.