]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
- release 5: ruby-doc added to Obsoletes for allow upgrade from MDK.
[packages/ruby.git] / ruby.spec
1 Summary:        Ruby - interpreted scripting language
2 Summary(pl):    Ruby - interpretowany jêzyk skryptowy
3 Name:           ruby
4 Version:        1.6.4
5 Release:        5
6 License:        GPL
7 Group:          Development/Languages
8 Group(de):      Entwicklung/Sprachen
9 Group(pl):      Programowanie/Jêzyki
10 URL:            http://www.ruby-lang.org
11 Source0:        ftp://ftp.netlab.co.jp/pub/lang/ruby/%{name}-%{version}.tar.gz
12 Source1:        ftp://ftp.netlab.co.jp/pub/lang/ruby/doc/%{name}-texi-1.4-en.tar.gz
13 Source2:        http://www.math.sci.hokudai.ac.jp/~gotoken/ruby/%{name}-uguide-981227.tar.gz
14 Source3:        ftp://ftp.netlab.co.jp/pub/lang/ruby/doc/%{name}faq-990927.tar.gz
15 Source4:        irb.1
16 Patch0:         %{name}-info.patch
17 BuildRequires:  autoconf
18 BuildRequires:  gdbm-devel
19 BuildRequires:  ncurses-devel
20 BuildRequires:  readline-devel >= 4.2
21 BuildRequires:  texinfo
22 BuildRequires:  tk-devel
23 Prereq:         /sbin/ldconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25 Obsoletes:      ruby-doc
26
27 %description
28 Ruby is the interpreted scripting language for quick and easy
29 object-oriented programming. It has many features to process text
30 files and to do system management tasks (as in Perl). It is simple,
31 straight-forward, extensible, and portable.
32
33 %description -l pl
34 Ruby to interpretowany jêzyk skryptowy, w sam raz dla ³atwego i
35 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
36 u³atwiaj±cych przetwarzanie plików tekstowych i wykonywanie prac
37 zwi±zanych z zarz±dzaniem systemu (podobnie jak Perl). Jest prosty,
38 rozszerzalny i przeno¶ny.
39
40 %prep
41 %setup -q -a1 -a2 -a3
42 %patch0 -p1
43
44 %build
45 autoconf
46 %configure \
47         --enable-shared
48 %{__make}
49 %{__make} -C ruby-texi-1.4-en
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
54
55 # workaround (rather mkconfig.rb should be fixed, but I don't know ruby)
56 sed -e 's/\(@ECHO_C@,\)\\c/\1\\\\c/' config.status > config.status.new
57 mv -f config.status.new config.status
58
59 %{__make} install DESTDIR=$RPM_BUILD_ROOT
60
61 install sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 install %{name}-texi-1.4-en/ruby.info* $RPM_BUILD_ROOT%{_infodir}
63 install %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
64
65 mv -f ruby-uguide guide
66 mv -f rubyfaq faq
67
68 gzip -9nf README README.EXT ChangeLog ToDo
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
75 /sbin/ldconfig 
76
77 %postun
78 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
79 /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc guide faq misc *.gz
84 %attr(755,root,root) %{_bindir}/*
85 %attr(755,root,root) %{_libdir}/lib*.so.*.*
86 %attr(755,root,root) %{_libdir}/lib*.so
87 %{_libdir}/%{name}
88 %{_mandir}/*/*
89 %{_infodir}/*
90 %{_examplesdir}/%{name}-%{version}
This page took 0.037625 seconds and 4 git commands to generate.