]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
perl -pi -e "s/^automake -a -c -f --foreing/\%\{__automake\}/; \
[packages/ruby.git] / ruby.spec
1 Summary:        Ruby - interpreted scripting language
2 Summary(pl):    Ruby - interpretowany jêzyk skryptowy
3 Name:           ruby
4 Version:        1.6.7
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 URL:            http://www.ruby-lang.org
9 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{name}-%{version}.tar.gz
10 Source1:        ftp://ftp.netlab.co.jp/pub/lang/ruby/doc/%{name}-texi-1.4-en.tar.gz
11 Source2:        http://www.math.sci.hokudai.ac.jp/~gotoken/ruby/%{name}-uguide-981227.tar.gz
12 Source3:        ftp://ftp.netlab.co.jp/pub/lang/ruby/doc/%{name}faq-990927.tar.gz
13 Source4:        irb.1
14 Patch0:         %{name}-info.patch
15 BuildRequires:  autoconf
16 BuildRequires:  gdbm-devel
17 BuildRequires:  ncurses-devel
18 BuildRequires:  readline-devel >= 4.2
19 BuildRequires:  texinfo
20 BuildRequires:  tk-devel
21 Prereq:         /sbin/ldconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 Obsoletes:      ruby-doc
24
25 %description
26 Ruby is the interpreted scripting language for quick and easy
27 object-oriented programming. It has many features to process text
28 files and to do system management tasks (as in Perl). It is simple,
29 straight-forward, extensible, and portable.
30
31 %description -l pl
32 Ruby to interpretowany jêzyk skryptowy, w sam raz dla ³atwego i
33 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
34 u³atwiaj±cych przetwarzanie plików tekstowych i wykonywanie prac
35 zwi±zanych z zarz±dzaniem systemu (podobnie jak Perl). Jest prosty,
36 rozszerzalny i przeno¶ny.
37
38 %prep
39 %setup -q -a1 -a2 -a3
40 %patch0 -p1
41
42 %build
43 %{__autoconf}
44 %configure \
45         --enable-shared
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
51
52 # workaround (rather mkconfig.rb should be fixed, but I don't know ruby)
53 sed -e 's/\(@ECHO_C@,\)\\c/\1\\\\c/' config.status > config.status.new
54 mv -f config.status.new config.status
55
56 %{__make} install DESTDIR=$RPM_BUILD_ROOT
57
58 install sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59 install %{name}-texi-1.4-en/ruby.info* $RPM_BUILD_ROOT%{_infodir}
60 install %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
61
62 mv -f ruby-uguide guide
63 mv -f rubyfaq faq
64
65 gzip -9nf README README.EXT ChangeLog ToDo
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
72 /sbin/ldconfig
73
74 %postun
75 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
76 /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %doc guide faq misc *.gz
81 %attr(755,root,root) %{_bindir}/*
82 %attr(755,root,root) %{_libdir}/lib*.so.*.*
83 %attr(755,root,root) %{_libdir}/lib*.so
84 %{_libdir}/%{name}
85 %{_mandir}/*/*
86 %{_infodir}/*
87 %{_examplesdir}/%{name}-%{version}
This page took 0.032668 seconds and 4 git commands to generate.