]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
9f275cd87e4e4693adbf4c93816ade3c11345871
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json or rake
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      392
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 Summary:        Ruby - interpreted scripting language
25 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
26 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
27 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
28 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
29 Name:           ruby
30 Version:        %{basever}.%{patchlevel}
31 # NOTE: do not decrease Release, when updating Version,
32 # unless rdoc_ver, rubygems_ver *both* are increased as well
33 Release:        4
34 Epoch:          1
35 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
36 License:        (Ruby or BSD) and Public Domain
37 Group:          Development/Languages
38 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{ruby_version}/%{name}-%{basever}-p%{patchlevel}.tar.bz2
39 # Source0-md5:  a810d64e2255179d2f334eb61fb8519c
40 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
41 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
42 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
43 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
44 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
45 # Source3-md5:  1892aadde51d36106c513bced2193dff
46 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
47 # Source100-md5:        50a49edb787211598d08e756e733e42e
48 Source4:        rdoc.1
49 Source5:        testrb.1
50 Patch0:         %{name}-lib64.patch
51 Patch1:         %{name}-ffs.patch
52 Patch2:         fix-bison-invocation.patch
53 # http://redmine.ruby-lang.org/issues/5231
54 Patch3:         disable-versioned-paths.patch
55 # TODO: Should be submitted upstream?
56 Patch4:         arch-specific-dir.patch
57 # http://redmine.ruby-lang.org/issues/5281
58 Patch5:         site-and-vendor-arch-flags.patch
59 URL:            http://www.ruby-lang.org/
60 BuildRequires:  autoconf >= 2.60
61 BuildRequires:  automake
62 BuildRequires:  bison
63 BuildRequires:  db-devel
64 BuildRequires:  gdbm-devel >= 1.8.3
65 BuildRequires:  libffi-devel
66 BuildRequires:  ncurses-devel
67 BuildRequires:  openssl-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  readline-devel >= 4.2
70 # boostrap needs ruby binary, erb module
71 %{!?with_bootstrap:BuildRequires:       ruby-modules}
72 %{!?with_bootstrap:BuildRequires:       ruby}
73 BuildRequires:  sed >= 4.0
74 BuildRequires:  yaml-devel
75 %if %{with tk}
76 BuildRequires:  tk-devel
77 %endif
78 Requires(post,postun):  /sbin/ldconfig
79 Provides:       ruby(ver) = %{ruby_version}
80 Obsoletes:      rdoc
81 Obsoletes:      ruby-REXML
82 Obsoletes:      ruby-doc < 1.8.4
83 Obsoletes:      ruby-fastthread
84 %if %{with batteries}
85 Provides:       json = %{json_ver}
86 Provides:       rake = %{rake_ver}
87 Provides:       ruby-json = %{json_ver}
88 Provides:       ruby-rake = %{rake_ver}
89 Obsoletes:      ruby-json
90 Obsoletes:      ruby-rake
91 %endif
92 Conflicts:      ruby-activesupport < 2.3.11-2
93 Conflicts:      ruby-activesupport2 < 2.3.11-2
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
97 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
98
99 # The RubyGems library has to stay out of Ruby directory three, since the
100 # RubyGems should be share by all Ruby implementations.
101 %define rubygems_dir            %{_datadir}/rubygems
102
103 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
104 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
105
106 # This is the local lib/arch and should not be used for packaging.
107 %define sitedir                 site_ruby
108 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
109 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
110 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
111
112 # This is the general location for libs/archs compatible with all
113 # or most of the Ruby versions available in the PLD repositories.
114 %define vendordir               vendor_ruby
115 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
116 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
117 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
118
119 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
120 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
121 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
122 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
123 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
124 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
125 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
126 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
127 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
128
129 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
130 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
131 %define legacy_loadpath         %{legacy_archdir}
132 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
133
134 # bleh, some nasty (gcc or ruby) bug still not fixed
135 # (SEGV or "unexpected break" on miniruby run during build)
136 %define         specflags_ia64  -O0
137
138 # ruby needs frame pointers for correct exception handling
139 %define         specflags_ia32  -fno-omit-frame-pointer
140
141 %description
142 Ruby is the interpreted scripting language for quick and easy
143 object-oriented programming. It has many features to process text
144 files and to do system management tasks (as in Perl). It is simple,
145 straight-forward, extensible, and portable.
146
147 This package contains only shared library and ruby interpreter. To get
148 full-functional ruby environment install ruby-modules package.
149
150 %description -l ja.UTF-8
151 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
152 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
153 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
154
155 %description -l pl.UTF-8
156 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
157 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
158 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
159 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
160 rozszerzalny i przenośny.
161
162 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
163 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
164 funkcjonalnego środowiska ruby.
165
166 %description -l pt_BR.UTF-8
167 Ruby é uma linguagem de script interpretada de programação orientada a
168 objeto. Possui diversas características para processamento de texto. É
169 simples, extensível e direta.
170
171 %package modules
172 Summary:        Ruby standard modules and utilities
173 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
174 Group:          Development/Languages
175 Requires:       %{name} = %{epoch}:%{version}-%{release}
176 Suggests:       ruby-rubygems
177 # workaround for autodep generator not getting version properly
178 Provides:       ruby(abi) = %{ruby_version}
179 Provides:       ruby-modules(ver) = %{ruby_version}
180 Obsoletes:      ruby-minitest
181
182 %description modules
183 Ruby standard modules and utilities:
184 - erb - Tiny eRuby
185 - irb - interactive Ruby
186 - testrb - automatic runner for Test::Unit of Ruby
187
188 %description modules -l pl.UTF-8
189 Standardowe moduły i narzędzia Ruby:
190 - erb - mały eRuby
191 - irb - interaktywny Ruby
192 - testrb - automatyczny runner dla Ruby Test::Unit
193
194 %package tk
195 Summary:        Ruby/Tk bindings
196 Summary(pl.UTF-8):      Wiązania Ruby/Tk
197 Group:          Development/Languages
198 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
199
200 %description tk
201 This pachage contains Ruby/Tk bindings.
202
203 %description tk -l pl.UTF-8
204 Ten pakiet zawiera wiązania Ruby/Tk.
205
206 %package devel
207 Summary:        Ruby development libraries
208 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
209 Group:          Development/Languages
210 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
211
212 %description devel
213 Ruby development libraries.
214
215 %description devel -l pl.UTF-8
216 Biblioteki programistyczne interpretera języka Ruby.
217
218 %package static
219 Summary:        Ruby static libraries
220 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
221 Group:          Development/Languages
222 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
223
224 %description static
225 Ruby static libraries.
226
227 %description static -l pl.UTF-8
228 Biblioteki statyczne Ruby.
229
230 %package doc
231 Summary:        Ruby HTML documentation
232 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
233 Group:          Documentation
234
235 %description doc
236 Ruby HTML documentation: FAQ, guide, core and standard library.
237
238 %description doc -l pl.UTF-8
239 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
240 stdlib.
241
242 %package doc-ri
243 Summary:        Ruby ri documentation
244 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
245 Group:          Documentation
246 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
247
248 %description doc-ri
249 Ruby ri documentation.
250
251 %description doc-ri -l pl.UTF-8
252 Dokumentacja Ruby w formacie ri.
253
254 %package examples
255 Summary:        Ruby examples
256 Summary(pl.UTF-8):      Przykłady dla języka Ruby
257 Group:          Development/Languages
258
259 %description examples
260 Ruby examples.
261
262 %description examples -l pl.UTF-8
263 Przykłady programów w języku Ruby.
264
265 # IMPORTANT: keep this as last package, as we reset Epoch
266 %package rdoc
267 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
268 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
269 Version:        %{rdoc_ver}
270 Epoch:          0
271 License:        GPL v2 and Ruby and MIT
272 Group:          Development/Libraries
273 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
274
275 %description rdoc
276 RDoc produces HTML and command-line documentation for Ruby projects.
277 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
278 online documentation.
279
280 %description rdoc -l pl.UTF-8
281 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
282 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
283 wyświetlania dokumentacji online.
284
285 %package rubygems
286 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
287 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
288 Version:        %{rubygems_ver}
289 License:        Ruby or MIT
290 Group:          Development/Libraries
291 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
292 Requires:       %{name}-rdoc >= %{rdoc_ver}
293 Provides:       rubygems = %{rubygems_ver}
294 %if "%{_rpmversion}" >= "5"
295 BuildArch:      noarch
296 %endif
297
298 %description rubygems
299 RubyGems is the Ruby standard for publishing and managing third party
300 libraries.
301
302 %description rubygems -l pl.UTF-8
303 RubyGems to standardowe narzędzie języka Ruby do publikowania i
304 zarządzania zewnętrznymi bibliotekami.
305
306 %prep
307 %if %{with bootstrap}
308 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
309 %else
310 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
311 %endif
312 %patch0 -p1
313 %patch1 -p1
314 %patch2 -p1
315 %patch3 -p1
316 %patch4 -p1
317 %patch5 -p1
318
319 # must be regenerated with new bison
320 %{__rm} parse.{c,h}
321
322 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
323
324 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
325         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
326         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
327
328 %build
329 cp -f /usr/share/automake/config.sub .
330
331 # build ruby-1.8.7 first
332 %if %{with bootstrap}
333 cd %{name}-1.8.7-p330
334 %configure
335 %{__make}
336 cd ..
337 %endif
338
339 %{__autoconf}
340 %configure \
341         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
342         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
343         --with-archdir=%{ruby_archdir} \
344         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
345         --with-sitearchdir=%{ruby_sitearchdir} \
346         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
347         --with-vendorarchdir=%{ruby_vendorarchdir} \
348         --with-rubygemsdir=%{rubygems_dir} \
349         --with-search-path="%{legacy_loadpaths}" \
350         --enable-shared \
351         --enable-pthread \
352         --disable-rubygems \
353         --disable-install-doc \
354         --with-ruby-version=minor
355
356 %{__make} -j1 main \
357         COPY="cp -p" Q= \
358         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
359
360 %if %{with doc}
361 %{__make} -j1 rdoc
362 %endif
363
364 %install
365 rm -rf $RPM_BUILD_ROOT
366 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
367         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
368         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
369
370 %{__make} install %{?with_doc:install-doc} \
371         DESTDIR=$RPM_BUILD_ROOT
372
373 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
374 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
375 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
376
377 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
378
379 %if %{without batteries}
380 # packaged separately
381 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json}
382 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
383 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
384 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
385 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
386 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON
387 %endif
388
389 %if %{with doc}
390 # too much .ri
391 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
392 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
393 %endif
394
395 %clean
396 rm -rf $RPM_BUILD_ROOT
397
398 %post   -p /sbin/ldconfig
399 %postun -p /sbin/ldconfig
400
401 %files
402 %defattr(644,root,root,755)
403 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
404 %attr(755,root,root) %{_bindir}/ruby
405 %if %{with batteries}
406 %attr(755,root,root) %{_bindir}/rake
407 %endif
408 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
409 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
410 %{_mandir}/man1/ruby.1*
411 %if %{with batteries}
412 %{_mandir}/man1/rake.1*
413 %endif
414
415 %dir %{_libdir}/%{name}
416 %dir %{_libdir}/%{name}/%{vendordir}
417 %dir %{_datadir}/%{name}
418 %dir %{_datadir}/%{name}/%{vendordir}
419
420 %dir %{ruby_libdir}
421 %dir %{ruby_archdir}
422 %dir %{ruby_vendorlibdir}
423 %dir %{ruby_vendorarchdir}
424
425 %dir %{_datadir}/ri
426 %dir %{_datadir}/ri/%{ruby_version}
427 %dir %{ruby_ridir}
428
429 %dir %{ruby_rdocdir}
430
431 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
432 %dir %{legacy_archdir}
433 %dir %{legacy_sitedir}
434 %dir %{legacy_sitelibdir}
435 %dir %{legacy_sitearchdir}
436 %dir %{legacy_vendorarchdir}
437 %dir %{legacy_libdir}/tasks
438 %dir %{legacy_archdir}/racc
439
440 %files devel
441 %defattr(644,root,root,755)
442 %attr(755,root,root) %{_libdir}/libruby.so
443 %{_includedir}/%{name}-%{ruby_version}
444 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
445
446 %files static
447 %defattr(644,root,root,755)
448 %{_libdir}/libruby-static.a
449
450 %if %{with tk}
451 %files tk
452 %defattr(644,root,root,755)
453 %{ruby_libdir}/tcltk.rb
454 %{ruby_libdir}/tk*.rb
455 %{ruby_libdir}/tk
456 %{ruby_libdir}/tkextlib
457 %attr(755,root,root) %{ruby_archdir}/t*.so
458 %endif
459
460 %files rdoc
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_bindir}/rdoc
463 %attr(755,root,root) %{_bindir}/ri
464 %{_mandir}/man1/rdoc.1*
465 %{ruby_libdir}/rdoc
466 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
467 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
468 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
469 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
470 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
471
472 %if %{with batteries}
473 %files rubygems
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{_bindir}/gem
476 %{ruby_libdir}/rubygems
477 %{ruby_libdir}/rubygems.rb
478 %{ruby_libdir}/ubygems.rb
479
480 %{gem_dir}/specifications/io-console-*.gemspec
481 %{gem_dir}/specifications/bigdecimal-*.gemspec
482 %if %{with batteries}
483 %dir %{gem_dir}/gems/rake-%{rake_ver}
484 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
485 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
486 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
487 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
488 %{gem_dir}/specifications/json-%{json_ver}.gemspec
489 %endif
490 %endif
491
492 %files modules
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_bindir}/erb
495 %attr(755,root,root) %{_bindir}/irb
496 %attr(755,root,root) %{_bindir}/testrb
497 %{ruby_libdir}/bigdecimal
498 %{ruby_libdir}/cgi
499 %{ruby_libdir}/date
500 %{ruby_libdir}/digest
501 %{ruby_libdir}/dl
502 %{ruby_libdir}/drb
503 %{ruby_libdir}/fiddle
504 %{ruby_libdir}/io
505 %{ruby_libdir}/irb
506 %{ruby_libdir}/matrix
507 %{ruby_libdir}/minitest
508 %{ruby_libdir}/net
509 %{ruby_libdir}/openssl
510 %{ruby_libdir}/optparse
511 %if %{with batteries}
512 %{ruby_libdir}/json
513 %{ruby_libdir}/rake
514 %endif
515 %{ruby_libdir}/psych
516 %{ruby_libdir}/racc
517 %{ruby_libdir}/rbconfig
518 %{ruby_libdir}/rexml
519 %{ruby_libdir}/rinda
520 %{ruby_libdir}/ripper
521 %{ruby_libdir}/rss
522 %{ruby_libdir}/shell
523 %{ruby_libdir}/syck
524 %{ruby_libdir}/test
525 %{ruby_libdir}/uri
526 %{ruby_libdir}/webrick
527 %{ruby_libdir}/xmlrpc
528 %{ruby_libdir}/yaml
529 %{ruby_libdir}/[A-Za-s]*.rb
530 %{ruby_libdir}/tempfile.rb
531 %{ruby_libdir}/thread.rb
532 %{ruby_libdir}/thwait.rb
533 %{ruby_libdir}/time.rb
534 %{ruby_libdir}/timeout.rb
535 %{ruby_libdir}/tmpdir.rb
536 %{ruby_libdir}/tracer.rb
537 %{ruby_libdir}/tsort.rb
538 %{ruby_libdir}/[u-z]*.rb
539 %exclude %{ruby_libdir}/rubygems.rb
540 %exclude %{ruby_libdir}/ubygems.rb
541 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
542 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
543 %dir %{ruby_archdir}/digest
544 %attr(755,root,root) %{ruby_archdir}/digest/*.so
545 %dir %{ruby_archdir}/dl
546 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
547 %dir %{ruby_archdir}/enc
548 %attr(755,root,root) %{ruby_archdir}/enc/*.so
549 %dir %{ruby_archdir}/enc/trans
550 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
551 %dir %{ruby_archdir}/io
552 %attr(755,root,root) %{ruby_archdir}/io/*.so
553 %if %{with batteries}
554 %dir %{ruby_archdir}/json
555 %dir %{ruby_archdir}/json/ext
556 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
557 %endif
558 %dir %{ruby_archdir}/mathn
559 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
560 %dir %{ruby_archdir}/racc
561 %attr(755,root,root) %{ruby_archdir}/racc/*.so
562 %{ruby_archdir}/rbconfig.rb
563
564 # parents of gem_dir
565 %dir %{_datadir}/%{name}/gems
566 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
567 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
568
569 %dir %{gem_dir}
570 %dir %{gem_dir}/specifications
571 %{_mandir}/man1/erb.1*
572 %{_mandir}/man1/irb.1*
573 %{_mandir}/man1/ri.1*
574 %{_mandir}/man1/testrb.1*
575
576 %files doc
577 %defattr(644,root,root,755)
578 %doc ruby-doc-bundle/*
579 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
580 %{?with_doc:%doc ruby_%{doc_version}_core}
581
582 %if %{with doc}
583 %files doc-ri
584 %defattr(644,root,root,755)
585 %{ruby_ridir}/*
586 %endif
587
588 %files examples
589 %defattr(644,root,root,755)
590 %{_examplesdir}/%{name}-%{version}
This page took 0.111903 seconds and 3 git commands to generate.