]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
324b3822d9ee5a99c2b995e5ab5c62a4c1495bb6
[packages/ruby.git] / ruby.spec
1 # TODO:
2 #       - include ext/ in docs
3 #       - replace ri with fastri
4 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
5 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
6 # - fix requires/provides 'ruby(abi) = '
7 # - fix tk build
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
13 %bcond_without  default_ruby    # use this Ruby as default system Ruby
14 %bcond_with     bootstrap       # build bootstrap version
15
16 %define         rel             0.5
17 %define         ruby_version    2.0
18 %define         basever         2.0.0
19 %define         patchlevel      451
20
21 %define         ruby_suffix %{!?with_default_ruby:%{ruby_version}}
22 %define         doc_version     2_0_0
23
24 %define         bigdecimal_ver  1.2.0
25 %define         io_console_ver  0.4.2
26 %define         irb_ver         0.9.6
27 %define         json_ver        1.7.7
28 %define         minitest_ver    4.3.2
29 %define         psych_ver       2.0.0
30 %define         rake_ver        0.9.6
31 %define         rdoc_ver        4.0.0
32 %define         rubygems_ver    2.0.14
33 %define         test_unit_ver   2.0.0.0
34
35 %define         oname   ruby
36 Summary:        Ruby - interpreted scripting language
37 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
38 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
39 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
40 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
41 Name:           ruby%{ruby_suffix}
42 Version:        %{basever}.%{patchlevel}
43 Release:        %{rel}
44 Epoch:          1
45 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
46 License:        (Ruby or BSD) and Public Domain
47 Group:          Development/Languages
48 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/2.0/%{oname}-%{basever}-p%{patchlevel}.tar.bz2
49 # Source0-md5:  908e4d1dbfe7362b15892f16af05adf8
50 Source1:        http://www.ruby-doc.org/download/%{oname}-doc-bundle.tar.gz
51 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
52 Source2:        http://www.ruby-doc.org/downloads/%{oname}_%{doc_version}_stdlib_rdocs.tgz
53 # Source2-md5:  e93307804295a43512cafbf660a4cbe0
54 Source3:        http://www.ruby-doc.org/downloads/%{oname}_%{doc_version}_core_rdocs.tgz
55 # Source3-md5:  900186f317b51edfbb2f5317f8855719
56 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{oname}-1.8.7-p330.tar.gz
57 # Source100-md5:        50a49edb787211598d08e756e733e42e
58 Source4:        rdoc.1
59 Source5:        testrb.1
60 Patch0:         %{oname}-lib64.patch
61 Patch1:         %{oname}-ffs.patch
62 Patch2:         fix-bison-invocation.patch
63 # http://redmine.ruby-lang.org/issues/5231
64 #Patch3:                disable-versioned-paths.patch
65 # TODO: Should be submitted upstream?
66 #Patch4:                arch-specific-dir.patch
67 # http://redmine.ruby-lang.org/issues/5281
68 #Patch5:                site-and-vendor-arch-flags.patch
69 # Make mkmf verbose by default
70 Patch6:         mkmf-verbose.patch
71 Patch7:         strip-ccache.patch
72 Patch8:         duplicated-paths.patch
73 Patch9:         DESTDIR.patch
74 Patch10:        empty-ruby-version.patch
75 Patch11:        rubygems-2.0.0-binary-extensions.patch
76 Patch12:        custom-rubygems-location.patch
77 Patch13:        readline-6.3.patch
78 URL:            http://www.ruby-lang.org/
79 BuildRequires:  autoconf >= 2.60
80 BuildRequires:  automake
81 BuildRequires:  bison >= 1.875
82 BuildRequires:  db-devel
83 BuildRequires:  gdbm-devel >= 1.8.3
84 BuildRequires:  libffi-devel
85 BuildRequires:  ncurses-devel
86 BuildRequires:  openssl-devel
87 BuildRequires:  pkgconfig
88 BuildRequires:  readline-devel >= 4.2
89 BuildRequires:  rpm-build >= 5.4.10-49
90 # boostrap needs ruby binary, erb module
91 %{!?with_bootstrap:BuildRequires:       rpm-rubyprov}
92 %{!?with_bootstrap:BuildRequires:       ruby-modules}
93 %{!?with_bootstrap:BuildRequires:       ruby}
94 BuildRequires:  sed >= 4.0
95 BuildRequires:  yaml-devel
96 %if %{with tk}
97 BuildRequires:  tk-devel
98 %endif
99 Requires(post,postun):  /sbin/ldconfig
100 Provides:       ruby(ver) = %{ruby_version}
101 Obsoletes:      ruby-REXML <= 2.4.0-2
102 Obsoletes:      ruby-doc < 1.8.4
103 Obsoletes:      ruby-fastthread <= 0.6.3
104 Conflicts:      rpm-build-macros < 1.692
105 Conflicts:      ruby-activesupport < 2.3.11-2
106 Conflicts:      ruby-activesupport2 < 2.3.11-2
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
110 #%define        gem_dir                 %{_datadir}/gems
111 #%define        gem_dir                 %{_datadir}/%{oname}/gems/%{ruby_version}
112 %define gem_dir                 %{_datadir}/%{oname}/%{ruby_version}/gems
113
114 # location where rubygems is installed
115 %define rubygems_dir            %{ruby_libdir}
116
117 %define ruby_archdir            %{_libdir}/%{oname}/%{ruby_version}
118 %define ruby_libarchdir         %{_libdir}/%{oname}/%{ruby_version}
119 %define ruby_libdir             %{_datadir}/%{oname}/%{ruby_version}
120
121 # This is the local lib/arch and should not be used for packaging.
122 %define sitedir                 site_ruby
123 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{oname}/%{sitedir}/%{ruby_version}
124 %define ruby_sitelibdir         %{_prefix}/local/share/%{oname}/%{sitedir}
125
126 # This is the general location for libs/archs compatible with all
127 # or most of the Ruby versions available in the PLD repositories.
128 %define vendordir               vendor_ruby
129 %define ruby_vendorarchdir      %{_libdir}/%{oname}/%{vendordir}/%{ruby_version}
130 %define ruby_vendorlibdir       %{_datadir}/%{oname}/%{vendordir}
131
132 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
133 %define legacy_libdir           %{_libdir}/%{oname}/%{ruby_version}
134 %define legacy_archdir          %{_libdir}/%{oname}/%{ruby_version}/%{_target_cpu}-linux
135 %define legacy_sitedir          %{_libdir}/%{oname}/%{sitedir}
136 %define legacy_sitelibdir       %{_libdir}/%{oname}/%{sitedir}/%{ruby_version}
137 %define legacy_sitearchdir      %{_libdir}/%{oname}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
138 %define legacy_vendordir        %{_libdir}/%{oname}/%{vendordir}
139 %define legacy_vendorlibdir     %{_libdir}/%{oname}/%{vendordir}/%{ruby_version}
140 %define legacy_vendorarchdir    %{_libdir}/%{oname}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
141
142 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
143 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
144 %define legacy_loadpath         %{legacy_archdir}
145 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
146
147 # bleh, some nasty (gcc or ruby) bug still not fixed
148 # (SEGV or "unexpected break" on miniruby run during build)
149 %define         specflags_ia64  -O0
150
151 # ruby needs frame pointers for correct exception handling
152 %define         specflags_ia32  -fno-omit-frame-pointer
153
154 %description
155 Ruby is the interpreted scripting language for quick and easy
156 object-oriented programming. It has many features to process text
157 files and to do system management tasks (as in Perl). It is simple,
158 straight-forward, extensible, and portable.
159
160 This package contains only shared library and ruby interpreter. To get
161 full-functional ruby environment install ruby-modules package.
162
163 %description -l ja.UTF-8
164 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
165 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
166 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
167
168 %description -l pl.UTF-8
169 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
170 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
171 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
172 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
173 rozszerzalny i przenośny.
174
175 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
176 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
177 funkcjonalnego środowiska ruby.
178
179 %description -l pt_BR.UTF-8
180 Ruby é uma linguagem de script interpretada de programação orientada a
181 objeto. Possui diversas características para processamento de texto. É
182 simples, extensível e direta.
183
184 %package modules
185 Summary:        Ruby standard modules and utilities
186 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
187 Group:          Development/Languages
188 Requires:       %{name} = %{epoch}:%{version}-%{release}
189 Suggests:       ruby-rubygems
190 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
191 Provides:       ruby-io-console = %{io_console_ver}
192 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
193 Provides:       ruby-modules(ver) = %{ruby_version}
194 %if %{with batteries}
195 Provides:       ruby-minitest = %{minitest_ver}
196 Obsoletes:      ruby-minitest <= 1.5.0
197 %endif
198 # FIXME later
199 Provides:       ruby(abi) = %{ruby_version}
200
201 %description modules
202 Ruby standard modules and utilities:
203 - erb - Tiny eRuby
204 - testrb - automatic runner for Test::Unit of Ruby
205
206 %description modules -l pl.UTF-8
207 Standardowe moduły i narzędzia Ruby:
208 - erb - mały eRuby
209 - testrb - automatyczny runner dla Ruby Test::Unit
210
211 %package tk
212 Summary:        Ruby/Tk bindings
213 Summary(pl.UTF-8):      Wiązania Ruby/Tk
214 Group:          Development/Languages
215 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
216
217 %description tk
218 This package contains Ruby/Tk bindings.
219
220 %description tk -l pl.UTF-8
221 Ten pakiet zawiera wiązania Ruby/Tk.
222
223 %package devel
224 Summary:        Ruby development libraries
225 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
226 Group:          Development/Languages
227 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
228 Requires:       gcc
229 Requires:       glibc-devel
230 Requires:       pkgconfig
231
232 %description devel
233 Ruby development libraries.
234
235 %description devel -l pl.UTF-8
236 Biblioteki programistyczne interpretera języka Ruby.
237
238 %package static
239 Summary:        Ruby static libraries
240 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
241 Group:          Development/Languages
242 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
243
244 %description static
245 Ruby static libraries.
246
247 %description static -l pl.UTF-8
248 Biblioteki statyczne Ruby.
249
250 %package doc
251 Summary:        Ruby HTML documentation
252 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
253 Group:          Documentation
254 %if "%{_rpmversion}" >= "5"
255 BuildArch:      noarch
256 %endif
257
258 %description doc
259 Ruby HTML documentation: FAQ, guide, core and standard library.
260
261 %description doc -l pl.UTF-8
262 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
263 stdlib.
264
265 %package doc-ri
266 Summary:        Ruby ri documentation
267 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
268 Group:          Documentation
269 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
270 %if "%{_rpmversion}" >= "5"
271 BuildArch:      noarch
272 %endif
273
274 %description doc-ri
275 Ruby ri documentation.
276
277 %description doc-ri -l pl.UTF-8
278 Dokumentacja Ruby w formacie ri.
279
280 %package examples
281 Summary:        Ruby examples
282 Summary(pl.UTF-8):      Przykłady dla języka Ruby
283 Group:          Development/Languages
284 %if "%{_rpmversion}" >= "5"
285 BuildArch:      noarch
286 %endif
287
288 %description examples
289 Ruby examples.
290
291 %description examples -l pl.UTF-8
292 Przykłady programów w języku Ruby.
293
294 # IMPORTANT: keep irb, rdoc, rubygems, rake, json as last packages as we reset epoch/version/release
295 # and %{version},%{release} macros may not be used directly as they take last
296 # subpackage value not main package one what you intend to use
297
298 %package irb
299 Summary:        The Interactive Ruby
300 Version:        %{irb_ver}
301 Release:        %{basever}.%{patchlevel}.%{rel}
302 Epoch:          0
303 Group:          Development/Languages
304 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
305 Provides:       irb = %{version}-%{release}
306 Provides:       ruby(irb) = %{version}-%{release}
307 %if "%{_rpmversion}" >= "5"
308 BuildArch:      noarch
309 %endif
310
311 %description irb
312 The irb is acronym for Interactive Ruby. It evaluates ruby expression
313 from the terminal.
314
315 %package rdoc
316 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
317 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
318 Version:        %{rdoc_ver}
319 Release:        %{basever}.%{patchlevel}.%{rel}
320 Epoch:          0
321 License:        GPL v2 and Ruby and MIT
322 Group:          Development/Libraries
323 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
324 Obsoletes:      rdoc <= 0.9.0
325 %if "%{_rpmversion}" >= "5"
326 BuildArch:      noarch
327 %endif
328
329 %description rdoc
330 RDoc produces HTML and command-line documentation for Ruby projects.
331 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
332 online documentation.
333
334 %description rdoc -l pl.UTF-8
335 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
336 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
337 wyświetlania dokumentacji online.
338
339 %package rubygems
340 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
341 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
342 Version:        %{rubygems_ver}
343 Release:        %{basever}.%{patchlevel}.%{rel}
344 Epoch:          0
345 License:        Ruby or MIT
346 Group:          Development/Libraries
347 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
348 Requires:       %{name}-rdoc >= %{rdoc_ver}
349 Suggests:       %{name}-devel
350 Provides:       rubygems = %{rubygems_ver}
351 %if "%{_rpmversion}" >= "5"
352 BuildArch:      noarch
353 %endif
354
355 %description rubygems
356 RubyGems is the Ruby standard for publishing and managing third party
357 libraries.
358
359 %description rubygems -l pl.UTF-8
360 RubyGems to standardowe narzędzie języka Ruby do publikowania i
361 zarządzania zewnętrznymi bibliotekami.
362
363 %package rake
364 Summary:        Rake is a Make-like program implemented in Ruby
365 Summary(pl.UTF-8):      Program typu Make dla języka Ruby
366 Version:        %{rake_ver}
367 Release:        %{basever}.%{patchlevel}.%{rel}
368 Epoch:          0
369 License:        MIT
370 Group:          Development/Languages
371 Provides:       rake = %{rake_ver}
372 Conflicts:      ruby-modules < 1:1.9.3.429-2
373 %if "%{_rpmversion}" >= "5"
374 BuildArch:      noarch
375 %endif
376
377 %description rake
378 Rake is a simple Ruby build program with capabilities similar to make.
379
380 It has the following features:
381 - Rakefiles (rake's version of Makefiles) are completely defined in
382   standard Ruby syntax. No XML files to edit. No quirky Makefile syntax
383   to worry about (is that a tab or a space?)
384 - Users can specify tasks with prerequisites.
385 - Rake supports rule patterns to synthesize implicit tasks.
386 - Rake is lightweight. It can be distributed with other projects as a
387   single file. Projects that depend upon rake do not require that rake
388   be installed on target systems.
389
390 %description rake -l pl.UTF-8
391 Rake to prosty program do budowania w języku Ruby o możliwościach
392 podobnych do make.
393
394 Ma następujące cechy:
395 - Pliki Rakefile (rake'owa odmiana plików Makefile) są definiowane
396   całkowicie w standardowej składni języka Ruby. Nie trzeba modyfikować
397   plików XML. Nie trzeba martwić się kaprysami składni Makefile (czy to
398   tabulacja czy spacja?).
399 - Użytkownicy mogą określać zadania z ich zależnościami.
400 - Rake obsługuje wzorce reguł do tworzenia z nich wynikowych zadań.
401 - Rake jest lekki. Może być rozpowszechniany z innymi projektami jako
402   pojedynczy plik. Projekty używające rake'a nie wymagają go
403   zainstalowanego na systemach docelowych.
404
405 %package json
406 Summary:        JSON library for Ruby
407 Summary(pl.UTF-8):      Biblioteka JSON dla języka Ruby
408 Version:        %{json_ver}
409 Release:        %{basever}.%{patchlevel}.%{rel}
410 Epoch:          0
411 License:        MIT
412 Group:          Development/Languages
413 Obsoletes:      ruby-json-rubyforge
414 Conflicts:      ruby-modules < 1:1.9.3.429-3
415
416 %description json
417 This is a JSON implementation as a Ruby extension in C.
418
419 %description json -l pl.UTF-8
420 Biblioteka JSON dla języka Ruby.
421
422 %prep
423 %if %{with bootstrap}
424 %setup -q -n %{oname}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
425 %else
426 %setup -q -n %{oname}-%{basever}-p%{patchlevel} -a1 -a2 -a3
427 %endif
428 %patch0 -p1
429 %patch1 -p1
430 %patch2 -p1
431 #%patch3 -p1
432 #%patch4 -p1
433 #%patch5 -p1
434 %patch6 -p1
435 %patch7 -p1
436 %patch8 -p1
437 %patch9 -p1
438 %patch10 -p1
439 %patch11 -p1
440 %patch12 -p1
441 %patch13 -p1
442
443 # must be regenerated with new bison
444 %{__rm} parse.{c,h}
445
446 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
447
448 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
449         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
450         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
451
452 %build
453 rubygems_ver=$(awk '/VERSION =/ && $1 == "VERSION" {print $3}' lib/rubygems.rb | xargs)
454 if [ $rubygems_ver != %{rubygems_ver} ]; then
455         echo "Set %%define rubygems_ver to $rubygems_ver and re-run."
456         exit 1
457 fi
458 rdoc_ver=$(awk '/VERSION =/ && $1 == "VERSION" {print $3}' lib/rdoc.rb | xargs)
459 if [ $rdoc_ver != %{rdoc_ver} ]; then
460         echo "Set %%define rdoc_ver to $rdoc_ver and re-run."
461         exit 1
462 fi
463
464 cp -f /usr/share/automake/config.sub .
465
466 # build ruby-1.8.7 first
467 %if %{with bootstrap}
468 cd %{oname}-1.8.7-p330
469 %configure
470 %{__make}
471 cd ..
472 %endif
473
474 %{__autoconf}
475 %configure \
476         %{?with_bootstrap:--with-baseruby=%{oname}-1.8.7-p330/miniruby} \
477         --program-suffix=%{ruby_suffix} \
478         --with-rubygemsdir=%{rubygems_dir} \
479         --with-rubylibprefix=%{ruby_libdir} \
480         --with-rubyarchprefix=%{ruby_archdir} \
481         --with-sitedir=%{ruby_sitelibdir} \
482         --with-sitearchdir=%{ruby_sitearchdir} \
483         --with-vendordir=%{ruby_vendorlibdir} \
484         --with-vendorarchdir=%{ruby_vendorarchdir} \
485         --with-rubyhdrdir=%{_includedir}/%{oname}-%{ruby_version} \
486         --with-rubyarchhdrdir=%{_includedir}/%{oname}-%{ruby_version} \
487         --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
488         --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
489         --enable-shared \
490         --enable-pthread \
491         --enable-multiarch \
492         --disable-rubygems \
493         --disable-install-doc \
494         --with-ruby-version=''
495
496 %{__make} -j1 main \
497         COPY="cp -p" Q= \
498         %{?with_bootstrap:BASERUBY="%{oname}-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
499
500 %if %{with doc}
501 %{__make} -j1 rdoc
502 %endif
503
504 %install
505 rm -rf $RPM_BUILD_ROOT
506 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{ruby_ridir}} \
507         $RPM_BUILD_ROOT%{ruby_vendorarchdir} \
508         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
509         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/data \
510
511 %{__make} install %{?with_doc:install-doc} \
512         DESTDIR=$RPM_BUILD_ROOT
513
514 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{oname}-%{basever}.%{patchlevel}
515 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{oname}-%{basever}.%{patchlevel}
516 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1/rdoc%{ruby_suffix}.1
517 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/testrb%{ruby_suffix}.1
518
519 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
520
521 ln -sf %{gem_dir}/gems/rake-%{rake_ver}/bin/rake $RPM_BUILD_ROOT%{_bindir}/rake%{ruby_suffix}
522
523 %if %{without batteries}
524 # packaged separately
525 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
526 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
527 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
528 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
529 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
530 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
531 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/default/{json,minitest,rake}-*.gemspec
532 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
533 %endif
534
535 %if %{with doc}
536 # too much .ri
537 #%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
538 #%{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
539 %endif
540
541 %clean
542 rm -rf $RPM_BUILD_ROOT
543
544 %post   -p /sbin/ldconfig
545 %postun -p /sbin/ldconfig
546
547 %files
548 %defattr(644,root,root,755)
549 %doc NEWS LEGAL README README.EXT ChangeLog
550 %attr(755,root,root) %{_bindir}/ruby%{ruby_suffix}
551 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
552 %attr(755,root,root) %ghost %{_libdir}/libruby.so.%{ruby_version}
553 %{_mandir}/man1/ruby%{ruby_suffix}.1*
554
555 %dir %{_libdir}/%{oname}
556 %dir %{_libdir}/%{oname}/%{vendordir}
557 %dir %{_datadir}/%{oname}
558
559 %dir %{ruby_libdir}
560 %dir %{ruby_archdir}
561 %dir %{ruby_vendorlibdir}
562 %dir %{ruby_vendorarchdir}
563
564 %dir %{_datadir}/ri
565 %dir %{_datadir}/ri/%{ruby_version}
566 %dir %{ruby_ridir}
567
568 #%dir %{ruby_rdocdir}
569
570 # common dirs for ruby vendor modules
571 %dir %{ruby_vendorlibdir}/data
572 %dir %{ruby_vendorlibdir}/net
573
574 %if 0
575 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
576 %dir %{legacy_archdir}
577 %dir %{legacy_sitedir}
578 %dir %{legacy_sitelibdir}
579 %dir %{legacy_sitearchdir}
580 %dir %{legacy_vendorarchdir}
581 %dir %{legacy_libdir}/tasks
582 %dir %{legacy_archdir}/racc
583 %endif
584
585 %files devel
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/libruby.so
588 %{_includedir}/%{oname}-%{ruby_version}
589 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
590 %{ruby_libdir}/mkmf.rb
591
592 %files static
593 %defattr(644,root,root,755)
594 %{_libdir}/libruby-static.a
595
596 %if %{with tk}
597 %files tk
598 %defattr(644,root,root,755)
599 %{ruby_libdir}/tcltk.rb
600 %{ruby_libdir}/tk*.rb
601 %{ruby_libdir}/tk
602 %{ruby_libdir}/tkextlib
603 %attr(755,root,root) %{ruby_archdir}/t*.so
604 %endif
605
606 %files irb
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_bindir}/irb%{ruby_suffix}
609 %{ruby_libdir}/irb.rb
610 %{ruby_libdir}/irb
611 %{_mandir}/man1/irb%{ruby_suffix}.1*
612
613 %files rdoc
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_bindir}/rdoc%{ruby_suffix}
616 %attr(755,root,root) %{_bindir}/ri%{ruby_suffix}
617 %{_mandir}/man1/rdoc%{ruby_suffix}.1*
618 %{ruby_libdir}/rdoc
619 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
620 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
621 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
622 %{gem_dir}/specifications/default/rdoc-%{rdoc_ver}.gemspec
623 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
624
625 %if %{with batteries}
626 %files rubygems
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_bindir}/gem%{ruby_suffix}
629 %dir %{rubygems_dir}
630 %{rubygems_dir}/rubygems
631 %{rubygems_dir}/rubygems.rb
632 %{rubygems_dir}/ubygems.rb
633 %{rubygems_dir}/rbconfig
634
635 %files rake
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/rake%{ruby_suffix}
638 %{_mandir}/man1/rake%{ruby_suffix}.1*
639 %{ruby_libdir}/rake
640 %dir %{gem_dir}/gems/rake-%{rake_ver}
641 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
642 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
643 %{gem_dir}/specifications/default/rake-%{rake_ver}.gemspec
644
645 %files json
646 %defattr(644,root,root,755)
647 %{ruby_libdir}/json
648 %dir %{ruby_archdir}/json
649 %dir %{ruby_archdir}/json/ext
650 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
651 %{gem_dir}/specifications/default/json-%{json_ver}.gemspec
652 %endif
653
654 %files modules
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_bindir}/erb%{ruby_suffix}
657 %attr(755,root,root) %{_bindir}/testrb%{ruby_suffix}
658 %{ruby_libdir}/bigdecimal
659 %{ruby_libdir}/cgi
660 %{ruby_libdir}/date
661 %{ruby_libdir}/digest
662 %{ruby_libdir}/dl
663 %{ruby_libdir}/drb
664 %{ruby_libdir}/fiddle
665 %{ruby_libdir}/io
666 %{ruby_libdir}/matrix
667 %{ruby_libdir}/net
668 %{ruby_libdir}/openssl
669 %{ruby_libdir}/optparse
670 %{ruby_libdir}/psych
671 %{ruby_libdir}/racc
672 %{ruby_libdir}/rbconfig
673 %{ruby_libdir}/rexml
674 %{ruby_libdir}/rinda
675 %{ruby_libdir}/ripper
676 %{ruby_libdir}/rss
677 %{ruby_libdir}/shell
678 #%{ruby_libdir}/syck
679 %{ruby_libdir}/syslog
680 %{ruby_libdir}/test
681 %{ruby_libdir}/uri
682 %{ruby_libdir}/webrick
683 %{ruby_libdir}/xmlrpc
684 %{ruby_libdir}/yaml
685 %{ruby_libdir}/[A-Za-s]*.rb
686 %{ruby_libdir}/tempfile.rb
687 %{ruby_libdir}/thread.rb
688 %{ruby_libdir}/thwait.rb
689 %{ruby_libdir}/time.rb
690 %{ruby_libdir}/timeout.rb
691 %{ruby_libdir}/tmpdir.rb
692 %{ruby_libdir}/tracer.rb
693 %{ruby_libdir}/tsort.rb
694 %{ruby_libdir}/[u-z]*.rb
695 %if %{with batteries}
696 %exclude %{ruby_libdir}/rubygems.rb
697 %exclude %{ruby_libdir}/ubygems.rb
698 %exclude %{ruby_libdir}/rbconfig/datadir.rb
699 %exclude %{ruby_libdir}/rbconfig/obsolete.rb
700 %endif
701 %exclude %{ruby_libdir}/irb.rb
702 %exclude %{ruby_libdir}/mkmf.rb
703 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
704 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
705 %dir %{ruby_archdir}/digest
706 %attr(755,root,root) %{ruby_archdir}/digest/*.so
707 %dir %{ruby_archdir}/dl
708 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
709 %dir %{ruby_archdir}/enc
710 %attr(755,root,root) %{ruby_archdir}/enc/*.so
711 %dir %{ruby_archdir}/enc/trans
712 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
713 %dir %{ruby_archdir}/io
714 %attr(755,root,root) %{ruby_archdir}/io/*.so
715 %dir %{ruby_archdir}/mathn
716 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
717 %dir %{ruby_archdir}/racc
718 %attr(755,root,root) %{ruby_archdir}/racc/*.so
719 %{ruby_archdir}/rbconfig.rb
720
721 %{gem_dir}/specifications/default/bigdecimal-%{bigdecimal_ver}.gemspec
722 %{gem_dir}/specifications/default/io-console-%{io_console_ver}.gemspec
723
724 %if %{with batteries}
725 # minitest
726 %{ruby_libdir}/minitest
727 %{gem_dir}/specifications/default/minitest-%{minitest_ver}.gemspec
728 %endif
729
730 %{gem_dir}/specifications/default/psych-%{psych_ver}.gemspec
731
732 # test-unit
733 %{gem_dir}/specifications/default/test-unit-%{test_unit_ver}.gemspec
734 %dir %{gem_dir}/gems/test-unit-%{test_unit_ver}
735 %dir %{gem_dir}/gems/test-unit-%{test_unit_ver}/bin
736 %attr(755,root,root) %{gem_dir}/gems/test-unit-%{test_unit_ver}/bin/testrb
737
738 # parents of gem_dir
739 #%dir %{_datadir}/%{oname}/gems
740 #%dir %{_datadir}/%{oname}/gems/%{ruby_version}
741 #%dir %{_datadir}/%{oname}/gems/%{ruby_version}/gems
742
743 %dir %{_datadir}/%{oname}/%{ruby_version}/gems/gems
744
745 %dir %{gem_dir}
746 %dir %{gem_dir}/specifications
747 %dir %{gem_dir}/specifications/default
748 %{_mandir}/man1/erb%{ruby_suffix}.1*
749 %{_mandir}/man1/ri%{ruby_suffix}.1*
750 %{_mandir}/man1/testrb%{ruby_suffix}.1*
751
752 %files doc
753 %defattr(644,root,root,755)
754 %doc ruby-doc-bundle/*
755 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
756 %{?with_doc:%doc ruby_%{doc_version}_core}
757
758 %if %{with doc}
759 %files doc-ri
760 %defattr(644,root,root,755)
761 %{ruby_ridir}/*
762 %endif
763
764 %files examples
765 %defattr(644,root,root,755)
766 %{_examplesdir}/%{oname}-*
This page took 0.0979179999999999 seconds and 3 git commands to generate.