]> git.pld-linux.org Git - packages/ruby-ohai.git/blob - ruby-ohai.spec
make net-dhcp module optional
[packages/ruby-ohai.git] / ruby-ohai.spec
1 #
2 # Release Notes: https://github.com/opscode/ohai/blob/master/CHANGELOG.md
3 #
4 # Conditional build:
5 %bcond_with     tests           # build without tests
6
7 %define pkgname ohai
8 Summary:        Profiles your system and emits JSON
9 Name:           ruby-%{pkgname}
10 Version:        7.6.0
11 Release:        0.3
12 License:        Apache v2.0
13 Group:          Development/Languages
14 Source0:        https://github.com/opscode/ohai/archive/%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  b28339ec7f835a2ed4ec0f876178fb14
16 Patch0:         virtualization-vserver.patch
17 Patch1:         platform-pld.patch
18 Patch2:         soft-net-dhcp.patch
19 URL:            http://docs.getchef.com/ohai.html
20 BuildRequires:  rpm-rubyprov
21 BuildRequires:  rpmbuild(macros) >= 1.665
22 BuildRequires:  ruby-rake
23 BuildRequires:  sed >= 4.0
24 # rake gem uses installed ohai version not version we intend to build!
25 BuildConflicts: ruby-ohai
26 %if %{with tests}
27 BuildRequires:  ruby-ffi >= 1.9
28 BuildRequires:  ruby-ffi-yajl >= 1.1
29 BuildRequires:  ruby-ipaddress
30 BuildRequires:  ruby-mixlib-config
31 BuildRequires:  ruby-mixlib-log
32 BuildRequires:  ruby-mixlib-shellout >= 2.0.0
33 BuildRequires:  ruby-rspec
34 BuildRequires:  ruby-systemu >= 2.6.4
35 %endif
36 Requires:       iproute2
37 Requires:       lsb-release
38 Requires:       mount
39 Requires:       ruby-ffi >= 1.9
40 Requires:       ruby-ffi-yajl >= 1.1
41 Requires:       ruby-ipaddress
42 Requires:       ruby-mime-types >= 1.16
43 Requires:       ruby-mixlib-cli
44 Requires:       ruby-mixlib-config >= 2.0
45 Requires:       ruby-mixlib-log
46 Requires:       ruby-mixlib-shellout >= 2.0.0
47 Requires:       ruby-systemu >= 2.6.4
48 Suggests:       ruby-net-dhcp
49 BuildArch:      noarch
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Ohai detects data about your operating system and prints out a JSON
54 data blob. It can be used standalone, but it's primary purpose is to
55 provide node data to Chef.
56
57 %package doc
58 Summary:        Documentation for %{name}
59 Group:          Documentation
60 Requires:       %{name} = %{version}-%{release}
61
62 %description doc
63 This package contains documentation for %{name}.
64
65 %prep
66 %setup -q -n ohai-%{version}
67 #%patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
71
72 # no plist and not darwin so don't care
73 rm spec/unit/plugins/darwin/system_profiler_spec.rb
74
75 # can't figure how to fix -r rubygems does not help
76 # ohai-6.16.0/spec/unit/plugins/ruby_spec.rb:52:in `block in <top (required)>': uninitialized cons tant Gem (NameError)
77 rm spec/unit/plugins/ruby_spec.rb
78
79 %build
80 rake -Ilib gem
81 %{__tar} -xmf pkg/ohai-%{version}*.gem
82 %__gem_helper spec
83
84 %if %{with tests}
85 # Occasionally fails with "undefined method `rfc2822' for nil:NilClass" during
86 # mock. Unsure why - disable for now.
87 #sed -i 's^Time.should_receive(:now)^^' spec/ohai/plugins/ohai_time_spec.rb
88 LC_ALL=en_US.utf8 \
89 rake -r rubygems spec
90 %endif
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir},%{_mandir}/man1}
95 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
96 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
97 cp -p docs/man/man1/ohai.1 $RPM_BUILD_ROOT%{_mandir}/man1
98 cp -p %{pkgname}-%{version}*.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc README.md CHANGELOG.md RELEASE_NOTES.md OHAI_MVPS.md NOTICE
106 %attr(755,root,root) %{_bindir}/ohai
107 %{_mandir}/man1/ohai.1*
108 %{ruby_vendorlibdir}/%{pkgname}.rb
109 %{ruby_vendorlibdir}/%{pkgname}
110 %{ruby_specdir}/%{pkgname}-%{version}*.gemspec
This page took 0.055534 seconds and 3 git commands to generate.