]> git.pld-linux.org Git - packages/ruby-ohai.git/blob - ruby-ohai.spec
f25b58c32276edcd3b14e7bb2f442ec92780105d
[packages/ruby-ohai.git] / ruby-ohai.spec
1 #
2 # Release Notes: https://github.com/opscode/ohai/blob/master/CHANGELOG.md
3 #
4 # Conditional build:
5 %bcond_with     tests           # build without tests
6
7 %define pkgname ohai
8 Summary:        Profiles your system and emits JSON
9 Name:           ruby-%{pkgname}
10 Version:        7.6.0
11 Release:        0.3
12 License:        Apache v2.0
13 Group:          Development/Languages
14 Source0:        https://github.com/opscode/ohai/archive/%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  b28339ec7f835a2ed4ec0f876178fb14
16 Patch0:         virtualization-vserver.patch
17 Patch1:         platform-pld.patch
18 URL:            http://docs.getchef.com/ohai.html
19 BuildRequires:  rpm-rubyprov
20 BuildRequires:  rpmbuild(macros) >= 1.665
21 BuildRequires:  ruby-rake
22 BuildRequires:  sed >= 4.0
23 %if %{with tests}
24 BuildRequires:  ruby-ffi >= 1.9
25 BuildRequires:  ruby-ffi-yajl >= 1.1
26 BuildRequires:  ruby-ipaddress
27 BuildRequires:  ruby-mixlib-config
28 BuildRequires:  ruby-mixlib-log
29 BuildRequires:  ruby-mixlib-shellout >= 2.0.0
30 BuildRequires:  ruby-rspec
31 BuildRequires:  ruby-systemu >= 2.6.4
32 %endif
33 Requires:       iproute2
34 Requires:       lsb-release
35 Requires:       ruby-ffi >= 1.9
36 Requires:       ruby-ffi-yajl >= 1.1
37 Requires:       ruby-ipaddress
38 Requires:       ruby-mime-types >= 1.16
39 Requires:       ruby-mixlib-cli
40 Requires:       ruby-mixlib-config >= 2.0
41 Requires:       ruby-mixlib-log
42 Requires:       mount
43 Requires:       ruby-mixlib-shellout >= 2.0.0
44 Requires:       ruby-systemu >= 2.6.4
45 BuildArch:      noarch
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Ohai detects data about your operating system and prints out a JSON
50 data blob. It can be used standalone, but it's primary purpose is to
51 provide node data to Chef.
52
53 %package doc
54 Summary:        Documentation for %{name}
55 Group:          Documentation
56 Requires:       %{name} = %{version}-%{release}
57
58 %description doc
59 This package contains documentation for %{name}.
60
61 %prep
62 %setup -q -n ohai-%{version}
63 #%patch0 -p1
64 %patch1 -p1
65 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
66
67 # no plist and not darwin so don't care
68 rm spec/unit/plugins/darwin/system_profiler_spec.rb
69
70 # can't figure how to fix -r rubygems does not help
71 # ohai-6.16.0/spec/unit/plugins/ruby_spec.rb:52:in `block in <top (required)>': uninitialized cons tant Gem (NameError)
72 rm spec/unit/plugins/ruby_spec.rb
73
74 %build
75 rake gem
76 %{__tar} -xmf pkg/ohai-%{version}*.gem
77 %__gem_helper spec
78
79 %if %{with tests}
80 # Occasionally fails with "undefined method `rfc2822' for nil:NilClass" during
81 # mock. Unsure why - disable for now.
82 #sed -i 's^Time.should_receive(:now)^^' spec/ohai/plugins/ohai_time_spec.rb
83 LC_ALL=en_US.utf8 \
84 rake -r rubygems spec
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir},%{_mandir}/man1}
90 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
91 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
92 cp -p docs/man/man1/ohai.1 $RPM_BUILD_ROOT%{_mandir}/man1
93 cp -p %{pkgname}-%{version}*.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README.md CHANGELOG.md RELEASE_NOTES.md OHAI_MVPS.md NOTICE
101 %attr(755,root,root) %{_bindir}/ohai
102 %{_mandir}/man1/ohai.1*
103 %{ruby_vendorlibdir}/%{pkgname}.rb
104 %{ruby_vendorlibdir}/%{pkgname}
105 %{ruby_specdir}/%{pkgname}-%{version}*.gemspec
This page took 0.050282 seconds and 3 git commands to generate.