]> git.pld-linux.org Git - packages/ruby-ohai.git/blob - ruby-ohai.spec
update deps from ohai.gemspec
[packages/ruby-ohai.git] / ruby-ohai.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname ohai
6 Summary:        Profiles your system and emits JSON
7 Name:           ruby-%{pkgname}
8 Version:        7.4.0
9 Release:        0.1
10 License:        Apache v2.0
11 Group:          Development/Languages
12 Source0:        https://github.com/opscode/ohai/archive/%{version}/%{pkgname}-%{version}.tar.gz
13 # Source0-md5:  5275e5f79b618ce2af85311cd760b977
14 Patch0:         virtualization-vserver.patch
15 URL:            http://docs.getchef.com/ohai.html
16 BuildRequires:  rpm-rubyprov
17 BuildRequires:  rpmbuild(macros) >= 1.665
18 BuildRequires:  ruby-rake
19 BuildRequires:  sed >= 4.0
20 %if %{with tests}
21 BuildRequires:  ruby-ffi >= 1.9
22 BuildRequires:  ruby-ffi-yajl >= 1.0
23 BuildRequires:  ruby-ipaddress
24 BuildRequires:  ruby-mixlib-config
25 BuildRequires:  ruby-mixlib-log
26 BuildRequires:  ruby-mixlib-shellout >= 1.2
27 BuildRequires:  ruby-rspec
28 BuildRequires:  ruby-systemu >= 2.6.4
29 %endif
30 Requires:       lsb-release
31 Requires:       ruby-ffi >= 1.9
32 Requires:       ruby-ffi-yajl >= 1.0
33 Requires:       ruby-ipaddress
34 Requires:       ruby-mime-types >= 1.16
35 Requires:       ruby-mixlib-cli
36 Requires:       ruby-mixlib-config >= 2.0
37 Requires:       ruby-mixlib-log
38 Requires:       ruby-mixlib-shellout >= 1.2
39 Requires:       ruby-systemu >= 2.6.4
40 BuildArch:      noarch
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Ohai detects data about your operating system and prints out a JSON
45 data blob. It can be used standalone, but it's primary purpose is to
46 provide node data to Chef.
47
48 %package doc
49 Summary:        Documentation for %{name}
50 Group:          Documentation
51 Requires:       %{name} = %{version}-%{release}
52
53 %description doc
54 This package contains documentation for %{name}.
55
56 %prep
57 %setup -q -n ohai-%{version}
58 %patch0 -p1
59 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
60
61 # no plist and not darwin so don't care
62 rm spec/unit/plugins/darwin/system_profiler_spec.rb
63
64 # can't figure how to fix -r rubygems does not help
65 # ohai-6.16.0/spec/unit/plugins/ruby_spec.rb:52:in `block in <top (required)>': uninitialized cons tant Gem (NameError)
66 rm spec/unit/plugins/ruby_spec.rb
67
68 %build
69 rake gem
70 %{__tar} -xmf pkg/ohai-%{version}*.gem
71 %__gem_helper spec
72
73 %if %{with tests}
74 # Occasionally fails with "undefined method `rfc2822' for nil:NilClass" during
75 # mock. Unsure why - disable for now.
76 #sed -i 's^Time.should_receive(:now)^^' spec/ohai/plugins/ohai_time_spec.rb
77 LC_ALL=en_US.utf8 \
78 rake -r rubygems spec
79 %endif
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir},%{_mandir}/man1}
84 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
85 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
86 cp -p docs/man/man1/ohai.1 $RPM_BUILD_ROOT%{_mandir}/man1
87 cp -p %{pkgname}-%{version}*.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc README.md CHANGELOG.md RELEASE_NOTES.md OHAI_MVPS.md NOTICE
95 %attr(755,root,root) %{_bindir}/ohai
96 %{_mandir}/man1/ohai.1*
97 %{ruby_vendorlibdir}/%{pkgname}.rb
98 %{ruby_vendorlibdir}/%{pkgname}
99 %{ruby_specdir}/%{pkgname}-%{version}*.gemspec
This page took 0.293646 seconds and 3 git commands to generate.