]> git.pld-linux.org Git - packages/ruby-ohai.git/blob - ruby-ohai.spec
drop mime-types dep
[packages/ruby-ohai.git] / ruby-ohai.spec
1 #
2 # Release Notes: https://github.com/opscode/ohai/blob/master/CHANGELOG.md
3 #
4 # Conditional build:
5 %bcond_with     tests           # build without tests
6
7 %define pkgname ohai
8 Summary:        Profiles your system and emits JSON
9 Name:           ruby-%{pkgname}
10 Version:        8.16.0
11 Release:        0.1
12 License:        Apache v2.0
13 Group:          Development/Languages
14 Source0:        https://github.com/opscode/ohai/archive/%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  7a2182e562bab7dcc48e0b68e07daf92
16 Patch1:         platform-pld.patch
17 URL:            http://docs.getchef.com/ohai.html
18 BuildRequires:  rpm-rubyprov
19 BuildRequires:  rpmbuild(macros) >= 1.665
20 BuildRequires:  ruby-rake
21 BuildRequires:  sed >= 4.0
22 # rake gem uses installed ohai version not version we intend to build!
23 BuildConflicts: ruby-ohai
24 %if %{with tests}
25 BuildRequires:  ruby-ffi >= 1.9
26 BuildRequires:  ruby-ffi-yajl >= 1.1
27 BuildRequires:  ruby-ipaddress
28 BuildRequires:  ruby-mixlib-config
29 BuildRequires:  ruby-mixlib-log
30 BuildRequires:  ruby-mixlib-shellout >= 1.2
31 BuildRequires:  ruby-rspec
32 BuildRequires:  ruby-systemu >= 2.6.4
33 %endif
34 Requires:       iproute2
35 Requires:       lsb-release
36 Requires:       mount
37 Requires:       ruby(abi) >= 2.0
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Ohai detects data about your operating system and prints out a JSON
43 data blob. It can be used standalone, but it's primary purpose is to
44 provide node data to Chef.
45
46 %package doc
47 Summary:        Documentation for %{name}
48 Group:          Documentation
49 Requires:       %{name} = %{version}-%{release}
50
51 %description doc
52 This package contains documentation for %{name}.
53
54 %prep
55 %setup -q -n ohai-%{version}
56 %patch1 -p1
57 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
58
59 # don't need shellout 2.0 yet, but 2.0 is ok
60 %{__sed} -i -e '/mixlib-shellout/ s/">= 2.0.0.rc.0", "< 3.0"/">= 1.2", "< 3.0"/' %{pkgname}.gemspec
61 # optional
62 %{__sed} -i -e '/net-dhcp/d' %{pkgname}.gemspec
63 # platform specific and optional
64 %{__sed} -i -e '/wmi-lite/d' %{pkgname}.gemspec
65 %{__sed} -i -e '/plist/d' %{pkgname}.gemspec
66 # dev dep
67 %{__sed} -i -e '/rake/d' %{pkgname}.gemspec
68
69 # no plist and not darwin so don't care
70 rm spec/unit/plugins/darwin/system_profiler_spec.rb
71
72 # can't figure how to fix -r rubygems does not help
73 # ohai-6.16.0/spec/unit/plugins/ruby_spec.rb:52:in `block in <top (required)>': uninitialized constant Gem (NameError)
74 rm spec/unit/plugins/ruby_spec.rb
75
76 %build
77 # make gemspec self-contained
78 ruby -r rubygems -e 'spec = eval(File.read("%{pkgname}.gemspec"))
79         File.open("%{pkgname}-%{version}.gemspec", "w") do |file|
80         file.puts spec.to_ruby_for_cache
81 end'
82
83 %if %{with tests}
84 # Occasionally fails with "undefined method `rfc2822' for nil:NilClass" during
85 # mock. Unsure why - disable for now.
86 #sed -i 's^Time.should_receive(:now)^^' spec/ohai/plugins/ohai_time_spec.rb
87 LC_ALL=en_US.utf8 \
88 rake -r rubygems spec
89 %endif
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir},%{_mandir}/man1}
94 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
95 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
96 cp -p docs/man/man1/ohai.1 $RPM_BUILD_ROOT%{_mandir}/man1
97 cp -p %{pkgname}-%{version}*.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README.md CHANGELOG.md RELEASE_NOTES.md OHAI_MVPS.md NOTICE
105 %attr(755,root,root) %{_bindir}/ohai
106 %{_mandir}/man1/ohai.1*
107 %{ruby_vendorlibdir}/%{pkgname}.rb
108 %{ruby_vendorlibdir}/%{pkgname}
109 %{ruby_specdir}/%{pkgname}-%{version}*.gemspec
This page took 0.086716 seconds and 3 git commands to generate.