]> git.pld-linux.org Git - packages/ruby-facter.git/blob - ruby-facter.spec
8a9365335111efe6380d295c92d0554a81127f81
[packages/ruby-facter.git] / ruby-facter.spec
1 %define         pkgname facter
2 Summary:        Ruby module for collecting simple facts about a host operating system
3 Name:           ruby-%{pkgname}
4 Version:        1.6.18
5 Release:        1
6 License:        GPL v2+
7 Group:          Development/Languages
8 Source0:        http://downloads.puppetlabs.com/%{pkgname}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  c209df5909ccd4112c19cf4b535027a7
10 URL:            http://puppetlabs.com/puppet/related-projects/facter/
11 BuildRequires:  docutils
12 BuildRequires:  rpm-rubyprov
13 BuildRequires:  rpmbuild(macros) >= 1.656
14 Requires:       net-tools
15 Requires:       which
16 # dmidecode and pciutils are not available on all arches
17 %ifarch %{ix86} %{x8664} ia64
18 Requires:       dmidecode
19 Requires:       pciutils
20 %endif
21 Obsoletes:      facter < 1.5.9
22 # due arch specific dependencies
23 #BuildArch:     noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Facter is a lightweight program that gathers basic node information
28 about the hardware and operating system. Facter is especially useful
29 for retrieving things like operating system names, hardware
30 characteristics, IP addresses, MAC addresses, and SSH keys.
31
32 Facter is extensible and allows gathering of node information that may
33 be custom or site specific. It is easy to extend by including your own
34 custom facts. Facter can also be used to create conditional
35 expressions in Puppet that key off the values returned by facts.
36
37 %prep
38 %setup -q -n %{pkgname}-%{version}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{ruby_sitelibdir}
43 %{__ruby} install.rb \
44         --quick \
45         --no-man \
46         --no-rdoc \
47         --sitelibdir=%{ruby_vendorlibdir} \
48         --destdir=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README.md etc/facter.conf
56 %attr(755,root,root) %{_bindir}/facter
57 %{ruby_vendorlibdir}/facter
58 %{ruby_vendorlibdir}/facter.rb
This page took 0.035998 seconds and 3 git commands to generate.