]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- added fr, ko man pages; added rpm2cpio.8 pl man page
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        36
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(pl):      Podstawowe
11 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
12 Source1:        %{name}.groups
13 Source2:        %{name}.macros
14 Source3:        %{name}-install-tree
15 Source4:        %{name}-find-rpm-provides
16 Source5:        %{name}-macros.perl
17 Source6:        %{name}-find-perl-provides
18 Source7:        %{name}-find-perl-requires
19 Source8:        %{name}-find-spec-bcond
20 Source9:        %{name}-find-lang
21 Source10:       %{name}-find-provides
22 Source11:       %{name}-find-requires
23 Source12:       %{name}-non-english-man-pages.tar.gz
24 Patch0:         %{name}-rpmrc.patch
25 Patch1:         %{name}-macros.patch
26 Patch2:         %{name}-arch.patch
27 Patch3:         %{name}-rpmpopt.patch
28 Patch4:         %{name}-perl-macros.patch
29 Patch5:         %{name}-db3.patch
30 Patch6:         %{name}-segv.patch
31 Patch7:         %{name}-am_fix.patch
32 Patch8:         %{name}-perl-req-perlfile.patch
33 Patch9:         %{name}-installplatform.patch
34 Patch10:        %{name}-cache.patch
35 Patch11:        %{name}-suggestions.patch
36 Patch12:        %{name}-rh-lame.patch
37 Patch13:        %{name}-glob.patch
38 Patch14:        %{name}-header_h.patch  
39 Patch15:        %{name}-fast-alAddPackage.patch
40 Patch16:        %{name}-byKey.patch
41 Patch17:        %{name}-perlprov.patch
42 Patch18:        %{name}-noperldir.patch
43 Patch19:        popt-cvs20010530.patch
44 Patch20:        %{name}-noexpand.patch
45 Patch21:        %{name}-scripts-closefds.patch
46 Patch22:        %{name}-python-amfix.patch
47 Patch23:        %{name}-non-english-man-pages.patch
48 Patch37:        %{name}-short_circuit.patch
49 Patch38:        %{name}-section_test.patch
50 BuildRequires:  gettext-devel >= 0.10.38-3
51 BuildRequires:  automake
52 BuildRequires:  db3-devel >= 3.1.17-9
53 BuildRequires:  bzip2-devel >= 1.0.1
54 BuildRequires:  zlib-devel
55 BuildRequires:  gettext-devel >= 0.10.38-3
56 BuildRequires:  libtool
57 BuildRequires:  automake
58 BuildRequires:  autoconf >= 2.50
59 BuildRequires:  python-devel
60 BuildRequires:  python-modules >= 2.2.1
61 BuildRequires:  zlib-devel >= 1.1.4
62 # Require static library only for static build
63 BuildRequires:  db3-static >= 3.1.17-9
64 BuildRequires:  bzip2-static >= 1.0.1
65 BuildRequires:  zlib-static
66 BuildRequires:  glibc-static >= 2.2.0
67 %endif
68 BuildRequires:  zlib-static >= 1.1.4
69 Obsoletes:      rpm-libs
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71 Obsoletes:      rpm-libs
72 %define __find_provides %{SOURCE4}
73 %define _binary_payload w9.gzdio
74 %define         __find_provides %{SOURCE4}
75 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
76 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
77 %define python_includedir  %{_includedir}/python%{python_version}
78 %define python_libdir      %{python_prefix}/lib/python%{python_version}
79 %define python_sitedir     %{python_libdir}/site-packages
80 %define         py_dyndir       %{py_libdir}/lib-dynload
81 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
82
83 %description
84 RPM is a powerful package manager, which can be used to build,
85 install, query, verify, update, and uninstall individual software
86 packages. A package consists of an archive of files, and package
87 information, including name, version, and description.
88
89 %description -l de
90 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
91 Installation, Anfrage, Verifizierung, Aktualisierung und
92 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
93 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
94 nombre, versión y descripción.
95
96 %description -l pl
97 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
98 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
99 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
100 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
101 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
102 do pacote, permissões dos arquivos, etc.
103
104 %package devel
105 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
106 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
107 Group(de):      Entwicklung/Libraries
108 Group(fr):      Development/Librairies
109 Group(pl):      Programowanie/Biblioteki
110 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
111 Group:          Development/Libraries
112 Requires:       %{name} = %{version}
113 Requires:       popt-devel
114
115 %description devel
116 The RPM packaging system includes a C library that makes it easy to
117 manipulate RPM packages and databases. It is intended to ease the
118 creation of graphical package managers and other tools that need
119 intimate knowledge of RPM packages.
120
121 %description devel -l de
122 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
123 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
124 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
125 herramientas que necesiten un conocimiento profundo de paquetes RPM.
126 Pliki nag³ówkowe i biblioteki statyczne.
127 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
128 ferramentas que precisem de conhecimento profundo de pacotes RPM.
129
130 %package static
131 Summary(pl):    Biblioteki statyczne rpm-a
132 Summary(pl):    Biblioteki statyczne RPM-a
133 Group(de):      Entwicklung/Libraries
134 Group(fr):      Development/Librairies
135 Group(pl):      Programowanie/Biblioteki
136 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
137 Group:          Development/Libraries
138 Requires:       %{name}-devel = %{version}
139
140 %description static
141 RPM static libraries.
142
143 %description static -l de
144 RPMs statische Libraries.
145 Biblioteki statyczne rpm-a.
146 %description static -l pl
147 Bibliotecas estáticas para desenvolvimento.
148
149 %package utils
150 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami
151 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
152 Group(de):      Applikationen/Datei
153 Group(pl):      Aplikacje/Pliki
154 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
155 Group:          Applications/File
156 Requires:       %{name} = %{version}
157
158 %description utils
159 Additional utilities for managing rpm packages and database.
160
161 %description utils -l de
162 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
163 Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami.
164 %description utils -l pl
165 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
166
167 %package perlprov
168 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
169 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
170 Group(de):      Applikationen/Datei
171 Group(pl):      Aplikacje/Pliki
172 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
173 Group:          Applications/File
174 Requires:       perl-modules
175 Requires:       findutils
176
177 %description perlprov
178 Additional utilities for checking perl provides/requires in rpm
179 packages.
180
181 %description perlprov -l de
182 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
183 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
184 %description perlprov -l pl
185 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
186 %package python
187
188 Group:          Development/Languages/Python
189 Group(de):      Entwicklung/Sprachen/Python
190 Group(pl):      Programowanie/Jêzyki/Python
191 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
192 %pyrequires_eq  python
193 %description python
194
195 %description -n python-rpm
196 The rpm-python package contains a module which permits applications
197 written in the Python programming language to use the interface
198 supplied by RPM (RPM Package Manager) libraries.
199
200 This package should be installed if you want to develop Python
201 Python para manipular pacotes e bancos de dados RPM.
202
203 %package build
204 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPMów
205 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
206 Group(de):      Applikationen/Datei
207 Group(pl):      Aplikacje/Pliki
208 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
209 Group:          Applications/File
210 Requires:       sh-utils
211 Requires:       binutils
212 Requires:       patch
213 Requires:       texinfo
214 Requires:       file >= 3.31
215 Requires:       binutils
216 Requires:       gcc >= 3.0.3
217 Requires:       gcc
218 Requires:       diffutils
219 Requires:       libtool
220 Requires:       glibc-devel
221 Requires:       sed
222 Requires:       sed
223 Requires:       autoconf
224 Requires:       automake
225 Requires:       popt >= 1.6.2-2
226 Requires:       tar
227 Requires:       textutils
228
229 %description build
230 %description -l de build
231
232 %description build -l de
233 %description -l pl build
234 Skrypty pomocnicze do budowania binarnych RPMów.
235 %description build -l pl
236 construir pacotes usando o RPM.
237
238 %prep
239 %setup -q -a12
240 %patch0 -p1
241 %patch1 -p1
242 %patch2 -p1
243 %patch3 -p1
244 %patch4 -p1
245 %patch5 -p1
246 %patch6 -p1
247 %patch7 -p1
248 %patch8 -p1
249 %patch11 -p0
250 %patch12 -p0
251 %patch11 -p0
252 %patch12 -p0
253 %patch15 -p0
254 %patch16 -p0
255 %patch15 -p0
256 %patch16 -p0
257 %patch17 -p1
258 %patch18 -p1
259 %patch19 -p1
260 %patch22 -p1
261 %patch23 -p1
262 %patch31 -p1
263 %patch36 -p1
264 cp platform.in macros.pld.in
265 %patch38 -p1
266 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
267 cp -f platform.in macros.pld.in
268 install %{SOURCE9} scripts/find-lang.sh
269 install %{SOURCE13} macros.python.in
270 install %{SOURCE6} scripts/find-perl-provides
271 install %{SOURCE7} scripts/find-perl-requires
272 install %{SOURCE9} scripts/find-lang.sh
273
274 (cd scripts;
275 mv -f perl.req perl.req.in
276 mv -f perl.prov perl.prov.in)
277 %build
278 awk -f %{SOURCE14} %{SOURCE1}
279
280 cd popt
281 autoconf
282 automake -a -c
283 aclocal
284 autoheader
285 %{__automake}
286 cd ..
287
288 rm -f missing
289 libtoolize --force --copy
290 autoconf
291 # ugly workaround for automake
292 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
293         lib/Makefile.am > lib/Makefile.am.new
294 mv -f lib/Makefile.am.new lib/Makefile.am
295 automake -a -c
296 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
297         lib/Makefile.in > lib/Makefile.in.new
298 mv -f lib/Makefile.in.new lib/Makefile.in
299
300 sed -e 's#python1.5#python%{python_version}#g' \
301         python/Makefile.in > python/Makefile.in.new
302 mv -f python/Makefile.in.new python/Makefile.in
303
304 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
305         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
306         --enable-v1-packages \
307         --with-python
308 %configure \
309         --enable-v1-packages \
310         --with-python
311
312
313 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
314
315         DESTDIR="$RPM_BUILD_ROOT" \
316 rm -rf $RPM_BUILD_ROOT
317
318 %{__make} install \
319         pkgbindir="%{_bindir}"
320
321 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
322 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
323
324 install %{SOURCE1} doc/manual/groups
325 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
326 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
327 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
328 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
329 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
330
331 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
332
333 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
334 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
335 # customized rpm macros - global for host
336 #
337 #%%_install_langs pl_PL:en_US
338 %%distribution PLD
339 EOF
340
341 %find_lang %{name}
342
343 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
344
345 %clean
346 %clean
347 rm -rf $RPM_BUILD_ROOT
348
349 rm -rf $RPM_BUILD_ROOT
350
351 %post   -p /sbin/ldconfig
352 %postun -p /sbin/ldconfig
353
354 %attr(755,root,root) %{_libdir}/rpm/rpmdb
355 %attr(755,root,root) %{_libdir}/rpm/rpmq
356 %attr(755,root,root) %{_libdir}/rpm/rpmk
357 %attr(755,root,root) %{_libdir}/rpm/rpmv
358 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
359 %attr(755,root,root) %{_libdir}/rpm/rpmdb
360 %attr(755,root,root) %{_libdir}/rpm/rpmq
361 %attr(755,root,root) %{_libdir}/rpm/rpmk
362 %attr(755,root,root) %{_libdir}/rpm/rpmv
363 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
364
365 %dir %{_sysconfdir}/rpm
366 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
367
368 %{_mandir}/man8/rpm.8*
369 %lang(fr) %{_mandir}/fr/man8/rpm.8*
370 %lang(ja) %{_mandir}/ja/man8/rpm.8*
371 %lang(ko) %{_mandir}/ko/man8/rpm.8*
372 %lang(pl) %{_mandir}/pl/man8/rpm.8*
373 %lang(ru) %{_mandir}/ru/man8/rpm.8*
374 %lang(sk) %{_mandir}/sk/man8/rpm.8*
375
376 %dir /var/lib/rpm
377 %dir %{_libdir}/rpm
378
379 %{_libdir}/rpm/noarch-linux
380 %{_libdir}/rpm/noarch-pld-linux
381 %ifarch i386 i486 i586 i686
382 %{_libdir}/rpm/rpmpopt*
383 %{_libdir}/rpm/noarch-linux
384 %{_libdir}/rpm/noarch-pld-linux
385 %ifarch i386 i486 i586 i686 athlon
386 %{_libdir}/rpm/i?86*
387 %{_libdir}/rpm/athlon*
388 %endif
389 %ifarch sparc sparc64
390 %endif
391 %ifarch ppc
392 %{_libdir}/rpm/ppc*
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_bindir}/rpmbuild
395 %attr(755,root,root) %{_bindir}/rpme
396 %attr(755,root,root) %{_bindir}/rpmi
397 %attr(755,root,root) %{_bindir}/rpmu
398 %attr(755,root,root) %{_libdir}/rpm/find-requires
399 %attr(755,root,root) %{_libdir}/rpm/find-provides
400 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
401 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
402 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
403 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
404 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
405 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
406 %attr(755,root,root) %{_libdir}/rpm/brp-*
407 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
408 %attr(755,root,root) %{_libdir}/rpm/compress-doc
409 %attr(755,root,root) %{_libdir}/rpm/cpanflute
410 %attr(755,root,root) %{_libdir}/rpm/http.req
411 %attr(755,root,root) %{_libdir}/rpm/magic.*
412 %attr(755,root,root) %{_libdir}/rpm/rpmi
413 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
414 %attr(755,root,root) %{_libdir}/rpm/rpme
415 %attr(755,root,root) %{_libdir}/rpm/rpmu
416 %attr(755,root,root) %{_libdir}/rpm/rpmb
417 %attr(755,root,root) %{_libdir}/rpm/rpmi
418 %attr(755,root,root) %{_libdir}/rpm/rpmt
419 %attr(755,root,root) %{_libdir}/rpm/rpme
420 %attr(755,root,root) %{_libdir}/librpm*.la
421 %attr(755,root,root) %{_libdir}/librpm*.so
422 %files devel
423 %defattr(644,root,root,755)
424 %{_includedir}/rpm
425 %attr(755,root,root) %{_libdir}/librpm*.la
426 %attr(755,root,root) %{_libdir}/librpm*.so
427
428 %files static
429 %attr(755,root,root) %{_bindir}/*
430 %files utils
431 %defattr(644,root,root,755)
432 %{_mandir}/man1/*
433 %attr(755,root,root) %{_bindir}/javadeps
434 %attr(755,root,root) %{_bindir}/rpm2cpio
435
436 %{_mandir}/man8/rpm2cpio.8*
437 %{_mandir}/man1/*
438 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
439 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
440 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
441 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
442
443 %files perlprov
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_libdir}/rpm/perl*
446 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
447 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
448 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
449 %files python
450 %defattr(644,root,root,755)
451 %{python_sitedir}/*.so
452 %{_libdir}/rpm/macros.python
453
454 %files -n python-rpm
455 * %{date} PLD Team <pld-list@pld.org.pl>
456 %{py_sitedir}/*.so
This page took 0.057023 seconds and 4 git commands to generate.