]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- changes in descriptions.
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        46
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(es):      Base
11 Group(pl):      Podstawowe
12 Group(pt_BR):   Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch27:        %{name}-hardlink-fixes.patch
55 Patch37:        %{name}-short_circuit.patch
56 Patch38:        %{name}-section_test.patch
57 URL:            http://www.rpm.org/
58 Icon:           rpm.gif
59 BuildRequires:  autoconf >= 2.50
60 BuildRequires:  automake
61 BuildRequires:  db3-devel >= 3.1.17-9
62 BuildRequires:  db1-devel >= 1.85
63 BuildRequires:  db3-devel >= 3.1.17-9
64 BuildRequires:  gettext-devel >= 0.10.38-3
65 BuildRequires:  python-devel
66 BuildRequires:  zlib-devel
67 BuildRequires:  python-modules >= 2.2.1
68 BuildRequires:  zlib-devel >= 1.1.4
69 %if %{!?_without_static:1}%{?_without_static:0}
70 # Require static library only for static build
71 BuildRequires:  db3-static >= 3.1.17-9
72 BuildRequires:  db1-static >= 1.85
73 BuildRequires:  zlib-static
74 %endif
75 BuildRequires:  zlib-static >= 1.1.4
76 Obsoletes:      rpm-libs
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78 Obsoletes:      rpm-libs
79 %define __find_provides %{SOURCE4}
80 %define _binary_payload w9.gzdio
81 %define         __find_provides %{SOURCE4}
82 %define py_ver         %(echo `python -c "import sys; print sys.version[:3]"`)
83 %define py_prefix      %(echo `python -c "import sys; print sys.prefix"`)
84 %define py_libdir      %{py_prefix}/lib/python%{py_ver}
85 %define py_sitedir     %{py_libdir}/site-packages
86 %define py_dyndir      %{py_libdir}/lib-dynload
87 %define         py_dyndir       %{py_libdir}/lib-dynload
88 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
89
90 %description
91 RPM is a powerful package manager, which can be used to build,
92 install, query, verify, update, and uninstall individual software
93 packages. A package consists of an archive of files, and package
94 information, including name, version, and description.
95
96 %description -l de
97 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
98 Installation, Anfrage, Verifizierung, Aktualisierung und
99 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
100 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
101 nombre, versión y descripción.
102
103 %description -l pl
104 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
105 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
106 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
107 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
108 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
109 do pacote, permissões dos arquivos, etc.
110
111 %package devel
112 Summary(de):    Header-Dateien uns Libraries
113 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
114 Group(de):      Entwicklung/Libraries
115 Group(es):      Desarrollo/Bibliotecas
116 Group(fr):      Development/Librairies
117 Group(pl):      Programowanie/Biblioteki
118 Group(pt_BR):   Desenvolvimento/Bibliotecas
119 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
120 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
121 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
122 Group:          Development/Libraries
123 Requires:       %{name} = %{version}
124 Requires:       popt-devel
125
126 %description devel
127 The RPM packaging system includes a C library that makes it easy to
128 manipulate RPM packages and databases. It is intended to ease the
129 creation of graphical package managers and other tools that need
130 intimate knowledge of RPM packages.
131
132 %description devel -l de
133 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
134 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
135 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
136 herramientas que necesiten un conocimiento profundo de paquetes RPM.
137
138 %description devel -l pl
139 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
140 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
141 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
142 ferramentas que precisem de conhecimento profundo de pacotes RPM.
143
144 %package static
145 Summary:        RPM static libraries
146 Summary(pl):    Biblioteki statyczne RPM-a
147 Group(de):      Entwicklung/Libraries
148 Group(es):      Desarrollo/Bibliotecas
149 Group(fr):      Development/Librairies
150 Group(pl):      Programowanie/Biblioteki
151 Group(pt_BR):   Desenvolvimento/Bibliotecas
152 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
153 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
154 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
155 Group:          Development/Libraries
156 Requires:       %{name}-devel = %{version}
157
158 %description static
159 RPM static libraries.
160
161 %description static -l de
162 RPMs statische Libraries.
163
164 %description static -l pl
165 Bibliotecas estáticas para desenvolvimento.
166
167 %package utils
168 Summary:        Additional utilities for managing rpm packages and database
169 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
170 Group(de):      Applikationen/Datei
171 Group(pl):      Aplikacje/Pliki
172 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
173 Group:          Applications/File
174 Requires:       %{name} = %{version}
175
176 %description utils
177 Additional utilities for managing rpm packages and database.
178
179 %description utils -l de
180 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
181
182 %description utils -l pl
183 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
184
185 %package perlprov
186 Summary:        Additional utilities for checking perl provides/requires in rpm packages
187 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
188 Group(de):      Applikationen/Datei
189 Group(pl):      Aplikacje/Pliki
190 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
191 Group:          Applications/File
192 Requires:       perl-modules
193 Requires:       findutils
194
195 %description perlprov
196 Additional utilities for checking perl provides/requires in rpm
197 packages.
198
199 %description perlprov -l de
200 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
201
202 %description perlprov -l pl
203 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
204 pakietach rpm.
205
206 %package pythonprov
207 Summary:        Python macros, which simplifies creation of rpm packages with Python software
208 Group(de):      Applikationen/Datei
209 Group(pl):      Aplikacje/Pliki
210 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
211 Requires:       python
212 Requires:       %{name} = %{version}
213 Requires:       python-modules
214
215 %description pythonprov
216 Python macros, which simplifies creation of rpm packages with Python
217 software.
218 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi
219 w Pythonie.
220 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
221 %package python
222
223 %package -n python-rpm
224 Group:          Development/Languages/Python
225 Group(de):      Entwicklung/Sprachen/Python
226 Group(pl):      Programowanie/Jêzyki/Python
227 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
228 %pyrequires_eq  python
229 %description python
230
231 %description -n python-rpm
232 The rpm-python package contains a module which permits applications
233 written in the Python programming language to use the interface
234 supplied by RPM (RPM Package Manager) libraries.
235
236 This package should be installed if you want to develop Python
237 %description python -l pl
238 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym
239 w Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
240 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
241 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ
242 w Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
243 Esse pacote deve ser instalado se você quiser desenvolver programas em
244 Python para manipular pacotes e bancos de dados RPM.
245
246 %package build
247 Summary:        Scripts for building binary RPM packages
248 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
249 Group(de):      Applikationen/Datei
250 Group(pl):      Aplikacje/Pliki
251 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
252 Group:          Applications/File
253 Requires:       /bin/id
254 Requires:       awk
255 Requires:       binutils
256 Requires:       file >= 3.31
257 Requires:       gcc >= 3.0.3
258 Requires:       gcc
259 Requires:       glibc-devel
260 Requires:       grep
261 Requires:       gzip
262 Requires:       make
263 Requires:       patch
264 Requires:       popt >= 1.6.2-2
265 Requires:       sed
266 Requires:       tar
267 Requires:       textutils
268
269 %description build
270 Scripts for building binary RPM packages.
271
272 %description build -l de
273 Scripts fürs Bauen binärer RPM-Pakete.
274
275 %description build -l pl
276 construir pacotes usando o RPM.
277
278 %prep
279 %setup -q -a12
280 %patch0 -p1
281 %patch1 -p1
282 %patch2 -p1
283 %patch3 -p1
284 %patch4 -p1
285 %patch5 -p1
286 %patch6 -p1
287 %patch7 -p1
288 %patch8 -p1
289 %patch11 -p0
290 %patch12 -p0
291 %patch11 -p0
292 %patch12 -p0
293 %patch15 -p0
294 %patch16 -p0
295 %patch15 -p0
296 %patch16 -p0
297 %patch17 -p1
298 %patch18 -p1
299 %patch19 -p1
300 %patch22 -p1
301 %patch23 -p1
302 %patch24 -p1
303 %patch25 -p1
304 %patch26 -p0
305 %patch27 -p1
306 %patch31 -p1
307 %patch36 -p1
308 %patch37 -p1
309 %patch38 -p1
310
311 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
312 cp -f platform.in macros.pld.in
313 install %{SOURCE9} scripts/find-lang.sh
314 install %{SOURCE13} macros.python.in
315 install %{SOURCE6} scripts/find-perl-provides
316 install %{SOURCE7} scripts/find-perl-requires
317 install %{SOURCE9} scripts/find-lang.sh
318
319 (cd scripts;
320 mv -f perl.req perl.req.in
321 mv -f perl.prov perl.prov.in)
322 %build
323 awk -f %{SOURCE14} %{SOURCE1}
324
325 cd popt
326 autoconf
327 automake -a -c
328 aclocal
329 autoheader
330 %{__automake}
331 cd ..
332
333 rm -f missing
334 libtoolize --force --copy
335 autoconf
336 # ugly workaround for automake
337 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
338         lib/Makefile.am > lib/Makefile.am.new
339 mv -f lib/Makefile.am.new lib/Makefile.am
340 automake -a -c
341 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
342         lib/Makefile.in > lib/Makefile.in.new
343 mv -f lib/Makefile.in.new lib/Makefile.in
344
345 sed -e 's#python1.5#python%{py_ver}#g' \
346         python/Makefile.in > python/Makefile.in.new
347 mv -f python/Makefile.in.new python/Makefile.in
348
349 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
350         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
351         --enable-v1-packages \
352         --with-python
353 %configure \
354         --enable-v1-packages \
355         --with-python
356
357
358 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
359
360 %install
361 rm -rf $RPM_BUILD_ROOT
362
363 %{__make} install \
364         DESTDIR=$RPM_BUILD_ROOT \
365         pkgbindir="%{_bindir}"
366
367 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
368 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
369
370 install %{SOURCE1} doc/manual/groups
371 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
372 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
373 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
374 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
375 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
376
377 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
378
379 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
380 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
381 # customized rpm macros - global for host
382 #
383 #%%_install_langs pl_PL:en_US
384 %%distribution PLD
385 EOF
386
387 %find_lang %{name}
388
389 # DON'T BREAK BUILD TREE!!!
390 # rm -f doc/manual/Makefile*
391
392 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
393
394 %clean
395 rm -rf $RPM_BUILD_ROOT
396
397 %post   -p /sbin/ldconfig
398 %postun -p /sbin/ldconfig
399
400 %attr(755,root,root) %{_libdir}/rpm/rpmdb
401 %attr(755,root,root) %{_libdir}/rpm/rpmq
402 %attr(755,root,root) %{_libdir}/rpm/rpmk
403 %attr(755,root,root) %{_libdir}/rpm/rpmv
404 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
405 %attr(755,root,root) %{_libdir}/rpm/rpmdb
406 %attr(755,root,root) %{_libdir}/rpm/rpmq
407 %attr(755,root,root) %{_libdir}/rpm/rpmk
408 %attr(755,root,root) %{_libdir}/rpm/rpmv
409 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
410
411 %dir %{_sysconfdir}/rpm
412 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
413
414 %{_mandir}/man8/rpm.8*
415 %lang(fr) %{_mandir}/fr/man8/rpm.8*
416 %lang(ja) %{_mandir}/ja/man8/rpm.8*
417 %lang(ko) %{_mandir}/ko/man8/rpm.8*
418 %lang(pl) %{_mandir}/pl/man8/rpm.8*
419 %lang(ru) %{_mandir}/ru/man8/rpm.8*
420 %lang(sk) %{_mandir}/sk/man8/rpm.8*
421
422 %dir /var/lib/rpm
423 %dir %{_libdir}/rpm
424
425 %{_libdir}/rpm/macros.python
426 %{_libdir}/rpm/noarch-linux
427 %{_libdir}/rpm/noarch-pld-linux
428 %ifarch i386 i486 i586 i686
429 %{_libdir}/rpm/rpmpopt*
430 %{_libdir}/rpm/noarch-linux
431 %{_libdir}/rpm/noarch-pld-linux
432 %ifarch i386 i486 i586 i686 athlon
433 %{_libdir}/rpm/i?86*
434 %{_libdir}/rpm/athlon*
435 %endif
436 %ifarch sparc sparc64
437 %{_libdir}/rpm/sparc*
438 %endif
439 %ifarch alpha
440 %{_libdir}/rpm/alpha*
441 %endif
442 %ifarch ppc
443 %{_libdir}/rpm/ppc*
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_bindir}/rpmbuild
446 %attr(755,root,root) %{_bindir}/rpme
447 %attr(755,root,root) %{_bindir}/rpmi
448 %attr(755,root,root) %{_bindir}/rpmu
449 %attr(755,root,root) %{_libdir}/rpm/find-requires
450 %attr(755,root,root) %{_libdir}/rpm/find-provides
451 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
452 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
453 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
454 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
455 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
456 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
457 %attr(755,root,root) %{_libdir}/rpm/brp-*
458 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
459 %attr(755,root,root) %{_libdir}/rpm/compress-doc
460 %attr(755,root,root) %{_libdir}/rpm/cpanflute
461 %attr(755,root,root) %{_libdir}/rpm/http.req
462 %attr(755,root,root) %{_libdir}/rpm/magic.*
463 %attr(755,root,root) %{_libdir}/rpm/rpmi
464 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
465 %attr(755,root,root) %{_libdir}/rpm/rpme
466 %attr(755,root,root) %{_libdir}/rpm/rpmu
467 %attr(755,root,root) %{_libdir}/rpm/rpmb
468 %attr(755,root,root) %{_libdir}/rpm/rpmi
469 %attr(755,root,root) %{_libdir}/rpm/rpmt
470 %attr(755,root,root) %{_libdir}/rpm/rpme
471 %attr(755,root,root) %{_libdir}/librpm*.la
472 %attr(755,root,root) %{_libdir}/librpm*.so
473 %files devel
474 %defattr(644,root,root,755)
475 %{_includedir}/rpm
476 %attr(755,root,root) %{_libdir}/librpm*.la
477 %attr(755,root,root) %{_libdir}/librpm*.so
478
479 %files static
480 %attr(755,root,root) %{_bindir}/*
481 %files utils
482 %defattr(644,root,root,755)
483 %{_mandir}/man1/*
484 %attr(755,root,root) %{_bindir}/javadeps
485 %attr(755,root,root) %{_bindir}/rpm2cpio
486
487 %{_mandir}/man8/rpm2cpio.8*
488 %{_mandir}/man1/*
489 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
490 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
491 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
492 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
493
494 %files perlprov
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{_libdir}/rpm/perl*
497 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
498 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
499 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
500 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
501 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
502
503 %{_libdir}/rpm/macros.perl
504 %files python
505 %defattr(644,root,root,755)
506 %{py_sitedir}/*.so
507 %{_libdir}/rpm/macros.python
508
509 %files -n python-rpm
510 * %{date} PLD Team <pld-list@pld.org.pl>
511 %{py_sitedir}/*.so
This page took 0.060812 seconds and 4 git commands to generate.