]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- revision up to 4
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        3.0.1
5 Release:        4
6 Group:          Base
7 Group(pl):      Bazowe
8 Copyright:      GPL
9 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/%{name}-%{version}.tar.gz
10 Source1:        rpm.groups
11 Source2:        rpm.8pl
12 Source3:        rpm.macros
13 Source4:        rpm.pl.po
14 Patch0:         rpm-rpmrc.patch
15 Patch1:         rpm-i18n.patch
16 Patch2:         rpm-find-requires.patch
17 Patch3:         rpm-macros.patch
18 Patch4:         rpm-po.patch
19 Patch5:         rpm-GNUconfigure.patch
20 Patch37:        %{name}-short_circuit.patch
21 Patch38:        %{name}-section_test.patch
22 BuildPrereq:    bzip2-static
23 BuildPrereq:    gdbm-static
24 BuildPrereq:    zlib-static
25 BuildPrereq:    patch >= 2.2
26 BuildPrereq:    libtool
27 BuildPrereq:    automake
28 BuildPrereq:    autoconf
29 BuildPrereq:    gettext
30 Requires:       glibc >= 2.1
31 BuildRoot:      /tmp/%{name}-%{version}-root
32 Obsoletes:      rpm-libs
33 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
34 RPM is a powerful package manager, which can be used to build, install, 
35 query, verify, update, and uninstall individual software packages. A 
36 package consists of an archive of files, and package information, including 
37 name, version, and description.
38 packages. A package consists of an archive of files, and package
39 nombre, versión y descripción.
40 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
41 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
42 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
43 systemu.
44 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
45 %package        devel
46 Summary:        Header files and libraries 
47 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
48 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
49 Group(pl):      Programowanie/Biblioteki
50 Requires:       %{name} = %{version}
51 Requires:       %{name} = %{version}
52 Requires:       popt-devel
53
54 %description devel
55 The RPM packaging system includes a C library that makes it easy to
56 manipulate RPM packages and databases. It is intended to ease the
57 creation of graphical package managers and other tools that need
58 %description -l pl devel
59 Pliki nag³ówkowe i biblioteki statyczne.
60 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
61 construir pacotes usando o RPM.
62 %setup  -q
63 %patch0 -p1 
64 %patch1 -p1
65 %patch2 -p1
66 %patch1 -p1
67 %patch4 -p1 
68 %patch5 -p1
69 %patch31 -p1
70 install %{SOURCE4} po/pl.po
71 install %{SOURCE13} macros.python.in
72 mv -f perl.prov perl.prov.in)
73 LDFLAGS="-s"; export LDFLAGS
74
75 ( cd popt; 
76 %GNUconfigure
77 )
78
79 %GNUconfigure -- --disable-shared 
80 %configure \
81 make
82         --with-python
83
84
85 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
86 install -d $RPM_BUILD_ROOT/var/lib/rpm \
87         $RPM_BUILD_ROOT/usr/man/{ru,pl}/man8 \
88         $RPM_BUILD_ROOT/etc/skel/C/rpm/{SRPMS,RPMS,SOURCES,SPECS,BUILD}
89
90 make DESTDIR="$RPM_BUILD_ROOT" install
91
92 install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/rpm/macros.pld
93         pkgbindir="%{_bindir}"
94 install rpm.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm.8
95 install rpm2cpio.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm2cpio.8
96 install %{SOURCE2} $RPM_BUILD_ROOT/usr/man/pl/man8/rpm.8
97
98 install %{SOURCE1} docs/groups
99 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
100 strip  $RPM_BUILD_ROOT/bin/rpm
101
102 gzip -9fn $RPM_BUILD_ROOT/usr/man/{{ru,pl}/man8/*,man8/*} \
103         RPM-PGP-KEY CHANGES docs/*
104
105 %post
106 /bin/rpm --initdb
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112
113 %doc RPM-PGP-KEY.gz CHANGES.gz docs/*
114 %postun -p /sbin/ldconfig
115
116 %attr(755,root,root) /usr/bin/gendiff
117 %attr(755,root,root) /usr/bin/rpm2cpio
118 %attr(755,root,root) %{_libdir}/rpm/rpmdb
119 /usr/man/man8/*
120 %lang(ru) /usr/man/ru/man8/*
121 %lang(pl) /usr/man/pl/man8/*
122
123 %lang(cs)    /usr/share/locale/cs/LC_MESSAGES/rpm.mo
124 %lang(de)    /usr/share/locale/de/LC_MESSAGES/rpm.mo
125 %lang(fi)    /usr/share/locale/fi/LC_MESSAGES/rpm.mo
126 %lang(fr)    /usr/share/locale/fr/LC_MESSAGES/rpm.mo
127 %lang(pl)    /usr/share/locale/pl/LC_MESSAGES/rpm.mo
128 %lang(pt_BR) /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo
129 %lang(ru)    /usr/share/locale/ru/LC_MESSAGES/rpm.mo
130 %lang(sk)    /usr/share/locale/sk/LC_MESSAGES/rpm.mo
131 %lang(sr)    /usr/share/locale/sr/LC_MESSAGES/rpm.mo
132 %lang(sv)    /usr/share/locale/sv/LC_MESSAGES/rpm.mo
133 %lang(tr)    /usr/share/locale/tr/LC_MESSAGES/rpm.mo
134 %lang(ru) %{_mandir}/ru/man8/rpm.8*
135 %attr(755,root,root) %dir /var/lib/rpm
136
137 %dir /usr/lib/rpm
138 %attr(755,root,root) /usr/lib/rpm/find-*
139 %attr(755,root,root) /usr/lib/rpm/freshen.sh
140 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
141 %attr(755,root,root) /usr/lib/rpm/config.*
142 %attr(755,root,root) /usr/lib/rpm/getpo.sh
143
144 /usr/lib/rpm/rpm*
145 /usr/lib/rpm/macros*
146
147 /etc/skel/C/rpm
148 %attr(755,root,root) %{_libdir}/rpm/rpmb
149 %attr(755,root,root) %{_libdir}/rpm/rpmi
150 %attr(755,root,root) %{_libdir}/rpm/rpmt
151 /usr/include/rpm
152 /usr/lib/librpm*.a
153 %files utils
154 %files -n python-rpm
155 * Fri Apr 30 1999 Artur Frysiak <wiget@pld.org.pl>
156   [3.0.1-4]
157 - added 4 macros:
158 -- %GNUconfigure and %GNUconfigureS to complete remake autoconf/automake stuff
159 -- %configure and %configureS to corect run ./configure
160 -- *S add "-s" to LDFLAGS
161 - added user skelet dirs (for adduser)
162
163 * Mon Apr 19 1999 Artur Frysiak <wiget@pld.org.pl>
164   [3.0-7]
165 - upgraded to 3.0
166 - added polish man page
167 - added macros for PLD
168
169 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
170   [2.5.6-5]
171 - added rpm-find-requires.patch with beter finding list packages containing
172   required shared libraries (Artur Frysiak <wiget@usa.net>),
173 - added ru man pages,
174 - added "Requires: glibc >= 2.1" (rpm is linked statically but it use by
175   dlopen() some shared glibc libraries),
176 - removed man group from man pages.
177
178 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
179   [2.5.6-4d]
180 - fixed ignorance about international character sets.
181
182 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
183   [2.5.6-1d]
184 - updated to latest stable version,
185 - added URL,
186 - added Group(pl) && changed gropup to Base,
187 - added small patch against GNU libc-2.1.
188
189 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
190   [2.5.5-1d]
191 - updated to 2.5.5. 
192
193 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
194   [2.5.2-2d]
195 - translation modified for pl,
196 - compressed man pages && documentation,
197 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
198 - moved /usr/src/redhat to /usr/src/rpm.
199
200 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
201   [2.5.2-2]
202 - fixed tr.po,
203 - added -q %setup parameter,
204 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
205 - added using %%{name} and %%{version} in Source,
206 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
207 - added %attr and %defattr macros in %files (allow build package from
208   non-root account),
209 - build against GNU libc-2.1.
210
211 Revision 1.79  2000/02/17 03:42:17  kloczek
212 - release 25,
213 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
214   /bin.
This page took 0.053848 seconds and 4 git commands to generate.