]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- perlprov-regonly patch: check for perl requirements only in regular files
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        47
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(es):      Base
11 Group(pl):      Podstawowe
12 Group(pt_BR):   Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch27:        %{name}-hardlink-fixes.patch
55 Patch28:        %{name}-perlprov-regonly.patch
56 Patch37:        %{name}-short_circuit.patch
57 Patch38:        %{name}-section_test.patch
58 URL:            http://www.rpm.org/
59 Icon:           rpm.gif
60 BuildRequires:  autoconf >= 2.50
61 BuildRequires:  automake
62 BuildRequires:  db3-devel >= 3.1.17-9
63 BuildRequires:  db1-devel >= 1.85
64 BuildRequires:  db3-devel >= 3.1.17-9
65 BuildRequires:  gettext-devel >= 0.10.38-3
66 BuildRequires:  python-devel
67 BuildRequires:  zlib-devel
68 BuildRequires:  python-modules >= 2.2.1
69 BuildRequires:  zlib-devel >= 1.1.4
70 %if %{!?_without_static:1}%{?_without_static:0}
71 # Require static library only for static build
72 BuildRequires:  db3-static >= 3.1.17-9
73 BuildRequires:  db1-static >= 1.85
74 BuildRequires:  zlib-static
75 %endif
76 BuildRequires:  zlib-static >= 1.1.4
77 Obsoletes:      rpm-libs
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79 Obsoletes:      rpm-libs
80 Conflicts:      glibc < 2.2
81
82 %define         __find_provides %{SOURCE4}
83 %define         _binary_payload w9.gzdio
84
85 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
86 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
87 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
88 %define         py_dyndir       %{py_libdir}/lib-dynload
89 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
90
91 %description
92 RPM is a powerful package manager, which can be used to build,
93 install, query, verify, update, and uninstall individual software
94 packages. A package consists of an archive of files, and package
95 information, including name, version, and description.
96
97 %description -l de
98 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
99 Installation, Anfrage, Verifizierung, Aktualisierung und
100 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
101 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
102 nombre, versión y descripción.
103
104 %description -l pl
105 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
106 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
107 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
108 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
109 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
110 do pacote, permissões dos arquivos, etc.
111
112 %package devel
113 Summary(de):    Header-Dateien uns Libraries
114 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
115 Group(de):      Entwicklung/Libraries
116 Group(es):      Desarrollo/Bibliotecas
117 Group(fr):      Development/Librairies
118 Group(pl):      Programowanie/Biblioteki
119 Group(pt_BR):   Desenvolvimento/Bibliotecas
120 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
121 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
122 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
123 Group:          Development/Libraries
124 Requires:       %{name} = %{version}
125 Requires:       popt-devel
126
127 %description devel
128 The RPM packaging system includes a C library that makes it easy to
129 manipulate RPM packages and databases. It is intended to ease the
130 creation of graphical package managers and other tools that need
131 intimate knowledge of RPM packages.
132
133 %description devel -l de
134 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
135 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
136 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
137 herramientas que necesiten un conocimiento profundo de paquetes RPM.
138
139 %description devel -l pl
140 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
141 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
142 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
143 ferramentas que precisem de conhecimento profundo de pacotes RPM.
144
145 %package static
146 Summary:        RPM static libraries
147 Summary(pl):    Biblioteki statyczne RPM-a
148 Group(de):      Entwicklung/Libraries
149 Group(es):      Desarrollo/Bibliotecas
150 Group(fr):      Development/Librairies
151 Group(pl):      Programowanie/Biblioteki
152 Group(pt_BR):   Desenvolvimento/Bibliotecas
153 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
154 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
155 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
156 Group:          Development/Libraries
157 Requires:       %{name}-devel = %{version}
158
159 %description static
160 RPM static libraries.
161
162 %description static -l de
163 RPMs statische Libraries.
164
165 %description static -l pl
166 Bibliotecas estáticas para desenvolvimento.
167
168 %package utils
169 Summary:        Additional utilities for managing rpm packages and database
170 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
171 Group(de):      Applikationen/Datei
172 Group(pl):      Aplikacje/Pliki
173 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
174 Group:          Applications/File
175 Requires:       %{name} = %{version}
176
177 %description utils
178 Additional utilities for managing rpm packages and database.
179
180 %description utils -l de
181 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
182
183 %description utils -l pl
184 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
185
186 %package perlprov
187 Summary:        Additional utilities for checking perl provides/requires in rpm packages
188 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
189 Group(de):      Applikationen/Datei
190 Group(pl):      Aplikacje/Pliki
191 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
192 Group:          Applications/File
193 Requires:       perl-modules
194 Requires:       findutils
195
196 %description perlprov
197 Additional utilities for checking perl provides/requires in rpm
198 packages.
199
200 %description perlprov -l de
201 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
202
203 %description perlprov -l pl
204 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
205 pakietach rpm.
206
207 %package pythonprov
208 Summary:        Python macros, which simplifies creation of rpm packages with Python software
209 Group(de):      Applikationen/Datei
210 Group(pl):      Aplikacje/Pliki
211 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
212 Requires:       python
213 Requires:       %{name} = %{version}
214 Requires:       python-modules
215
216 %description pythonprov
217 Python macros, which simplifies creation of rpm packages with Python
218 software.
219 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi
220 w Pythonie.
221 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
222 %package python
223
224 %package -n python-rpm
225 Group:          Development/Languages/Python
226 Group(de):      Entwicklung/Sprachen/Python
227 Group(pl):      Programowanie/Jêzyki/Python
228 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
229 %pyrequires_eq  python
230 %description python
231
232 %description -n python-rpm
233 The rpm-python package contains a module which permits applications
234 written in the Python programming language to use the interface
235 supplied by RPM (RPM Package Manager) libraries.
236
237 This package should be installed if you want to develop Python
238 %description python -l pl
239 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym
240 w Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
241 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
242 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ
243 w Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
244 Esse pacote deve ser instalado se você quiser desenvolver programas em
245 Python para manipular pacotes e bancos de dados RPM.
246
247 %package build
248 Summary:        Scripts for building binary RPM packages
249 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
250 Group(de):      Applikationen/Datei
251 Group(pl):      Aplikacje/Pliki
252 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
253 Group:          Applications/File
254 Requires:       /bin/id
255 Requires:       awk
256 Requires:       binutils
257 Requires:       diffutils
258 Requires:       file >= 3.31
259 Requires:       gcc >= 3.0.3
260 Requires:       gcc
261 Requires:       glibc-devel
262 Requires:       grep
263 Requires:       gzip
264 Requires:       make
265 Requires:       patch
266 Requires:       popt >= 1.6.2-2
267 Requires:       sed
268 Requires:       tar
269 Requires:       textutils
270
271 %description build
272 Scripts for building binary RPM packages.
273
274 %description build -l de
275 Scripts fürs Bauen binärer RPM-Pakete.
276
277 %description build -l pl
278 construir pacotes usando o RPM.
279
280 %prep
281 %setup -q -a12
282 %patch0 -p1
283 %patch1 -p1
284 %patch2 -p1
285 %patch3 -p1
286 %patch4 -p1
287 %patch5 -p1
288 %patch6 -p1
289 %patch7 -p1
290 %patch8 -p1
291 %patch11 -p0
292 %patch12 -p0
293 %patch11 -p0
294 %patch12 -p0
295 %patch15 -p0
296 %patch16 -p0
297 %patch15 -p0
298 %patch16 -p0
299 %patch17 -p1
300 %patch18 -p1
301 %patch19 -p1
302 %patch22 -p1
303 %patch23 -p1
304 %patch24 -p1
305 %patch25 -p1
306 %patch26 -p0
307 %patch27 -p1
308 %patch28 -p1
309 %patch31 -p1
310 %patch36 -p1
311 %patch37 -p1
312 %patch38 -p1
313
314 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
315 cp -f platform.in macros.pld.in
316 install %{SOURCE9} scripts/find-lang.sh
317 install %{SOURCE13} macros.python.in
318 install %{SOURCE6} scripts/find-perl-provides
319 install %{SOURCE7} scripts/find-perl-requires
320 install %{SOURCE9} scripts/find-lang.sh
321
322 (cd scripts;
323 mv -f perl.req perl.req.in
324 mv -f perl.prov perl.prov.in)
325 %build
326 awk -f %{SOURCE14} %{SOURCE1}
327
328 cd popt
329 autoconf
330 automake -a -c
331 aclocal
332 autoheader
333 %{__automake}
334 cd ..
335
336 rm -f missing
337 libtoolize --force --copy
338 autoconf
339 # ugly workaround for automake
340 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
341         lib/Makefile.am > lib/Makefile.am.new
342 mv -f lib/Makefile.am.new lib/Makefile.am
343 automake -a -c
344 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
345         lib/Makefile.in > lib/Makefile.in.new
346 mv -f lib/Makefile.in.new lib/Makefile.in
347
348 sed -e 's#python1.5#python%{py_ver}#g' \
349         python/Makefile.in > python/Makefile.in.new
350 mv -f python/Makefile.in.new python/Makefile.in
351
352 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
353         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
354         --enable-v1-packages \
355         --with-python
356 %configure \
357         --enable-v1-packages \
358         --with-python
359
360
361 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
362
363 %install
364 rm -rf $RPM_BUILD_ROOT
365
366 %{__make} install \
367         DESTDIR=$RPM_BUILD_ROOT \
368         pkgbindir="%{_bindir}"
369
370 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
371 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
372
373 install %{SOURCE1} doc/manual/groups
374 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
375 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
376 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
377 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
378 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
379
380 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
381
382 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
383 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
384 # customized rpm macros - global for host
385 #
386 #%%_install_langs pl_PL:en_US
387 %%distribution PLD
388 EOF
389
390 %find_lang %{name}
391
392 # DON'T BREAK BUILD TREE!!!
393 # rm -f doc/manual/Makefile*
394
395 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
396
397 %clean
398 rm -rf $RPM_BUILD_ROOT
399
400 %post   -p /sbin/ldconfig
401 %postun -p /sbin/ldconfig
402
403 %attr(755,root,root) %{_libdir}/rpm/rpmdb
404 %attr(755,root,root) %{_libdir}/rpm/rpmq
405 %attr(755,root,root) %{_libdir}/rpm/rpmk
406 %attr(755,root,root) %{_libdir}/rpm/rpmv
407 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
408 %attr(755,root,root) %{_libdir}/rpm/rpmdb
409 %attr(755,root,root) %{_libdir}/rpm/rpmq
410 %attr(755,root,root) %{_libdir}/rpm/rpmk
411 %attr(755,root,root) %{_libdir}/rpm/rpmv
412 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
413
414 %dir %{_sysconfdir}/rpm
415 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
416
417 %{_mandir}/man8/rpm.8*
418 %lang(fr) %{_mandir}/fr/man8/rpm.8*
419 %lang(ja) %{_mandir}/ja/man8/rpm.8*
420 %lang(ko) %{_mandir}/ko/man8/rpm.8*
421 %lang(pl) %{_mandir}/pl/man8/rpm.8*
422 %lang(ru) %{_mandir}/ru/man8/rpm.8*
423 %lang(sk) %{_mandir}/sk/man8/rpm.8*
424
425 %dir /var/lib/rpm
426 %dir %{_libdir}/rpm
427
428 %{_libdir}/rpm/macros.python
429 %{_libdir}/rpm/noarch-linux
430 %{_libdir}/rpm/noarch-pld-linux
431 %ifarch i386 i486 i586 i686
432 %{_libdir}/rpm/rpmpopt*
433 %{_libdir}/rpm/noarch-linux
434 %{_libdir}/rpm/noarch-pld-linux
435 %ifarch i386 i486 i586 i686 athlon
436 %{_libdir}/rpm/i?86*
437 %{_libdir}/rpm/athlon*
438 %endif
439 %ifarch sparc sparc64
440 %{_libdir}/rpm/sparc*
441 %endif
442 %ifarch alpha
443 %{_libdir}/rpm/alpha*
444 %endif
445 %ifarch ppc
446 %{_libdir}/rpm/ppc*
447 %defattr(644,root,root,755)
448 %attr(755,root,root) %{_bindir}/rpmbuild
449 %attr(755,root,root) %{_bindir}/rpme
450 %attr(755,root,root) %{_bindir}/rpmi
451 %attr(755,root,root) %{_bindir}/rpmu
452 %attr(755,root,root) %{_libdir}/rpm/find-requires
453 %attr(755,root,root) %{_libdir}/rpm/find-provides
454 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
455 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
456 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
457 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
458 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
459 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
460 %attr(755,root,root) %{_libdir}/rpm/brp-*
461 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
462 %attr(755,root,root) %{_libdir}/rpm/compress-doc
463 %attr(755,root,root) %{_libdir}/rpm/cpanflute
464 %attr(755,root,root) %{_libdir}/rpm/http.req
465 %attr(755,root,root) %{_libdir}/rpm/magic.*
466 %attr(755,root,root) %{_libdir}/rpm/rpmi
467 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
468 %attr(755,root,root) %{_libdir}/rpm/rpme
469 %attr(755,root,root) %{_libdir}/rpm/rpmu
470 %attr(755,root,root) %{_libdir}/rpm/rpmb
471 %attr(755,root,root) %{_libdir}/rpm/rpmi
472 %attr(755,root,root) %{_libdir}/rpm/rpmt
473 %attr(755,root,root) %{_libdir}/rpm/rpme
474 %attr(755,root,root) %{_libdir}/librpm*.la
475 %attr(755,root,root) %{_libdir}/librpm*.so
476 %files devel
477 %defattr(644,root,root,755)
478 %{_includedir}/rpm
479 %attr(755,root,root) %{_libdir}/librpm*.la
480 %attr(755,root,root) %{_libdir}/librpm*.so
481
482 %files static
483 %attr(755,root,root) %{_bindir}/*
484 %files utils
485 %defattr(644,root,root,755)
486 %{_mandir}/man1/*
487 %attr(755,root,root) %{_bindir}/javadeps
488 %attr(755,root,root) %{_bindir}/rpm2cpio
489
490 %{_mandir}/man8/rpm2cpio.8*
491 %{_mandir}/man1/*
492 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
493 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
494 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
495 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
496
497 %files perlprov
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{_libdir}/rpm/perl*
500 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
501 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
502 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
503 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
504 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
505
506 %{_libdir}/rpm/macros.perl
507 %files python
508 %defattr(644,root,root,755)
509 %{py_sitedir}/*.so
510 %{_libdir}/rpm/macros.python
511
512 %files -n python-rpm
513 %defattr(755,root,root,755)
514 %{py_sitedir}/*.so
This page took 0.102807 seconds and 4 git commands to generate.