]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- ac25x patch: allow build using autoconf 2.53
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        60
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch27:        %{name}-hardlink-fixes.patch
55 Patch28:        %{name}-perlprov-regonly.patch
56 Patch29:        %{name}-cxx.patch
57 Patch30:        %{name}-athlon.patch
58 Patch31:        %{name}-athlon-identify.patch
59 Patch32:        %{name}-gettext-in-header.patch
60 Patch33:        %{name}-perlprov-perl5.6.patch
61 Patch34:        %{name}-groups-po.patch
62 Patch35:        %{name}-ac25x.patch
63 Patch37:        %{name}-short_circuit.patch
64 Patch38:        %{name}-section_test.patch
65 URL:            http://www.rpm.org/
66 Icon:           rpm.gif
67 BuildRequires:  autoconf >= 2.50
68 BuildRequires:  automake
69 BuildRequires:  bzip2-devel >= 1.0.1
70 BuildRequires:  db1-devel >= 1.85
71 BuildRequires:  db3-devel >= 3.1.17-9
72 BuildRequires:  gettext-devel >= 0.10.38-3
73 BuildRequires:  python-devel >= 2.2
74 BuildRequires:  python-modules >= 2.2
75 BuildRequires:  python-devel >= 2.2.1
76 BuildRequires:  python-modules >= 2.2.1
77 BuildRequires:  zlib-devel >= 1.1.4
78 %if %{!?_without_static:1}%{?_without_static:0}
79 # Require static library only for static build
80 BuildRequires:  bzip2-static >= 1.0.1
81 BuildRequires:  db1-static >= 1.85
82 BuildRequires:  db3-static >= 3.1.17-9
83 BuildRequires:  glibc-static >= 2.2.0
84 BuildRequires:  zlib-static >= 1.1.4
85 %endif
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87 Obsoletes:      rpm-libs
88 Conflicts:      glibc < 2.2
89
90 %define         __find_provides %{SOURCE4}
91 %define         _binary_payload w9.gzdio
92
93 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
94 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
95 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
96 %define         py_dyndir       %{py_libdir}/lib-dynload
97 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
98
99 %description
100 RPM is a powerful package manager, which can be used to build,
101 install, query, verify, update, and uninstall individual software
102 packages. A package consists of an archive of files, and package
103 information, including name, version, and description.
104
105 %description -l de
106 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
107 Installation, Anfrage, Verifizierung, Aktualisierung und
108 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
109 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
110 Beschreibung.
111
112 %description -l es
113 RPM es un poderoso administrador de paquetes, que puede ser usado para
114 construir, instalar, pesquisar, verificar, actualizar y desinstalar
115 paquetes individuales de software. Un paquete consiste en un
116 almacenaje de archivos, y información sobre el paquete, incluyendo
117 nombre, versión y descripción.
118
119 %description -l pl
120 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
121 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
122 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
123 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
124 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
125 odpytywania programu rpm.
126
127 %description -l pt_BR
128 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
129 construir, instalar, pesquisar, verificar, atualizar e desinstalar
130 pacotes individuais de software. Um pacote consiste de um conjunto de
131 arquivos e informações adicionais, incluindo nome, versão e descrição
132 do pacote, permissões dos arquivos, etc.
133
134 %package devel
135 Summary:        Header files and libraries
136 Summary(de):    Header-Dateien uns Libraries
137 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
138 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
139 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
140 Group:          Development/Libraries
141 Requires:       %{name} = %{version}
142 Requires:       popt-devel
143
144 %description devel
145 The RPM packaging system includes a C library that makes it easy to
146 manipulate RPM packages and databases. It is intended to ease the
147 creation of graphical package managers and other tools that need
148 intimate knowledge of RPM packages.
149
150 %description devel -l de
151 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
152 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
153 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
154 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
155
156 %description devel -l es
157 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
158 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
159 facilitar la creación de administradores gráficos de paquetes y otras
160 herramientas que necesiten un conocimiento profundo de paquetes RPM.
161
162 %description devel -l pl
163 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
164 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
165 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
166 szczegó³owej wiedzy na temat pakietów RPM.
167
168 %description devel -l pt_BR
169 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
170 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
171 facilitar a criação de gerenciadores gráficos de pacotes e outras
172 ferramentas que precisem de conhecimento profundo de pacotes RPM.
173
174 %package static
175 Summary:        RPM static libraries
176 Summary(de):    RPMs statische Libraries
177 Summary(pl):    Biblioteki statyczne RPM-a
178 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
179 Group:          Development/Libraries
180 Requires:       %{name}-devel = %{version}
181
182 %description static
183 RPM static libraries.
184
185 %description static -l de
186 RPMs statische Libraries.
187
188 %description static -l pl
189 Biblioteki statyczne RPM-a.
190
191 %description static -l pt_BR
192 Bibliotecas estáticas para desenvolvimento.
193
194 %package utils
195 Summary:        Additional utilities for managing rpm packages and database
196 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
197 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
198 Group:          Applications/File
199 Requires:       %{name} = %{version}
200
201 %description utils
202 Additional utilities for managing rpm packages and database.
203
204 %description utils -l de
205 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
206
207 %description utils -l pl
208 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
209
210 %package perlprov
211 Summary:        Additional utilities for checking perl provides/requires in rpm packages
212 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
213 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
214 Group:          Applications/File
215 Requires:       %{name} = %{version}
216 Requires:       perl-modules
217 Requires:       findutils
218
219 %description perlprov
220 Additional utilities for checking perl provides/requires in rpm
221 packages.
222
223 %description perlprov -l de
224 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
225
226 %description perlprov -l pl
227 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
228 pakietach rpm.
229
230 %package pythonprov
231 Summary:        Python macros, which simplifies creation of rpm packages with Python software
232 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
233 Group:          Applications/File
234 Requires:       %{name} = %{version}
235 Requires:       python-modules
236
237 %description pythonprov
238 Python macros, which simplifies creation of rpm packages with Python
239 software.
240
241 %description pythonprov -l pl
242 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
243 Pythonie.
244
245 %package -n python-rpm
246 Summary:        Python interface to RPM library
247 Summary(pl):    Pythonowy interfejs do biblioteki RPM-a
248 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
249 %requires_eq    python
250 Requires:       %{name} = %{version}
251 %pyrequires_eq  python
252 Obsoletes:      rpm-python
253
254 %description -n python-rpm
255 The rpm-python package contains a module which permits applications
256 written in the Python programming language to use the interface
257 supplied by RPM (RPM Package Manager) libraries.
258
259 This package should be installed if you want to develop Python
260 programs that will manipulate RPM packages and databases.
261
262 %description -n python-rpm -l pl
263 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
264 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
265
266 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
267 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
268
269 %description -n python-rpm -l pt_BR
270 O pacote rpm-python contém um módulo que permite que aplicações
271 escritas em Python utilizem a interface fornecida pelas bibliotecas
272 RPM (RPM Package Manager).
273
274 Esse pacote deve ser instalado se você quiser desenvolver programas em
275 Python para manipular pacotes e bancos de dados RPM.
276
277 %package build
278 Summary:        Scripts for building binary RPM packages
279 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
280 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
281 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
282 Group:          Applications/File
283 Requires:       %{name} = %{version}
284 Requires:       /bin/id
285 Requires:       awk
286 Requires:       binutils
287 Requires:       diffutils
288 Requires:       file >= 3.31
289 Requires:       fileutils
290 Requires:       findutils
291 %ifarch athlon
292 Requires:       gcc >= 3.0.3
293 %else
294 Requires:       gcc
295 Requires:       glibc-devel
296 Requires:       grep
297 Requires:       gzip
298 Requires:       make
299 Requires:       patch
300 Requires:       popt >= 1.6.2-2
301 Requires:       sed
302 Requires:       sh-utils
303 Requires:       tar
304 Requires:       textutils
305
306 %description build
307 Scripts for building binary RPM packages.
308
309 %description build -l de
310 Scripts fürs Bauen binärer RPM-Pakete.
311
312 %description build -l pl
313 Skrypty pomocnicze do budowania binarnych RPM-ów.
314
315 %description build -l pt_BR
316 Este pacote contém scripts e programas executáveis que são usados para
317 construir pacotes usando o RPM.
318
319 %prep
320 %setup -q -a12
321 %patch0 -p1
322 %patch1 -p1
323 %patch2 -p1
324 %patch3 -p1
325 %patch4 -p1
326 %patch5 -p1
327 %patch6 -p1
328 %patch7 -p1
329 %patch8 -p1
330 %patch9 -p1
331 %patch10 -p1
332 %patch11 -p0
333 %patch12 -p0
334 %patch13 -p1
335 %patch14 -p1
336 %patch15 -p0
337 %patch16 -p0
338 %patch17 -p1
339 %patch18 -p1
340 %patch19 -p1
341 %patch20 -p1
342 %patch21 -p1
343 %patch22 -p1
344 %patch23 -p1
345 %patch24 -p1
346 %patch25 -p1
347 %patch26 -p0
348 %patch27 -p1
349 %patch28 -p1
350 %patch29 -p1
351 %patch30 -p1
352
353 %ifarch athlon
354 %patch31 -p1
355 %endif
356
357 %patch32 -p1
358 %patch35 -p1
359 %patch35 -p1
360 %patch36 -p1
361 %patch37 -p1
362 %patch38 -p1
363
364 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
365 cp -f platform.in macros.pld.in
366 install %{SOURCE5} macros.perl.in
367 install %{SOURCE13} macros.python.in
368 install %{SOURCE6} scripts/find-perl-provides
369 install %{SOURCE7} scripts/find-perl-requires
370 install %{SOURCE9} scripts/find-lang.sh
371
372 (cd scripts;
373 mv -f perl.req perl.req.in
374 mv -f perl.prov perl.prov.in)
375 %build
376 # generate Group translations to *.po
377 awk -f %{SOURCE14} %{SOURCE1}
378
379 cd popt
380 autoconf
381 automake -a -c -f
382 aclocal
383 autoheader
384 automake -a -c -f
385 %{__automake}
386 cd ..
387
388 rm -f missing
389 libtoolize --force --copy
390 autoconf
391 aclocal
392 autoupdate
393 autoheader || :
394 %{__autoconf}
395 automake -a -c -f
396 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
397         lib/Makefile.am > lib/Makefile.am.new
398 mv -f lib/Makefile.am.new lib/Makefile.am
399 %{__automake}
400 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
401         lib/Makefile.in > lib/Makefile.in.new
402 mv -f lib/Makefile.in.new lib/Makefile.in
403
404 sed -e 's#python1.5#python%{py_ver}#g' \
405         python/Makefile.in > python/Makefile.in.new
406 mv -f python/Makefile.in.new python/Makefile.in
407
408 # config.guess doesn't handle athlon, so we have to change it by hand.
409 # rpm checks for CPU type at runtime, but it looks better
410 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
411         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
412 mv -f macros.tmp macros.in
413
414 %configure \
415         --enable-shared \
416         --enable-v1-packages \
417         --with-python
418
419
420 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
421
422 %install
423 rm -rf $RPM_BUILD_ROOT
424
425 %{__make} install \
426         DESTDIR=$RPM_BUILD_ROOT \
427         pkgbindir="%{_bindir}"
428
429 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
430 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
431
432 install %{SOURCE1} doc/manual/groups
433 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
434 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
435 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
436 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
437 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
438
439 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
440
441 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
442 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
443 # customized rpm macros - global for host
444 #
445 #%%_install_langs pl_PL:en_US
446 %%distribution PLD
447 EOF
448
449 %find_lang %{name}
450
451 # DON'T BREAK BUILD TREE!!!
452 # rm -f doc/manual/Makefile*
453
454 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
455
456 %clean
457 rm -rf $RPM_BUILD_ROOT
458
459 %post   -p /sbin/ldconfig
460 %postun -p /sbin/ldconfig
461
462 %files -f %{name}.lang
463 %defattr(644,root,root,755)
464 %doc RPM-PGP-KEY.gz CHANGES.gz doc/manual/*
465
466 %attr(755,root,root) /bin/rpm
467 %attr(755,root,root) %{_bindir}/rpmdb
468 %attr(755,root,root) %{_bindir}/rpmquery
469 %attr(755,root,root) %{_bindir}/rpmsign
470 %attr(755,root,root) %{_bindir}/rpmverify
471 %attr(755,root,root) %{_libdir}/rpm/rpmdb
472 %attr(755,root,root) %{_libdir}/rpm/rpmq
473 %attr(755,root,root) %{_libdir}/rpm/rpmk
474 %attr(755,root,root) %{_libdir}/rpm/rpmv
475 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
476
477 %dir %{_sysconfdir}/rpm
478 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
479
480 %{_mandir}/man8/rpm.8*
481 %lang(fr) %{_mandir}/fr/man8/rpm.8*
482 %lang(ja) %{_mandir}/ja/man8/rpm.8*
483 %lang(ko) %{_mandir}/ko/man8/rpm.8*
484 %lang(pl) %{_mandir}/pl/man8/rpm.8*
485 %lang(ru) %{_mandir}/ru/man8/rpm.8*
486 %lang(sk) %{_mandir}/sk/man8/rpm.8*
487
488 %dir /var/lib/rpm
489 %dir %{_libdir}/rpm
490
491 %{_libdir}/rpm/macros.python
492 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
493
494 %{_libdir}/rpm/rpmrc
495 %{_libdir}/rpm/rpmpopt*
496 %{_libdir}/rpm/macros
497 %{_libdir}/rpm/noarch-linux
498 %{_libdir}/rpm/noarch-pld-linux
499 %ifarch i386 i486 i586 i686 athlon
500 %{_libdir}/rpm/i?86*
501 %{_libdir}/rpm/athlon*
502 %endif
503 %ifarch sparc sparc64
504 %{_libdir}/rpm/sparc*
505 %endif
506 %ifarch alpha
507 %{_libdir}/rpm/alpha*
508 %endif
509 %ifarch ppc
510 %{_libdir}/rpm/ppc*
511 %endif
512
513
514 %files build
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_bindir}/rpmbuild
517 %attr(755,root,root) %{_bindir}/rpme
518 %attr(755,root,root) %{_bindir}/rpmi
519 %attr(755,root,root) %{_bindir}/rpmu
520 %attr(755,root,root) %{_libdir}/rpm/find-requires
521 %attr(755,root,root) %{_libdir}/rpm/find-provides
522 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
523 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
524 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
525 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
526 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
527 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
528 %attr(755,root,root) %{_libdir}/rpm/brp-*
529 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
530 %attr(755,root,root) %{_libdir}/rpm/compress-doc
531 %attr(755,root,root) %{_libdir}/rpm/cpanflute
532 %attr(755,root,root) %{_libdir}/rpm/http.req
533 %attr(755,root,root) %{_libdir}/rpm/magic.*
534 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
535 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
536 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
537 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
538 %attr(755,root,root) %{_libdir}/rpm/rpmb
539 %attr(755,root,root) %{_libdir}/rpm/rpmi
540 %attr(755,root,root) %{_libdir}/rpm/rpmt
541 %attr(755,root,root) %{_libdir}/rpm/rpme
542 %attr(755,root,root) %{_libdir}/rpm/rpmu
543
544 %files devel
545 %defattr(644,root,root,755)
546 %{_includedir}/rpm
547 %attr(755,root,root) %{_libdir}/librpm*.la
548 %attr(755,root,root) %{_libdir}/librpm*.so
549
550 %files static
551 %defattr(644,root,root,755)
552 %{_libdir}/librpm*.a
553
554 %files utils
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_bindir}/gendiff
557 %attr(755,root,root) %{_bindir}/javadeps
558 %attr(755,root,root) %{_bindir}/rpm2cpio
559
560 %{_mandir}/man8/rpm2cpio.8*
561 %{_mandir}/man1/*
562 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
563 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
564 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
565 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
566
567 %files perlprov
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_libdir}/rpm/perl*
570 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
571 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
572 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
573 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
574 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
575
576 %{_libdir}/rpm/macros.perl
577
578 %files pythonprov
579 %defattr(644,root,root,755)
580 %{_libdir}/rpm/macros.python
581
582 %files -n python-rpm
583 %defattr(755,root,root,755)
584 %{py_sitedir}/*.so
This page took 0.149976 seconds and 4 git commands to generate.