]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- added signverify-fix.patch; rel 62
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        62
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Source14:       %{name}-groups-po.awk
28 Patch0:         %{name}-rpmrc.patch
29 Patch1:         %{name}-macros.patch
30 Patch2:         %{name}-arch.patch
31 Patch3:         %{name}-rpmpopt.patch
32 Patch4:         %{name}-perl-macros.patch
33 Patch5:         %{name}-db3.patch
34 Patch6:         %{name}-segv.patch
35 Patch7:         %{name}-am_fix.patch
36 Patch8:         %{name}-perl-req-perlfile.patch
37 Patch9:         %{name}-installplatform.patch
38 Patch10:        %{name}-cache.patch
39 Patch11:        %{name}-suggestions.patch
40 Patch12:        %{name}-rh-lame.patch
41 Patch13:        %{name}-glob.patch
42 Patch14:        %{name}-header_h.patch
43 Patch15:        %{name}-fast-alAddPackage.patch
44 Patch16:        %{name}-byKey.patch
45 Patch17:        %{name}-perlprov.patch
46 Patch18:        %{name}-noperldir.patch
47 Patch19:        popt-cvs20010530.patch
48 Patch20:        %{name}-noexpand.patch
49 Patch21:        %{name}-scripts-closefds.patch
50 Patch22:        %{name}-python-amfix.patch
51 Patch23:        %{name}-non-english-man-pages.patch
52 Patch24:        %{name}-progress-nontty.patch
53 Patch25:        %{name}-am_ac.patch
54 Patch26:        %{name}-python-macros.patch
55 Patch27:        %{name}-hardlink-fixes.patch
56 Patch28:        %{name}-perlprov-regonly.patch
57 Patch29:        %{name}-cxx.patch
58 Patch30:        %{name}-athlon.patch
59 Patch31:        %{name}-athlon-identify.patch
60 Patch32:        %{name}-gettext-in-header.patch
61 Patch33:        %{name}-perlprov-perl5.6.patch
62 Patch34:        %{name}-ac25x.patch
63 Patch35:        %{name}-signverify-fix.patch
64 Patch37:        %{name}-short_circuit.patch
65 Patch38:        %{name}-section_test.patch
66 URL:            http://www.rpm.org/
67 Icon:           rpm.gif
68 BuildRequires:  autoconf >= 2.50
69 BuildRequires:  automake
70 BuildRequires:  bzip2-devel >= 1.0.1
71 BuildRequires:  db1-devel >= 1.85
72 BuildRequires:  db3-devel >= 3.1.17-9
73 BuildRequires:  gettext-devel >= 0.10.38-3
74 BuildRequires:  python-devel >= 2.2
75 BuildRequires:  python-modules >= 2.2
76 BuildRequires:  python-devel >= 2.2.1
77 BuildRequires:  python-modules >= 2.2.1
78 BuildRequires:  zlib-devel >= 1.1.4
79 %if %{!?_without_static:1}%{?_without_static:0}
80 # Require static library only for static build
81 BuildRequires:  bzip2-static >= 1.0.1
82 BuildRequires:  db1-static >= 1.85
83 BuildRequires:  db3-static >= 3.1.17-9
84 BuildRequires:  glibc-static >= 2.2.0
85 BuildRequires:  zlib-static >= 1.1.4
86 %endif
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88 Obsoletes:      rpm-libs
89 Conflicts:      glibc < 2.2
90
91 %define         __find_provides %{SOURCE4}
92 %define         _binary_payload w9.gzdio
93
94 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
95 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
96 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
97 %define         py_dyndir       %{py_libdir}/lib-dynload
98 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
99
100 %description
101 RPM is a powerful package manager, which can be used to build,
102 install, query, verify, update, and uninstall individual software
103 packages. A package consists of an archive of files, and package
104 information, including name, version, and description.
105
106 %description -l de
107 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
108 Installation, Anfrage, Verifizierung, Aktualisierung und
109 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
110 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
111 Beschreibung.
112
113 %description -l es
114 RPM es un poderoso administrador de paquetes, que puede ser usado para
115 construir, instalar, pesquisar, verificar, actualizar y desinstalar
116 paquetes individuales de software. Un paquete consiste en un
117 almacenaje de archivos, y información sobre el paquete, incluyendo
118 nombre, versión y descripción.
119
120 %description -l pl
121 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
122 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
123 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
124 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
125 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
126 odpytywania programu rpm.
127
128 %description -l pt_BR
129 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
130 construir, instalar, pesquisar, verificar, atualizar e desinstalar
131 pacotes individuais de software. Um pacote consiste de um conjunto de
132 arquivos e informações adicionais, incluindo nome, versão e descrição
133 do pacote, permissões dos arquivos, etc.
134
135 %package devel
136 Summary:        Header files and libraries
137 Summary(de):    Header-Dateien uns Libraries
138 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
139 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
140 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
141 Group:          Development/Libraries
142 Requires:       %{name} = %{version}
143 Requires:       popt-devel
144
145 %description devel
146 The RPM packaging system includes a C library that makes it easy to
147 manipulate RPM packages and databases. It is intended to ease the
148 creation of graphical package managers and other tools that need
149 intimate knowledge of RPM packages.
150
151 %description devel -l de
152 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
153 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
154 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
155 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
156
157 %description devel -l es
158 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
159 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
160 facilitar la creación de administradores gráficos de paquetes y otras
161 herramientas que necesiten un conocimiento profundo de paquetes RPM.
162
163 %description devel -l pl
164 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
165 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
166 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
167 szczegó³owej wiedzy na temat pakietów RPM.
168
169 %description devel -l pt_BR
170 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
171 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
172 facilitar a criação de gerenciadores gráficos de pacotes e outras
173 ferramentas que precisem de conhecimento profundo de pacotes RPM.
174
175 %package static
176 Summary:        RPM static libraries
177 Summary(de):    RPMs statische Libraries
178 Summary(pl):    Biblioteki statyczne RPM-a
179 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
180 Group:          Development/Libraries
181 Requires:       %{name}-devel = %{version}
182
183 %description static
184 RPM static libraries.
185
186 %description static -l de
187 RPMs statische Libraries.
188
189 %description static -l pl
190 Biblioteki statyczne RPM-a.
191
192 %description static -l pt_BR
193 Bibliotecas estáticas para desenvolvimento.
194
195 %package utils
196 Summary:        Additional utilities for managing rpm packages and database
197 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
198 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
199 Group:          Applications/File
200 Requires:       %{name} = %{version}
201
202 %description utils
203 Additional utilities for managing rpm packages and database.
204
205 %description utils -l de
206 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
207
208 %description utils -l pl
209 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
210
211 %package perlprov
212 Summary:        Additional utilities for checking perl provides/requires in rpm packages
213 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
214 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
215 Group:          Applications/File
216 Requires:       %{name} = %{version}
217 Requires:       perl-modules
218 Requires:       findutils
219
220 %description perlprov
221 Additional utilities for checking perl provides/requires in rpm
222 packages.
223
224 %description perlprov -l de
225 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
226
227 %description perlprov -l pl
228 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
229 pakietach rpm.
230
231 %package pythonprov
232 Summary:        Python macros, which simplifies creation of rpm packages with Python software
233 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
234 Group:          Applications/File
235 Requires:       %{name} = %{version}
236 Requires:       python-modules
237
238 %description pythonprov
239 Python macros, which simplifies creation of rpm packages with Python
240 software.
241
242 %description pythonprov -l pl
243 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
244 Pythonie.
245
246 %package -n python-rpm
247 Summary:        Python interface to RPM library
248 Summary(pl):    Pythonowy interfejs do biblioteki RPM-a
249 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
250 %requires_eq    python
251 Requires:       %{name} = %{version}
252 %pyrequires_eq  python
253 Obsoletes:      rpm-python
254
255 %description -n python-rpm
256 The rpm-python package contains a module which permits applications
257 written in the Python programming language to use the interface
258 supplied by RPM (RPM Package Manager) libraries.
259
260 This package should be installed if you want to develop Python
261 programs that will manipulate RPM packages and databases.
262
263 %description -n python-rpm -l pl
264 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
265 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
266
267 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
268 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
269
270 %description -n python-rpm -l pt_BR
271 O pacote rpm-python contém um módulo que permite que aplicações
272 escritas em Python utilizem a interface fornecida pelas bibliotecas
273 RPM (RPM Package Manager).
274
275 Esse pacote deve ser instalado se você quiser desenvolver programas em
276 Python para manipular pacotes e bancos de dados RPM.
277
278 %package build
279 Summary:        Scripts for building binary RPM packages
280 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
281 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
282 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
283 Group:          Applications/File
284 Requires:       %{name} = %{version}
285 Requires:       /bin/id
286 Requires:       awk
287 Requires:       binutils
288 Requires:       diffutils
289 Requires:       file >= 3.31
290 Requires:       fileutils
291 Requires:       findutils
292 %ifarch athlon
293 Requires:       gcc >= 3.0.3
294 %else
295 Requires:       gcc
296 %endif
297 Requires:       glibc-devel
298 Requires:       grep
299 Requires:       gzip
300 Requires:       make
301 Requires:       patch
302 Requires:       popt >= 1.6.2-2
303 Requires:       sed
304 Requires:       sh-utils
305 Requires:       tar
306 Requires:       textutils
307
308 %description build
309 Scripts for building binary RPM packages.
310
311 %description build -l de
312 Scripts fürs Bauen binärer RPM-Pakete.
313
314 %description build -l pl
315 Skrypty pomocnicze do budowania binarnych RPM-ów.
316
317 %description build -l pt_BR
318 Este pacote contém scripts e programas executáveis que são usados para
319 construir pacotes usando o RPM.
320
321 %prep
322 %setup -q -a12
323 %patch0 -p1
324 %patch1 -p1
325 %patch2 -p1
326 %patch3 -p1
327 %patch4 -p1
328 %patch5 -p1
329 %patch6 -p1
330 %patch7 -p1
331 %patch8 -p1
332 %patch9 -p1
333 %patch10 -p1
334 %patch11 -p0
335 %patch12 -p0
336 %patch13 -p1
337 %patch14 -p1
338 %patch15 -p0
339 %patch16 -p0
340 %patch17 -p1
341 %patch18 -p1
342 %patch19 -p1
343 %patch20 -p1
344 %patch21 -p1
345 %patch22 -p1
346 %patch23 -p1
347 %patch24 -p1
348 %patch25 -p1
349 %patch26 -p0
350 %patch27 -p1
351 %patch28 -p1
352 %patch29 -p1
353 %patch30 -p1
354
355 %ifarch athlon
356 %patch31 -p1
357 %endif
358
359 %patch32 -p1
360 %patch33 -p1
361 %patch35 -p1
362 %patch36 -p1
363 %patch37 -p1
364 %patch38 -p1
365
366 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
367 cp -f platform.in macros.pld.in
368 install %{SOURCE5} macros.perl.in
369 install %{SOURCE13} macros.python.in
370 install %{SOURCE6} scripts/find-perl-provides
371 install %{SOURCE7} scripts/find-perl-requires
372 install %{SOURCE9} scripts/find-lang.sh
373
374 (cd scripts;
375 mv -f perl.req perl.req.in
376 mv -f perl.prov perl.prov.in)
377
378 chmod +x %{SOURCE4}
379
380 %build
381 # generate Group translations to *.po
382 awk -f %{SOURCE14} %{SOURCE1}
383
384 cd popt
385 autoconf
386 automake -a -c -f
387 aclocal
388 autoheader
389 automake -a -c -f
390 %{__automake}
391 cd ..
392
393 rm -f missing
394 libtoolize --force --copy
395 autoconf
396 aclocal
397 autoupdate
398 autoheader || :
399 %{__autoconf}
400 automake -a -c -f
401 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
402         lib/Makefile.am > lib/Makefile.am.new
403 mv -f lib/Makefile.am.new lib/Makefile.am
404 %{__automake}
405 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
406         lib/Makefile.in > lib/Makefile.in.new
407 mv -f lib/Makefile.in.new lib/Makefile.in
408
409 sed -e 's#python1.5#python%{py_ver}#g' \
410         python/Makefile.in > python/Makefile.in.new
411 mv -f python/Makefile.in.new python/Makefile.in
412
413 # config.guess doesn't handle athlon, so we have to change it by hand.
414 # rpm checks for CPU type at runtime, but it looks better
415 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
416         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
417 mv -f macros.tmp macros.in
418
419 %configure \
420         --enable-shared \
421         --enable-v1-packages \
422         --with-python
423
424
425 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
426
427 %install
428 rm -rf $RPM_BUILD_ROOT
429
430 %{__make} install \
431         DESTDIR=$RPM_BUILD_ROOT \
432         pkgbindir="%{_bindir}"
433
434 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
435 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
436
437 install %{SOURCE1} doc/manual/groups
438 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
439 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
440 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
441 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
442 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
443
444 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
445
446 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
447 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
448 # customized rpm macros - global for host
449 #
450 #%%_install_langs pl_PL:en_US
451 %%distribution PLD
452 EOF
453
454 %find_lang %{name}
455
456 # DON'T BREAK BUILD TREE!!!
457 # rm -f doc/manual/Makefile*
458
459 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
460
461 %clean
462 rm -rf $RPM_BUILD_ROOT
463
464 %post   -p /sbin/ldconfig
465 %postun -p /sbin/ldconfig
466
467 %files -f %{name}.lang
468 %defattr(644,root,root,755)
469 %doc RPM-PGP-KEY.gz CHANGES.gz doc/manual/*
470
471 %attr(755,root,root) /bin/rpm
472 %attr(755,root,root) %{_bindir}/rpmdb
473 %attr(755,root,root) %{_bindir}/rpmquery
474 %attr(755,root,root) %{_bindir}/rpmsign
475 %attr(755,root,root) %{_bindir}/rpmverify
476 %attr(755,root,root) %{_libdir}/rpm/rpmdb
477 %attr(755,root,root) %{_libdir}/rpm/rpmq
478 %attr(755,root,root) %{_libdir}/rpm/rpmk
479 %attr(755,root,root) %{_libdir}/rpm/rpmv
480 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
481
482 %dir %{_sysconfdir}/rpm
483 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
484
485 %{_mandir}/man8/rpm.8*
486 %lang(fr) %{_mandir}/fr/man8/rpm.8*
487 %lang(ja) %{_mandir}/ja/man8/rpm.8*
488 %lang(ko) %{_mandir}/ko/man8/rpm.8*
489 %lang(pl) %{_mandir}/pl/man8/rpm.8*
490 %lang(ru) %{_mandir}/ru/man8/rpm.8*
491 %lang(sk) %{_mandir}/sk/man8/rpm.8*
492
493 %dir /var/lib/rpm
494 %dir %{_libdir}/rpm
495
496 %{_libdir}/rpm/macros.python
497 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
498
499 %{_libdir}/rpm/rpmrc
500 %{_libdir}/rpm/rpmpopt*
501 %{_libdir}/rpm/macros
502 %{_libdir}/rpm/noarch-linux
503 %{_libdir}/rpm/noarch-pld-linux
504 %ifarch i386 i486 i586 i686 athlon
505 %{_libdir}/rpm/i?86*
506 %{_libdir}/rpm/athlon*
507 %endif
508 %ifarch sparc sparc64
509 %{_libdir}/rpm/sparc*
510 %endif
511 %ifarch alpha
512 %{_libdir}/rpm/alpha*
513 %endif
514 %ifarch ppc
515 %{_libdir}/rpm/ppc*
516 %endif
517
518
519 %files build
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_bindir}/rpmbuild
522 %attr(755,root,root) %{_bindir}/rpme
523 %attr(755,root,root) %{_bindir}/rpmi
524 %attr(755,root,root) %{_bindir}/rpmu
525 %attr(755,root,root) %{_libdir}/rpm/find-requires
526 %attr(755,root,root) %{_libdir}/rpm/find-provides
527 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
528 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
529 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
530 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
531 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
532 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
533 %attr(755,root,root) %{_libdir}/rpm/brp-*
534 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
535 %attr(755,root,root) %{_libdir}/rpm/compress-doc
536 %attr(755,root,root) %{_libdir}/rpm/cpanflute
537 %attr(755,root,root) %{_libdir}/rpm/http.req
538 %attr(755,root,root) %{_libdir}/rpm/magic.*
539 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
540 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
541 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
542 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
543 %attr(755,root,root) %{_libdir}/rpm/rpmb
544 %attr(755,root,root) %{_libdir}/rpm/rpmi
545 %attr(755,root,root) %{_libdir}/rpm/rpmt
546 %attr(755,root,root) %{_libdir}/rpm/rpme
547 %attr(755,root,root) %{_libdir}/rpm/rpmu
548
549 %files devel
550 %defattr(644,root,root,755)
551 %{_includedir}/rpm
552 %attr(755,root,root) %{_libdir}/librpm*.la
553 %attr(755,root,root) %{_libdir}/librpm*.so
554
555 %files static
556 %defattr(644,root,root,755)
557 %{_libdir}/librpm*.a
558
559 %files utils
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_bindir}/gendiff
562 %attr(755,root,root) %{_bindir}/javadeps
563 %attr(755,root,root) %{_bindir}/rpm2cpio
564
565 %{_mandir}/man8/rpm2cpio.8*
566 %{_mandir}/man1/*
567 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
568 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
569 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
570 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
571
572 %files perlprov
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/rpm/perl*
575 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
576 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
577 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
578 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
579 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
580
581 %{_libdir}/rpm/macros.perl
582
583 %files pythonprov
584 %defattr(644,root,root,755)
585 %{_libdir}/rpm/macros.python
586
587 %files -n python-rpm
588 %defattr(755,root,root,755)
589 %{py_sitedir}/*.so
This page took 0.064885 seconds and 4 git commands to generate.