]> git.pld-linux.org Git - packages/redland.git/blob - redland.spec
- release 2
[packages/redland.git] / redland.spec
1 #
2 # Conditional build:
3 %bcond_without  threestore      # with 3store
4 #
5 Summary:        Redland - a library that provides a high-level interface for RDF
6 Summary(pl.UTF-8):      Redland - biblioteka udostępniająca wysokopoziomowy interfejs do RDF
7 Name:           redland
8 Version:        1.0.7
9 Release:        2
10 License:        LGPL v2.1+ or GPL v2+ or Apache v2.0
11 Group:          Libraries
12 Source0:        http://download.librdf.org/source/%{name}-%{version}.tar.gz
13 # Source0-md5:  4c066d3dcf6c25f8fb8c9007e73f293c
14 Patch0:         %{name}-link.patch
15 Patch1:         %{name}-storage-file.patch
16 URL:            http://librdf.org/
17 %if %{with threestore}
18 BuildRequires:  3store-devel >= 2.0
19 BuildRequires:  3store-devel < 3.0
20 %endif
21 BuildRequires:  autoconf >= 2.53
22 BuildRequires:  automake >= 1:1.7
23 BuildRequires:  db-devel
24 BuildRequires:  gtk-doc
25 BuildRequires:  libltdl-devel
26 BuildRequires:  libraptor-devel >= 1.4.16
27 BuildRequires:  libtool
28 BuildRequires:  mysql-devel >= 3.23.58
29 BuildRequires:  openssl-devel >= 0.9.7d
30 BuildRequires:  pkgconfig
31 BuildRequires:  postgresql-devel
32 BuildRequires:  rasqal-devel >= 1:0.9.15
33 BuildRequires:  rpmbuild(macros) >= 1.98
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  sqlite3-devel >= 3
36 Requires:       libraptor >= 1.4.16
37 Requires:       rasqal >= 1:0.9.15
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Redland is a library that provides a high-level interface for RDF
42 allowing the RDF graph to be parsed from XML, stored, queried and
43 manipulated. Redland implements each of the RDF concepts in its own
44 class via an object based API, reflected into the other language APIs:
45 Perl, Python, Tcl, Java and Ruby. Some of the classes providing the
46 parsers, storage mechanisms and other elements are built as modules
47 that can be added or removed as required.
48
49 %description -l pl.UTF-8
50 Redland to biblioteka udostępniająca wysokopoziomowy interfejs do RDF,
51 pozwalająca na analizę grafu RDF z XML-a, jego przechowywanie,
52 odpytywanie i obróbkę. Redland zawiera implementacje każdego pojęcia z
53 RDF w osobnej klasie poprzez obiekt oparty na API, mający
54 odzwierciedlenie w API dla innych języków: Perla, Pythona, Tcl-a, Javy
55 i Ruby'ego. Część klas udostępniających analizatory, mechanizmy
56 przechowywania i inne elementy jest zbudowana jako moduły, które mogą
57 być dodawane lub usuwane w razie potrzeby.
58
59 %package devel
60 Summary:        Headers for Redland RDF library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Redland RDF
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       db-devel
65 Requires:       libltdl-devel
66 Requires:       libraptor-devel >= 1.4.16
67 Requires:       rasqal-devel >= 1:0.9.15
68
69 %description devel
70 Headers for Redland RDF library.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe biblioteki Redland RDF.
74
75 %package static
76 Summary:        Static Redland RDF library
77 Summary(pl.UTF-8):      Statyczna biblioteka Redland RDF
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static Redland RDF library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka Redland RDF.
86
87 %package storage-mysql
88 Summary:        MySQL storage plugin for Redland RDF library
89 Summary(pl.UTF-8):      Wtyczka przechowywania danych w bazie MySQL dla biblioteki Redland RDF
90 Group:          Libraries
91 Requires:       %{name} = %{version}-%{release}
92
93 %description storage-mysql
94 MySQL storage plugin for Redland RDF library.
95
96 %description storage-mysql -l pl.UTF-8
97 Wtyczka przechowywania danych w bazie MySQL dla biblioteki Redland
98 RDF.
99
100 %package storage-postgresql
101 Summary:        PostgreSQL storage plugin for Redland RDF library
102 Summary(pl.UTF-8):      Wtyczka przechowywania danych w bazie PostgreSQL dla biblioteki Redland RDF
103 Group:          Libraries
104 Requires:       %{name} = %{version}-%{release}
105
106 %description storage-postgresql
107 PostgreSQL storage plugin for Redland RDF library.
108
109 %description storage-postgresql -l pl.UTF-8
110 Wtyczka przechowywania danych w bazie PostgreSQL dla biblioteki
111 Redland RDF.
112
113 %package storage-sqlite
114 Summary:        SQLite storage plugin for Redland RDF library
115 Summary(pl.UTF-8):      Wtyczka przechowywania danych w bazie SQLite dla biblioteki Redland RDF
116 Group:          Libraries
117 Requires:       %{name} = %{version}-%{release}
118
119 %description storage-sqlite
120 SQLite storage plugin for Redland RDF library.
121
122 %description storage-sqlite -l pl.UTF-8
123 Wtyczka przechowywania danych w bazie SQLite dla biblioteki Redland
124 RDF.
125
126 %package storage-tstore
127 Summary:        3store storage plugin for Redland RDF library
128 Summary(pl.UTF-8):      Wtyczka przechowywania danych w bazie 3store dla biblioteki Redland RDF
129 Group:          Libraries
130 Requires:       %{name} = %{version}-%{release}
131
132 %description storage-tstore
133 3store storage plugin for Redland RDF library.
134
135 %description storage-tstore -l pl.UTF-8
136 Wtyczka przechowywania danych w bazie 3store dla biblioteki Redland
137 RDF.
138
139 %prep
140 %setup -q
141 %patch0 -p1
142 %patch1 -p1
143
144 sed -i -e 's,bdbc_prefix/lib$,bdbc_prefix/%{_lib},' configure.ac
145
146 %build
147 %{__libtoolize}
148 %{__gtkdocize}
149 %{__aclocal}
150 %{__autoconf}
151 %{__autoheader}
152 %{__automake}
153 %configure \
154         --enable-modular \
155         --with-html-dir=%{_gtkdocdir} \
156         --with-raptor=system \
157         --with-rasqal=system \
158         --with%{!?with_threestore:out}-threestore
159
160 %{__make}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 rm -f $RPM_BUILD_ROOT%{_libdir}/redland/*.{la,a}
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files
177 %defattr(644,root,root,755)
178 %doc AUTHORS ChangeLog* FAQS.html LICENSE.html NEWS.html README.html RELEASE.html TODO.html
179 %attr(755,root,root) %{_bindir}/rdfproc
180 %attr(755,root,root) %{_bindir}/redland-db-upgrade
181 %attr(755,root,root) %{_libdir}/librdf.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/librdf.so.0
183 %dir %{_libdir}/redland
184 %attr(755,root,root) %{_libdir}/redland/librdf_storage_file.so
185 %dir %{_datadir}/redland
186 %{_datadir}/redland/mysql-v*.ttl
187 %{_mandir}/man1/rdfproc.1*
188 %{_mandir}/man1/redland-db-upgrade.1*
189
190 %files devel
191 %defattr(644,root,root,755)
192 %doc docs/{README.html,storage.html}
193 %attr(755,root,root) %{_bindir}/redland-config
194 %attr(755,root,root) %{_libdir}/librdf.so
195 %{_libdir}/librdf.la
196 %{_includedir}/librdf.h
197 %{_includedir}/rdf_*.h
198 %{_includedir}/redland.h
199 %{_datadir}/redland/Redland.i
200 %{_pkgconfigdir}/redland.pc
201 %{_mandir}/man1/redland-config.1*
202 %{_mandir}/man3/redland.3*
203 %{_gtkdocdir}/redland
204
205 %files static
206 %defattr(644,root,root,755)
207 %{_libdir}/librdf.a
208
209 %files storage-mysql
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/redland/librdf_storage_mysql.so
212
213 %files storage-postgresql
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_libdir}/redland/librdf_storage_postgresql.so
216
217 %files storage-sqlite
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/redland/librdf_storage_sqlite.so
220
221 %if %{with threestore}
222 %files storage-tstore
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/redland/librdf_storage_tstore.so
225 %endif
This page took 0.037586 seconds and 3 git commands to generate.