]> git.pld-linux.org Git - packages/redland.git/blob - redland.spec
b4d9746a36bf7ecf9c932ebb23df8a68ea1edb1d
[packages/redland.git] / redland.spec
1 #
2 # Conditional build:
3 %bcond_without  threestore      # with 3store
4 #
5 Summary:        Redland - a library that provides a high-level interface for RDF
6 Summary(pl.UTF-8):      Redland - biblioteka udostępniająca wysokopoziomowy interfejs do RDF
7 Name:           redland
8 Version:        1.0.6
9 Release:        2
10 License:        LGPL v2.1+ or GPL v2+ or Apache v2
11 Group:          Libraries
12 Source0:        http://download.librdf.org/source/%{name}-%{version}.tar.gz
13 # Source0-md5:  901bf87252658c8b247dc6eda00f8724
14 Patch0:         %{name}-link.patch
15 URL:            http://librdf.org/
16 %if %{with threestore}
17 BuildRequires:  3store-devel >= 2.0
18 BuildRequires:  3store-devel < 3.0
19 %endif
20 BuildRequires:  autoconf >= 2.53
21 BuildRequires:  automake >= 1:1.7
22 BuildRequires:  db-devel
23 BuildRequires:  libraptor-devel >= 1.4.15
24 BuildRequires:  libtool
25 BuildRequires:  mysql-devel >= 3.23.58
26 BuildRequires:  openssl-devel >= 0.9.7d
27 BuildRequires:  pkgconfig
28 BuildRequires:  postgresql-devel
29 BuildRequires:  rasqal-devel >= 1:0.9.14
30 BuildRequires:  rpmbuild(macros) >= 1.98
31 BuildRequires:  sqlite3-devel >= 3
32 Requires:       libraptor >= 1.4.15
33 Requires:       rasqal >= 1:0.9.14
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Redland is a library that provides a high-level interface for RDF
38 allowing the RDF graph to be parsed from XML, stored, queried and
39 manipulated. Redland implements each of the RDF concepts in its own
40 class via an object based API, reflected into the other language APIs:
41 Perl, Python, Tcl, Java and Ruby. Some of the classes providing the
42 parsers, storage mechanisms and other elements are built as modules
43 that can be added or removed as required.
44
45 %description -l pl.UTF-8
46 Redland to biblioteka udostępniająca wysokopoziomowy interfejs do RDF,
47 pozwalająca na analizę grafu RDF z XML-a, jego przechowywanie,
48 odpytywanie i obróbkę. Redland zawiera implementacje każdego pojęcia z
49 RDF w osobnej klasie poprzez obiekt oparty na API, mający
50 odzwierciedlenie w API dla innych języków: Perla, Pythona, Tcl-a, Javy
51 i Ruby'ego. Część klas udostępniających analizatory, mechanizmy
52 przechowywania i inne elementy jest zbudowana jako moduły, które mogą
53 być dodawane lub usuwane w razie potrzeby.
54
55 %package devel
56 Summary:        Headers for Redland RDF library
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Redland RDF
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 %if %{with threestore}
61 Requires:       3store-devel >= 2.0
62 Requires:       3store-devel < 3.0
63 %endif
64 Requires:       db-devel
65 Requires:       libraptor-devel >= 1.4.15
66 Requires:       mysql-devel >= 3.23.58
67 Requires:       postgresql-devel
68 Requires:       rasqal-devel >= 1:0.9.14
69 Requires:       sqlite3-devel >= 3
70
71 %description devel
72 Headers for Redland RDF library.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe biblioteki Redland RDF.
76
77 %package static
78 Summary:        Static Redland RDF library
79 Summary(pl.UTF-8):      Statyczna biblioteka Redland RDF
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static Redland RDF library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka Redland RDF.
88
89 %package -n python-redland
90 Summary:        Python bindings for Redland RDF library
91 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki Redland RDF
92 Group:          Libraries/Python
93 Requires:       %{name} = %{version}-%{release}
94 %pyrequires_eq  python
95
96 %description -n python-redland
97 Python bindings for Redland RDF library
98
99 %description -n python-redland -l pl.UTF-8
100 Pythonowy interfejs do biblioteki Redland RDF
101
102 %prep
103 %setup -q
104 %patch0 -p1
105
106 %build
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --with-html-dir=%{_gtkdocdir} \
114         --with-threestore=%{!?with_threestore:no}%{?with_threestore:yes} \
115         --with-raptor=system \
116         --with-rasqal=system
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog* FAQS.html LICENSE.html NEWS.html README.html RELEASE.html TODO.html
135 %attr(755,root,root) %{_bindir}/rdfproc
136 %attr(755,root,root) %{_bindir}/redland-db-upgrade
137 %attr(755,root,root) %{_libdir}/librdf.so.*.*.*
138 %dir %{_datadir}/redland
139 %{_datadir}/redland/mysql-v*.ttl
140 %{_mandir}/man1/rdfproc.1*
141 %{_mandir}/man1/redland-db-upgrade.1*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %doc docs/{README.html,storage.html}
146 %attr(755,root,root) %{_bindir}/redland-config
147 %attr(755,root,root) %{_libdir}/librdf.so
148 %{_libdir}/librdf.la
149 %{_includedir}/librdf.h
150 %{_includedir}/rdf_*.h
151 %{_includedir}/redland.h
152 %{_datadir}/redland/Redland.i
153 %{_pkgconfigdir}/redland.pc
154 %{_mandir}/man1/redland-config.1*
155 %{_mandir}/man3/redland.3*
156 %{_gtkdocdir}/redland
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/librdf.a
This page took 0.054338 seconds and 2 git commands to generate.