]> git.pld-linux.org Git - packages/redland.git/blob - redland.spec
- BR added
[packages/redland.git] / redland.spec
1 #
2 # Conditional build:
3 %bcond_without  threestore      # with 3store
4 #
5 Summary:        Redland - a library that provides a high-level interface for RDF
6 Summary(pl.UTF-8):      Redland - biblioteka udostępniająca wysokopoziomowy interfejs do RDF
7 Name:           redland
8 Version:        1.0.6
9 Release:        3
10 License:        LGPL v2.1+ or GPL v2+ or Apache v2
11 Group:          Libraries
12 Source0:        http://download.librdf.org/source/%{name}-%{version}.tar.gz
13 # Source0-md5:  901bf87252658c8b247dc6eda00f8724
14 Patch0:         %{name}-link.patch
15 URL:            http://librdf.org/
16 %if %{with threestore}
17 BuildRequires:  3store-devel >= 2.0
18 BuildRequires:  3store-devel < 3.0
19 %endif
20 BuildRequires:  autoconf >= 2.53
21 BuildRequires:  automake >= 1:1.7
22 BuildRequires:  db-devel
23 BuildRequires:  db-static
24 BuildRequires:  libraptor-devel >= 1.4.15
25 BuildRequires:  libtool
26 BuildRequires:  mysql-devel >= 3.23.58
27 BuildRequires:  openssl-devel >= 0.9.7d
28 BuildRequires:  pkgconfig
29 BuildRequires:  postgresql-devel
30 BuildRequires:  rasqal-devel >= 1:0.9.14
31 BuildRequires:  rpmbuild(macros) >= 1.98
32 BuildRequires:  sqlite3-devel >= 3
33 Requires:       libraptor >= 1.4.15
34 Requires:       rasqal >= 1:0.9.14
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Redland is a library that provides a high-level interface for RDF
39 allowing the RDF graph to be parsed from XML, stored, queried and
40 manipulated. Redland implements each of the RDF concepts in its own
41 class via an object based API, reflected into the other language APIs:
42 Perl, Python, Tcl, Java and Ruby. Some of the classes providing the
43 parsers, storage mechanisms and other elements are built as modules
44 that can be added or removed as required.
45
46 %description -l pl.UTF-8
47 Redland to biblioteka udostępniająca wysokopoziomowy interfejs do RDF,
48 pozwalająca na analizę grafu RDF z XML-a, jego przechowywanie,
49 odpytywanie i obróbkę. Redland zawiera implementacje każdego pojęcia z
50 RDF w osobnej klasie poprzez obiekt oparty na API, mający
51 odzwierciedlenie w API dla innych języków: Perla, Pythona, Tcl-a, Javy
52 i Ruby'ego. Część klas udostępniających analizatory, mechanizmy
53 przechowywania i inne elementy jest zbudowana jako moduły, które mogą
54 być dodawane lub usuwane w razie potrzeby.
55
56 %package devel
57 Summary:        Headers for Redland RDF library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Redland RDF
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 %if %{with threestore}
62 Requires:       3store-devel >= 2.0
63 Requires:       3store-devel < 3.0
64 %endif
65 Requires:       db-devel
66 Requires:       libraptor-devel >= 1.4.15
67 Requires:       mysql-devel >= 3.23.58
68 Requires:       postgresql-devel
69 Requires:       rasqal-devel >= 1:0.9.14
70 Requires:       sqlite3-devel >= 3
71
72 %description devel
73 Headers for Redland RDF library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe biblioteki Redland RDF.
77
78 %package static
79 Summary:        Static Redland RDF library
80 Summary(pl.UTF-8):      Statyczna biblioteka Redland RDF
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static Redland RDF library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka Redland RDF.
89
90 %package -n python-redland
91 Summary:        Python bindings for Redland RDF library
92 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki Redland RDF
93 Group:          Libraries/Python
94 Requires:       %{name} = %{version}-%{release}
95 %pyrequires_eq  python
96
97 %description -n python-redland
98 Python bindings for Redland RDF library
99
100 %description -n python-redland -l pl.UTF-8
101 Pythonowy interfejs do biblioteki Redland RDF
102
103 %prep
104 %setup -q
105 %patch0 -p1
106
107 %build
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --with-html-dir=%{_gtkdocdir} \
115         --with-threestore=%{!?with_threestore:no}%{?with_threestore:yes} \
116         --with-raptor=system \
117         --with-rasqal=system
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog* FAQS.html LICENSE.html NEWS.html README.html RELEASE.html TODO.html
136 %attr(755,root,root) %{_bindir}/rdfproc
137 %attr(755,root,root) %{_bindir}/redland-db-upgrade
138 %attr(755,root,root) %{_libdir}/librdf.so.*.*.*
139 %dir %{_datadir}/redland
140 %{_datadir}/redland/mysql-v*.ttl
141 %{_mandir}/man1/rdfproc.1*
142 %{_mandir}/man1/redland-db-upgrade.1*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %doc docs/{README.html,storage.html}
147 %attr(755,root,root) %{_bindir}/redland-config
148 %attr(755,root,root) %{_libdir}/librdf.so
149 %{_libdir}/librdf.la
150 %{_includedir}/librdf.h
151 %{_includedir}/rdf_*.h
152 %{_includedir}/redland.h
153 %{_datadir}/redland/Redland.i
154 %{_pkgconfigdir}/redland.pc
155 %{_mandir}/man1/redland-config.1*
156 %{_mandir}/man3/redland.3*
157 %{_gtkdocdir}/redland
158
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/librdf.a
This page took 0.078174 seconds and 3 git commands to generate.