]> git.pld-linux.org Git - packages/redland.git/blob - redland.spec
5e2adb49772565494c08c6b93c65e590474df438
[packages/redland.git] / redland.spec
1 #
2 # Conditional build:
3 %bcond_without  threestore      # with 3store
4 #
5 Summary:        Redland - a library that provides a high-level interface for RDF
6 Summary(pl.UTF-8):      Redland - biblioteka udostępniająca wysokopoziomowy interfejs do RDF
7 Name:           redland
8 Version:        1.0.6
9 Release:        4
10 License:        LGPL v2.1+ or GPL v2+ or Apache v2
11 Group:          Libraries
12 Source0:        http://download.librdf.org/source/%{name}-%{version}.tar.gz
13 # Source0-md5:  901bf87252658c8b247dc6eda00f8724
14 Patch0:         %{name}-link.patch
15 URL:            http://librdf.org/
16 %if %{with threestore}
17 BuildRequires:  3store-devel >= 2.0
18 BuildRequires:  3store-devel < 3.0
19 %endif
20 BuildRequires:  autoconf >= 2.53
21 BuildRequires:  automake >= 1:1.7
22 BuildRequires:  db-devel
23 BuildRequires:  gtk-doc
24 BuildRequires:  libraptor-devel >= 1.4.15
25 BuildRequires:  libtool
26 BuildRequires:  mysql-devel >= 3.23.58
27 BuildRequires:  openssl-devel >= 0.9.7d
28 BuildRequires:  pkgconfig
29 BuildRequires:  postgresql-devel
30 BuildRequires:  rasqal-devel >= 1:0.9.14
31 BuildRequires:  rpmbuild(macros) >= 1.98
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  sqlite3-devel >= 3
34 Requires:       libraptor >= 1.4.15
35 Requires:       rasqal >= 1:0.9.14
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Redland is a library that provides a high-level interface for RDF
40 allowing the RDF graph to be parsed from XML, stored, queried and
41 manipulated. Redland implements each of the RDF concepts in its own
42 class via an object based API, reflected into the other language APIs:
43 Perl, Python, Tcl, Java and Ruby. Some of the classes providing the
44 parsers, storage mechanisms and other elements are built as modules
45 that can be added or removed as required.
46
47 %description -l pl.UTF-8
48 Redland to biblioteka udostępniająca wysokopoziomowy interfejs do RDF,
49 pozwalająca na analizę grafu RDF z XML-a, jego przechowywanie,
50 odpytywanie i obróbkę. Redland zawiera implementacje każdego pojęcia z
51 RDF w osobnej klasie poprzez obiekt oparty na API, mający
52 odzwierciedlenie w API dla innych języków: Perla, Pythona, Tcl-a, Javy
53 i Ruby'ego. Część klas udostępniających analizatory, mechanizmy
54 przechowywania i inne elementy jest zbudowana jako moduły, które mogą
55 być dodawane lub usuwane w razie potrzeby.
56
57 %package devel
58 Summary:        Headers for Redland RDF library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Redland RDF
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 %if %{with threestore}
63 Requires:       3store-devel >= 2.0
64 Requires:       3store-devel < 3.0
65 %endif
66 Requires:       db-devel
67 Requires:       libraptor-devel >= 1.4.15
68 Requires:       mysql-devel >= 3.23.58
69 Requires:       postgresql-devel
70 Requires:       rasqal-devel >= 1:0.9.14
71 Requires:       sqlite3-devel >= 3
72
73 %description devel
74 Headers for Redland RDF library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki Redland RDF.
78
79 %package static
80 Summary:        Static Redland RDF library
81 Summary(pl.UTF-8):      Statyczna biblioteka Redland RDF
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static Redland RDF library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka Redland RDF.
90
91 %package -n python-redland
92 Summary:        Python bindings for Redland RDF library
93 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki Redland RDF
94 Group:          Libraries/Python
95 Requires:       %{name} = %{version}-%{release}
96 %pyrequires_eq  python
97
98 %description -n python-redland
99 Python bindings for Redland RDF library
100
101 %description -n python-redland -l pl.UTF-8
102 Pythonowy interfejs do biblioteki Redland RDF
103
104 %prep
105 %setup -q
106 %patch0 -p1
107
108 sed -i -e 's,bdbc_prefix/lib$,bdbc_prefix/%{_lib},' configure.ac
109
110 %build
111 %{__libtoolize}
112 %{__gtkdocize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         --with-html-dir=%{_gtkdocdir} \
119         --with-threestore=%{!?with_threestore:no}%{?with_threestore:yes} \
120         --with-raptor=system \
121         --with-rasqal=system
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog* FAQS.html LICENSE.html NEWS.html README.html RELEASE.html TODO.html
140 %attr(755,root,root) %{_bindir}/rdfproc
141 %attr(755,root,root) %{_bindir}/redland-db-upgrade
142 %attr(755,root,root) %{_libdir}/librdf.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/librdf.so.0
144 %dir %{_datadir}/redland
145 %{_datadir}/redland/mysql-v*.ttl
146 %{_mandir}/man1/rdfproc.1*
147 %{_mandir}/man1/redland-db-upgrade.1*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %doc docs/{README.html,storage.html}
152 %attr(755,root,root) %{_bindir}/redland-config
153 %attr(755,root,root) %{_libdir}/librdf.so
154 %{_libdir}/librdf.la
155 %{_includedir}/librdf.h
156 %{_includedir}/rdf_*.h
157 %{_includedir}/redland.h
158 %{_datadir}/redland/Redland.i
159 %{_pkgconfigdir}/redland.pc
160 %{_mandir}/man1/redland-config.1*
161 %{_mandir}/man3/redland.3*
162 %{_gtkdocdir}/redland
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/librdf.a
This page took 0.035692 seconds and 2 git commands to generate.