]> git.pld-linux.org Git - packages/redland.git/blob - redland.spec
403b2381c278442e890cdfd9ed4c5b3718066cbd
[packages/redland.git] / redland.spec
1 # TODO: various language support (java, perl, php, ruby, tcl)
2 %include        /usr/lib/rpm/macros.python
3 Summary:        Redland - a library that provides a high-level interface for RDF
4 Summary(pl):    Redland - biblioteka udostêpniaj±ca wysokopoziomowy interfejs do RDF
5 Name:           redland
6 Version:        0.9.16
7 Release:        0.1
8 License:        LGPL v2 or MPL 1.1
9 Group:          Libraries
10 Source0:        http://www.redland.opensource.ac.uk/dist/source/%{name}-%{version}.tar.gz
11 # Source0-md5:  d78c768825df2727aec8336fe9772d8d
12 Patch0:         %{name}-system-raptor.patch
13 URL:            http://www.redland.opensource.ac.uk/
14 BuildRequires:  autoconf >= 2.53
15 BuildRequires:  automake >= 1.6
16 BuildRequires:  db-devel
17 BuildRequires:  libraptor-devel >= 1.2.0
18 BuildRequires:  libtool
19 BuildRequires:  mysql-devel >= 3.23.58
20 BuildRequires:  openssl-devel
21 BUildRequires:  rpm-pythonprov
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Redland is a library that provides a high-level interface for RDF
26 allowing the RDF graph to be parsed from XML, stored, queried and
27 manipulated. Redland implements each of the RDF concepts in its own
28 class via an object based API, reflected into the other language APIs:
29 Perl, Python, Tcl, Java and Ruby. Some of the classes providing the
30 parsers, storage mechanisms and other elements are built as modules
31 that can be added or removed as required.
32
33 %description -l pl
34 Redland to biblioteka udostêpniaj±ca wysokopoziomowy interfejs do RDF,
35 pozwalaj±ca na analizê grafu RDF z XML-a, jego przechowywanie,
36 odpytywanie i obróbkê. Redland zawiera implementacje ka¿dego pojêcia z
37 RDF w odobnej klasie poprzez obiekt oparty na API, maj±cy
38 odzwierciedlenie w API dla innych jêzyków: Perla, Pythona, Tcl-a, Javy
39 i Ruby'ego. Czê¶æ klas udostêpniaj±cych analizatory, mechanizmy
40 przechowywania i inne elementy jest zbudowana jako modu³y, które mog±
41 byæ dodawane lub usuwane w razie potrzeby.
42
43 %package devel
44 Summary:        Headers for Redland RDF library
45 Summary(pl):    Pliki nag³ówkowe biblioteki Redland RDF
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       db-devel
49 Requires:       libraptor-devel >= 1.2.0
50 Requires:       mysql-devel >= 3.23.58
51
52 %description devel
53 Headers for Redland RDF library.
54
55 %description devel -l pl
56 Pliki nag³ówkowe biblioteki Redland RDF.
57
58 %package static
59 Summary:        Static Redland RDF library
60 Summary(pl):    Statyczna biblioteka Redland RDF
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static Redland RDF library.
66
67 %description static -l pl
68 Statyczna biblioteka Redland RDF.
69
70 %package rapper
71 Summary:        Raptor RDF parser test program with Redland RDF support
72 Summary(pl):    Testowy program parsera Raptor RDF ze wsparciem dla Redland RDF
73 Group:          Applications
74 Requires:       %{name} = %{version}-%{release}
75
76 %description rapper
77 Raptor RDF parser test program with Redland RDF support.
78
79 %description rapper -l pl
80 Testowy program parsera Raptor RDF ze wsparciem dla Redland RDF.
81
82 %package -n python-redland
83 Summary:        Python bindings for Redland RDF library
84 Summary(pl):    Pythonowy interfejs do biblioteki Redland RDF
85 Group:          Libraries/Python
86 Requires:       %{name} = %{version}-%{release}
87 %pyrequires_eq  python
88
89 %description -n python-redland
90 Python bindings for Redland RDF library
91
92 %description -n python-redland -l pl
93 Pythonowy interfejs do biblioteki Redland RDF
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 cd raptor
106 %{__aclocal}
107 %{__autoconf}
108 %{__autoheader}
109 # don't use -f here
110 automake -a -c --foreign
111 cd ..
112 %configure \
113         --with-raptor=system \
114         --with-python
115
116 #       --with-java --with-jdk=/usr/lib/java  -- builds, but can be only optional
117 #       --with-perl  -- needs INSTALLDIRS=vendor in perl/Makefile.am
118 #       --with-ruby  -- missing install -d before installing *.so
119 #       --with-tcl  -- missing install -d before installing *.so
120 #       --with-php  -- cannot find config.h
121 #       --with-ecma-cli=mono  -- TODO
122
123 %{__make}
124
125 # build rapper with Redland/RDF support
126 %{__make} -C raptor
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__make} install -C raptor \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog FAQS.html LICENSE.html NEWS.html README.html RELEASE.html TODO.html
146 %attr(755,root,root) %{_bindir}/rdfproc
147 %attr(755,root,root) %{_bindir}/redland-db-upgrade
148 %attr(755,root,root) %{_libdir}/librdf.so.*.*.*
149 %{_mandir}/man1/rdfproc.1*
150 %{_mandir}/man1/redland-db-upgrade.1*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %doc docs/{README.html,overview.png,api}
155 %attr(755,root,root) %{_bindir}/redland-config
156 %attr(755,root,root) %{_libdir}/librdf.so
157 %{_libdir}/librdf.la
158 %{_includedir}/librdf.h
159 %{_includedir}/rdf_*.h
160 %{_includedir}/redland.h
161 %{_pkgconfigdir}/redland.pc
162 %{_mandir}/man1/redland-config.1*
163 %{_mandir}/man3/redland.3*
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/librdf.a
168
169 %files rapper
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/rapper
172 %{_mandir}/man1/rapper.1*
173
174 %files -n python-redland
175 %defattr(644,root,root,755)
176 %{py_sitedir}/RDF.py
177 %attr(755,root,root) %{py_sitedir}/Redland.so
This page took 0.034112 seconds and 2 git commands to generate.