]> git.pld-linux.org Git - packages/rc-scripts.git/blob - rc-scripts.spec
- masive changes:
[packages/rc-scripts.git] / rc-scripts.spec
1 Summary:        inittab and /etc/rc.d scripts
2 Summary(de):    inittab und /etc/rc.d Scripts
3 Summary(fr):    inittab et scripts /etc/rc.d
4 Summary(pl):    inittab i skrypty startowe z katalogu /etc/rc.d
5 Summary(tr):    inittab ve /etc/rc.d dosyalarý
6 Name:           rc-scripts
7 Version:        0.0.3
8 Copyright:      GPL
9 Group:          Base
10 Group(pl):      Bazowe  
11 Release:        1
12 Source:         %{name}-%{version}.tar.gz
13 Buildroot:      /tmp/buildroot-%{name}-%{version}
14 Requires:       mingetty
15 Requires:       mktemp
16 Requires:       modutils >= 2.1.121
17 Prereq:         /sbin/chkconfig
18 Obsoletes:      initscripts
19
20 %description
21 This package contains the scripts use to boot a system, change run
22 levels, and shut the system down cleanly.
23
24 %description -l de
25 Dieses Paket enthält die Scripts, die zum Hochfahren des Systems, Ändern
26 der Betriebsebene und sauberem Herunterfahren des Systems erforderlich sind.
27 Außerdem enthält es die Scripts, die Netzwerkschnittstellen aktivieren und
28 deaktivieren.
29
30 %description -l fr
31 Ce package contient les scripts utilisés pour démarrer le systéme,
32 changer les niveaux d'exécution, et arréter le systéme proprement.
33 Il contient aussi les scripts qui activent et désactivent la plupart
34 des inetrfaces réseau.
35
36 %description -l pl
37 Pakiet zawiera skrypty uruchamiane przy starcie i zamykaniu systemu, a
38 tak¿e przy zmianie poziomu uruchomienia. 
39
40 %description -l tr
41 Bu paket, sistem açmak, çalýþma düzeylerini deðiþtirmek ve sistemi düzgün bir
42 þekilde kapatmak için gereken dosyalarý içerir. Ayrýca pek çok bilgisayar aðý
43 arayüzlerini etkinleþtiren ya da edilginleþtiren programcýklar içerir.
44
45 %package -n net-scripts
46 Summary:        network startup scripts
47 Summary(pl):    skrypty startowe sieci
48 Group:          Base
49 Group(pl):      Bazowe  
50 Requires:       rc-scripts = %{version}
51 Requires:       modutils >= 2.1.121
52 Provides:       initscripts
53 Prereq:         /sbin/chkconfig
54
55 %description -n net-scripts
56 Scripts that activate and deactivate most network interfaces.
57
58 %description -n net-scripts
59 Skrypty s³u¿±ce do aktywacji i deaktywacji interfejsów sieciowych
60
61 %prep
62 %setup -q
63
64 %build
65 CFLAGS="$RPM_OPT_FLAGS -w" make
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
70
71 make ROOT=$RPM_BUILD_ROOT install 
72
73 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
74         sysconfig.txt
75
76 %post
77 for i in  halt nfsfs random reboot single  
78         do /sbin/chkconfig --add $i
79 done 
80 if [ -f /etc/inittab.rpmsave ]; then
81         echo "**** Found old /etc/inittab.rpmsave ****"
82         echo "/etc/inittab renamed to /etc/inittab.rpmnew"
83         mv /etc/inittab /etc/inittab.rpmnew
84         echo "/etc/inittab.rpmsave renamed to /etc/inittab."
85         mv /etc/inittab.rpmsave /etc/inittab
86 fi
87
88 %preun
89 if [ "$1" = "0" ]; then
90         /sbin/chkconfig --del random
91         /sbin/chkconfig --del nfsfs
92 fi
93
94 %post -n net-scripts
95 /sbin/chkconfig --add network
96 for l in /etc/sysconfig/network-scripts/ifcfg-* ; do 
97   if [ -f "$l" ] ; then
98     NEWNAME=`basename $l | sed -e 's /^ifcfg-//'`
99     [ -f /etc/sysconfig/interfaces/$NEWNAME ] || cp $l /etc/sysconfig/interfaces/$NEWNAME
100   fi
101 done
102
103 %preun -n net-scripts
104 if [ "$1" = "0" ]; then
105         /sbin/chkconfig --del network
106 fi
107
108 %files
109 %defattr(644,root,root,754)
110 %doc sysconfig.txt.gz
111
112 %config(noreplace) %verify(not md5 mtime size) /etc/adjtime
113 %config(noreplace) %verify(not md5 mtime size) /etc/inittab
114
115 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/system
116
117 %attr(644,root,root) /etc/rc.d/init.d/functions
118 %attr(754,root,root) /etc/rc.d/init.d/halt
119 %attr(754,root,root) /etc/rc.d/init.d/killall
120 %attr(754,root,root) /etc/rc.d/init.d/nfsfs
121 %attr(754,root,root) /etc/rc.d/init.d/random
122 %attr(754,root,root) /etc/rc.d/init.d/reboot
123 %attr(754,root,root) /etc/rc.d/init.d/shutdwn
124 %attr(754,root,root) /etc/rc.d/init.d/single
125
126 %attr(754,root,root) /etc/rc.d/rc.sysinit
127 %attr(754,root,root) /etc/rc.d/rc.serial
128 %attr(754,root,root) /etc/rc.d/rc
129 %attr(754,root,root) /etc/rc.d/rc.local
130 %attr(755,root,root) /etc/profile.d/lang.sh
131 %attr(755,root,root) /bin/doexec
132 %attr(755,root,root) /bin/usleep
133 %attr(755,root,root) /sbin/setsysfont
134
135 %{_mandir}/man1/usleep.1.gz
136 %{_mandir}/man1/doexec.1.gz
137
138 %files -n net-scripts
139 %doc sysconfig/interfaces/*-template!
140 %doc sysconfig/interfaces/data/chat-ppp*
141 %attr(754,root,root) /etc/rc.d/init.d/network
142 %attr(750,root,root) %dir /var/run/netreport
143 %attr(755,root,root,755) /etc/ppp
144
145 %attr(755,root,root) %dir /etc/sysconfig/interfaces
146 %attr(755,root,root) %dir /sbin/network-scripts
147 %attr(755,root,root) /sbin/network-scripts/if*
148 %attr(644,root,root) /sbin/network-scripts/network-functions
149 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/interfaces/lo
150
151 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/network
152 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/static-routes
153
154 %attr(755,root,root) /usr/sbin/usernetctl
155 %attr(755,root,root) /bin/ipcalc
156 %attr(755,root,root) /sbin/netreport
157 %attr(755,root,root) /sbin/ifup
158 %attr(755,root,root) /sbin/ifdown
159
160 %{_mandir}/man1/netreport.1.gz
161 %{_mandir}/man1/usernetctl.1.gz
162 %{_mandir}/man1/ipcalc.1.gz
163
164 %changelog
165 * Thu Apr 22 1999 Jacek Konieczny <jajcus@zeus.polsl.gliwice.pl>
166   [0.0.3-1]
167 - split into two packages: rc-scripts & net-scripts  
168 - directory structure changed - only config in /etc
169
170 * Tue Mar 23 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
171   [0.0.2-1]
172 - be more verbose while upgrading when /etc/inittab.rpmsave is found,
173 - added seting NETWORK="no" variable to when /etc/sysconfig/network is not present
174   or when NETWORK in this file is not defined.
175
176 * Sun Mar 21 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
177   [0.0.1-1]
178 - added /etc/sysconfig/system,
179 - removed man group from man pages,
180 - added in %post not replacing /etc/inittab on upgrade from initscripts,
181 - removed %config from scripts.
182
183 * Fri Mar 19 1999 PLD Team <bugs@pld.org.pl>
184 - Full changelog in PLD's CVS.
185 - First Release.
186 - Package based on RedHat's initscripts-3.78.
This page took 0.083427 seconds and 3 git commands to generate.