]> git.pld-linux.org Git - packages/radsecproxy.git/blob - radsecproxy.spec
- rel.3 - fticksVISINST support
[packages/radsecproxy.git] / radsecproxy.spec
1 # TODO:
2 # - own UID/GID
3 Summary:        RADIUS proxy that in addition to to usual RADIUS UDP transport, also supports TLS (RadSec)
4 Name:           radsecproxy
5 Version:        1.5
6 Release:        3
7 License:        GPLv2+ or BSD-like
8 Group:          Networking/Daemons/Radius
9 Source0:        http://software.uninett.no/radsecproxy/%{name}-%{version}.tar.gz
10 # Source0-md5:  c65742a1b471c572ca7f6d11000d41f5
11 Source1:        %{name}.init
12 Source2:        %{name}.logrotate
13 Source3:        %{name}.upstart
14 Patch0:         %{name}-docbook2x.patch
15 ## will be included in 1.6
16 Patch1:         %{name}-fticks.patch
17 Patch2:         %{name}-visinst.patch
18 URL:            http://software.uninett.no/radsecproxy/
19 # For manual creation:
20 BuildRequires:  docbook2X
21 Requires:       openssl >= 1.0.0b
22 Requires(post,preun):   /sbin/chkconfig
23 Requires:       rc-scripts >= 0.4.3.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 radsecproxy is a generic RADIUS proxy that in addition to to usual
28 RADIUS UDP transport, also supports TLS (RadSec). The aim is for the
29 proxy to have sufficient features to be flexible, while at the same
30 time to be small, efficient and easy to configure. Currently the
31 executable on Linux is only about 48 Kb, and it uses about 64 Kb
32 (depending on the number of peers) while running.
33
34 %package upstart
35 Summary:        Upstart job description for %{name}
36 Summary(pl.UTF-8):      Opis zadania Upstart dla %{name}
37 Group:          Daemons
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       upstart >= 0.6
40
41 %description upstart
42 Upstart job description for %{name}.
43
44 %description upstart -l pl.UTF-8
45 Opis zadania Upstart dla %{name}.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50 %patch1 -p1
51 %patch2 -p1
52
53 %build
54 %{__aclocal}
55 %{__autoconf}
56 %configure \
57         --enable-fticks
58 # Some trash comes with tar:
59 %{__make} clean
60 %{__make}
61 # FIXME:
62 mv ______radsecproxy.conf\ ____.5 radsecproxy.conf.5
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_sysconfdir}/radsecproxy.conf.d \
67         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d,init}
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 cp -p radsecproxy.conf-example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
73
74 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
75 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
76 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/init/%{name}.conf
77
78 install -p radsecproxy.conf.5 $RPM_BUILD_ROOT/%{_mandir}/man5
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post
84 /sbin/chkconfig --add %{name}
85 %service %{name} restart "RADIUS secure proxy"
86
87 %preun
88 if [ "$1" = "0" ]; then
89         %service %{name} stop
90         /sbin/chkconfig --del %{name}
91 fi
92
93 %post upstart
94 %upstart_post %{name}
95
96 %postun upstart
97 %upstart_postun %{name}
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS ChangeLog README
102 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/radsecproxy.conf
103 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
104 %attr(750,root,root) %dir %{_sysconfdir}/radsecproxy.conf.d
105 %attr(755,root,root) %{_sbindir}/radsecproxy
106 %attr(755,root,root) %{_bindir}/radsecproxy-conf
107 %attr(755,root,root) %{_bindir}/radsecproxy-hash
108 %attr(754,root,root) /etc/rc.d/init.d/%{name}
109 %{_mandir}/man1/*
110 %{_mandir}/man5/*
111
112 %files upstart
113 %defattr(644,root,root,755)
114 %config(noreplace) %verify(not md5 mtime size) /etc/init/%{name}.conf
This page took 0.101591 seconds and 3 git commands to generate.