]> git.pld-linux.org Git - packages/radsecproxy.git/blob - radsecproxy.spec
- rel.2 - works fine
[packages/radsecproxy.git] / radsecproxy.spec
1 # TODO:
2 # - own UID/GID
3 Summary:        RADIUS proxy that in addition to to usual RADIUS UDP transport, also supports TLS (RadSec)
4 Name:           radsecproxy
5 Version:        1.5
6 Release:        2
7 License:        GPLv2+ or BSD-like
8 Group:          Networking/Daemons/Radius
9 Source0:        http://software.uninett.no/radsecproxy/%{name}-%{version}.tar.gz
10 # Source0-md5:  c65742a1b471c572ca7f6d11000d41f5
11 Source1:        %{name}.init
12 Source2:        %{name}.logrotate
13 Source3:        %{name}.upstart
14 Patch0:         %{name}-docbook2x.patch
15 Patch1:         %{name}-fticks.patch
16 URL:            http://software.uninett.no/radsecproxy/
17 # For manual creation:
18 BuildRequires:  docbook2X
19 Requires:       openssl >= 1.0.0b
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       rc-scripts >= 0.4.3.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 radsecproxy is a generic RADIUS proxy that in addition to to usual
26 RADIUS UDP transport, also supports TLS (RadSec). The aim is for the
27 proxy to have sufficient features to be flexible, while at the same
28 time to be small, efficient and easy to configure. Currently the
29 executable on Linux is only about 48 Kb, and it uses about 64 Kb
30 (depending on the number of peers) while running.
31
32 %package upstart
33 Summary:        Upstart job description for %{name}
34 Summary(pl.UTF-8):      Opis zadania Upstart dla %{name}
35 Group:          Daemons
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       upstart >= 0.6
38
39 %description upstart
40 Upstart job description for %{name}.
41
42 %description upstart -l pl.UTF-8
43 Opis zadania Upstart dla %{name}.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48 %patch1 -p1
49
50 %build
51 %{__aclocal}
52 %{__autoconf}
53 %configure \
54         --enable-fticks
55 # Some trash comes with tar:
56 %{__make} clean
57 %{__make}
58 # FIXME:
59 mv ______radsecproxy.conf\ ____.5 radsecproxy.conf.5
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_sysconfdir}/radsecproxy.conf.d \
64         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d,init}
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 cp -p radsecproxy.conf-example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
70
71 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
72 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
73 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/init/%{name}.conf
74
75 install -p radsecproxy.conf.5 $RPM_BUILD_ROOT/%{_mandir}/man5
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 /sbin/chkconfig --add %{name}
82 %service %{name} restart "RADIUS secure proxy"
83
84 %preun
85 if [ "$1" = "0" ]; then
86         %service %{name} stop
87         /sbin/chkconfig --del %{name}
88 fi
89
90 %post upstart
91 %upstart_post %{name}
92
93 %postun upstart
94 %upstart_postun %{name}
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS ChangeLog README
99 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/radsecproxy.conf
100 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
101 %attr(750,root,root) %dir %{_sysconfdir}/radsecproxy.conf.d
102 %attr(755,root,root) %{_sbindir}/radsecproxy
103 %attr(755,root,root) %{_bindir}/radsecproxy-conf
104 %attr(755,root,root) %{_bindir}/radsecproxy-hash
105 %attr(754,root,root) /etc/rc.d/init.d/%{name}
106 %{_mandir}/man1/*
107 %{_mandir}/man5/*
108
109 %files upstart
110 %defattr(644,root,root,755)
111 %config(noreplace) %verify(not md5 mtime size) /etc/init/%{name}.conf
This page took 0.056976 seconds and 3 git commands to generate.