]> git.pld-linux.org Git - packages/qt5-qtwebengine.git/blob - qt5-qtwebengine.spec
- attempt to fix x32 build, still doesn't fully work, tho
[packages/qt5-qtwebengine.git] / qt5-qtwebengine.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtwebengine
6 %define         qtbase_ver              %{version}
7 %define         qtdeclarative_ver       %{version}
8 %define         qttools_ver             %{version}
9 %define         qtwebchannel_ver        %{version}
10 Summary:        The Qt5 WebEngine library
11 Summary(pl.UTF-8):      Biblioteka Qt5 WebEngine
12 Name:           qt5-%{orgname}
13 Version:        5.11.1
14 Release:        0.1
15 License:        LGPL v3 or GPL v2+ or commercial
16 Group:          X11/Libraries
17 Source0:        http://download.qt.io/official_releases/qt/5.11/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
18 # Source0-md5:  75d2ff31addba4ec41981b0f459cc587
19 Patch0:         remove-compiler-check.patch
20 Patch1:         chromium-66.0.3359.170-gcc8-alignof.patch
21 Patch2:         x32.patch
22 URL:            http://www.qt.io/
23 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
24 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
25 BuildRequires:  Qt5Network-devel >= %{qtbase_ver}
26 BuildRequires:  Qt5Qml-devel >= %{qtdeclarative_ver}
27 BuildRequires:  Qt5Quick-devel >= %{qtdeclarative_ver}
28 BuildRequires:  Qt5WebChannel-devel >= %{qtwebchannel_ver}
29 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
30 %if %{with doc}
31 BuildRequires:  qt5-assistant >= %{qttools_ver}
32 %endif
33 BuildRequires:  qt5-build >= %{qtbase_ver}
34 BuildRequires:  qt5-qmake >= %{qtbase_ver}
35 BuildRequires:  rpmbuild(macros) >= 1.654
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         specflags       -fno-strict-aliasing
41 %define         qt5dir          %{_libdir}/qt5
42
43 %description
44 Qt is a cross-platform application and UI framework. Using Qt, you can
45 write web-enabled applications once and deploy them across desktop,
46 mobile and embedded systems without rewriting the source code.
47
48 This package contains Qt5 WebEngine library.
49
50 %description -l pl.UTF-8
51 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
52 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
53 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
54 źródłowego.
55
56 Ten pakiet zawiera bibliotekę Qt5 WebEngine.
57
58 %package -n Qt5WebEngine
59 Summary:        The Qt5 WebEngine library
60 Summary(pl.UTF-8):      Biblioteka Qt5 WebEngine
61 Group:          Libraries
62 Requires:       Qt5Core >= %{qtbase_ver}
63 Requires:       Qt5Network >= %{qtbase_ver}
64 Requires:       Qt5Qml >= %{qtdeclarative_ver}
65
66 %description -n Qt5WebEngine
67 Qt5 WebEngine library provides seamless integration of C++ and QML
68 applications with HTML/JavaScript clients.
69
70 %description -n Qt5WebEngine -l pl.UTF-8
71 Biblioteka Qt5 WebEngine udostępnia integrację aplikacji C++ i QML z
72 klientami w HTML-u/JavaScripcie.
73
74 %package -n Qt5WebEngine-devel
75 Summary:        Qt5 WebEngine library - development files
76 Summary(pl.UTF-8):      Biblioteka Qt5 WebEngine - pliki programistyczne
77 Group:          Development/Libraries
78 Requires:       Qt5Core-devel >= %{qtbase_ver}
79 Requires:       Qt5Network-devel >= %{qtbase_ver}
80 Requires:       Qt5Qml-devel >= %{qtdeclarative_ver}
81 Requires:       Qt5WebEngine = %{version}-%{release}
82
83 %description -n Qt5WebEngine-devel
84 Qt5 WebEngine library - development files.
85
86 %description -n Qt5WebEngine-devel -l pl.UTF-8
87 Biblioteka Qt5 WebEngine - pliki programistyczne.
88
89 %package doc
90 Summary:        Qt5 WebEngine documentation in HTML format
91 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 WebEngine w formacie HTML
92 Group:          Documentation
93 Requires:       qt5-doc-common >= %{qtbase_ver}
94 %if "%{_rpmversion}" >= "5"
95 BuildArch:      noarch
96 %endif
97
98 %description doc
99 Qt5 WebEngine documentation in HTML format.
100
101 %description doc -l pl.UTF-8
102 Dokumentacja do biblioteki Qt5 WebEngine w formacie HTML.
103
104 %package doc-qch
105 Summary:        Qt5 WebEngine documentation in QCH format
106 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 WebEngine w formacie QCH
107 Group:          Documentation
108 Requires:       qt5-doc-common >= %{qtbase_ver}
109 %if "%{_rpmversion}" >= "5"
110 BuildArch:      noarch
111 %endif
112
113 %description doc-qch
114 Qt5 WebEngine documentation in QCH format.
115
116 %description doc-qch -l pl.UTF-8
117 Dokumentacja do biblioteki Qt5 WebEngine w formacie QCH.
118
119 %package examples
120 Summary:        Qt5 WebEngine examples
121 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 WebEngine
122 Group:          X11/Development/Libraries
123 %if "%{_rpmversion}" >= "5"
124 BuildArch:      noarch
125 %endif
126
127 %description examples
128 Qt5 WebEngine examples.
129
130 %description examples -l pl.UTF-8
131 Przykłady do biblioteki Qt5 WebEngine.
132
133 %prep
134 %setup -q -n %{orgname}-everywhere-src-%{version}
135 %patch0 -p1
136 %ifarch x32
137 %patch2 -p1
138 %endif
139 cd ./src/3rdparty/chromium
140 %patch1 -p1
141
142 %build
143 %ifarch x32
144 export V8_TARGET_ARCH="x32"
145 %endif
146 qmake-qt5
147 %{__make}
148 %{?with_doc:%{__make} docs}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 %{__make} install \
153         INSTALL_ROOT=$RPM_BUILD_ROOT
154
155 %if %{with doc}
156 %{__make} install_docs \
157         INSTALL_ROOT=$RPM_BUILD_ROOT
158 %endif
159
160 # useless symlinks
161 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
162 # actually drop *.la, follow policy of not packaging them when *.pc exist
163 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
164
165 # Prepare some files list
166 ifecho() {
167         r="$RPM_BUILD_ROOT$2"
168         if [ -d "$r" ]; then
169                 echo "%%dir $2" >> $1.files
170         elif [ -x "$r" ] ; then
171                 echo "%%attr(755,root,root) $2" >> $1.files
172         elif [ -f "$r" ]; then
173                 echo "$2" >> $1.files
174         else
175                 echo "Error generation $1 files list!"
176                 echo "$r: no such file or directory!"
177                 return 1
178         fi
179 }
180 ifecho_tree() {
181         ifecho $1 $2
182         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
183                 ifecho $1 $2/$f
184         done
185 }
186
187 echo "%defattr(644,root,root,755)" > examples.files
188 ifecho_tree examples %{_examplesdir}/qt5/webengine
189 ifecho_tree examples %{_examplesdir}/qt5/webenginewidgets
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %post   -n Qt5WebEngine -p /sbin/ldconfig
195 %postun -n Qt5WebEngine -p /sbin/ldconfig
196
197 %files -n Qt5WebEngine
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/libQt5WebEngine.so.*.*.*
200 %attr(755,root,root) %ghost %{_libdir}/libQt5WebEngine.so.5
201 %attr(755,root,root) %{_libdir}/libQt5WebEngineCore.so.*.*.*
202 %attr(755,root,root) %ghost %{_libdir}/libQt5WebEngineCore.so.5
203 %attr(755,root,root) %{_libdir}/libQt5WebEngineWidgets.so.*.*.*
204 %attr(755,root,root) %ghost %{_libdir}/libQt5WebEngineWidgets.so.5
205 %dir %{qt5dir}/qml/QtWebEngine
206 %{qt5dir}/qml/QtWebEngine/plugins.qmltypes
207 %{qt5dir}/qml/QtWebEngine/qmldir
208 %{qt5dir}/qml/QtWebEngine/Controls1Delegates
209 %{qt5dir}/qml/QtWebEngine/Controls2Delegates
210 %attr(755,root,root) %{qt5dir}/qml/QtWebEngine/libqtwebengineplugin.so
211 %dir %{_datadir}/qt5/resources
212 %{_datadir}/qt5/resources/icudtl.dat
213 %{_datadir}/qt5/resources/qtwebengine*.pak
214 %attr(755,root,root)  %{_libdir}/qt5/bin/qwebengine_convert_dict
215 %attr(755,root,root) %{_libdir}/qt5/libexec/QtWebEngineProcess
216 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/libqwebengineview.so
217
218 %files -n Qt5WebEngine-devel
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/libQt5WebEngine.so
221 %attr(755,root,root) %{_libdir}/libQt5WebEngineCore.so
222 %attr(755,root,root) %{_libdir}/libQt5WebEngineWidgets.so
223 %{_libdir}/libQt5WebEngine.prl
224 %{_libdir}/libQt5WebEngineCore.prl
225 %{_libdir}/libQt5WebEngineWidgets.prl
226 %{_includedir}/qt5/QtWebEngine
227 %{_includedir}/qt5/QtWebEngineCore
228 %{_includedir}/qt5/QtWebEngineWidgets
229 %{_pkgconfigdir}/Qt5WebEngine.pc
230 %{_pkgconfigdir}/Qt5WebEngineCore.pc
231 %{_pkgconfigdir}/Qt5WebEngineWidgets.pc
232 %{_libdir}/cmake/Qt5WebEngine
233 %{_libdir}/cmake/Qt5WebEngineCore
234 %{_libdir}/cmake/Qt5WebEngineWidgets
235 %{_libdir}/cmake/Qt5Designer/Qt5Designer_QWebEngineViewPlugin.cmake
236 %{qt5dir}/mkspecs/modules/qt_lib_webengine.pri
237 %{qt5dir}/mkspecs/modules/qt_lib_webengine_private.pri
238 %{_libdir}/qt5/mkspecs/modules/qt_lib_webenginecore.pri
239 %{_libdir}/qt5/mkspecs/modules/qt_lib_webenginecore_private.pri
240 %{_libdir}/qt5/mkspecs/modules/qt_lib_webenginecoreheaders_private.pri
241 %{_libdir}/qt5/mkspecs/modules/qt_lib_webenginewidgets.pri
242 %{_libdir}/qt5/mkspecs/modules/qt_lib_webenginewidgets_private.pri
243
244 %if %{with doc}
245 %files doc
246 %defattr(644,root,root,755)
247 %{_docdir}/qt5-doc/qtwebengine
248
249 %files doc-qch
250 %defattr(644,root,root,755)
251 %{_docdir}/qt5-doc/qtwebengine.qch
252 %endif
253
254 %files examples -f examples.files
255 %defattr(644,root,root,755)
256 # XXX: dir shared with qt5-qtbase-examples
257 %dir %{_examplesdir}/qt5
This page took 0.070001 seconds and 4 git commands to generate.