]> git.pld-linux.org Git - packages/qt5-qtconnectivity.git/blob - qt5-qtconnectivity.spec
- split into Qt5Bluetooth* and Qt5Nfc* (not related with each other)
[packages/qt5-qtconnectivity.git] / qt5-qtconnectivity.spec
1 #
2 # Conditional build:
3 %bcond_without  qch     # documentation in QCH format
4
5 %define         orgname         qtconnectivity
6 %define         qtbase_ver              %{version}
7 %define         qtdeclarative_ver       %{version}
8 %define         qttools_ver             %{version}
9 Summary:        The Qt5 Connectivity libraries
10 Summary(pl.UTF-8):      Biblioteki Qt5 Connectivity
11 Name:           qt5-%{orgname}
12 Version:        5.3.0
13 Release:        1
14 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
15 Group:          Libraries
16 Source0:        http://download.qt-project.org/official_releases/qt/5.3/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
17 # Source0-md5:  46e4e8df94b4da4415aa5f5076b8bc45
18 URL:            http://qt-project.org/
19 BuildRequires:  Qt5Concurrent-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
21 BuildRequires:  Qt5DBus-devel >= %{qtbase_ver}
22 BuildRequires:  Qt5Qml-devel >= %{qtdeclarative_ver}
23 BuildRequires:  bluez-libs-devel
24 %if %{with qch}
25 BuildRequires:  qt5-assistant >= %{qttools_ver}
26 %endif
27 BuildRequires:  qt5-build >= %{qtbase_ver}
28 BuildRequires:  qt5-qmake >= %{qtbase_ver}
29 BuildRequires:  rpmbuild(macros) >= 1.654
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         specflags       -fno-strict-aliasing
35 %define         qt5dir          %{_libdir}/qt5
36
37 %description
38 Qt is a cross-platform application and UI framework. Using Qt, you can
39 write web-enabled applications once and deploy them across desktop,
40 mobile and embedded systems without rewriting the source code.
41
42 This package contains Qt5 Connectivity libraries: Qt5Bluetooth and
43 QtNfc.
44
45 %description -l pl.UTF-8
46 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
47 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
48 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
49 źródłowego.
50
51 Ten pakiet zawiera biblioteki Qt5 Connectivity: Qt5Bluetooth i Qt5Nfc.
52
53 %package -n Qt5Bluetooth
54 Summary:        Qt5 Bluetooth library
55 Summary(pl.UTF-8):      Biblioteka Qt5 Bluetooth
56 Group:          Libraries
57 Requires:       Qt5Core >= %{qtbase_ver}
58 Requires:       Qt5DBus >= %{qtbase_ver}
59 Requires:       Qt5Qml >= %{qtdeclarative_ver}
60 Obsoletes:      qt5-qtconnectivity
61
62 %description -n Qt5Bluetooth
63 Qt5 Bluetooth library provides classes that enable basic Bluetooth
64 operations like scanning for devices and connecting them.
65
66 %description -n Qt5Bluetooth -l pl.UTF-8
67 Biblioteka Qt5 Bluetooth dostarcza klasy umożliwiające podstawowe
68 operacje Bluetooth, takie jak wyszukiwanie urządzeń i łączenie z nimi.
69
70 %package -n Qt5Bluetooth-devel
71 Summary:        The Qt5 Bluetooth - development files
72 Summary(pl.UTF-8):      Biblioteka Qt5 Bluetooth - pliki programistyczne
73 Group:          Development/Libraries
74 Requires:       Qt5Bluetooth = %{version}-%{release}
75 Requires:       Qt5Core-devel >= %{qtbase_ver}
76 Requires:       Qt5DBus-devel >= %{qtbase_ver}
77 Requires:       Qt5Qml-devel >= %{qtdeclarative_ver}
78 Obsoletes:      qt5-qtconnectivity-devel
79
80 %description -n Qt5Bluetooth-devel
81 The Qt5 Bluetooth - development files.
82
83 %description -n Qt5Bluetooth-devel -l pl.UTF-8
84 Biblioteka Qt5 Bluetooth - pliki programistyczne.
85
86 %package -n Qt5Nfc
87 Summary:        Qt5 Nfc library
88 Summary(pl.UTF-8):      Biblioteka Qt5 Nfc
89 Group:          Libraries
90 Requires:       Qt5Core >= %{qtbase_ver}
91 Requires:       Qt5DBus >= %{qtbase_ver}
92 Requires:       Qt5Qml >= %{qtdeclarative_ver}
93 Obsoletes:      qt5-qtconnectivity
94
95 %description -n Qt5Nfc
96 Qt5 Nfc library provides classes to access NFC Forum Tags.
97
98 %description -n Qt5Nfc -l pl.UTF-8
99 Biblioteka Qt5 Nfc dostarcza klasy służace do dostępu do urządzeń NFC
100 Forum.
101
102 %package -n Qt5Nfc-devel
103 Summary:        The Qt5 Nfc - development files
104 Summary(pl.UTF-8):      Biblioteka Qt5 Nfc - pliki programistyczne
105 Group:          Development/Libraries
106 Requires:       Qt5Nfc = %{version}-%{release}
107 Requires:       Qt5Core-devel >= %{qtbase_ver}
108 Requires:       Qt5DBus-devel >= %{qtbase_ver}
109 Requires:       Qt5Qml-devel >= %{qtdeclarative_ver}
110 Obsoletes:      qt5-qtconnectivity-devel
111
112 %description -n Qt5Nfc-devel
113 The Qt5 Nfc - development files.
114
115 %description -n Qt5Nfc-devel -l pl.UTF-8
116 Biblioteka Qt5 Nfc - pliki programistyczne.
117
118 %package doc
119 Summary:        Qt5 Connectivity documentation in HTML format
120 Summary(pl.UTF-8):      Dokumentacja do bibliotek Qt5 Connectivity w formacie HTML
121 Group:          Documentation
122 Requires:       qt5-doc-common >= %{qtbase_ver}
123 %if "%{_rpmversion}" >= "5"
124 BuildArch:      noarch
125 %endif
126
127 %description doc
128 Qt5 Connectivity documentation in HTML format.
129
130 %description doc -l pl.UTF-8
131 Dokumentacja do bibliotek Qt5 Connectivity w formacie HTML.
132
133 %package doc-qch
134 Summary:        Qt5 Connectivity documentation in QCH format
135 Summary(pl.UTF-8):      Dokumentacja do bibliotek Qt5 Connectivity w formacie QCH
136 Group:          Documentation
137 Requires:       qt5-doc-common >= %{qtbase_ver}
138 %if "%{_rpmversion}" >= "5"
139 BuildArch:      noarch
140 %endif
141
142 %description doc-qch
143 Qt5 Connectivity documentation in QCH format.
144
145 %description doc-qch -l pl.UTF-8
146 Dokumentacja do bibliotek Qt5 Connectivity w formacie QCH.
147
148 %package examples
149 Summary:        Qt5 Connectivity examples
150 Summary(pl.UTF-8):      Przykłady do bibliotek Qt5 Connectivity
151 Group:          X11/Development/Libraries
152 %if "%{_rpmversion}" >= "5"
153 BuildArch:      noarch
154 %endif
155
156 %description examples
157 Qt5 Connectivity examples.
158
159 %description examples -l pl.UTF-8
160 Przykłady do bibliotek Qt5 Connectivity.
161
162 %prep
163 %setup -q -n %{orgname}-opensource-src-%{version}
164
165 %build
166 qmake-qt5
167 %{__make}
168 %{__make} %{!?with_qch:html_}docs
169
170 %install
171 rm -rf $RPM_BUILD_ROOT
172 %{__make} install \
173         INSTALL_ROOT=$RPM_BUILD_ROOT
174
175 %{__make} install_%{!?with_qch:html_}docs \
176         INSTALL_ROOT=$RPM_BUILD_ROOT
177
178 # useless symlinks
179 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
180 # actually drop *.la, follow policy of not packaging them when *.pc exist
181 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
182
183 # Prepare some files list
184 ifecho() {
185         r="$RPM_BUILD_ROOT$2"
186         if [ -d "$r" ]; then
187                 echo "%%dir $2" >> $1.files
188         elif [ -x "$r" ] ; then
189                 echo "%%attr(755,root,root) $2" >> $1.files
190         elif [ -f "$r" ]; then
191                 echo "$2" >> $1.files
192         else
193                 echo "Error generation $1 files list!"
194                 echo "$r: no such file or directory!"
195                 return 1
196         fi
197 }
198 ifecho_tree() {
199         ifecho $1 $2
200         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
201                 ifecho $1 $2/$f
202         done
203 }
204
205 echo "%defattr(644,root,root,755)" > examples.files
206 ifecho_tree examples %{_examplesdir}/qt5/bluetooth
207 ifecho_tree examples %{_examplesdir}/qt5/nfc
208
209 %clean
210 rm -rf $RPM_BUILD_ROOT
211
212 %post   -n Qt5Bluetooth -p /sbin/ldconfig
213 %postun -n Qt5Bluetooth -p /sbin/ldconfig
214
215 %post   -n Qt5Nfc -p /sbin/ldconfig
216 %postun -n Qt5Nfc -p /sbin/ldconfig
217
218 %files -n Qt5Bluetooth
219 %defattr(644,root,root,755)
220 %doc LGPL_EXCEPTION.txt dist/changes-*
221 %attr(755,root,root) %{_libdir}/libQt5Bluetooth.so.*.*.*
222 %attr(755,root,root) %ghost %{_libdir}/libQt5Bluetooth.so.5
223 %dir %{qt5dir}/qml/QtBluetooth
224 %attr(755,root,root) %{qt5dir}/qml/QtBluetooth/libdeclarative_bluetooth.so
225 %{qt5dir}/qml/QtBluetooth/plugins.qmltypes
226 %{qt5dir}/qml/QtBluetooth/qmldir
227
228 %files -n Qt5Bluetooth-devel
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_libdir}/libQt5Bluetooth.so
231 %{_libdir}/libQt5Bluetooth.prl
232 %{_includedir}/qt5/QtBluetooth
233 %{_pkgconfigdir}/Qt5Bluetooth.pc
234 %{_libdir}/cmake/Qt5Bluetooth
235 %{qt5dir}/mkspecs/modules/qt_lib_bluetooth.pri
236 %{qt5dir}/mkspecs/modules/qt_lib_bluetooth_private.pri
237
238 %files -n Qt5Nfc
239 %defattr(644,root,root,755)
240 %doc LGPL_EXCEPTION.txt dist/changes-*
241 %attr(755,root,root) %{_libdir}/libQt5Nfc.so.*.*.*
242 %attr(755,root,root) %ghost %{_libdir}/libQt5Nfc.so.5
243 %dir %{qt5dir}/qml/QtNfc
244 %attr(755,root,root) %{qt5dir}/qml/QtNfc/libdeclarative_nfc.so
245 %{qt5dir}/qml/QtNfc/plugins.qmltypes
246 %{qt5dir}/qml/QtNfc/qmldir
247
248 %files -n Qt5Nfc-devel
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_libdir}/libQt5Nfc.so
251 %{_libdir}/libQt5Nfc.prl
252 %{_includedir}/qt5/QtNfc
253 %{_pkgconfigdir}/Qt5Nfc.pc
254 %{_libdir}/cmake/Qt5Nfc
255 %{qt5dir}/mkspecs/modules/qt_lib_nfc.pri
256 %{qt5dir}/mkspecs/modules/qt_lib_nfc_private.pri
257
258 %files doc
259 %defattr(644,root,root,755)
260 %{_docdir}/qt5-doc/qtbluetooth
261 %{_docdir}/qt5-doc/qtnfc
262
263 %if %{with qch}
264 %files doc-qch
265 %defattr(644,root,root,755)
266 %{_docdir}/qt5-doc/qtbluetooth.qch
267 %{_docdir}/qt5-doc/qtnfc.qch
268 %endif
269
270 %files examples -f examples.files
271 %defattr(644,root,root,755)
272 # XXX: dir shared with qt5-qtbase-examples
273 %dir %{_examplesdir}/qt5
This page took 0.068509 seconds and 4 git commands to generate.