]> git.pld-linux.org Git - packages/qt4.git/blob - qt4.spec
- cosmetics, tabs, %%attr.
[packages/qt4.git] / qt4.spec
1 #
2 # TODO:
3 #               - better descriptions
4 #
5 # Conditional build:
6 %bcond_with     nas             # enable NAS audio support
7 # static libs disabled for now
8 %bcond_with     static_libs     # don't build static libraries
9 %bcond_without  cups            # disable CUPS support
10 %bcond_without  mysql           # don't build MySQL plugin
11 %bcond_without  odbc            # don't build unixODBC plugin
12 %bcond_without  pgsql           # don't build PostgreSQL plugin
13 %bcond_without  designer        # don't build designer (it takes long)
14 %bcond_without  sqlite3         # don't build SQLite3 plugin
15 %bcond_without  sqlite          # don't build SQLite2 plugin
16 %bcond_without  ibase           # build ibase (InterBase/Firebird) plugin
17 %bcond_without  pch             # enable pch in qmake
18 %bcond_with     dont_enable     # blocks translations, they are not yeat available
19
20 %undefine       with_dont_enable
21
22 %ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
23 %undefine       with_ibase
24 %endif
25 %define         _withsql        1
26 %{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%undefine _withsql}}}}}}
27
28 %define         _snap           050513
29 %define         _ver            4.0.0
30 %define         _packager       djurban
31
32 Summary:        The Qt GUI application framework
33 Summary(es):    Biblioteca para ejecutar aplicaciones GUI Qt
34 Summary(pl):    Biblioteka Qt do tworzenia GUI
35 Summary(pt_BR): Estrutura para rodar aplicações GUI Qt
36 Name:           qt4
37 Version:        %{_ver}
38 Release:        1.%{_snap}.0.1
39 License:        GPL/QPL
40 Group:          X11/Libraries
41 Source0:        http://ep09.pld-linux.org/~%{_packager}/kde/qt-copy-%{_snap}.tar.bz2
42 #Source0:       http://wftp.tu-chemnitz.de/pub/Qt/source//%{_name}-x11-opensource-%{version}-b1.tar.bz2
43 # Source0-md5:  df41290b627b28dc00991bf1e0f7a440
44 #Source1:       http://ep09.pld-linux.org/~%{_packager}/kde/%{_name}-copy-patches-040531.tar.bz2
45 #Source1-md5    2e38e44b6ef26bfb8a7f3b6900ee53c0
46 Source2:        qtconfig.desktop
47 Source3:        designer.desktop
48 Source4:        assistant.desktop
49 Source5:        linguist.desktop
50 Patch0:         %{name}-tools.patch
51 %if %{with dont_enable}
52 Patch1:         qt-FHS.patch
53 # no tutorials exist
54 Patch3:         qt-disable_tutorials.patch
55 %endif
56 Patch2:         %{name}-buildsystem.patch
57 Patch4:         %{name}-locale.patch
58 Patch8:         %{name}-antialias.patch
59 URL:            http://www.trolltech.com/products/qt/
60 Icon:           qt.xpm
61 %{?with_ibase:BuildRequires:    Firebird-devel}
62 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
63 BuildRequires:  OpenGL-devel
64 # incompatible with bison
65 BuildRequires:  byacc
66 %{?with_cups:BuildRequires:     cups-devel}
67 BuildRequires:  flex
68 BuildRequires:  freetype-devel >= 2.0.0
69 %{?with_pch:BuildRequires:      gcc >= 5:3.4.0}
70 BuildRequires:  libjpeg-devel
71 BuildRequires:  libmng-devel >= 1.0.0
72 BuildRequires:  libpng-devel >= 1.0.8
73 BuildRequires:  libstdc++-devel
74 BuildRequires:  libungif-devel
75 %{?with_mysql:BuildRequires:    mysql-devel}
76 %{?with_nas:BuildRequires:      nas-devel}
77 BuildRequires:  perl-base
78 %{?with_pgsql:BuildRequires:    postgresql-backend-devel}
79 %{?with_pgsql:BuildRequires:    postgresql-devel}
80 # uncomment this in rel. 1 - no time to upgrade rpm
81 #BuildRequires: rpmbuild(macros) >= 1.213
82 BuildRequires:  sed >= 4.0
83 %{?with_odbc:BuildRequires:     unixODBC-devel}
84 %{?with_sqlite:BuildRequires:   sqlite-devel}
85 BuildRequires:  xcursor-devel
86 BuildRequires:  xft-devel
87 BuildRequires:  xrender-devel
88 BuildRequires:  zlib-devel
89 Requires:       OpenGL
90 Conflicts:      kdelibs <= 8:3.2-0.030602.1
91 Obsoletes:      qt-extensions
92 Obsoletes:      qt-utils
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
96 %define         _noautostrip    '.*_debug\.so*'
97
98 %description
99 Qt is a complete C++ application development framework, which includes
100 a class library and tools for multiplatform development and
101 internationalization. Using Qt, a single source code tree can build
102 applications that run natively on different platforms (Windows,
103 Unix/Linux, Mac OS X, embedded Linux).
104
105 Qt has a rich set of standard widgets, and lets you write custom
106 controls. It encapsulates four different platform-specific APIs, and
107 the APIs for file-handling, networking, process-handling, threading,
108 database access, etc. Qt now also has Motif migration oraz Netscape
109 LiveConnect plugin.
110
111 %description -l es
112 Contiene las bibliotecas compartidas necesarias para ejecutar
113 aplicaciones Qt, bien como los archivos README.
114
115 %description -l pl
116 Qt oferuje kompletny system do tworzenia i rozwijania aplikacji w
117 jêzyku C++, w którego sk³ad wchodzi biblioteka z klasami oraz
118 wieloplatformowymi narzêdziami do rozwijania i t³umaczenia aplikacji.
119 Z pomoc± Qt jeden kod ¼ród³owy mo¿e byæ natywnie uruchamiany na
120 ró¿nych platformach (Windows, Unix/Linux, Mac OS X).
121
122 Qt ma bogaty zbiór standardowych elementów interfejsu graficznego, ale
123 pozwala równie¿ na pisanie w³asnych elementów. £±czy w sposób
124 niewidoczny dla programisty interfejsy programowania ró¿nych systemów,
125 tworz±c w ten sposób jeden interfejs dla obs³ugi plików, sieci,
126 procesów, w±tków, baz danych itp. Umo¿liwia tak¿e ³atwe przenoszenie
127 na Qt aplikacji korzystaj±cych z Motif oraz pisanie wtyczek z
128 wykorzystaniem Netscape LiveConnect.
129
130 %package -n QtCore
131 Summary:        Core classes used by other modules
132 Group:          X11/Development/Libraries
133
134 %description -n QtCore
135 Core classes used by other modules.
136
137 %package -n QtCore-devel
138 Summary:        Core classes used by other modules
139 Group:          X11/Development/Libraries
140 Requires:       QtCore >= %{epoch}:%{version}-%{release}
141
142 %description -n QtCore-devel
143 Core classes used by other modules.
144
145 %package -n QtGui
146 Summary:        Graphical User Interface components
147 Group:          X11/Development/Libraries
148 Requires:       QtCore >= %{epoch}:%{version}-%{release}
149
150 %description -n QtGui
151 Graphical User Interface components.
152
153 %package -n QtGui-devel
154 Summary:        Graphical User Interface components
155 Group:          X11/Development/Libraries
156 Requires:       QtCore-devel >= %{epoch}:%{version}-%{release}
157
158 %description -n QtGui-devel
159 Graphical User Interface components.
160
161 %package -n QtNetwork
162 Summary:        Classes for network programming
163 Group:          X11/Development/Libraries
164 Requires:       QtCore >= %{epoch}:%{version}-%{release}
165
166 %description -n QtNetwork
167 Classes for network programming.
168
169 %package -n QtNetwork-devel
170 Summary:        Classes for network programming
171 Group:          X11/Development/Libraries
172 Requires:       QtCore-devel >= %{epoch}:%{version}-%{release}
173
174 %description -n QtNetwork-devel
175 Classes for network programming.
176
177 %package -n QtOpenGL
178 Summary:        OpenGL support classes
179 Group:          X11/Development/Libraries
180 Requires:       QtCore >= %{epoch}:%{version}-%{release}
181
182 %description -n QtOpenGL
183 OpenGL support classes.
184
185 %package -n QtOpenGL-devel
186 Summary:        OpenGL support classes
187 Group:          X11/Development/Libraries
188 Requires:       QtCore-devel >= %{epoch}:%{version}-%{release}
189
190 %description -n QtOpenGL-devel
191 OpenGL support classes.
192
193 %package -n QtSql
194 Summary:        Classes for database integration using SQL
195 Group:          X11/Development/Libraries
196 Requires:       QtCore >= %{epoch}:%{version}-%{release}
197
198 %description -n QtSql
199 Classes for database integration using SQL.
200
201 %package -n QtSql-devel
202 Summary:        Classes for database integration using SQL
203 Group:          X11/Development/Libraries
204 Requires:       QtCore-devel >= %{epoch}:%{version}-%{release}
205
206 %description -n QtSql-devel
207 Classes for database integration using SQL.
208
209 %package -n QtSql-ibase
210 Summary:        Database plugin for InterBase/Firebird Qt support
211 Summary(pl):    Wtyczka InterBase/Firebird do Qt
212 Summary(pt_BR): Plugin de suporte a InterBase/Firebird para Qt
213 Group:          X11/Development/Libraries
214 Provides:       QtSql-backend = %{epoch}:%{version}-%{release}
215 Requires:       QtSql >= %{epoch}:%{version}-%{release}
216
217 %description -n QtSql-ibase
218 This package contains a plugin for accessing Interbase/Firebird
219 database via the QSql classes.
220
221 %description -n QtSql-ibase -l pl
222 Ten pakiet zawiera wtyczki do Qt umo¿liwiaj±ce korzystanie z baz
223 danych Interbase/Firebird poprzez klasy QSql.
224
225 %description -n QtSql-ibase -l pt_BR
226 Plugin de suporte a InterBase/Firebird para Qt.
227
228 %package -n QtSql-mysql
229 Summary:        Database plugin for MySQL Qt support
230 Summary(pl):    Wtyczka MySQL do Qt
231 Summary(pt_BR): Plugin de suporte a MySQL para Qt
232 Group:          X11/Development/Libraries
233 Provides:       QtSql-backend = %{epoch}:%{version}-%{release}
234 Requires:       QtSql >= %{epoch}:%{version}-%{release}
235
236 %description -n QtSql-mysql
237 This package contains a plugin for accessing MySQL database via the
238 QSql classes.
239
240 %description -n QtSql-mysql -l pl
241 Ten pakiet zawiera wtyczki do Qt umo¿liwiaj±ce korzystanie z baz
242 danych MySQL poprzez klasy QSql.
243
244 %description -n QtSql-mysql -l pt_BR
245 Plugin de suporte a MySQL para Qt.
246
247 %package -n QtSql-odbc
248 Summary:        Database plugin for ODBC Qt support
249 Summary(pl):    Wtyczka ODBC do Qt
250 Summary(pt_BR): Plugin de suporte a ODBC para Qt
251 Group:          X11/Development/Libraries
252 Provides:       QtSql-backend = %{epoch}:%{version}-%{release}
253 Requires:       QtSql >= %{epoch}:%{version}-%{release}
254
255 %description -n QtSql-odbc
256 This package contains a plugin for accessing unixODBC services via the
257 QSql classes.
258
259 %description -n QtSql-odbc -l pl
260 Ten pakiet zawiera wtyczki do Qt umo¿liwiaj±ce korzystanie z us³ug
261 unixODBC poprzez klasy QSql.
262
263 %description -n QtSql-odbc -l pt_BR
264 Plugin de suporte a ODBC para Qt.
265
266 %package -n QtSql-pgsql
267 Summary:        Database plugin for PostgreSQL Qt support
268 Summary(pl):    Wtyczka PostgreSQL do Qt
269 Summary(pt_BR): Plugin de suporte a PostgreSQL para Qt
270 Group:          X11/Development/Libraries
271 Provides:       QtSql-backend = %{epoch}:%{version}-%{release}
272 Requires:       QtSql >= %{epoch}:%{version}-%{release}
273
274 %description -n QtSql-pgsql
275 This package contains a plugin for accessing PostgreSQL database via
276 the QSql classes.
277
278 %description -n QtSql-pgsql -l pl
279 Ten pakiet zawiera wtyczki do Qt umo¿liwiaj±ce korzystanie z baz
280 danych PostgreSQL poprzez klasy QSql.
281
282 %description -n QtSql-pgsql -l es
283 Plugin de suporte a PostgreSQL para Qt.
284
285 %package -n QtSql-sqlite
286 Summary:        QtSql sqlite plugin
287 Summary:        Database plugin for SQLite Qt support
288 Summary(pl):    Wtyczka SQLite do Qt
289 Summary(pt_BR): Plugin de suporte a SQLite para Qt
290 Group:          X11/Development/Libraries
291 Provides:       QtSql-backend = %{epoch}:%{version}-%{release}
292 Requires:       QtSql >= %{epoch}:%{version}-%{release}
293
294 %description -n QtSql-sqlite
295 This package contains a plugin for using the SQLite library (which
296 allows to acces virtually any SQL database) via the QSql classes.
297
298 %description -n QtSql-sqlite -l pl
299 Ten pakiet zawiera wtyczki do Qt umo¿liwiaj±ce korzystanie z baz
300 danych SQLite poprzez klasy QSql.
301
302 %description -n QtSql-sqlite -l pt_BR
303 Plugin de suporte a SQLite para Qt.
304
305 %package -n QtSql-sqlite3
306 Summary:        Database plugin for SQLite3 Qt support
307 Summary(pl):    Wtyczka SQLite3 do Qt
308 Summary(pt_BR): Plugin de suporte a SQLite3 para Qt
309 Group:          X11/Development/Libraries
310 Provides:       QtSql-backend = %{epoch}:%{version}-%{release}
311 Requires:       QtSql >= %{epoch}:%{version}-%{release}
312
313 %description -n QtSql-sqlite3
314 This package contains a plugin for using the SQLite3 library (which
315 allows to acces virtually any SQL database) via the QSql classes.
316
317 %description -n QtSql-sqlite3 -l pl
318 Ten pakiet zawiera wtyczki do Qt umo¿liwiaj±ce korzystanie z baz
319 danych SQLite3 poprzez klasy QSql.
320
321 %description -n QtSql-sqlite3 -l pt_BR
322 Plugin de suporte a SQLite3 para Qt.
323
324 %package -n QtXml
325 Summary:        Classes for handling XML
326 Group:          X11/Development/Libraries
327 Requires:       QtCore >= %{epoch}:%{version}-%{release}
328
329 %description -n QtXml
330 Classes for handling XML.
331
332 %package -n QtXml-devel
333 Summary:        Classes for handling XML
334 Group:          X11/Development/Libraries
335 Requires:       QtCore-devel >= %{epoch}:%{version}-%{release}
336
337 %description -n QtXml-devel
338 Classes for handling XML.
339
340 %package -n Qt3Support
341 Summary:        Qt3 compat library
342 Group:          X11/Development/Libraries
343 Requires:       QtCore >= %{epoch}:%{version}-%{release}
344
345 %description -n Qt3Support
346 Qt3 compat library.
347
348 %package -n Qt3Support-devel
349 Summary:        Qt3 compat library
350 Group:          X11/Development/Libraries
351 Requires:       QtCore-devel >= %{epoch}:%{version}-%{release}
352
353 %description -n Qt3Support-devel
354 Qt3 compat library.
355
356 %package assistant
357 Summary:        Qt documentation browser
358 Summary(pl):    Przegl±darka dokumentacji Qt
359 Group:          X11/Development/Tools
360 Requires:       %{name}-doc
361
362 %description assistant
363 Qt Assistant is a tool for browsing on-line documentation with
364 indexing, bookmarks and full-text search.
365
366 %description assistant -l pl
367 Qt Assistant to narzêdzie do przegl±dania dokumentacji z mo¿liwo¶ci±
368 indeksowania, dodawania zak³adek i pe³notekstowego wyszukiwania.
369
370 %package build
371 Summary:        Build tools for Qt4
372 Group:          X11/Development/Libraries
373 Requires:       QtCore >= %{epoch}:%{version}-%{release}
374 Requires:       QtXml >= %{epoch}:%{version}-%{release}
375
376 %description build
377 This package includes the Qt resource compiler (rcc), meta objects
378 compiler (moc), user interface compiler (uic) and qt3to4 include names
379 converter.
380
381 %package designer
382 Summary:        IDE used for GUI designing with Qt library
383 Summary(pl):    IDE s³u¿±ce do projektowania GUI za pomoc± biblioteki Qt
384 Group:          X11/Applications
385 Requires:       %{name}-designer-libs = %{epoch}:%{version}-%{release}
386
387 %description designer
388 An advanced tool used for GUI designing with Qt library.
389
390 %description designer -l pl
391 Zaawansowane narzêdzie s³u¿±ce do projektowania interfejsu graficznego
392 za pomoc± biblioteki Qt.
393
394 %package designer-libs
395 Summary:        Libraries IDE used for GUI designing with Qt library
396 Summary(pl):    Biblioteki do IDE s³u¿±cego do projektowania GUI za pomoc± biblioteki Qt
397 Group:          X11/Applications
398
399 %description designer-libs
400 Libraries used by the Qt GUI Designer.
401
402 %description designer-libs -l pl
403 Biblioteki wykorzystywane przez narzêdzie projektowania interfejsu
404 graficznego - Qt Designer.
405
406 %package linguist
407 Summary:        Translation helper for Qt
408 Summary(pl):    Aplikacja u³atwiaj±ca t³umaczenie aplikacji oparty o Qt
409 Group:          X11/Development/Tools
410
411 %description linguist
412 This program provides an interface that shortens and helps systematize
413 the process of translating GUIs. Qt Linguist takes all of the text of
414 a UI that will be shown to the user, and presents it to a human
415 translator in a simple window. When one UI text is translated, the
416 program automatically progresses to the next, until they are all
417 completed.
418
419 %description linguist -l pl
420 Ten program oferuje interfejs znacznie przy¶pieszaj±cy proces
421 t³umaczenia interfejsu u¿ytkownika. Zbiera wszystkie teksty
422 przeznaczone do t³umaczenia i przedstawia w ³atwym w obs³udze oknie.
423 Gdy jeden z nich jest ju¿ przet³umaczony, automatycznie przechodzi do
424 nastêpnego, a¿ wszystkie bêd± przet³umaczone.
425
426 %package -n qmake
427 Summary:        Qt makefile generator
428 Summary(pl):    Generator plików makefile dla aplikacji Qt
429 Group:          X11/Development/Tools
430
431 %description -n qmake
432 A powerful makefile generator. It can create makefiles on any platform
433 from a simple .pro definitions file.
434
435 %description -n qmake -l pl
436 Rozbudowany generator plików makefile. Potrafi tworzyæ pliki makefile
437 na ka¿dej platformi na podstawie ³atwego w przygotowaniu pliku .pro.
438
439 %package -n qtconfig
440 Summary:        Qt widgets configuration tool
441 Summary(pl):    Narzêdzie do konfigurowania widgetów Qt
442 Group:          X11/Applications
443
444 %description -n qtconfig
445 A tool for configuring look and behavior of Qt widgets.
446
447 %description -n qtconfig -l pl
448 Narzêdie do konfiguracji wygl±du i zachowania widgetów Qt.
449
450 %package -n qvfb
451 Summary:        Qt Virtual framebuffer
452 Group:          X11/Development/Libraries
453
454 %description -n qvfb
455 Qt Virtual framebuffer alllows you to run Qt/Embedded applications in
456 XWindow.
457
458 %package demos
459 Summary:        Demos of new qt4 features
460 Group:          X11/Development/Libraries
461 Requires:       QtCore >= %{epoch}:%{version}-%{release}
462 Requires:       QtXml >= %{epoch}:%{version}-%{release}
463
464 %description demos
465 Demos are spiders that fly.
466
467 %package doc
468 Summary:        Qt Documentation in HTML format
469 Summary(pl):    Dokumentacja Qt w formacie HTML
470 Group:          X11/Development/Libraries
471
472 %description doc
473 Qt documentation in HTML format.
474
475 %description doc -l pl
476 Dokumentacja qt w formacie HTML.
477
478 %package man
479 Summary:        Qt man pages
480 Summary(pl):    Qt - strony man
481 Group:          X11/Development/Libraries
482
483 %description man
484 Qt documentation in man pages format.
485
486 %description man -l pl
487 Dokumentacja qt w formacie stron man.
488
489 %package examples
490 Summary:        Example programs bundled with Qt
491 Summary(pl):    Æwiczenia i przyk³ady do Qt
492 Summary(pt_BR): Programas exemplo desenvolvidos com o Qt
493 Group:          X11/Development/Libraries
494 # no it does not , we cant be sure the user wants to compile them right?
495 # he might just want to take a look, anwyay no single devel package now
496 #Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
497
498 %description examples
499 Example programs bundled with Qt version.
500
501 %description examples -l pl
502 Æwiczenia/przyk³ady do³±czone do Qt.
503
504 %description examples -l pt_BR
505 Programas exemplo para o Qt versão.
506
507 %prep
508 #setup -q -n %{_name}-copy-%{_snap}
509 %setup -q -n qt-copy
510 %patch0 -p1
511 %if %{with dont_enable}
512 %patch1 -p1
513 %patch3 -p1
514 %endif
515 %patch2 -p1 -b .niedakh
516 %patch4 -p1 -b .niedakh
517 #patch7 -p1 -b .niedakh
518 %patch8 -p1 -b .niedakh
519
520 #cat >> patches/DISABLED <<EOF
521 #0005
522 #0039
523 #0042
524 #0043
525 #0047
526 #EOF
527 #./apply_patches
528
529 # change QMAKE_CFLAGS_RELEASE to build
530 # properly optimized libs
531 plik="mkspecs/linux-g++/qmake.conf"
532
533 perl -pi -e "
534         s|/usr/X11R6/lib|/usr/X11R6/%{_lib}|;
535         s|/usr/lib|%{_libdir}|;
536         s|\\(QTDIR\\)/lib|\\(QTDIR\\)/%{_lib}|;
537         " $plik
538
539 cat $plik \
540         |grep -v QMAKE_CFLAGS_RELEASE \
541         |grep -v QMAKE_CXXFLAGS_RELEASE \
542         |grep -v QMAKE_CFLAGS_DEBUG \
543         |grep -v QMAKE_CXXFLAGS_DEBUG \
544         > $plik.1
545
546 mv $plik.1 $plik
547 echo >> $plik
548 echo -e "QMAKE_CFLAGS_RELEASE\t=\t%{rpmcflags}" >> $plik
549 echo -e "QMAKE_CXXFLAGS_RELEASE\t=\t%{rpmcflags}" >> $plik
550 echo -e "QMAKE_CFLAGS_DEBUG\t=\t%{debugcflags}" >> $plik
551 echo -e "QMAKE_CXXFLAGS_DEBUG\t=\t%{debugcflags}" >> $plik
552
553 %build
554 export QTDIR=`/bin/pwd`
555 export YACC='byacc -d'
556 export PATH=$QTDIR/bin:$PATH
557 if test -n "$LD_LIBRARY_PATH"; then
558 export LD_LIBRARY_PATH=$QTDIR/%{_lib}:$LD_LIBRARY_PATH
559 else
560 export LD_LIBRARY_PATH=$QTDIR/lib
561 fi
562
563 export QMAKESPEC=$QTDIR/mkspecs/linux-g++
564
565 if [ "%{_lib}" != "lib" ] ; then
566         ln -s lib "%{_lib}"
567 fi
568
569 # pass OPTFLAGS to build qmake itself with optimization
570 export OPTFLAGS="%{rpmcflags}"
571
572 #%{__make} -f Makefile.cvs
573
574 ##################################
575 # DEFAULT OPTIONS FOR ALL BUILDS #
576 ##################################
577
578 DEFAULTOPT=" \
579         -DQT_CLEAN_NAMESPACE \
580         -DQT_COMPAT \
581         -verbose \
582         -prefix %{_prefix} \
583         -libdir %{_libdir} \
584         -headerdir %{_includedir}/qt \
585         -datadir %{_datadir}/qt \
586         -docdir %{_docdir}/%{name}-doc \
587         -sysconfdir %{_sysconfdir}/qt \
588         -translationdir %{_datadir}/locale/ \
589         -fast \
590         -%{!?with_pch:no-}pch \
591         -qt-gif \
592         -system-libjpeg \
593         -system-libpng \
594         -system-zlib \
595         -no-exceptions \
596         -I%{_includedir}/postgresql/server \
597         -I%{_includedir}/mysql \
598         %{!?with_cups:-no-cups} \
599         %{?with_nas:-system-nas-sound} \
600         %{?with_nvidia:-dlopen-opengl} \
601         %{?with_pch:-pch} \
602         %{?debug:-debug} \
603         -xcursor \
604         -xshape \
605         -xrender \
606         -fontconfig \
607         -xkb \
608         -sm \
609         -nis"
610
611 ##################################
612 #      STATIC MULTI-THREAD       #
613 ##################################
614
615 %if %{with static_libs}
616 STATICOPT=" \
617         %{?with_mysql:-qt-sql-mysql} \
618         %{?with_odbc:-qt-sql-odbc} \
619         %{?with_pgsql:-qt-sql-psql} \
620         %{?with_sqlite3:-qt-sql-sqlite} \
621         %{?with_sqlite:-qt-sql-sqlite2} \
622         %{?with_ibase:-qt-sql-ibase} \
623         -static"
624
625 ./configure \
626         $DEFAULTOPT \
627         $STATICOPT \
628         <<_EOF_
629 yes
630 _EOF_
631
632 # Do not build tutorial and examples. Provide them as sources.
633 %{__make} sub-qmake sub-src
634
635 # This will not remove previously compiled libraries.
636 %{__make} clean
637 %endif
638
639 ##################################
640 #      SHARED MULTI-THREAD       #
641 ##################################
642
643 SHAREDOPT=" \
644         %{?with_mysql:-plugin-sql-mysql} \
645         %{?with_odbc:-plugin-sql-odbc} \
646         %{?with_pgsql:-plugin-sql-psql} \
647         %{?with_sqlite3:-plugin-sql-sqlite} \
648         %{?with_sqlite:-plugin-sql-sqlite2} \
649         %{?with_ibase:-plugin-sql-ibase}"
650
651 ./configure \
652         $DEFAULTOPT \
653         $SHAREDOPT \
654         -plugindir %{_libdir}/qt4/plugins \
655         <<_EOF_
656 yes
657 _EOF_
658
659 %if 0
660 %if %{with dont_enable}
661 %if %{without designer}
662 grep -v designer tools/tools.pro > tools/tools.pro.1
663 mv tools/tools.pro{.1,}
664 %{__make} -C tools/designer/uic \
665         UIC="LD_PRELOAD=$QTDIR/%{_lib}/libqt-mt.so.3 $QTDIR/bin/uic -L $QTDIR/plugins"
666 %endif
667 %endif
668
669 # Do not build tutorial and examples. Provide them as sources.
670 %{__make} sub-src-all-ordered
671
672 cd tools/qtconfig
673 $QTDIR/bin/uic previewwidgetbase.ui -o ui_previewwidgetbase.h
674 cd -
675 %{__make} sub-tools-all-ordered sub-demos-all-ordered
676 %endif
677 %if %{with dont_enable}
678 %if %{with designer}
679 cd tools/designer/designer
680 lrelease designer_de.ts
681 lrelease designer_fr.ts
682 %endif
683 cd $QTDIR/tools/assistant
684 lrelease assistant_de.ts
685 lrelease assistant_fr.ts
686 cd $QTDIR/tools/linguist/linguist
687 lrelease linguist_de.ts
688 lrelease linguist_fr.ts
689 cd $QTDIR
690 %endif
691
692 %install
693 rm -rf $RPM_BUILD_ROOT
694
695 export QTDIR=`/bin/pwd`
696
697 %{__make} install \
698         INSTALL_ROOT=$RPM_BUILD_ROOT
699
700 install -d \
701         $RPM_BUILD_ROOT%{_sysconfdir}/qt \
702         $RPM_BUILD_ROOT%{_libdir}/qt4/plugins/{crypto,network} \
703         $RPM_BUILD_ROOT%{_examplesdir}/%{name}/lib \
704         $RPM_BUILD_ROOT%{_mandir}/man{1,3} \
705         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
706
707 install bin/findtr \
708         tools/qvfb/qvfb \
709         $RPM_BUILD_ROOT%{_bindir}
710
711 mv -f $RPM_BUILD_ROOT{%{_prefix}/qt.conf,%{_sysconfdir}/qt}
712
713 # we fix qmakespecs. from now QMAKE_INCDIR_QT becomes %{_includedir}/qt4
714 perl -pi -e "
715         s|(QMAKE_INCDIR_QT\\s*=\\s*\\\$\\(QTDIR\\)/include)|\$1/qt4|
716         " $RPM_BUILD_ROOT/%{_datadir}/qt4/mkspecs/linux-g++/qmake.conf
717
718 #tools/{msg2qm/msg2qm,mergetr/mergetr}
719 #       $RPM_BUILD_ROOT%{_bindir}
720
721 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
722 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
723
724 install tools/qtconfig/images/appicon.png \
725         $RPM_BUILD_ROOT%{_pixmapsdir}/qtconfig.png
726
727 install tools/linguist/linguist/images/appicon.png \
728         $RPM_BUILD_ROOT%{_pixmapsdir}/linguist.png
729
730 install tools/assistant/images/appicon.png \
731         $RPM_BUILD_ROOT%{_pixmapsdir}/assistant.png
732
733 %if %{with designer}
734 install tools/designer/src/designer/images/designer.png \
735 $RPM_BUILD_ROOT%{_pixmapsdir}/designer.png
736 %endif
737
738 %if %{with static_libs}
739 install %{_lib}/libqt*.a $RPM_BUILD_ROOT%{_libdir}
740 %endif
741
742 %if %{with designer}
743 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/designer.desktop
744 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
745 install bin/uic $RPM_BUILD_ROOT%{_bindir}
746 %endif
747
748 install tools/linguist/{qm2ts,lrelease,lupdate}/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
749
750 # not yet available
751 #install doc/man/man1/*.1       $RPM_BUILD_ROOT%{_mandir}/man1
752 #install doc/man/man3/*.3qt     $RPM_BUILD_ROOT%{_mandir}/man3
753
754 %if %{with dont_enable}
755 install -d $RPM_BUILD_ROOT%{_datadir}/locale/{ar,de,fr,ru,he,cs,sk}/LC_MESSAGES
756 install translations/qt_ar.qm $RPM_BUILD_ROOT%{_datadir}/locale/ar/LC_MESSAGES/qt.qm
757 install translations/qt_de.qm $RPM_BUILD_ROOT%{_datadir}/locale/de/LC_MESSAGES/qt.qm
758 install translations/qt_fr.qm $RPM_BUILD_ROOT%{_datadir}/locale/fr/LC_MESSAGES/qt.qm
759 install translations/qt_ru.qm $RPM_BUILD_ROOT%{_datadir}/locale/ru/LC_MESSAGES/qt.qm
760 install translations/qt_iw.qm $RPM_BUILD_ROOT%{_datadir}/locale/he/LC_MESSAGES/qt.qm
761 install translations/qt_cs.qm $RPM_BUILD_ROOT%{_datadir}/locale/cs/LC_MESSAGES/qt.qm
762 install translations/qt_sk.qm $RPM_BUILD_ROOT%{_datadir}/locale/sk/LC_MESSAGES/qt.qm
763
764 %if %{with designer}
765 install tools/designer/designer/designer_de.qm $RPM_BUILD_ROOT%{_datadir}/locale/de/LC_MESSAGES/designer.qm
766 install tools/designer/designer/designer_fr.qm $RPM_BUILD_ROOT%{_datadir}/locale/fr/LC_MESSAGES/designer.qm
767 %endif
768
769 install tools/assistant/assistant_de.qm $RPM_BUILD_ROOT%{_datadir}/locale/de/LC_MESSAGES/assistant.qm
770 install tools/assistant/assistant_fr.qm $RPM_BUILD_ROOT%{_datadir}/locale/fr/LC_MESSAGES/assistant.qm
771
772 install tools/linguist/linguist/linguist_de.qm $RPM_BUILD_ROOT%{_datadir}/locale/de/LC_MESSAGES/linguist.qm
773 install tools/linguist/linguist/linguist_fr.qm $RPM_BUILD_ROOT%{_datadir}/locale/fr/LC_MESSAGES/linguist.qm
774 %endif
775
776 cp -dpR examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}
777 mv $RPM_BUILD_ROOT{%{_libdir}/*.prl,%{_examplesdir}/%{name}/lib}
778
779 for i in `find $RPM_BUILD_ROOT -name \*.svn`
780 do
781         rm -rf "$i";
782 done
783
784 cd $RPM_BUILD_ROOT%{_examplesdir}/%{name}
785 for i in `find ./ -name Makefile`;
786 do
787
788 %{__sed} -i -e "s,$RPM_BUILD_DIR,%{_prefix},g" $i
789 %{__sed} -i -e "s,examples,src/examples/qt4/examples,g" $i
790
791 done
792 cd -
793
794 # we will be only packaging modularized qt no need to package the same headers twice
795 rm -rf $RPM_BUILD_ROOT%{_includedir}/qt4/Qt
796
797 #cd $RPM_BUILD_ROOT%{_includedir}/Qt
798 #rm -rf *.h
799 #mkdir arch
800 #for i in `find \`find ../  -maxdepth 1 -type d | egrep -v -w 'Qt|./'\` -name \*.h|cut -c 4-`;
801 #do
802 #y=`echo $i|cut -d '/' -f2-`;
803 #ln -s $y ../$i;
804 #done
805 #cd -
806
807 install demos/arthur/{affine/affine,deform/deform,gradients/gradients,pathstroke/pathstroke} \
808         demos/{downloadwidget/downloadwidget,interview/interview,mainwindow/mainwindow} \
809         demos/{textedit/textedit,sqlbrowser/sqlbrowser,spreadsheet/spreadsheet,scrollarea/scrollarea} \
810         demos/{plasmatable/plasmatable,pimelim/pimelim} \
811         $RPM_BUILD_ROOT%{_bindir}
812
813 %clean
814 rm -rf $RPM_BUILD_ROOT
815
816 %post   -n QtCore
817 /sbin/ldconfig
818 cat << EOF
819  *******************************************************
820  *                                                     *
821  *  NOTE:                                              *
822  *  With qt 4.0.0 the single threaded version was      *
823  *  removed. Also the library is modular now so be     *
824  *  sure to check that you have every module you need. *
825  *                                                     *
826  *******************************************************
827 EOF
828 %postun -n QtCore       -p /sbin/ldconfig
829
830 %post   -n QtGui        -p /sbin/ldconfig
831 %postun -n QtGui        -p /sbin/ldconfig
832
833 %post   -n QtNetwork    -p /sbin/ldconfig
834 %postun -n QtNetwork    -p /sbin/ldconfig
835
836 %post   -n QtOpenGL     -p /sbin/ldconfig
837 %postun -n QtOpenGL     -p /sbin/ldconfig
838
839 %post   -n QtSql        -p /sbin/ldconfig
840 %postun -n QtSql        -p /sbin/ldconfig
841
842 %post   -n QtXml        -p /sbin/ldconfig
843 %postun -n QtXml        -p /sbin/ldconfig
844
845 %post   -n Qt3Support   -p /sbin/ldconfig
846 %postun -n Qt3Support   -p /sbin/ldconfig
847
848 %post   -n assistant    -p /sbin/ldconfig
849 %postun -n assistant    -p /sbin/ldconfig
850
851 %post   -n designer-libs        -p /sbin/ldconfig
852 %postun -n designer-libs        -p /sbin/ldconfig
853
854 %files -n QtCore
855 %defattr(644,root,root,755)
856 %dir %{_sysconfdir}/qt
857 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qt/qt.conf
858 %attr(755,root,root) %{_libdir}/libQtCore*.so.*
859 %dir %{_libdir}/qt4/plugins
860 %dir %{_libdir}/qt4/plugins/codecs
861 %dir %{_libdir}/qt4/plugins/imageformats
862 %dir %{_libdir}/qt4/plugins/sqldrivers
863 %dir %{_libdir}/qt4/plugins/crypto
864 %dir %{_libdir}/qt4/plugins/network
865 %dir %{_datadir}/qt4
866
867 %files -n QtCore-devel
868 %defattr(644,root,root,755)
869 %dir %{_includedir}/qt4
870 %attr(755,root,root) %{_libdir}/libQtCore*.so
871 %{_libdir}/libQtCore*.la
872 %{_includedir}/qt4/QtCore
873 %{_pkgconfigdir}/QtCore*.pc
874
875 %files -n QtGui
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/libQtGui*.so.*
878 %{_libdir}/qt4/plugins/codecs/*
879 %{_libdir}/qt4/plugins/imageformats/*
880
881 %files -n QtGui-devel
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/libQtGui*.so
884 %{_libdir}/libQtGui*.la
885 %{_includedir}/qt4/QtGui
886 %{_pkgconfigdir}/QtGui*.pc
887
888 %files -n QtNetwork
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %{_libdir}/libQtNetwork*.so.*
891
892 %files -n QtNetwork-devel
893 %defattr(644,root,root,755)
894 %{_libdir}/libQtNetwork*.la
895 %attr(755,root,root) %{_libdir}/libQtNetwork*.so
896 %{_includedir}/qt4/QtNetwork
897 %{_pkgconfigdir}/QtNetwork*.pc
898
899 %files -n QtOpenGL
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/libQtOpenGL*.so.*
902
903 %files -n QtOpenGL-devel
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_libdir}/libQtOpenGL*.so
906 %{_libdir}/libQtOpenGL*.la
907 %{_includedir}/qt4/QtOpenGL
908 %{_pkgconfigdir}/QtOpenGL*.pc
909
910 %files -n QtSql
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_libdir}/libQtSql*.so.*
913
914 %files -n QtSql-devel
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/libQtSql*.so
917 %{_libdir}/libQtSql*.la
918 %{_includedir}/qt4/QtSql
919 %{_pkgconfigdir}/QtSql*.pc
920
921 %if %{with mysql}
922 %files -n QtSql-mysql
923 %defattr(644,root,root,755)
924 %attr(755,root,root)  %{_libdir}/qt4/plugins/sqldrivers/libqsqlmysql*.so
925 %endif
926
927 %if %{with pgsql}
928 %files -n QtSql-pgsql
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_libdir}/qt4/plugins/sqldrivers/libqsqlpsql*.so
931 %endif
932
933 %if %{with sqlite}
934 %files -n QtSql-sqlite
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_libdir}/qt4/plugins/sqldrivers/libqsqlite2*.so
937 %endif
938
939 %if %{with sqlite3}
940 %files -n QtSql-sqlite3
941 %defattr(644,root,root,755)
942 %attr(755,root,root) %{_libdir}/qt4/plugins/sqldrivers/libqsqlite*.so
943 %endif
944
945 %if %{with ibase}
946 %files -n QtSql-ibase
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/qt4/plugins/sqldrivers/libqsqlibase*.so
949 %endif
950
951 %if %{with odbc}
952 %files -n QtSql-odbc
953 %defattr(644,root,root,755)
954 %attr(755,root,root) %{_libdir}/qt4/plugins/sqldrivers/libqsqlodbc*.so
955 %endif
956
957 %files -n QtXml
958 %defattr(644,root,root,755)
959 %attr(755,root,root) %{_libdir}/libQtXml*.so.*
960
961 %files -n QtXml-devel
962 %defattr(644,root,root,755)
963 %attr(755,root,root) %{_libdir}/libQtXml*.so
964 %{_libdir}/libQtXml*.la
965 %{_includedir}/qt4/QtXml
966 %{_pkgconfigdir}/QtXml*.pc
967
968 %files -n Qt3Support
969 %defattr(644,root,root,755)
970 %attr(755,root,root) %{_bindir}/uic3
971 %attr(755,root,root) %{_libdir}/libQt3Support*.so.*
972
973 %files -n Qt3Support-devel
974 %defattr(644,root,root,755)
975 %attr(755,root,root) %{_libdir}/libQt3Support*.so
976 %{_libdir}/libQt3Support*.la
977 %{_includedir}/qt4/Qt3Support
978 %{_pkgconfigdir}/Qt3Support*.pc
979
980 %files assistant
981 %defattr(644,root,root,755)
982 %attr(755,root,root) %{_bindir}/assistant
983 %attr(755,root,root) %{_libdir}/libQtAssistantClient*.so*
984 #%lang(de) %{_datadir}/locale/de/LC_MESSAGES/assistant.qm
985 #%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/assistant.qm
986 %{_desktopdir}/assistant.desktop
987 %{_pixmapsdir}/assistant.png
988
989 %files build
990 %defattr(644,root,root,755)
991 %attr(755,root,root) %{_bindir}/rcc
992 %attr(755,root,root) %{_bindir}/moc
993 %attr(755,root,root) %{_bindir}/qt3to4
994 %attr(755,root,root) %{_bindir}/uic
995 %{_datadir}/qt4/q3porting.xml
996
997 %if %{with designer}
998 %files designer-libs
999 %defattr(644,root,root,755)
1000 %attr(755,root,root) %{_libdir}/libQtDesigner*.so.*.*.*
1001
1002 %files designer
1003 %defattr(644,root,root,755)
1004 %attr(755,root,root) %{_bindir}/designer
1005 #%dir %{_libdir}/%{name}/plugins-?t/designer
1006 #%lang(de) %{_datadir}/locale/de/LC_MESSAGES/designer.qm
1007 #%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/designer.qm
1008 %{_desktopdir}/designer.desktop
1009 %{_pixmapsdir}/designer.png
1010 %endif
1011
1012 %files linguist
1013 %defattr(644,root,root,755)
1014 %attr(755,root,root) %{_bindir}/linguist
1015 %attr(755,root,root) %{_bindir}/findtr
1016 %attr(755,root,root) %{_bindir}/lrelease
1017 %attr(755,root,root) %{_bindir}/lupdate
1018 %attr(755,root,root) %{_bindir}/qm2ts
1019 #%lang(de) %{_datadir}/locale/de/LC_MESSAGES/linguist.qm
1020 #%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/linguist.qm
1021 %{_mandir}/man1/qm2ts.1*
1022 %{_mandir}/man1/lupdate*.1*
1023 %{_mandir}/man1/lrelease*.1*
1024 %{_datadir}/qt4/phrasebooks
1025 %{_desktopdir}/linguist.desktop
1026 %{_pixmapsdir}/linguist.png
1027
1028 %files -n qmake
1029 %defattr(644,root,root,755)
1030 %attr(755,root,root) %{_bindir}/qmake
1031 %{_datadir}/qt4/mkspecs
1032
1033 %files -n qtconfig
1034 %defattr(644,root,root,755)
1035 %attr(755,root,root) %{_bindir}/qtconfig
1036 %{_desktopdir}/qtconfig.desktop
1037 %{_pixmapsdir}/qtconfig.png
1038
1039 %files -n qvfb
1040 %defattr(644,root,root,755)
1041 %attr(755,root,root) %{_bindir}/qvfb
1042
1043 %files demos
1044 %defattr(644,root,root,755)
1045 %attr(755,root,root) %{_bindir}/affine
1046 %attr(755,root,root) %{_bindir}/deform
1047 %attr(755,root,root) %{_bindir}/downloadwidget
1048 %attr(755,root,root) %{_bindir}/gradients
1049 %attr(755,root,root) %{_bindir}/interview
1050 %attr(755,root,root) %{_bindir}/mainwindow
1051 %attr(755,root,root) %{_bindir}/pathstroke
1052 %attr(755,root,root) %{_bindir}/pimelim
1053 %attr(755,root,root) %{_bindir}/plasmatable
1054 %attr(755,root,root) %{_bindir}/scrollarea
1055 %attr(755,root,root) %{_bindir}/spreadsheet
1056 %attr(755,root,root) %{_bindir}/sqlbrowser
1057 %attr(755,root,root) %{_bindir}/textedit
1058
1059 %files doc
1060 %defattr(644,root,root,755)
1061 %{_docdir}/%{name}-doc
1062
1063 %files examples
1064 %defattr(644,root,root,755)
1065 %{_examplesdir}/qt4
This page took 1.271075 seconds and 4 git commands to generate.