]> git.pld-linux.org Git - packages/qt-gstreamer.git/blob - qt-gstreamer.spec
cec752f5c6cde490d26d93ebc9d59328cb31d4d3
[packages/qt-gstreamer.git] / qt-gstreamer.spec
1 # NOTE: copy package to qt-gstreamer0.10 before updating to 1.0.x (when available)
2 # TODO: finish Qt5 packages (Quick1/QtDeclarative?)
3 #
4 # Conditional build:
5 %bcond_without  qt4     # Qt 4 libraries
6 %bcond_without  qt5     # Qt 5 libraries
7 #
8 Summary:        QtGStreamer - libraries integrating Qt 4 with GStreamer
9 Summary(pl.UTF-8):      QtGStreamer - biblioteki integrujące Qt 4 z GStreamerem
10 Name:           qt-gstreamer
11 Version:        0.10.3
12 Release:        1
13 License:        LGPL v2+
14 Group:          Libraries
15 Source0:        http://gstreamer.freedesktop.org/src/qt-gstreamer/%{name}-%{version}.tar.bz2
16 # Source0-md5:  1dfbca4ffa924b0896dadb42221600e2
17 URL:            http://gstreamer.net/
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  bison
20 BuildRequires:  boost-devel >= 1.39
21 BuildRequires:  cmake >= 2.8.9
22 BuildRequires:  flex
23 BuildRequires:  glib2-devel >= 2.0
24 BuildRequires:  gstreamer0.10-devel >= 0.10.33
25 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10.33
26 BuildRequires:  libstdc++-devel >= 6:4.5
27 BuildRequires:  pkgconfig
28 %if %{with qt4}
29 BuildRequires:  QtCore-devel >= 4.7
30 BuildRequires:  QtDeclarative-devel >= 4.7
31 BuildRequires:  QtGui-devel >= 4.7
32 BuildRequires:  QtOpenGL-devel >= 4.7
33 BuildRequires:  QtTest-devel >= 4.7
34 BuildRequires:  qt4-qmake >= 4.7
35 %endif
36 %if %{with qt5}
37 BuildRequires:  Qt5Core-devel >= 5.0.0
38 # ?
39 #BuildRequires: Qt5Declarative-devel >= 5.0.0
40 #BuildRequires: Qt5Quick1-devel >= 5.0.0
41 BuildRequires:  Qt5Gui-devel >= 5.0.0
42 BuildRequires:  Qt5OpenGL-devel >= 5.0.0
43 BuildRequires:  Qt5Widgets-devel >= 5.0.0
44 BuildRequires:  Qt5Test-devel >= 5.0.0
45 BuildRequires:  qt5-qmake >= 5.0.0
46 %endif
47 Requires:       QtCore >= 4.7
48 Requires:       QtGui >= 4.7
49 Requires:       QtOpenGL >= 4.7
50 Requires:       gstreamer0.10 >= 0.10.33
51 Requires:       gstreamer0.10-plugins-base >= 0.10.33
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 QtGStreamer is a set of libraries and plugins providing C++ bindings
56 for GStreamer with a Qt-style API plus some helper classes for
57 integrating GStreamer better in Qt 4 applications.
58
59 Currently, it consists of the following parts:
60  * QtGLib - library providing C++/Qt 4 bindings for parts of the GLib
61    and GObject APIs, a base on which QtGStreamer is built.
62  * QtGStreamer - library providing C++/Qt 4 bindings for GStreamer
63  * QtGStreamerUi - library providing integration with QtGui;
64    currently, it only provides a video widget that embeds GStreamer's
65    video sinks.
66  * QtGStreamerUtils - library providing some high level utility
67    classes.
68
69 In addition, it provides a "qwidgetvideosink" GStreamer element, an
70 video sink element that can draw directly on QWidgets using QPainter.
71
72 %description -l pl.UTF-8
73 QtGStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
74 GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
75 integracji GStreamera w aplikacjach Qt 4.
76
77 Obecnie zawiera następujące części:
78  - QtGLib - biblioteka z wiązaniami C++/Qt 4 dla części API bibliotek
79    GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
80  - QtGStreamer - biblioteka z wiązaniami C++/Qt 4 do GStreamera
81  - QtGStreamerUi - biblioteka integrująca z QtGui; obecnie zawiera
82    tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
83  - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
84    wysokiego poziomu.
85
86 Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
87 element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
88 użyciu QPaintera.
89
90 %package devel
91 Summary:        Header files for QtGStreamer libraries
92 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek QtGStreamer
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       QtCore-devel >= 4.7
96 Requires:       QtGui-devel >= 4.7
97 Requires:       gstreamer0.10-devel >= 0.10.33
98 Requires:       gstreamer0.10-plugins-base-devel >= 0.10.33
99
100 %description devel
101 Header files for QtGStreamer libraries.
102
103 %description devel -l pl.UTF-8
104 Pliki nagłówkowe bibliotek QtGStreamer.
105
106 %package -n QtDeclarative-plugin-gstreamer
107 Summary:        Qt GStreamer plugin for QtDeclarative
108 Summary(pl.UTF-8):      Wtyczka Qt GStreamer dla QtDeclarative
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       QtDeclarative >= 4.7
112
113 %description -n QtDeclarative-plugin-gstreamer
114 Qt GStreamer plugin for QtDeclarative.
115
116 %description -n QtDeclarative-plugin-gstreamer -l pl.UTF-8
117 Wtyczka Qt GStreamer dla QtDeclarative.
118
119 %package -n qt5-gstreamer
120 Summary:        Qt5GStreamer - libraries integrating Qt 5 with GStreamer
121 Summary(pl.UTF-8):      Qt5GStreamer - biblioteki integrujące Qt 5 z GStreamerem
122 Group:          Libraries
123 Requires:       Qt5Core >= 5.0.0
124 Requires:       Qt5Gui >= 5.0.0
125 Requires:       Qt5OpenGL >= 5.0.0
126 Requires:       gstreamer0.10 >= 0.10.33
127 Requires:       gstreamer0.10-plugins-base >= 0.10.33
128
129 %description -n qt5-gstreamer
130 Qt5GStreamer is a set of libraries and plugins providing C++ bindings
131 for GStreamer with a Qt-style API plus some helper classes for
132 integrating GStreamer better in Qt 5 applications.
133
134 Currently, it consists of the following parts:
135  * Qt5GLib - library providing C++/Qt 5 bindings for parts of the GLib
136    and GObject APIs, a base on which Qt5GStreamer is built.
137  * Qt5GStreamer - library providing C++/Qt 5 bindings for GStreamer
138  * Qt5GStreamerUi - library providing integration with Qt5Gui;
139    currently, it only provides a video widget that embeds GStreamer's
140    video sinks.
141  * Qt5GStreamerUtils - library providing some high level utility
142    classes.
143
144 In addition, it provides a "qwidgetvideosink" GStreamer element, an
145 video sink element that can draw directly on QWidgets using QPainter.
146
147 %description -n qt5-gstreamer -l pl.UTF-8
148 Qt5GStreamer to zestaw bibliotek i wtyczek z wiązaniami C++ do
149 GStreamera o API w stylu Qt oraz klasami pomocniczymi dla lepszej
150 integracji GStreamera w aplikacjach Qt 5.
151
152 Obecnie zawiera następujące części:
153  - Qt5GLib - biblioteka z wiązaniami C++/Qt 5 dla części API bibliotek
154    GLib i GObject; w oparciu o nią zbudowany jest QtGStreamer
155  - Qt5GStreamer - biblioteka z wiązaniami C++/Qt 5 do GStreamera
156  - Qt5GStreamerUi - biblioteka integrująca z Qt5Gui; obecnie zawiera
157    tylko widget wideo osadzający wyjście obrazu (videosink) GStremera.
158  - QtGStreamerUtils - biblioteka udostępniająca klasy narzędziowe
159    wysokiego poziomu.
160
161 Ponadto pakiet udostępnia element GStreamera "qwidgetvideosink" -
162 element wyjściowy obrazu rysujący bezpośrednio na QWidgetach przy
163 użyciu QPaintera.
164
165 %package -n qt5-gstreamer-devel
166 Summary:        Header files for Qt5GStreamer libraries
167 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek QtGStreamer
168 Group:          Development/Libraries
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       Qt5Core-devel >= 5.0.0
171 Requires:       Qt5Gui-devel >= 5.0.0
172 Requires:       gstreamer0.10-devel >= 0.10.33
173 Requires:       gstreamer0.10-plugins-base-devel >= 0.10.33
174
175 %description -n qt5-gstreamer-devel
176 Header files for Qt5GStreamer libraries.
177
178 %description -n qt5-gstreamer-devel -l pl.UTF-8
179 Pliki nagłówkowe bibliotek Qt5GStreamer.
180
181 %prep
182 %setup -q
183
184 %build
185 %if %{with qt4}
186 install -d build-qt4
187 cd build-qt4
188 %cmake .. \
189         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
190         -DQTGSTREAMER_EXAMPLES=OFF \
191         -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4
192 %{__make}
193 cd ..
194 %endif
195
196 %if %{with qt5}
197 install -d build-qt5
198 cd build-qt5
199 %cmake .. \
200         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
201         -DQTGSTREAMER_EXAMPLES=OFF \
202         -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt5 \
203         -DQT_VERSION=5
204 %{__make}
205 cd ..
206 %endif
207
208 %install
209 rm -rf $RPM_BUILD_ROOT
210
211 %if %{with qt4}
212 %{__make} -C build-qt4 install \
213         DESTDIR=$RPM_BUILD_ROOT
214 %endif
215
216 %if %{with qt5}
217 %{__make} -C build-qt5 install \
218         DESTDIR=$RPM_BUILD_ROOT
219 %endif
220
221 %clean
222 rm -rf $RPM_BUILD_ROOT
223
224 %post   -p /sbin/ldconfig
225 %postun -p /sbin/ldconfig
226
227 %post   -n qt5-gstreamer -p /sbin/ldconfig
228 %postun -n qt5-gstreamer -p /sbin/ldconfig
229
230 %if %{with qt4}
231 %files
232 %defattr(644,root,root,755)
233 %doc NEWS README
234 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so.*.*.*
235 %attr(755,root,root) %ghost %{_libdir}/libQtGLib-2.0.so.0
236 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so.*.*.*
237 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamer-0.10.so.0
238 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so.*.*.*
239 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUi-0.10.so.0
240 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so.*.*.*
241 %attr(755,root,root) %ghost %{_libdir}/libQtGStreamerUtils-0.10.so.0
242 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqtvideosink.so
243
244 %files devel
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_libdir}/libQtGLib-2.0.so
247 %attr(755,root,root) %{_libdir}/libQtGStreamer-0.10.so
248 %attr(755,root,root) %{_libdir}/libQtGStreamerUi-0.10.so
249 %attr(755,root,root) %{_libdir}/libQtGStreamerUtils-0.10.so
250 %{_includedir}/QtGStreamer
251 %{_pkgconfigdir}/QtGLib-2.0.pc
252 %{_pkgconfigdir}/QtGStreamer-0.10.pc
253 %{_pkgconfigdir}/QtGStreamerUi-0.10.pc
254 %{_pkgconfigdir}/QtGStreamerUtils-0.10.pc
255 %{_libdir}/cmake/QtGStreamer
256
257 %files -n QtDeclarative-plugin-gstreamer
258 %defattr(644,root,root,755)
259 %dir %{_libdir}/qt4/imports/QtGStreamer
260 %attr(755,root,root) %{_libdir}/qt4/imports/QtGStreamer/libQtGStreamerQuick1.so
261 %{_libdir}/qt4/imports/QtGStreamer/qmldir
262 %endif
263
264 %if %{with qt5}
265 %files -n qt5-gstreamer
266 %defattr(644,root,root,755)
267 %doc NEWS README
268 %attr(755,root,root) %{_libdir}/libQt5GLib-2.0.so.*.*.*
269 %attr(755,root,root) %ghost %{_libdir}/libQt5GLib-2.0.so.0
270 %attr(755,root,root) %{_libdir}/libQt5GStreamer-0.10.so.*.*.*
271 %attr(755,root,root) %ghost %{_libdir}/libQt5GStreamer-0.10.so.0
272 %attr(755,root,root) %{_libdir}/libQt5GStreamerUi-0.10.so.*.*.*
273 %attr(755,root,root) %ghost %{_libdir}/libQt5GStreamerUi-0.10.so.0
274 %attr(755,root,root) %{_libdir}/libQt5GStreamerUtils-0.10.so.*.*.*
275 %attr(755,root,root) %ghost %{_libdir}/libQt5GStreamerUtils-0.10.so.0
276 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libgstqt5videosink.so
277
278 %files -n qt5-gstreamer-devel
279 %defattr(644,root,root,755)
280 %attr(755,root,root) %{_libdir}/libQt5GLib-2.0.so
281 %attr(755,root,root) %{_libdir}/libQt5GStreamer-0.10.so
282 %attr(755,root,root) %{_libdir}/libQt5GStreamerUi-0.10.so
283 %attr(755,root,root) %{_libdir}/libQt5GStreamerUtils-0.10.so
284 %{_includedir}/Qt5GStreamer
285 %{_pkgconfigdir}/Qt5GLib-2.0.pc
286 %{_pkgconfigdir}/Qt5GStreamer-0.10.pc
287 %{_pkgconfigdir}/Qt5GStreamerUi-0.10.pc
288 %{_pkgconfigdir}/Qt5GStreamerUtils-0.10.pc
289 %{_libdir}/cmake/Qt5GStreamer
290 %endif
This page took 0.093629 seconds and 3 git commands to generate.