]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- md5
[packages/qemu.git] / qemu.spec
1 Summary:        QEMU CPU Emulator
2 Name:           qemu
3 Version:        0.5.2
4 Release:        0.1
5 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
6 # Source0-md5:  81acda062219c82973e82585b0eb357a
7 Patch0:         %{name}-nostatic.patch
8 Patch1:         %{name}-DESTDIR.patch
9 #Patch0:                qemu-0.5.0-cvsupdates.patch.bz2
10 #Patch1:                qemu-0.1.6-glibc23-ldscripts.patch.bz2
11 #Patch2:                qemu-0.5.0-sdl-static-libs.patch.bz2
12 #Patch3:                qemu-0.5.0-DESTDIR.patch.bz2
13 #Patch4:                qemu-0.5.0-lib64.patch.bz2
14 #Patch5:                qemu-0.5.0-amd64.patch.bz2
15 #Patch6:                qemu-0.5.0-vl-amd64.patch.bz2
16 License:        GPL
17 URL:            http://fabrice.bellard.free.fr/qemu/
18 Group:          Applications/Emulators
19 BuildRequires:  SDL-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 QEMU is a FAST! processor emulator. By using dynamic translation it
24 achieves a reasonnable speed while being easy to port on new host
25 CPUs. QEMU has two operating modes:
26
27 - User mode emulation. In this mode, QEMU can launch Linux processes
28   compiled for one CPU on another CPU. Linux system calls are converted
29   because of endianness and 32/64 bit mismatches. Wine (Windows
30   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
31
32 - Full system emulation. In this mode, QEMU emulates a full system,
33   including a processor and various peripherials. Currently, it is only
34   used to launch an x86 Linux kernel on an x86 Linux system. It enables
35   easier testing and debugging of system code. It can also be used to
36   provide virtual hosting of several virtual PC on a single server.
37
38 %prep
39 %setup -q
40 %patch0 -p1
41 %patch1 -p1
42 #%patch0 -p1 -b .cvsupdates
43 #%patch1 -p1 -b .glibc23-ldscripts
44 #%patch2 -p1 -b .sdl-static-libs
45 #%patch3 -p1 -b .DESTDIR
46 #%patch4 -p1 -b .lib64
47 #%patch5 -p1 -b .amd64
48 # needs to 64-bit clean softmmu code or MAP_32BIT physical_ram_base
49 # but other problems remain.
50 #%patch6 -p1 -b .vl-amd64
51
52 %build
53 ./configure \
54         --prefix=%{_prefix} \
55         --cc=%{__cc} \
56         --make=%{__make}
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README qemu-doc.html
70 %ifarch %{ix86}
71 %attr(755,root,root) %{_bindir}/qemu-fast
72 %endif
73 %ifarch %{ix86} ppc
74 %{_bindir}/qemu
75 %endif
76 %{_bindir}/qemu-mkcow
77 %{_bindir}/qemu-arm
78 %{_bindir}/qemu-i386
79 %{_bindir}/qemu-sparc
80 %{_bindir}/qemu-ppc
81 %{_mandir}/man1/qemu.1*
82 %dir %{_datadir}/qemu
83 %{_datadir}/qemu/bios.bin
84 %{_datadir}/qemu/vgabios.bin
This page took 0.057724 seconds and 4 git commands to generate.