]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- ppc related compilation fix.
[packages/qemu.git] / qemu.spec
1 Summary:        QEMU CPU Emulator
2 Summary(pl):    QEMU - emulator procesora
3 Name:           qemu
4 Version:        0.6.0
5 Release:        0.2
6 License:        GPL
7 Group:          Applications/Emulators
8 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
9 # Source0-md5:  cdbc7258f122f381cba7ac1ca6ce0722
10 # Source0-size: 874397
11 Patch0:         %{name}-nostatic.patch
12 Patch1:         %{name}-DESTDIR.patch
13 Patch2:         %{name}-amd64.patch
14 Patch3:         %{name}-longjmp.patch
15 Patch4:         %{name}-gcc34.patch
16 Patch5:         %{name}-ppc.patch
17 #Patch0:                qemu-0.5.0-cvsupdates.patch.bz2
18 #Patch1:                qemu-0.1.6-glibc23-ldscripts.patch.bz2
19 #Patch2:                qemu-0.5.0-sdl-static-libs.patch.bz2
20 #Patch3:                qemu-0.5.0-DESTDIR.patch.bz2
21 #Patch4:                qemu-0.5.0-lib64.patch.bz2
22 #Patch5:                qemu-0.5.0-amd64.patch.bz2
23 #Patch6:                qemu-0.5.0-vl-amd64.patch.bz2
24 URL:            http://fabrice.bellard.free.fr/qemu/
25 BuildRequires:  SDL-devel
26 ExclusiveArch:  %{ix86} amd64 ppc sparc
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 QEMU is a FAST! processor emulator. By using dynamic translation it
31 achieves a reasonnable speed while being easy to port on new host
32 CPUs. QEMU has two operating modes:
33
34 - User mode emulation. In this mode, QEMU can launch Linux processes
35   compiled for one CPU on another CPU. Linux system calls are converted
36   because of endianness and 32/64 bit mismatches. Wine (Windows
37   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
38
39 - Full system emulation. In this mode, QEMU emulates a full system,
40   including a processor and various peripherials. Currently, it is only
41   used to launch an x86 Linux kernel on an x86 Linux system. It enables
42   easier testing and debugging of system code. It can also be used to
43   provide virtual hosting of several virtual PC on a single server.
44
45 %description -l pl
46 QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
47 t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
48 aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
49
50 - Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
51   procesy linuksowe skompilowane dla jednego procesora na innym
52   procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu
53   na niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
54   s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
55   cele QEMU.
56
57 - Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
58   w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Aktualnie
59   dzia³a to tylko przy uruchamianiu j±dra Linuksa x86 na systemie
60   linuksowym x86, pozwalaj±c na ³atwiejsze testowanie i odpluskwianie
61   kodu systemu. Mo¿e byæ tak¿e u¿ywane do wirtualnego hostowania kilku
62   wirtualnych pecetów na pojedynczym serwerze.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69 %patch3 -p1
70 %patch4 -p1
71 %patch5 -p1
72
73 #%patch0 -p1 -b .cvsupdates
74 #%patch1 -p1 -b .glibc23-ldscripts
75 #%patch2 -p1 -b .sdl-static-libs
76 #%patch3 -p1 -b .DESTDIR
77 #%patch4 -p1 -b .lib64
78 #%patch5 -p1 -b .amd64
79 # needs to 64-bit clean softmmu code or MAP_32BIT physical_ram_base
80 # but other problems remain.
81 #%patch6 -p1 -b .vl-amd64
82
83 %build
84 ./configure \
85         --prefix=%{_prefix} \
86         --cc=%{__cc} \
87         --make=%{__make} \
88 %ifarch %{ix86} amd64
89         --target-list="i386-user i386 i386-softmmu"
90 %endif
91 %ifarch ppc powerpc
92         --target-list="ppc-user ppc-softmmu"
93 %endif
94 %ifarch sparc
95         --target-list="sparc-user"
96 %endif
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc README qemu-doc.html
112 %ifarch %{ix86}
113 %attr(755,root,root) %{_bindir}/qemu-fast
114 %endif
115 %ifarch %{ix86} ppc
116 %{_bindir}/qemu
117 %endif
118 %{_bindir}/qemu-mkcow
119 %{_bindir}/qemu-arm
120 %{_bindir}/qemu-i386
121 %{_bindir}/qemu-sparc
122 %{_bindir}/qemu-ppc
123 %{_mandir}/man1/qemu.1*
124 %dir %{_datadir}/qemu
125 %{_datadir}/qemu/bios.bin
126 %{_datadir}/qemu/vgabios.bin
This page took 0.095888 seconds and 4 git commands to generate.