]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- only one kernel subpackage
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4 #
5 # Conditional build:
6 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
7 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
8 %bcond_with     dosguest                # add special patch when use with DOS as guest os
9 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
10 # Note that gcc4 build is very problematic and not supported by qemu team
11 %bcond_without  gcc4                    # use gcc4 patches (broke build on gcc33)
12 %bcond_without  dist_kernel             # without distribution kernel
13 %bcond_without  kernel                  # build kqemu KERNEL MODULES
14 %bcond_without  userspace               # don't build userspace
15 #
16
17 # no kqemu for ppc
18 %ifarch ppc
19 %undefine       with_kqemu
20 %undefine       with_kernel
21 %endif
22 %define _kqemu_version  1.3.0pre11
23 %define         _rel    1
24 Summary:        QEMU CPU Emulator
25 Summary(pl.UTF-8):      QEMU - emulator procesora
26 Name:           qemu
27 Version:        0.9.0
28 Release:        %{_rel}%{?with_kqemu:k}
29 License:        GPL
30 Group:          Applications/Emulators
31 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
32 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
33 # Source0-md5:  ab11a03ba30cf4a70641f0f170473d69
34 Source1:        http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
35 # Source1-md5:  970521874ef8b1ba4598925ace5936c3
36 Patch0:         %{name}-nostatic.patch
37 Patch1:         %{name}-cc.patch
38 Patch3:         %{name}-dot.patch
39 Patch4:         %{name}-gcc4_x86.patch
40 Patch5:         %{name}-gcc4_ppc.patch
41 Patch6:         %{name}-nosdlgui.patch
42 Patch7:         %{name}-ifup.patch
43 # Proof of concept, for reference, do not remove
44 Patch8:         %{name}-kde_virtual_workspaces_hack.patch
45 # http://gwenole.beauchesne.info/en/projects/qemu
46 Patch9:         %{name}-0.8.0-gcc4-hacks.patch
47 Patch11:        %{name}-0.7.2-gcc4-opts.patch
48 #Patch12:       %{name}-0.7.2-dyngen-check-stack-clobbers.patch
49 Patch13:        %{name}-dosguest.patch
50 URL:            http://fabrice.bellard.free.fr/qemu/
51 %if %{with kernel} && %{with dist_kernel}
52 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
53 BuildRequires:  rpmbuild(macros) >= 1.379
54 %endif
55 %if %{with userspace}
56 BuildRequires:  SDL-devel >= 1.2.1
57 BuildRequires:  alsa-lib-devel
58 %{!?with_gcc4:BuildRequires:    gcc < 5:4.0}
59 BuildRequires:  perl-tools-pod
60 BuildRequires:  tetex
61 BuildRequires:  sed >= 4.0
62 %endif
63 Requires:       SDL >= 1.2.1
64 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
65 ExclusiveArch:  %{ix86} %{x8664} ppc
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 # some SPARC boot image in ELF format
69 %define         _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
70
71 %description
72 QEMU is a FAST! processor emulator. By using dynamic translation it
73 achieves a reasonnable speed while being easy to port on new host
74 CPUs. QEMU has two operating modes:
75
76 - User mode emulation. In this mode, QEMU can launch Linux processes
77   compiled for one CPU on another CPU. Linux system calls are converted
78   because of endianness and 32/64 bit mismatches. Wine (Windows
79   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
80
81 - Full system emulation. In this mode, QEMU emulates a full system,
82   including a processor and various peripherials. It can also be used to
83   provide virtual hosting of several virtual PC on a single server.
84
85 %description -l pl.UTF-8
86 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
87 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
88 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
89
90 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
91   procesy linuksowe skompilowane dla jednego procesora na innym
92   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
93   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
94   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
95   cele QEMU.
96
97 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
98   włączając w to procesor i różne urządzenia peryferyjne. Może być także
99   używane do wirtualnego hostowania kilku wirtualnych pecetów na
100   pojedynczym serwerze.
101
102 %package -n kernel%{_alt_kernel}-misc-kqemu
103 Summary:        kqemu - kernel module
104 Summary(pl.UTF-8):      kqemu - moduł jądra
105 Version:        %{_kqemu_version}
106 Release:        %{_rel}@%{_kernel_ver_str}
107 Group:          Base/Kernel
108 %{?with_dist_kernel:%requires_releq_kernel}
109 License:        GPL v2
110 Obsoletes:      kernel%{_alt_kernel}-smp-misc-kqemu
111 Requires(post,postun):  /sbin/depmod
112 Requires:       module-init-tools >= 3.2.2-2
113
114 %description -n kernel%{_alt_kernel}-misc-kqemu
115 kqemu - kernel module.
116
117 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
118 kqemu - moduł jądra.
119
120 %prep
121 %if %{without kernel} && %{without dist_kernel}
122 %{error:%{name}: If building kernel module You need to enable at least one of up or smp}
123 exit 1
124 %endif
125
126 %setup -q %{?with_kernel:-a1}
127 %patch0 -p1
128 %patch1 -p1
129 %patch3 -p1
130 %if %{with gcc4}
131 %patch9 -p1
132 %patch11 -p1
133 #%patch12 -p1
134 #%patch4 -p0
135 %patch5 -p1
136 %endif
137 %{?with_nosdlgui:%patch6 -p1}
138 %patch7 -p1
139 #%patch8 -p1
140
141 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
142 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
143
144 # cannot use optflags on x86 - they cause "no register to spill" errors
145 %if %{with cflags_passing}
146 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
147 %else
148 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
149 %endif
150
151 %if %{with kernel}
152 echo -n > kqemu-%{_kqemu_version}/install.sh
153
154 cat <<'EOF' > modprobe.conf
155 # enable dynamic major
156 options kqemu major=0
157 # for autoloading from static dev
158 #alias char-major-250 kqemu
159 EOF
160
161 cat <<'EOF' > udev.conf
162 KERNEL=="kqemu", NAME="%k", MODE="0666"
163 EOF
164 %endif
165
166 %if %{with dosguest}
167 %patch13 -p1
168 %endif
169
170 %build
171 %if %{with kernel}
172 cd kqemu-%{_kqemu_version}
173
174 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
175 %ifarch %{x8664}
176 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
177 %{__make} -j1 -C common
178 mv -f kqemu-mod-x86_64.o{,.bin}
179 %else
180 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
181 %{__make} -j1 -C common
182 mv -f kqemu-mod-i386.o{,.bin}
183 %endif
184
185 mv -f kqemu-linux.c{,.orig}
186 cat > Makefile <<'EOF'
187 obj-m := kqemu.o
188 kqemu-objs:= kqemu-linux.o kqemu-mod.o
189
190 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
191         cp $< $@
192 EOF
193
194 %build_kernel_modules -m kqemu <<'EOF'
195 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
196         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
197                 kqemu-linux.c.orig > kqemu-linux.c
198 else
199         cat kqemu-linux.c.orig > kqemu-linux.c
200 fi
201 EOF
202 cd -
203 %endif
204
205 %if %{with userspace}
206 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
207 # they can be passed if the cflags_passing bcond is used
208 ./configure \
209         --prefix=%{_prefix} \
210         --cc="%{__cc}" \
211         --host-cc="%{__cc}" \
212         --make="%{__make}" \
213 %if %{with kqemu}
214         --kernel-path=%{_kernelsrcdir} \
215 %else
216         --disable-kqemu \
217 %endif
218         %{?with_gcc4:--disable-gcc-check} \
219         --enable-alsa \
220         --interp-prefix=%{_libdir}/%{name}
221 %{__make}
222 %endif
223
224 %install
225 rm -rf $RPM_BUILD_ROOT
226
227 %if %{with userspace}
228 %{__make} install \
229         DESTDIR=$RPM_BUILD_ROOT
230
231 install -d $RPM_BUILD_ROOT/sbin
232 cat <<'EOF' > $RPM_BUILD_ROOT/sbin/qemu-ifup
233 #!/bin/sh
234 if [ -f /etc/sysconfig/qemu ]; then
235         . /etc/sysconfig/qemu
236 fi
237 # of course this will work only for one interface. a lot possible to involve
238 sudo /sbin/ifconfig $1 ${INTERFACE_ADDR:-172.20.0.1}
239 EOF
240 %endif
241
242 %if %{with kernel}
243 %install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
244 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
245 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
246 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
247 %endif
248
249 # already packaged
250 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
251
252 %clean
253 rm -rf $RPM_BUILD_ROOT
254
255 %if %{with kernel}
256 %post
257 %banner %{name} -e <<EOF
258 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
259 modprobe kqemu
260 EOF
261 %endif
262
263 %post   -n kernel%{_alt_kernel}-misc-kqemu
264 %depmod %{_kernel_ver}
265
266 %postun -n kernel%{_alt_kernel}-misc-kqemu
267 %depmod %{_kernel_ver}
268
269 %if %{with userspace}
270 %files
271 %defattr(644,root,root,755)
272 %doc README qemu-doc.html qemu-tech.html
273 %attr(755,root,root) /sbin/qemu-ifup
274 %attr(755,root,root) %{_bindir}/*
275 %{_datadir}/qemu
276 %{_mandir}/man1/qemu.1*
277 %{_mandir}/man1/qemu-img.1*
278 %endif
279
280 %if %{with kernel}
281 %files -n kernel%{_alt_kernel}-misc-kqemu
282 %defattr(644,root,root,755)
283 %doc kqemu-%{_kqemu_version}/LICENSE
284 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
285 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
286 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
287 %endif
This page took 1.314792 seconds and 4 git commands to generate.