]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- add grsec_kernel bcond
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4 #
5 # Conditional build:
6 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
7 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
8 %bcond_with     dosguest                # add special patch when use with DOS as guest os
9 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
10 # Note that gcc4 build is very problematic and not supported by qemu team
11 %bcond_without  gcc4                    # use gcc4 patches (broke build on gcc33)
12 %bcond_without  dist_kernel             # without distribution kernel
13 %bcond_without  kernel                  # build kqemu KERNEL MODULES
14 %bcond_without  userspace               # don't build userspace
15 %bcond_with     grsec_kernel    # build for kernel-grsecurity
16 #
17 %if %{with kernel} && %{with dist_kernel} && %{with grsec_kernel}
18 %define alt_kernel      grsecurity
19 %endif
20
21 # no kqemu for ppc
22 %ifarch ppc
23 %undefine       with_kqemu
24 %undefine       with_kernel
25 %endif
26 %define _kqemu_version  1.3.0pre11
27 %define         _rel    2
28 Summary:        QEMU CPU Emulator
29 Summary(pl.UTF-8):      QEMU - emulator procesora
30 Name:           qemu
31 Version:        0.9.0
32 Release:        %{_rel}%{?with_kqemu:k}
33 License:        GPL
34 Group:          Applications/Emulators
35 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
36 Source0:        http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
37 # Source0-md5:  ab11a03ba30cf4a70641f0f170473d69
38 Source1:        http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
39 # Source1-md5:  970521874ef8b1ba4598925ace5936c3
40 Patch0:         %{name}-nostatic.patch
41 Patch1:         %{name}-cc.patch
42 Patch3:         %{name}-dot.patch
43 Patch4:         %{name}-gcc4_x86.patch
44 Patch5:         %{name}-gcc4_ppc.patch
45 Patch6:         %{name}-nosdlgui.patch
46 # Proof of concept, for reference, do not remove
47 Patch8:         %{name}-kde_virtual_workspaces_hack.patch
48 # http://gwenole.beauchesne.info/en/projects/qemu
49 Patch9:         %{name}-0.8.0-gcc4-hacks.patch
50 Patch11:        %{name}-0.7.2-gcc4-opts.patch
51 #Patch12:       %{name}-0.7.2-dyngen-check-stack-clobbers.patch
52 Patch13:        %{name}-dosguest.patch
53 URL:            http://fabrice.bellard.free.fr/qemu/
54 %if %{with kernel} && %{with dist_kernel}
55 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
56 BuildRequires:  rpmbuild(macros) >= 1.379
57 %endif
58 %if %{with userspace}
59 BuildRequires:  SDL-devel >= 1.2.1
60 BuildRequires:  alsa-lib-devel
61 %{!?with_gcc4:BuildRequires:    gcc < 5:4.0}
62 BuildRequires:  perl-tools-pod
63 BuildRequires:  tetex
64 BuildRequires:  sed >= 4.0
65 %endif
66 Requires:       SDL >= 1.2.1
67 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
68 ExclusiveArch:  %{ix86} %{x8664} ppc
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 # some SPARC boot image in ELF format
72 %define         _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
73
74 %description
75 QEMU is a FAST! processor emulator. By using dynamic translation it
76 achieves a reasonnable speed while being easy to port on new host
77 CPUs. QEMU has two operating modes:
78
79 - User mode emulation. In this mode, QEMU can launch Linux processes
80   compiled for one CPU on another CPU. Linux system calls are converted
81   because of endianness and 32/64 bit mismatches. Wine (Windows
82   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
83
84 - Full system emulation. In this mode, QEMU emulates a full system,
85   including a processor and various peripherials. It can also be used to
86   provide virtual hosting of several virtual PC on a single server.
87
88 %description -l pl.UTF-8
89 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
90 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
91 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
92
93 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
94   procesy linuksowe skompilowane dla jednego procesora na innym
95   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
96   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
97   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
98   cele QEMU.
99
100 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
101   włączając w to procesor i różne urządzenia peryferyjne. Może być także
102   używane do wirtualnego hostowania kilku wirtualnych pecetów na
103   pojedynczym serwerze.
104
105 %package -n kernel%{_alt_kernel}-misc-kqemu
106 Summary:        kqemu - kernel module
107 Summary(pl.UTF-8):      kqemu - moduł jądra
108 Version:        %{_kqemu_version}
109 Release:        %{_rel}@%{_kernel_ver_str}
110 Group:          Base/Kernel
111 %{?with_dist_kernel:%requires_releq_kernel}
112 License:        GPL v2
113 Obsoletes:      kernel%{_alt_kernel}-smp-misc-kqemu
114 Requires(post,postun):  /sbin/depmod
115 Requires:       module-init-tools >= 3.2.2-2
116
117 %description -n kernel%{_alt_kernel}-misc-kqemu
118 kqemu - kernel module.
119
120 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
121 kqemu - moduł jądra.
122
123 %prep
124 %if %{without kernel} && %{without dist_kernel}
125 %{error:%{name}: If building kernel module You need to enable at least one of up or smp}
126 exit 1
127 %endif
128
129 %setup -q %{?with_kernel:-a1}
130 %patch0 -p1
131 %patch1 -p1
132 %patch3 -p1
133 %if %{with gcc4}
134 %patch9 -p1
135 %patch11 -p1
136 #%patch12 -p1
137 #%patch4 -p0
138 %patch5 -p1
139 %endif
140 %{?with_nosdlgui:%patch6 -p1}
141 #%patch8 -p1
142
143 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
144 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
145
146 # cannot use optflags on x86 - they cause "no register to spill" errors
147 %if %{with cflags_passing}
148 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
149 %else
150 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
151 %endif
152
153 %if %{with kernel}
154 echo -n > kqemu-%{_kqemu_version}/install.sh
155
156 cat <<'EOF' > modprobe.conf
157 # enable dynamic major
158 options kqemu major=0
159 # for autoloading from static dev
160 #alias char-major-250 kqemu
161 EOF
162
163 cat <<'EOF' > udev.conf
164 KERNEL=="kqemu", NAME="%k", MODE="0666"
165 EOF
166 %endif
167
168 %if %{with dosguest}
169 %patch13 -p1
170 %endif
171
172 %build
173 %if %{with kernel}
174 cd kqemu-%{_kqemu_version}
175
176 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
177 %ifarch %{x8664}
178 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
179 %{__make} -j1 -C common
180 mv -f kqemu-mod-x86_64.o{,.bin}
181 %else
182 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
183 %{__make} -j1 -C common
184 mv -f kqemu-mod-i386.o{,.bin}
185 %endif
186
187 mv -f kqemu-linux.c{,.orig}
188 cat > Makefile <<'EOF'
189 obj-m := kqemu.o
190 kqemu-objs:= kqemu-linux.o kqemu-mod.o
191
192 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
193         cp $< $@
194 EOF
195
196 %build_kernel_modules -m kqemu <<'EOF'
197 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
198         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
199                 kqemu-linux.c.orig > kqemu-linux.c
200 else
201         cat kqemu-linux.c.orig > kqemu-linux.c
202 fi
203 EOF
204 cd -
205 %endif
206
207 %if %{with userspace}
208 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
209 # they can be passed if the cflags_passing bcond is used
210 ./configure \
211         --prefix=%{_prefix} \
212         --cc="%{__cc}" \
213         --host-cc="%{__cc}" \
214         --make="%{__make}" \
215 %if %{with kqemu}
216         --kernel-path=%{_kernelsrcdir} \
217 %else
218         --disable-kqemu \
219 %endif
220         %{?with_gcc4:--disable-gcc-check} \
221         --enable-alsa \
222         --interp-prefix=%{_libdir}/%{name}
223 %{__make}
224 %endif
225
226 %install
227 rm -rf $RPM_BUILD_ROOT
228
229 %if %{with userspace}
230 %{__make} install \
231         DESTDIR=$RPM_BUILD_ROOT
232
233 install -d $RPM_BUILD_ROOT%{_sysconfdir}
234 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
235 #!/bin/sh
236
237 EOF
238 %endif
239
240 %if %{with kernel}
241 %install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
242 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
243 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
244 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
245 %endif
246
247 # already packaged
248 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
249
250 %clean
251 rm -rf $RPM_BUILD_ROOT
252
253 %if %{with kernel}
254 %post
255 %banner %{name} -e <<EOF
256 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
257 modprobe kqemu
258 EOF
259 %endif
260
261 %post   -n kernel%{_alt_kernel}-misc-kqemu
262 %depmod %{_kernel_ver}
263
264 %postun -n kernel%{_alt_kernel}-misc-kqemu
265 %depmod %{_kernel_ver}
266
267 %if %{with userspace}
268 %files
269 %defattr(644,root,root,755)
270 %doc README qemu-doc.html qemu-tech.html
271 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
272 %attr(755,root,root) %{_bindir}/*
273 %{_datadir}/qemu
274 %{_mandir}/man1/qemu.1*
275 %{_mandir}/man1/qemu-img.1*
276 %endif
277
278 %if %{with kernel}
279 %files -n kernel%{_alt_kernel}-misc-kqemu
280 %defattr(644,root,root,755)
281 %doc kqemu-%{_kqemu_version}/LICENSE
282 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
283 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
284 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
285 %endif
This page took 0.05951 seconds and 3 git commands to generate.