]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
- enable computed gotos (up to 20% speedup in some areas)
[packages/python3.git] / python3.spec
1 #
2 # TODO:
3 # - fix tests
4 # - check unpackaged files
5
6 # Conditional build:
7 %bcond_with     info                    # info pages (requires emacs)
8 %bcond_without  tkinter                 # disables tkinter module building
9 %bcond_without  tests                   # disables Python testing
10 %bcond_with     verbose_tests           # runs tests in verbose mode
11 #
12 # tests which will not work on 64-bit platforms
13 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
14 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16 # tests which fail because of some unknown/unresolved reason (this list should be empty)
17 %define         broken_tests test_httpservers
18
19 %define beta            %{nil}
20
21 %define py_ver          3.1
22 %define py_prefix       %{_prefix}
23 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
24 %define py_incdir       %{_includedir}/python%{py_ver}
25 %define py_sitedir      %{py_libdir}/site-packages
26 %define py_dyndir       %{py_libdir}/lib-dynload
27
28 Summary:        Very high level scripting language with X interface
29 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
30 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
31 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
32 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
33 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
34 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
35 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
36 Name:           python3
37 Version:        %{py_ver}
38 Release:        0.1
39 Epoch:          1
40 License:        PSF
41 Group:          Applications
42 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
43 # Source0-md5:  f64437a24d39f1917aa1878cc70621f6
44 Patch0:         %{name}-pythonpath.patch
45 Patch1:         %{name}-ac_fixes.patch
46 Patch2:         %{name}-lib64.patch
47 Patch3:         %{name}-noarch_to_datadir.patch
48 Patch4:         %{name}-cast-fix.patch
49 URL:            http://www.python.org/
50 BuildRequires:  autoconf
51 BuildRequires:  bluez-libs-devel
52 BuildRequires:  bzip2-devel
53 BuildRequires:  db-devel >= 4
54 %{?with_info:BuildRequires:     emacs >= 21}
55 BuildRequires:  expat-devel >= 1:1.95.7
56 BuildRequires:  file
57 BuildRequires:  gdbm-devel >= 1.8.3
58 BuildRequires:  gmp-devel >= 4.0
59 BuildRequires:  libffi-devel
60 BuildRequires:  libstdc++-devel
61 BuildRequires:  ncurses-ext-devel >= 5.2
62 BuildRequires:  openssl-devel >= 0.9.8
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-pythonprov
65 BuildRequires:  sed >= 4.0
66 BuildRequires:  sqlite3-devel >= 3.3.5
67 %{?with_info:BuildRequires:     tetex-makeindex}
68 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
69 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
70 BuildRequires:  zlib-devel
71 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         specflags_ppc   -D__ppc__=1
75 %define         specflags_ppc64 -D__ppc64__=1
76
77 %if %{with verbose_tests}
78 %define test_flags -v -l -x
79 %else
80 %define test_flags -l -x
81 %endif
82
83 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
84 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
85 %else
86 %define test_list %{nobuilder_tests} %{broken_tests}
87 %endif
88
89 %ifarch sparc
90 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
91 %endif
92
93 %description
94 Python is an interpreted, interactive, object-oriented programming
95 language. It incorporates modules, exceptions, dynamic typing, very
96 high level dynamic data types, and classes. Python combines remarkable
97 power with very clear syntax. It has interfaces to many system calls
98 and libraries, as well as to various window systems, and is extensible
99 in C or C++. It is also usable as an extension language for
100 applications that need a programmable interface. Finally, Python is
101 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
102 MS-DOS, Windows, Windows NT, and OS/2.
103
104 This package contains the Python binary.
105
106 %description -l de.UTF-8
107 Python ist eine interpretierte, interaktive, objektorientierte
108 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
109 Python enthält Module, Klassen, Exceptions, High-Level dynamische
110 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
111 zu vielen Systemaufrufen und Libraries, sowie verschiedene
112 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
113
114 Programmierer können neue built-in-Module für Python in C oder C++
115 schreiben. Python kann auch als Erweiterungssprache für Applikationen
116 benutzt werden, die ein programmierbares Interface brauchen. Dieses
117 Paket enthält die meisten Standard-Python-Module, und Module zum
118 Ansprechen von Tix (Tk-widget set) und RPM.
119
120 %description -l es.UTF-8
121 Python es un lenguaje de scripts interpretado orientado a objetos.
122 Contiene soporte para carga dinámica de objetos, clases, módulos y
123 excepciones.
124
125 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
126 través de código C, tornando Python fácil de usar en ambientes
127 particulares/personalizados. Este paquete Python incluye la mayoría de
128 los módulos padrón Python, junto con módulos para crear interfaces
129 para el conjunto de componentes Tix para Tk y RPM.
130
131 %description -l fr.UTF-8
132 Python est un langage de script interprété et orienté objet. Il gère
133 le chargement dynamique des objets, les classes, les modules et les
134 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
135 avec du code C est simple, ce qui rend Python facile à utiliser dans
136 des configs personnalisées.
137
138 Ce paquetage Python contient la plupart des modules Python standards,
139 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
140 et RPM.
141
142 %description -l pl.UTF-8
143 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
144 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
145 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
146 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
147 wielu wywołań systemowych i bibliotek, w tym również do różnych
148 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
149 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
150 użyty jako element aplikacji, którym potrzebny jest interpreter do
151 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
152 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
153 OS/2.
154
155 Ten pakiet zawiera binarkę Pythona.
156
157 %description -l pt_BR.UTF-8
158 Python é uma linguagem de scripts interpretada orientada a objetos.
159 Contém suporte para carga dinâmica de objetos, classes, módulos e
160 exceções. Adicionar interfaces para novos sistemas de biblioteca
161 através de código C é simples, tornando Python fácil de usar em
162 ambientes particulares/personalizados.
163
164 Este pacote Python inclui a maioria do módulos padrão Python, junto
165 com módulos para interfaceamento para o conjunto de componentes Tix
166 para Tk e RPM.
167
168 %description -l ru.UTF-8
169 Python - это интерпретируемый, объектно-ориентированный язык
170 программирования. Он поддерживает динамическую загрузку объектов,
171 классы, модули и обработку исключительных ситуаций (exceptions).
172 Простота добавления интерфейсов к новым системным библиотекам через
173 код на языке C делает Python хорошим выбором для использования в
174 специальных конфигурациях.
175
176 %description -l tr.UTF-8
177 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
178 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
179 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
180 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
181 arayüz birimlerini de içerir.
182
183 %description -l uk.UTF-8
184 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
185 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
186 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
187 нових системних бібліотек через код на мові C робить Python добрим
188 вибором для використання в спеціальних конфігураціях.
189
190 %package libs
191 Summary:        Python library
192 Summary(pl.UTF-8):      Biblioteka języka Python
193 Group:          Libraries/Python
194 # broken detection in rpm/pythondeps.sh
195 Provides:       python(abi) = %{py_ver}
196 # for compatibility with existing Ac packages
197 Provides:       python(bytecode) = %{py_ver}
198 %{!?with_info:Obsoletes:        python3-doc-info}
199
200 %description libs
201 Python shared library and very essental modules for Python binary.
202
203 %description libs -l pl.UTF-8
204 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
205 dla Pythona.
206
207 %package modules
208 Summary:        Python modules
209 Summary(pl.UTF-8):      Moduły języka Python
210 Group:          Libraries/Python
211 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
212
213 %description modules
214 Python officially distributed modules.
215
216 %description modules -l pl.UTF-8
217 Oficjalnie rozprowadzane moduły języka Python.
218
219 %package modules-sqlite
220 Summary:        Python SQLite modules
221 Summary(pl.UTF-8):      Moduły SQLite języka Python
222 Group:          Libraries/Python
223 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
224
225 %description modules-sqlite
226 Python officially distributed sqlite module.
227
228 %description modules-sqlite -l pl.UTF-8
229 Oficjalnie rozprowadzany moduł sqlite języka Python.
230
231 %package -n pydoc3
232 Summary:        Python interactive module documentation access support
233 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
234 Group:          Applications
235 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
236
237 %description -n pydoc3
238 Python interactive module documentation access support.
239
240 %description -n pydoc3 -l pl.UTF-8
241 Interaktywne korzystanie z dokumentacji modułów języka Python.
242
243 %package -n idle3
244 Summary:        IDE for Python language
245 Summary(pl.UTF-8):      IDE dla języka Python
246 Group:          Applications
247 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
248
249 %description -n idle3
250 IDE for Python language.
251
252 %description -n idle3 -l pl.UTF-8
253 IDE dla języka Python.
254
255 %package devel
256 Summary:        Libraries and header files for building python code
257 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
258 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
259 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
260 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
261 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
262 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
263 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
264 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
265 Group:          Development/Languages/Python
266 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
267
268 %description devel
269 The Python interpreter is relatively easy to extend with dynamically
270 loaded extensions and to embed in other programs. This package
271 contains the header files and libraries which are needed to do both of
272 these tasks.
273
274 %description devel -l de.UTF-8
275 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
276 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
277 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
278 die für beide Aufgaben erforderlich sind.
279
280 %description devel -l es.UTF-8
281 El interpretador Python permite incluir con facilidad extensiones
282 cargadas dinámicamente. Python es también fácil de ser empotrado en
283 otros programas. Este paquete contiene los archivos de inclusión y
284 bibliotecas necesarios para estas dos tareas.
285
286 %description devel -l fr.UTF-8
287 L'interpréteur Python est relativement facile à étendre avec des
288 extensions chargées dynamiquement et à insérer dans d'autres
289 programmes. Ce paquetage contient les en-têtes et les bibliothèques
290 nécessaires à ces deux tâches.
291
292 %description devel -l pl.UTF-8
293 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
294 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
295 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
296 wszystko inne co potrzebne do tych celów.
297
298 %description devel -l pt_BR.UTF-8
299 O interpretador Python permite incluir com facilidade extensões
300 carregadas dinamicamente. Python é também fácil de ser embutido em
301 outros programas. Este pacote contém os arquivos de inclusão e
302 bibliotecas necessários para estas duas tarefas.
303
304 %description devel -l ru.UTF-8
305 Интерпретатор Python относительно легко расширяется при помощи
306 динамически загружаемых расширений и встраивается в другие программы.
307 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
308 задач.
309
310 %description devel -l tr.UTF-8
311 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
312 dosyalarını ve kitaplıkları içerir.
313
314 %description devel -l uk.UTF-8
315 Інтерпретатор Python відносно легко розширюється за допомогою
316 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
317 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
318
319 %package devel-src
320 Summary:        Python module sources
321 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
322 Group:          Development/Languages/Python
323 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
324
325 %description devel-src
326 Python module sources.
327
328 %description devel-src -l pl.UTF-8
329 Pliki źródłowe modułów Pythona.
330
331 %package devel-tools
332 Summary:        Python development tools
333 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
334 Group:          Development/Languages/Python
335 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
336
337 %description devel-tools
338 Python development tools such as profilers and debugger.
339
340 %description devel-tools -l pl.UTF-8
341 Narzędzia programistyczne języka Python takie jak profiler oraz
342 debugger.
343
344 %package 2to3
345 Summary:        Automated Python 2 to 3 code translation
346 Summary(pl.UTF-8):      Automatyczne tłumaczenie kody Pythona 2 do 3
347 Group:          Development/Languages/Pythona
348
349 %description 2to3
350 2to3 is a Python program that reads Python 2.x source code and applies a series
351 of fixers to transform it into valid Python 3.x code. The standard library
352 contains a rich set of fixers that will handle almost all code. 2to3 supporting
353 library lib2to3 is, however, a flexible and generic library, so it is possible
354 to write your own fixers for 2to3. lib2to3 could also be adapted to custom
355 applications in which Python code needs to be edited automatically.
356
357 %package static
358 Summary:        Static python library
359 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
360 Group:          Development/Languages/Python
361 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
362
363 %description static
364 Static python library.
365
366 %description static -l pl.UTF-8
367 Statyczna biblioteka Pythona.
368
369 %package doc
370 Summary:        Documentation on Python
371 Summary(de.UTF-8):      Dokumentation zu Python
372 Summary(es.UTF-8):      Documentación para Python
373 Summary(fr.UTF-8):      Documentation sur Python
374 Summary(pl.UTF-8):      Dokumentacja do Pythona
375 Summary(pt_BR.UTF-8):   Documentação para a linguagem de programação Python
376 Summary(ru.UTF-8):      Документация по языку Python
377 Summary(tr.UTF-8):      Python belgeleri
378 Summary(uk.UTF-8):      Документація по мові Python
379 Group:          Documentation
380
381 %description doc
382 This package contains documentation on the Python language and
383 interpretor as a mix of plain ASCII files and LaTeX sources.
384
385 %description doc -l de.UTF-8
386 Dieses Paket enthält Dokumentationen zu Python (Sprache und
387 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
388
389 %description doc -l es.UTF-8
390 Documentación para Python. Contiene archivos en texto y PostScript.
391
392 %description doc -l fr.UTF-8
393 Ce paquetage contient la documentation sur le langage python et sur
394 son interpréteur sous forme de fichiers ASCII et LaTeX.
395
396 %description doc -l pl.UTF-8
397 Oficjalna dokumentacja do Pythona. Zawiera przykładowe programy,
398 narzędzia i dokumentację. Strony podręcznika man znajdują się w
399 głównym pakiecie. Ten pakiet nie zawiera źródeł dokumentacji
400 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
401 i HTML.
402
403 %description doc -l pt_BR.UTF-8
404 O pacote python-doc contém documentação para a linguagem de
405 programação e para o interpretador Python. Fornecida em arquivos texto
406 e Postcript.
407
408 %description doc -l ru.UTF-8
409 Этот пакет содержит документацию по собственно языку Python и по
410 исполняющему его интерпретатору в виде набора текстовых файлов и
411 исходных текстов в формате LaTeX.
412
413 %description doc -l tr.UTF-8
414 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyaları ve
415 LaTeX kaynaklarının bir karışımı olan yorumlayıcıyı içerir.
416
417 %description doc -l uk.UTF-8
418 Цей пакет містить документацію по власне мові Python та по виконуючому
419 її інтерпретатору у вигляді набора текстових файлів та вихідних
420 текстів у форматі LaTeX.
421
422 %package doc-info
423 Summary:        Documentation on Python in texinfo format
424 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
425 Group:          Documentation
426
427 %description doc-info
428 Documentation on Python in texinfo format.
429
430 %description doc-info -l pl.UTF-8
431 Dokumentacja do Pythona w formacie texinfo.
432
433 %package tkinter
434 Summary:        Standard Python interface to the Tk GUI toolkit
435 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
436 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
437 Summary(fr.UTF-8):      Interface graphique Tk pour Python
438 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
439 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
440 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
441 Group:          Libraries/Python
442 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
443 Requires:       tcl >= 8.4.3
444 Requires:       tix >= 1:8.1.4-4
445 Requires:       tk >= 8.4.3
446
447 %description tkinter
448 Standard Python interface to the Tk GUI toolkit.
449
450 %description tkinter -l de.UTF-8
451 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
452 vielen Konfigurations-Tools genutzt.
453
454 %description tkinter -l es.UTF-8
455 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
456 herramientas de configuración.
457
458 %description tkinter -l fr.UTF-8
459 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
460 beaucoup des outils de configuration.
461
462 %description tkinter -l pl.UTF-8
463 Standardowy interfejs Pythona do biblioteki Tk.
464
465 %description tkinter -l pt_BR.UTF-8
466 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
467 muitas ferramentas de configuração.
468
469 %description tkinter -l ru.UTF-8
470 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
471
472 %description tkinter -l tr.UTF-8
473 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
474 kullanılan grafik bir arayüzdür.
475
476 %description tkinter -l uk.UTF-8
477 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
478
479 %package examples
480 Summary:        Example programs in Python
481 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
482 Group:          Development/Languages/Python
483
484 %description examples
485 Example programs in Python.
486
487 These are for Python 2.3.4, not %{version}.
488
489 %description examples -l pl.UTF-8
490 Przykładowe programy w Pythonie.
491
492 Przykłady te są dla Pythona 2.3.4, nie %{version}.
493
494 %prep
495 %setup -q -n Python-%{version}%{beta}
496 %patch0 -p1
497 %patch1 -p1
498 %patch2 -p1
499 %patch3 -p1
500 %patch4 -p1
501 sed -i -e 's=@EXENAME@=%{_bindir}/python3=' Misc/python-config.in
502
503 %build
504 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
505 %{__autoconf}
506 CPPFLAGS="-I/usr/include/ncursesw"; export CPPFLAGS
507 %configure \
508         --with-cxx-main="%{__cxx}" \
509         --enable-shared \
510         --enable-ipv6 \
511         --with-computed-gotos \
512         --with-dbmliborder=gdbm:bdb \
513         --with-wide-unicode \
514         --with-signal-module \
515         --with-tsc \
516         --with-threads \
517         --with-doc-strings \
518         --with-fpectl \
519         --with-system-ffi \
520         LINKCC='$(PURIFY) $(CXX)' \
521         LDSHARED='$(CC) $(CFLAGS) -shared' \
522         BLDSHARED='$(CC) $(CFLAGS) -shared' \
523         LDFLAGS="%{rpmcflags} %{rpmldflags}"
524
525 %{__make} \
526         OPT="%{rpmcflags}" 2>&1 | awk '
527 BEGIN { fail = 0; logmsg = ""; }
528 {
529         if ($0 ~ /\*\*\* WARNING:/) {
530                 fail = 1;
531                 logmsg = logmsg $0;
532         }
533         print $0;
534 }
535 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
536
537 LC_ALL=C
538 export LC_ALL
539 %if %{with tests}
540 binlibdir=`echo build/lib.*`
541 %{__make} test \
542         TESTOPTS="%{test_flags} %{test_list}" \
543         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
544 %endif
545
546 %install
547 rm -rf $RPM_BUILD_ROOT
548 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
549         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
550         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
551         $RPM_BUILD_ROOT%{_infodir} \
552         $RPM_BUILD_ROOT/etc/shrc.d
553
554 %{__make} install \
555         DESTDIR=$RPM_BUILD_ROOT
556
557 %if %{with info}
558 %{__make} -C Doc/info
559 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
560 %endif
561
562 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
563
564 mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
565 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
566 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
567
568 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
569 cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
570
571 #
572 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
573 #
574
575 # for python devel tools
576 for script in timeit profile pdb pstats; do
577     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
578 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
579
580 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
581         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
582
583 sed 's/=/ /' \
584         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
585         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
586
587 # for python modules
588 for script in smtpd webbrowser; do
589     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
590 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
591
592 sed 's/=/ /' \
593         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
594         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
595
596 # xgettext specific for Python code
597 #
598 # we will have two commands: pygettext.py (an alias) and pygettext;
599 # this way there are no import (which is impossible now) conflicts and
600 # pygettext.py is provided for compatibility
601 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
602
603 # just to cut the noise, as they are not packaged (now)
604 # first tests
605 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
606 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
607 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
608 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
609 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
610 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
611 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
612 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
613
614 # other files
615 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
616 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
617 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
618 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
619 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
620 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
621 rm -rf $RPM_BUILD_ROOT%{_bindir}/smtpd.py
622 # already in %%doc
623 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
624 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
625
626 %clean
627 rm -rf $RPM_BUILD_ROOT
628
629 %post   libs -p /sbin/ldconfig
630 %postun libs -p /sbin/ldconfig
631
632 %post doc-info  -p      /sbin/postshell
633 -/usr/sbin/fix-info-dir -c %{_infodir}
634
635 %postun doc-info        -p      /sbin/postshell
636 -/usr/sbin/fix-info-dir -c %{_infodir}
637
638 %files
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_bindir}/python%{py_ver}
641 %attr(755,root,root) %{_bindir}/python3
642 %{_mandir}/man1/python*.1*
643
644 %files modules
645 %defattr(644,root,root,755)
646 /etc/shrc.d/python*-modules*
647 %exclude %{py_scriptdir}/_abcoll.py[co]
648 %exclude %{py_scriptdir}/_weakrefset.py[co]
649 %exclude %{py_scriptdir}/abc.py[co]
650 %exclude %{py_scriptdir}/codecs.py[co]
651 %exclude %{py_scriptdir}/copyreg.py[co]
652 %exclude %{py_scriptdir}/genericpath.py[co]
653 %exclude %{py_scriptdir}/io.py[co]
654 %exclude %{py_scriptdir}/locale.py[co]
655 %exclude %{py_scriptdir}/posixpath.py[co]
656 %exclude %{py_scriptdir}/pdb.py[co]
657 %exclude %{py_scriptdir}/profile.py[co]
658 %exclude %{py_scriptdir}/pstats.py[co]
659 %exclude %{py_scriptdir}/pydoc.py[co]
660 %exclude %{py_scriptdir}/site.py[co]
661 %exclude %{py_scriptdir}/stat.py[co]
662 %exclude %{py_scriptdir}/timeit.py[co]
663 %exclude %{py_scriptdir}/os.py[co]
664 %exclude %{py_scriptdir}/encodings/*.py[co]
665 %exclude %{py_scriptdir}/types.py[co]
666
667 %{py_scriptdir}/*.py[co]
668
669 %{py_dyndir}/*.egg-info
670
671 #
672 # list .so modules to be sure that all of them are built
673 #
674
675 # modules below do not work on 64-bit architectures
676 # see Python README file for explanation
677 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
678 %attr(755,root,root) %{py_dyndir}/audioop.so
679 %endif
680
681 %attr(755,root,root) %{py_dyndir}/array.so
682 %attr(755,root,root) %{py_dyndir}/atexit.so
683 %attr(755,root,root) %{py_dyndir}/audioop.so
684 %attr(755,root,root) %{py_dyndir}/binascii.so
685 %attr(755,root,root) %{py_dyndir}/_bisect.so
686 %attr(755,root,root) %{py_dyndir}/bz2.so
687 %attr(755,root,root) %{py_dyndir}/cmath.so
688 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
689 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
690 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
691 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
692 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
693 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
694 %attr(755,root,root) %{py_dyndir}/_collections.so
695 %attr(755,root,root) %{py_dyndir}/crypt.so
696 %attr(755,root,root) %{py_dyndir}/_csv.so
697 %attr(755,root,root) %{py_dyndir}/_ctypes*.so
698 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
699 %attr(755,root,root) %{py_dyndir}/_curses.so
700 %attr(755,root,root) %{py_dyndir}/datetime.so
701 %attr(755,root,root) %{py_dyndir}/_elementtree.so
702 #%attr(755,root,root) %{py_dyndir}/_functools.so
703 %attr(755,root,root) %{py_dyndir}/_hashlib.so
704 %attr(755,root,root) %{py_dyndir}/_heapq.so
705 %attr(755,root,root) %{py_dyndir}/_json.so
706 #%attr(755,root,root) %{py_dyndir}/_locale.so
707 %attr(755,root,root) %{py_dyndir}/_lsprof.so
708 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
709 %attr(755,root,root) %{py_dyndir}/_multiprocessing.so
710 %attr(755,root,root) %{py_dyndir}/_pickle.so
711 %attr(755,root,root) %{py_dyndir}/_random.so
712 %attr(755,root,root) %{py_dyndir}/_socket.so
713 %attr(755,root,root) %{py_dyndir}/_ssl.so
714 %attr(755,root,root) %{py_dyndir}/_testcapi.so
715 %ifnarch sparc64
716 %attr(755,root,root) %{py_dyndir}/_dbm.so
717 %endif
718 %attr(755,root,root) %{py_dyndir}/fcntl.so
719 %attr(755,root,root) %{py_dyndir}/_gdbm.so
720 %attr(755,root,root) %{py_dyndir}/grp.so
721 %attr(755,root,root) %{py_dyndir}/itertools.so
722 %attr(755,root,root) %{py_dyndir}/math.so
723 %attr(755,root,root) %{py_dyndir}/mmap.so
724 %attr(755,root,root) %{py_dyndir}/nis.so
725 %attr(755,root,root) %{py_dyndir}/operator.so
726 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
727 %attr(755,root,root) %{py_dyndir}/parser.so
728 %attr(755,root,root) %{py_dyndir}/pyexpat.so
729 %attr(755,root,root) %{py_dyndir}/readline.so
730 %attr(755,root,root) %{py_dyndir}/resource.so
731 %attr(755,root,root) %{py_dyndir}/select.so
732 %attr(755,root,root) %{py_dyndir}/syslog.so
733 %attr(755,root,root) %{py_dyndir}/termios.so
734 %attr(755,root,root) %{py_dyndir}/time.so
735 %attr(755,root,root) %{py_dyndir}/spwd.so
736 %attr(755,root,root) %{py_dyndir}/unicodedata.so
737 %attr(755,root,root) %{py_dyndir}/zlib.so
738
739 %dir %{py_scriptdir}/plat-*
740 %{py_scriptdir}/plat-*/*.py[co]
741
742 %dir %{py_scriptdir}/ctypes
743 %dir %{py_scriptdir}/ctypes/macholib
744
745 %{py_scriptdir}/ctypes/*.py[co]
746 %{py_scriptdir}/ctypes/macholib/*.py[co]
747 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
748
749 %dir %{py_scriptdir}/curses
750 %{py_scriptdir}/curses/*.py[co]
751
752 %dir %{py_scriptdir}/dbm
753 %{py_scriptdir}/dbm/*.py[co]
754
755 %dir %{py_scriptdir}/distutils
756 %dir %{py_scriptdir}/distutils/command
757 %doc %{py_scriptdir}/distutils/README
758 %{py_scriptdir}/distutils/*.py[co]
759 %{py_scriptdir}/distutils/command/*.py[co]
760 %{py_scriptdir}/distutils/command/command_template
761
762 %dir %{py_scriptdir}/email
763 %dir %{py_scriptdir}/email/mime
764 %{py_scriptdir}/email/*.py[co]
765 %{py_scriptdir}/email/mime/*.py[co]
766
767 %dir %{py_scriptdir}/html
768 %{py_scriptdir}/html/*.py[co]
769
770 %dir %{py_scriptdir}/http
771 %{py_scriptdir}/http/*.py[co]
772
773 %dir %{py_scriptdir}/json
774 %{py_scriptdir}/json/*.py[co]
775
776 %dir %{py_scriptdir}/logging
777 %{py_scriptdir}/logging/*.py[co]
778
779 %dir %{py_scriptdir}/multiprocessing
780 %{py_scriptdir}/multiprocessing/*.py[co]
781 %dir %{py_scriptdir}/multiprocessing/dummy
782 %{py_scriptdir}/multiprocessing/dummy/*.py[co]
783
784 %dir %{py_scriptdir}/urllib
785 %{py_scriptdir}/urllib/*.py[co]
786
787 %dir %{py_scriptdir}/wsgiref
788 %{py_scriptdir}/wsgiref/*.py[co]
789 %{py_scriptdir}/wsgiref.egg-info
790
791 %dir %{py_scriptdir}/xml
792 %dir %{py_scriptdir}/xml/dom
793 %dir %{py_scriptdir}/xml/etree
794 %dir %{py_scriptdir}/xml/parsers
795 %dir %{py_scriptdir}/xml/sax
796 %{py_scriptdir}/xml/*.py[co]
797 %{py_scriptdir}/xml/dom/*.py[co]
798 %{py_scriptdir}/xml/etree/*.py[co]
799 %{py_scriptdir}/xml/parsers/*.py[co]
800 %{py_scriptdir}/xml/sax/*.py[co]
801
802 %dir %{py_scriptdir}/xmlrpc
803 %{py_scriptdir}/xmlrpc/*.py[co]
804
805 %files modules-sqlite
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
808 %dir %{py_scriptdir}/sqlite3
809 %{py_scriptdir}/sqlite3/*.py[co]
810
811 %files libs
812 %defattr(644,root,root,755)
813 %doc LICENSE
814 %attr(755,root,root) %{_libdir}/libpython*.so.*
815
816 %dir %{py_dyndir}
817 %dir %{py_scriptdir}
818 %dir %{py_libdir}
819 %dir %{py_sitescriptdir}
820 %dir %{py_sitedir}
821
822 # shared modules required by python library
823 %attr(755,root,root) %{py_dyndir}/_struct.so
824
825 # modules required by python library
826 %{py_scriptdir}/_abcoll.py[co]
827 %{py_scriptdir}/_weakrefset.py[co]
828 %{py_scriptdir}/abc.py[co]
829 %{py_scriptdir}/codecs.py[co]
830 %{py_scriptdir}/copyreg.py[co]
831 %{py_scriptdir}/genericpath.py[co]
832 %{py_scriptdir}/locale.py[co]
833 %{py_scriptdir}/io.py[co]
834 %{py_scriptdir}/posixpath.py[co]
835 %{py_scriptdir}/site.py[co]
836 %{py_scriptdir}/stat.py[co]
837 %{py_scriptdir}/os.py[co]
838 # needed by the dynamic sys.lib patch
839 %{py_scriptdir}/types.py[co]
840
841 # encodings required by python library
842 %dir %{py_scriptdir}/encodings
843 %{py_scriptdir}/encodings/*.py[co]
844
845 %files -n pydoc3
846 %defattr(644,root,root,755)
847 %attr(755,root,root) %{_bindir}/pydoc3
848 %{py_scriptdir}/pydoc.py[co]
849
850 %files -n idle3
851 %defattr(644,root,root,755)
852 %attr(755,root,root) %{_bindir}/idle3
853 %dir %{py_scriptdir}/idlelib
854 %dir %{py_scriptdir}/idlelib/Icons
855 %{py_scriptdir}/idlelib/*.py[co]
856 %doc %{py_scriptdir}/idlelib/*.txt
857 %doc %{py_scriptdir}/idlelib/ChangeLog
858 %{py_scriptdir}/idlelib/Icons/*
859 %{py_scriptdir}/idlelib/*.def
860
861 %files devel
862 %defattr(644,root,root,755)
863 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
864 %attr(755,root,root) %{_bindir}/python*-config
865 %attr(755,root,root) %{_libdir}/lib*.so
866 %dir %{py_incdir}
867 %{py_incdir}/*.h
868
869 %dir %{py_libdir}/config
870 %attr(755,root,root) %{py_libdir}/config/makesetup
871 %attr(755,root,root) %{py_libdir}/config/install-sh
872 %{py_libdir}/config/Makefile
873 %{py_libdir}/config/Makefile.pre.in
874 %{py_libdir}/config/Setup
875 %{py_libdir}/config/Setup.config
876 %{py_libdir}/config/Setup.local
877 %{py_libdir}/config/config.c
878 %{py_libdir}/config/config.c.in
879 %{py_libdir}/config/python.o
880
881 %files devel-src
882 %defattr(644,root,root,755)
883 %attr(-,root,root) %{py_scriptdir}/*.py
884 %{py_scriptdir}/plat-*/*.py
885 %{py_scriptdir}/ctypes/*.py
886 %{py_scriptdir}/ctypes/macholib/*.py
887 %{py_scriptdir}/curses/*.py
888 %{py_scriptdir}/dbm/*.py
889 %{py_scriptdir}/distutils/*.py
890 %{py_scriptdir}/distutils/command/*.py
891 %{py_scriptdir}/email/*.py
892 %{py_scriptdir}/email/mime/*.py
893 %{py_scriptdir}/html/*.py
894 %{py_scriptdir}/http/*.py
895 %{py_scriptdir}/json/*.py
896 %{py_scriptdir}/lib2to3/*.py
897 %{py_scriptdir}/lib2to3/fixes/*.py
898 %{py_scriptdir}/lib2to3/pgen2/*.py
899 %{py_scriptdir}/logging/*.py
900 %{py_scriptdir}/multiprocessing/*.py
901 %{py_scriptdir}/multiprocessing/dummy/*.py
902 %{py_scriptdir}/sqlite3/*.py
903 %{py_scriptdir}/urllib/*.py
904 %{py_scriptdir}/wsgiref/*.py
905 %{py_scriptdir}/tkinter/*.py
906 %{py_scriptdir}/xml/*.py
907 %{py_scriptdir}/xml/dom/*.py
908 %{py_scriptdir}/xml/etree/*.py
909 %{py_scriptdir}/xml/parsers/*.py
910 %{py_scriptdir}/xml/sax/*.py
911 %{py_scriptdir}/xmlrpc/*.py
912 %{py_scriptdir}/encodings/*.py
913 %{py_scriptdir}/idlelib/*.py
914
915 %files devel-tools
916 %defattr(644,root,root,755)
917 %doc Lib/pdb.doc
918 /etc/shrc.d/python*-devel*
919
920 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
921
922 %{py_scriptdir}/pdb.py[co]
923 %{py_scriptdir}/profile.py[co]
924 %{py_scriptdir}/pstats.py[co]
925 %{py_scriptdir}/timeit.py[co]
926
927 %files 2to3
928 %attr(755,root,root) %{_bindir}/2to3
929 %dir %{py_scriptdir}/lib2to3
930 %{py_scriptdir}/lib2to3/*.txt
931 %{py_scriptdir}/lib2to3/*.pickle
932 %{py_scriptdir}/lib2to3/*.py[co]
933 %dir %{py_scriptdir}/lib2to3/fixes
934 %{py_scriptdir}/lib2to3/fixes/*.py[co]
935 %dir %{py_scriptdir}/lib2to3/pgen2
936 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
937
938 %files static
939 %defattr(644,root,root,755)
940 %{_libdir}/lib*.a
941
942 %files examples
943 %defattr(644,root,root,755)
944 %{_examplesdir}/%{name}-%{version}
945
946 %if %{with info}
947 %files doc-info
948 %defattr(644,root,root,755)
949 %{_infodir}/*.info*
950 %endif
951
952 %if %{with tkinter}
953 %files tkinter
954 %defattr(644,root,root,755)
955 %dir %{py_scriptdir}/tkinter
956 %{py_scriptdir}/tkinter/*.py[co]
957 %attr(755,root,root) %{py_dyndir}/_tkinter.so
958 %endif
This page took 2.254777 seconds and 4 git commands to generate.