]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
- added patch to fix bug 11254
[packages/python3.git] / python3.spec
1 #
2 # TODO:
3 # - fix tests
4 # - check unpackaged files
5
6 # Conditional build:
7 %bcond_with     info                    # info pages (requires emacs)
8 %bcond_without  tkinter                 # disables tkinter module building
9 %bcond_without  tests                   # disables Python testing
10 %bcond_with     verbose_tests           # runs tests in verbose mode
11 #
12 # tests which will not work on 64-bit platforms
13 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
14 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16 # tests which fail because of some unknown/unresolved reason (this list should be empty)
17 %define         broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib
18
19 %define py_ver          3.2
20 %define py_abi          %{py_ver}mu
21 %define py_prefix       %{_prefix}
22 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
23 %define py_incdir       %{_includedir}/python%{py_abi}
24 %define py_sitedir      %{py_libdir}/site-packages
25 %define py_dyndir       %{py_libdir}/lib-dynload
26
27 Summary:        Very high level scripting language with X interface
28 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
29 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
30 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
31 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
32 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
33 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
34 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
35 Name:           python3
36 Version:        %{py_ver}
37 Release:        0.3
38 Epoch:          1
39 License:        PSF
40 Group:          Applications
41 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
42 # Source0-md5:  563c0b4b8c8596e332cc076c4f013971
43 Patch0:         %{name}-pythonpath.patch
44 Patch1:         %{name}-ac_fixes.patch
45 Patch2:         %{name}-lib64.patch
46 Patch3:         %{name}-noarch_to_datadir.patch
47 Patch4:         %{name}-bug11254.patch
48 URL:            http://www.python.org/
49 BuildRequires:  autoconf
50 BuildRequires:  bluez-libs-devel
51 BuildRequires:  bzip2-devel
52 BuildRequires:  db-devel >= 4
53 %{?with_info:BuildRequires:     emacs >= 21}
54 BuildRequires:  expat-devel >= 1:1.95.7
55 BuildRequires:  file
56 BuildRequires:  gdbm-devel >= 1.8.3
57 BuildRequires:  gmp-devel >= 4.0
58 BuildRequires:  libffi-devel
59 BuildRequires:  libstdc++-devel
60 BuildRequires:  ncurses-ext-devel >= 5.2
61 BuildRequires:  openssl-devel >= 0.9.8
62 BuildRequires:  readline-devel >= 5.0
63 BuildRequires:  rpm-pythonprov
64 BuildRequires:  sed >= 4.0
65 BuildRequires:  sqlite3-devel >= 3.3.5
66 %{?with_info:BuildRequires:     tetex-makeindex}
67 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
68 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
69 BuildRequires:  zlib-devel
70 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %define         specflags_ppc   -D__ppc__=1
74 %define         specflags_ppc64 -D__ppc64__=1
75
76 %if %{with verbose_tests}
77 %define test_flags -v -l -x
78 %else
79 %define test_flags -w -l -x
80 %endif
81
82 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
83 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
84 %else
85 %define test_list %{nobuilder_tests} %{broken_tests}
86 %endif
87
88 %ifarch sparc
89 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
90 %endif
91
92 %description
93 Python is an interpreted, interactive, object-oriented programming
94 language. It incorporates modules, exceptions, dynamic typing, very
95 high level dynamic data types, and classes. Python combines remarkable
96 power with very clear syntax. It has interfaces to many system calls
97 and libraries, as well as to various window systems, and is extensible
98 in C or C++. It is also usable as an extension language for
99 applications that need a programmable interface. Finally, Python is
100 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
101 MS-DOS, Windows, Windows NT, and OS/2.
102
103 This package contains the Python binary.
104
105 %description -l de.UTF-8
106 Python ist eine interpretierte, interaktive, objektorientierte
107 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
108 Python enthält Module, Klassen, Exceptions, High-Level dynamische
109 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
110 zu vielen Systemaufrufen und Libraries, sowie verschiedene
111 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
112
113 Programmierer können neue built-in-Module für Python in C oder C++
114 schreiben. Python kann auch als Erweiterungssprache für Applikationen
115 benutzt werden, die ein programmierbares Interface brauchen. Dieses
116 Paket enthält die meisten Standard-Python-Module, und Module zum
117 Ansprechen von Tix (Tk-widget set) und RPM.
118
119 %description -l es.UTF-8
120 Python es un lenguaje de scripts interpretado orientado a objetos.
121 Contiene soporte para carga dinámica de objetos, clases, módulos y
122 excepciones.
123
124 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
125 través de código C, tornando Python fácil de usar en ambientes
126 particulares/personalizados. Este paquete Python incluye la mayoría de
127 los módulos padrón Python, junto con módulos para crear interfaces
128 para el conjunto de componentes Tix para Tk y RPM.
129
130 %description -l fr.UTF-8
131 Python est un langage de script interprété et orienté objet. Il gère
132 le chargement dynamique des objets, les classes, les modules et les
133 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
134 avec du code C est simple, ce qui rend Python facile à utiliser dans
135 des configs personnalisées.
136
137 Ce paquetage Python contient la plupart des modules Python standards,
138 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
139 et RPM.
140
141 %description -l pl.UTF-8
142 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
143 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
144 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
145 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
146 wielu wywołań systemowych i bibliotek, w tym również do różnych
147 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
148 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
149 użyty jako element aplikacji, którym potrzebny jest interpreter do
150 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
151 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
152 OS/2.
153
154 Ten pakiet zawiera binarkę Pythona.
155
156 %description -l pt_BR.UTF-8
157 Python é uma linguagem de scripts interpretada orientada a objetos.
158 Contém suporte para carga dinâmica de objetos, classes, módulos e
159 exceções. Adicionar interfaces para novos sistemas de biblioteca
160 através de código C é simples, tornando Python fácil de usar em
161 ambientes particulares/personalizados.
162
163 Este pacote Python inclui a maioria do módulos padrão Python, junto
164 com módulos para interfaceamento para o conjunto de componentes Tix
165 para Tk e RPM.
166
167 %description -l ru.UTF-8
168 Python - это интерпретируемый, объектно-ориентированный язык
169 программирования. Он поддерживает динамическую загрузку объектов,
170 классы, модули и обработку исключительных ситуаций (exceptions).
171 Простота добавления интерфейсов к новым системным библиотекам через
172 код на языке C делает Python хорошим выбором для использования в
173 специальных конфигурациях.
174
175 %description -l tr.UTF-8
176 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
177 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
178 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
179 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
180 arayüz birimlerini de içerir.
181
182 %description -l uk.UTF-8
183 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
184 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
185 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
186 нових системних бібліотек через код на мові C робить Python добрим
187 вибором для використання в спеціальних конфігураціях.
188
189 %package libs
190 Summary:        Python library
191 Summary(pl.UTF-8):      Biblioteka języka Python
192 Group:          Libraries/Python
193 # broken detection in rpm/pythondeps.sh
194 Provides:       python(abi) = %{py_ver}
195 # for compatibility with existing Ac packages
196 Provides:       python(bytecode) = %{py_ver}
197 %{!?with_info:Obsoletes:        python3-doc-info}
198
199 %description libs
200 Python shared library and very essental modules for Python binary.
201
202 %description libs -l pl.UTF-8
203 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
204 dla Pythona.
205
206 %package modules
207 Summary:        Python modules
208 Summary(pl.UTF-8):      Moduły języka Python
209 Group:          Libraries/Python
210 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
211 Obsoletes:      python3-modules-sqlite
212
213 %description modules
214 Python officially distributed modules.
215
216 %description modules -l pl.UTF-8
217 Oficjalnie rozprowadzane moduły języka Python.
218
219 %package -n pydoc3
220 Summary:        Python interactive module documentation access support
221 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
222 Group:          Applications
223 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
224
225 %description -n pydoc3
226 Python interactive module documentation access support.
227
228 %description -n pydoc3 -l pl.UTF-8
229 Interaktywne korzystanie z dokumentacji modułów języka Python.
230
231 %package -n idle3
232 Summary:        IDE for Python language
233 Summary(pl.UTF-8):      IDE dla języka Python
234 Group:          Applications
235 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
236
237 %description -n idle3
238 IDE for Python language.
239
240 %description -n idle3 -l pl.UTF-8
241 IDE dla języka Python.
242
243 %package devel
244 Summary:        Libraries and header files for building python code
245 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
246 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
247 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
248 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
249 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
250 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
251 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
252 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
253 Group:          Development/Languages/Python
254 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
255
256 %description devel
257 The Python interpreter is relatively easy to extend with dynamically
258 loaded extensions and to embed in other programs. This package
259 contains the header files and libraries which are needed to do both of
260 these tasks.
261
262 %description devel -l de.UTF-8
263 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
264 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
265 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
266 die für beide Aufgaben erforderlich sind.
267
268 %description devel -l es.UTF-8
269 El interpretador Python permite incluir con facilidad extensiones
270 cargadas dinámicamente. Python es también fácil de ser empotrado en
271 otros programas. Este paquete contiene los archivos de inclusión y
272 bibliotecas necesarios para estas dos tareas.
273
274 %description devel -l fr.UTF-8
275 L'interpréteur Python est relativement facile à étendre avec des
276 extensions chargées dynamiquement et à insérer dans d'autres
277 programmes. Ce paquetage contient les en-têtes et les bibliothèques
278 nécessaires à ces deux tâches.
279
280 %description devel -l pl.UTF-8
281 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
282 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
283 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
284 wszystko inne co potrzebne do tych celów.
285
286 %description devel -l pt_BR.UTF-8
287 O interpretador Python permite incluir com facilidade extensões
288 carregadas dinamicamente. Python é também fácil de ser embutido em
289 outros programas. Este pacote contém os arquivos de inclusão e
290 bibliotecas necessários para estas duas tarefas.
291
292 %description devel -l ru.UTF-8
293 Интерпретатор Python относительно легко расширяется при помощи
294 динамически загружаемых расширений и встраивается в другие программы.
295 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
296 задач.
297
298 %description devel -l tr.UTF-8
299 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
300 dosyalarını ve kitaplıkları içerir.
301
302 %description devel -l uk.UTF-8
303 Інтерпретатор Python відносно легко розширюється за допомогою
304 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
305 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
306
307 %package devel-src
308 Summary:        Python module sources
309 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
310 Group:          Development/Languages/Python
311 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
312
313 %description devel-src
314 Python module sources.
315
316 %description devel-src -l pl.UTF-8
317 Pliki źródłowe modułów Pythona.
318
319 %package devel-tools
320 Summary:        Python development tools
321 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
322 Group:          Development/Languages/Python
323 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
324
325 %description devel-tools
326 Python development tools such as profilers and debugger.
327
328 %description devel-tools -l pl.UTF-8
329 Narzędzia programistyczne języka Python takie jak profiler oraz
330 debugger.
331
332 %package 2to3
333 Summary:        Automated Python 2 to 3 code translation
334 Summary(pl.UTF-8):      Automatyczne tłumaczenie kodu Pythona 2 do 3
335 Group:          Development/Languages/Pythona
336
337 %description 2to3
338 2to3 is a Python program that reads Python 2.x source code and applies
339 a series of fixers to transform it into valid Python 3.x code. The
340 standard library contains a rich set of fixers that will handle almost
341 all code. 2to3 supporting library lib2to3 is, however, a flexible and
342 generic library, so it is possible to write your own fixers for 2to3.
343 lib2to3 could also be adapted to custom applications in which Python
344 code needs to be edited automatically.
345
346 %description 2to3 -l pl.UTF-8
347 2to3 to program w Pythonie czytający od źródłowy w Pythonie 2.x i
348 aplikujący serię poprawek przekształcających go w poprawny kod w
349 Pythonie 3.x. Biblioteka standardowa zawiera duży zbiór poprawek
350 obsługujących większość kodu. Biblioteka wspierająca 2to3 (lib2to3)
351 jest jednak elastyczną i ogólną biblioteką, więc można pisać własne
352 poprawki dla 2to3. lib2to3 można także zaadaptować na potrzeby
353 własnych zastosowań, w których kod w Pythonie musi być modyfikowany
354 automatycznie.
355
356 %package static
357 Summary:        Static python library
358 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
359 Group:          Development/Languages/Python
360 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
361
362 %description static
363 Static python library.
364
365 %description static -l pl.UTF-8
366 Statyczna biblioteka Pythona.
367
368 %package doc-info
369 Summary:        Documentation on Python in texinfo format
370 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
371 Group:          Documentation
372
373 %description doc-info
374 Documentation on Python in texinfo format.
375
376 %description doc-info -l pl.UTF-8
377 Dokumentacja do Pythona w formacie texinfo.
378
379 %package tkinter
380 Summary:        Standard Python interface to the Tk GUI toolkit
381 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
382 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
383 Summary(fr.UTF-8):      Interface graphique Tk pour Python
384 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
385 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
386 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
387 Group:          Libraries/Python
388 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
389 Requires:       tcl >= 8.4.3
390 Requires:       tix >= 1:8.1.4-4
391 Requires:       tk >= 8.4.3
392
393 %description tkinter
394 Standard Python interface to the Tk GUI toolkit.
395
396 %description tkinter -l de.UTF-8
397 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
398 vielen Konfigurations-Tools genutzt.
399
400 %description tkinter -l es.UTF-8
401 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
402 herramientas de configuración.
403
404 %description tkinter -l fr.UTF-8
405 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
406 beaucoup des outils de configuration.
407
408 %description tkinter -l pl.UTF-8
409 Standardowy interfejs Pythona do biblioteki Tk.
410
411 %description tkinter -l pt_BR.UTF-8
412 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
413 muitas ferramentas de configuração.
414
415 %description tkinter -l ru.UTF-8
416 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
417
418 %description tkinter -l tr.UTF-8
419 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
420 kullanılan grafik bir arayüzdür.
421
422 %description tkinter -l uk.UTF-8
423 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
424
425 %package examples
426 Summary:        Example programs in Python
427 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
428 Group:          Development/Languages/Python
429
430 %description examples
431 Example programs in Python.
432
433 These are for Python 2.3.4, not %{version}.
434
435 %description examples -l pl.UTF-8
436 Przykładowe programy w Pythonie.
437
438 Przykłady te są dla Pythona 2.3.4, nie %{version}.
439
440 %prep
441 %setup -q -n Python-%{version}
442 %patch0 -p1
443 %patch1 -p1
444 %patch2 -p1
445 %patch3 -p1
446 %patch4 -p1
447
448 %build
449 %{__autoconf}
450 CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
451 %configure \
452         --with-cxx-main="%{__cxx}" \
453         --enable-shared \
454         --enable-ipv6 \
455         --with-dbmliborder=gdbm:bdb \
456         --with-wide-unicode \
457         --with-signal-module \
458         --with-tsc \
459         --with-threads \
460         --with-doc-strings \
461         --with-fpectl \
462         --with-system-ffi \
463         --with-computed-gotos \
464         LINKCC='$(PURIFY) $(CXX)' \
465         LDSHARED='$(CC) $(CFLAGS) -shared' \
466         BLDSHARED='$(CC) $(CFLAGS) -shared' \
467         LDFLAGS="%{rpmcflags} %{rpmldflags}"
468
469 %{__make} \
470         OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
471 BEGIN { fail = 0; logmsg = ""; }
472 {
473         if ($0 ~ /\*\*\* WARNING:/) {
474                 fail = 1;
475                 logmsg = logmsg $0;
476         }
477         print $0;
478 }
479 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
480
481 LC_ALL=C
482 export LC_ALL
483 %if %{with tests}
484 binlibdir=`echo build/lib.*`
485 %{__make} test \
486         TESTOPTS="%{test_flags} %{test_list}" \
487         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
488 %endif
489
490 %install
491 rm -rf $RPM_BUILD_ROOT
492 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
493         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
494         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
495         $RPM_BUILD_ROOT%{_infodir} \
496         $RPM_BUILD_ROOT/etc/shrc.d
497
498 %{__make} install \
499         DESTDIR=$RPM_BUILD_ROOT
500
501 %if %{with info}
502 %{__make} -C Doc/info
503 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
504 %endif
505
506 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
507 cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
508
509 #
510 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
511 #
512
513 # for python devel tools
514 for script in timeit profile pdb pstats; do
515     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
516 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
517
518 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
519         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
520
521 sed 's/=/ /' \
522         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
523         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
524
525 # for python modules
526 for script in smtpd webbrowser; do
527     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
528 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
529
530 sed 's/=/ /' \
531         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
532         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
533
534 # xgettext specific for Python code
535 #
536 # we will have two commands: pygettext.py (an alias) and pygettext;
537 # this way there are no import (which is impossible now) conflicts and
538 # pygettext.py is provided for compatibility
539 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
540
541 # just to cut the noise, as they are not packaged (now)
542 # first tests
543 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/test
544 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
545 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
546 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/email/test
547 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
548 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
549 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
550 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
551 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/unittest/test
552
553 # other files
554 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
555 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
556 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
557 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
558 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
559 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
560 # already in %%doc
561 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
562
563 %clean
564 rm -rf $RPM_BUILD_ROOT
565
566 %post   libs -p /sbin/ldconfig
567 %postun libs -p /sbin/ldconfig
568
569 %post   doc-info -p /sbin/postshell
570 -/usr/sbin/fix-info-dir -c %{_infodir}
571
572 %postun doc-info -p /sbin/postshell
573 -/usr/sbin/fix-info-dir -c %{_infodir}
574
575 %files
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_bindir}/python%{py_ver}
578 %attr(755,root,root) %{_bindir}/python%{py_abi}
579 %attr(755,root,root) %{_bindir}/python3
580 %{_mandir}/man1/python%{py_ver}.1*
581
582 %files libs
583 %defattr(644,root,root,755)
584 %doc LICENSE
585 %attr(755,root,root) %{_libdir}/libpython%{py_abi}.so.*.*
586
587 %dir %{py_libdir}
588 %dir %{py_dyndir}
589 %dir %{py_sitedir}
590 %dir %{py_scriptdir}
591 %dir %{py_sitescriptdir}
592 %{py_scriptdir}/__pycache__
593
594 # shared modules required by python library
595 %attr(755,root,root) %{py_dyndir}/_struct.cpython-*.so
596
597 # modules required by python library
598 %{py_scriptdir}/_abcoll.py
599 %{py_scriptdir}/_weakrefset.py
600 %{py_scriptdir}/abc.py
601 %{py_scriptdir}/codecs.py
602 %{py_scriptdir}/copyreg.py
603 %{py_scriptdir}/genericpath.py
604 %{py_scriptdir}/locale.py
605 %{py_scriptdir}/io.py
606 %{py_scriptdir}/posixpath.py
607 %{py_scriptdir}/site.py
608 %{py_scriptdir}/stat.py
609 %{py_scriptdir}/os.py
610 # needed by the dynamic sys.lib patch
611 %{py_scriptdir}/types.py
612
613 # encodings required by python library
614 %dir %{py_scriptdir}/encodings
615 %{py_scriptdir}/encodings/__pycache__
616 %{py_scriptdir}/encodings/*.py
617
618 %files modules
619 %defattr(644,root,root,755)
620 /etc/shrc.d/python*-modules*
621 %exclude %{py_scriptdir}/_abcoll.py
622 %exclude %{py_scriptdir}/_weakrefset.py
623 %exclude %{py_scriptdir}/abc.py
624 %exclude %{py_scriptdir}/codecs.py
625 %exclude %{py_scriptdir}/copyreg.py
626 %exclude %{py_scriptdir}/genericpath.py
627 %exclude %{py_scriptdir}/io.py
628 %exclude %{py_scriptdir}/locale.py
629 %exclude %{py_scriptdir}/posixpath.py
630 %exclude %{py_scriptdir}/pdb.py
631 %exclude %{py_scriptdir}/profile.py
632 %exclude %{py_scriptdir}/pstats.py
633 %exclude %{py_scriptdir}/pydoc.py
634 %exclude %{py_scriptdir}/site.py
635 %exclude %{py_scriptdir}/stat.py
636 %exclude %{py_scriptdir}/timeit.py
637 %exclude %{py_scriptdir}/os.py
638 %exclude %{py_scriptdir}/encodings/*.py
639 %exclude %{py_scriptdir}/types.py
640
641 %{py_scriptdir}/*.py
642
643 %{py_dyndir}/Python-%{py_ver}-py*.egg-info
644
645 #
646 # list .so modules to be sure that all of them are built
647 #
648
649 # modules below do not work on 64-bit architectures
650 # see Python README file for explanation
651 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
652 %attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
653 %endif
654
655 %attr(755,root,root) %{py_dyndir}/_bisect.cpython-*.so
656 %attr(755,root,root) %{py_dyndir}/_codecs_cn.cpython-*.so
657 %attr(755,root,root) %{py_dyndir}/_codecs_hk.cpython-*.so
658 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.cpython-*.so
659 %attr(755,root,root) %{py_dyndir}/_codecs_jp.cpython-*.so
660 %attr(755,root,root) %{py_dyndir}/_codecs_kr.cpython-*.so
661 %attr(755,root,root) %{py_dyndir}/_codecs_tw.cpython-*.so
662 %attr(755,root,root) %{py_dyndir}/_csv.cpython-*.so
663 %attr(755,root,root) %{py_dyndir}/_ctypes*.cpython-*.so
664 %attr(755,root,root) %{py_dyndir}/_curses_panel.cpython-*.so
665 %attr(755,root,root) %{py_dyndir}/_curses.cpython-*.so
666 %attr(755,root,root) %{py_dyndir}/_datetime.cpython-*.so
667 %ifnarch sparc64
668 %attr(755,root,root) %{py_dyndir}/_dbm.cpython-*.so
669 %endif
670 %attr(755,root,root) %{py_dyndir}/_elementtree.cpython-*.so
671 %attr(755,root,root) %{py_dyndir}/_gdbm.cpython-*.so
672 %attr(755,root,root) %{py_dyndir}/_hashlib.cpython-*.so
673 %attr(755,root,root) %{py_dyndir}/_heapq.cpython-*.so
674 %attr(755,root,root) %{py_dyndir}/_json.cpython-*.so
675 %attr(755,root,root) %{py_dyndir}/_lsprof.cpython-*.so
676 %attr(755,root,root) %{py_dyndir}/_multibytecodec.cpython-*.so
677 %attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
678 %attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
679 %attr(755,root,root) %{py_dyndir}/_posixsubprocess.cpython-*.so
680 %attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
681 %attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
682 %attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
683 %attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
684 %attr(755,root,root) %{py_dyndir}/array.cpython-*.so
685 %attr(755,root,root) %{py_dyndir}/atexit.cpython-*.so
686 %attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
687 %attr(755,root,root) %{py_dyndir}/binascii.cpython-*.so
688 %attr(755,root,root) %{py_dyndir}/bz2.cpython-*.so
689 %attr(755,root,root) %{py_dyndir}/cmath.cpython-*.so
690 %attr(755,root,root) %{py_dyndir}/crypt.cpython-*.so
691 %attr(755,root,root) %{py_dyndir}/fcntl.cpython-*.so
692 %attr(755,root,root) %{py_dyndir}/grp.cpython-*.so
693 %attr(755,root,root) %{py_dyndir}/math.cpython-*.so
694 %attr(755,root,root) %{py_dyndir}/mmap.cpython-*.so
695 %attr(755,root,root) %{py_dyndir}/nis.cpython-*.so
696 %attr(755,root,root) %{py_dyndir}/ossaudiodev.cpython-*.so
697 %attr(755,root,root) %{py_dyndir}/parser.cpython-*.so
698 %attr(755,root,root) %{py_dyndir}/pyexpat.cpython-*.so
699 %attr(755,root,root) %{py_dyndir}/readline.cpython-*.so
700 %attr(755,root,root) %{py_dyndir}/resource.cpython-*.so
701 %attr(755,root,root) %{py_dyndir}/select.cpython-*.so
702 %attr(755,root,root) %{py_dyndir}/syslog.cpython-*.so
703 %attr(755,root,root) %{py_dyndir}/termios.cpython-*.so
704 %attr(755,root,root) %{py_dyndir}/time.cpython-*.so
705 %attr(755,root,root) %{py_dyndir}/spwd.cpython-*.so
706 %attr(755,root,root) %{py_dyndir}/unicodedata.cpython-*.so
707 %attr(755,root,root) %{py_dyndir}/zlib.cpython-*.so
708
709 %dir %{py_scriptdir}/plat-*
710 %{py_scriptdir}/plat-*/__pycache__
711 %{py_scriptdir}/plat-*/*.py
712
713 %{py_scriptdir}/concurrent
714
715 %dir %{py_scriptdir}/ctypes
716 %dir %{py_scriptdir}/ctypes/macholib
717 %{py_scriptdir}/ctypes/__pycache__
718 %{py_scriptdir}/ctypes/macholib/__pycache__
719
720 %{py_scriptdir}/ctypes/*.py
721 %{py_scriptdir}/ctypes/macholib/*.py
722 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
723
724 %dir %{py_scriptdir}/curses
725 %{py_scriptdir}/curses/__pycache__
726 %{py_scriptdir}/curses/*.py
727
728 %dir %{py_scriptdir}/dbm
729 %{py_scriptdir}/dbm/__pycache__
730 %{py_scriptdir}/dbm/*.py
731
732 %dir %{py_scriptdir}/distutils
733 %dir %{py_scriptdir}/distutils/command
734 %doc %{py_scriptdir}/distutils/README
735 %{py_scriptdir}/distutils/__pycache__
736 %{py_scriptdir}/distutils/command/__pycache__
737 %{py_scriptdir}/distutils/*.py
738 %{py_scriptdir}/distutils/command/*.py
739 %{py_scriptdir}/distutils/command/command_template
740
741 %dir %{py_scriptdir}/email
742 %dir %{py_scriptdir}/email/mime
743 %{py_scriptdir}/email/__pycache__
744 %{py_scriptdir}/email/mime/__pycache__
745 %{py_scriptdir}/email/*.py
746 %{py_scriptdir}/email/mime/*.py
747
748 %dir %{py_scriptdir}/html
749 %{py_scriptdir}/html/*.py
750 %{py_scriptdir}/html/__pycache__
751
752 %dir %{py_scriptdir}/http
753 %{py_scriptdir}/http/__pycache__
754 %{py_scriptdir}/http/*.py
755
756 %dir %{py_scriptdir}/importlib
757 %{py_scriptdir}/importlib/__pycache__
758 %{py_scriptdir}/importlib/*.py
759
760 %dir %{py_scriptdir}/json
761 %{py_scriptdir}/json/__pycache__
762 %{py_scriptdir}/json/*.py
763
764 %dir %{py_scriptdir}/logging
765 %{py_scriptdir}/logging/__pycache__
766 %{py_scriptdir}/logging/*.py
767
768 %dir %{py_scriptdir}/multiprocessing
769 %{py_scriptdir}/multiprocessing/__pycache__
770 %{py_scriptdir}/multiprocessing/*.py
771 %dir %{py_scriptdir}/multiprocessing/dummy
772 %{py_scriptdir}/multiprocessing/dummy/__pycache__
773 %{py_scriptdir}/multiprocessing/dummy/*.py
774
775 %{py_scriptdir}/turtledemo
776 %{py_scriptdir}/unittest
777
778 %dir %{py_scriptdir}/urllib
779 %{py_scriptdir}/urllib/__pycache__
780 %{py_scriptdir}/urllib/*.py
781
782 %dir %{py_scriptdir}/wsgiref
783 %{py_scriptdir}/wsgiref/__pycache__
784 %{py_scriptdir}/wsgiref/*.py
785 %{py_scriptdir}/wsgiref.egg-info
786
787 %dir %{py_scriptdir}/xml
788 %dir %{py_scriptdir}/xml/dom
789 %dir %{py_scriptdir}/xml/etree
790 %dir %{py_scriptdir}/xml/parsers
791 %dir %{py_scriptdir}/xml/sax
792 %{py_scriptdir}/xml/__pycache__
793 %{py_scriptdir}/xml/dom/__pycache__
794 %{py_scriptdir}/xml/etree/__pycache__
795 %{py_scriptdir}/xml/parsers/__pycache__
796 %{py_scriptdir}/xml/sax/__pycache__
797 %{py_scriptdir}/xml/*.py
798 %{py_scriptdir}/xml/dom/*.py
799 %{py_scriptdir}/xml/etree/*.py
800 %{py_scriptdir}/xml/parsers/*.py
801 %{py_scriptdir}/xml/sax/*.py
802
803 %dir %{py_scriptdir}/xmlrpc
804 %{py_scriptdir}/xmlrpc/__pycache__
805 %{py_scriptdir}/xmlrpc/*.py
806
807 %attr(755,root,root) %{py_dyndir}/_sqlite3.cpython-*.so
808 %dir %{py_scriptdir}/sqlite3
809 %{py_scriptdir}/sqlite3/__pycache__
810 %{py_scriptdir}/sqlite3/*.py
811
812 %files -n pydoc3
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_bindir}/pydoc3
815 %attr(755,root,root) %{_bindir}/pydoc3.2
816 %{py_scriptdir}/pydoc.py
817 %dir %{py_scriptdir}/pydoc_data
818 %{py_scriptdir}/pydoc_data/__pycache__
819 %{py_scriptdir}/pydoc_data/*.py
820 %{py_scriptdir}/pydoc_data/*.css
821
822 %files -n idle3
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_bindir}/idle3
825 %attr(755,root,root) %{_bindir}/idle3.2
826 %dir %{py_scriptdir}/idlelib
827 %dir %{py_scriptdir}/idlelib/Icons
828 %{py_scriptdir}/idlelib/__pycache__
829 %{py_scriptdir}/idlelib/*.py
830 %doc %{py_scriptdir}/idlelib/*.txt
831 %doc %{py_scriptdir}/idlelib/ChangeLog
832 %{py_scriptdir}/idlelib/Icons/*
833 %{py_scriptdir}/idlelib/*.def
834
835 %files devel
836 %defattr(644,root,root,755)
837 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
838 %attr(755,root,root) %{_bindir}/python%{py_ver}-config
839 %attr(755,root,root) %{_bindir}/python%{py_abi}-config
840 %attr(755,root,root) %{_bindir}/python3-config
841 %attr(755,root,root) %{_libdir}/libpython%{py_abi}.so
842 %attr(755,root,root) %{_libdir}/libpython3.so
843 %dir %{py_incdir}
844 %{py_incdir}/*.h
845 %{_pkgconfigdir}/python-%{py_ver}.pc
846
847 %dir %{py_libdir}/config-%{py_abi}
848 %attr(755,root,root) %{py_libdir}/config-%{py_abi}/makesetup
849 %attr(755,root,root) %{py_libdir}/config-%{py_abi}/install-sh
850 %{py_libdir}/config-%{py_abi}/Makefile
851 %{py_libdir}/config-%{py_abi}/Setup
852 %{py_libdir}/config-%{py_abi}/Setup.config
853 %{py_libdir}/config-%{py_abi}/Setup.local
854 %{py_libdir}/config-%{py_abi}/config.c
855 %{py_libdir}/config-%{py_abi}/config.c.in
856 %{py_libdir}/config-%{py_abi}/python.o
857
858 %files devel-tools
859 %defattr(644,root,root,755)
860 /etc/shrc.d/python*-devel*
861
862 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
863
864 %{py_scriptdir}/pdb.py
865 %{py_scriptdir}/profile.py
866 %{py_scriptdir}/pstats.py
867 %{py_scriptdir}/timeit.py
868
869 %files 2to3
870 %attr(755,root,root) %{_bindir}/2to3-%{py_ver}
871 %dir %{py_scriptdir}/lib2to3
872 %{py_scriptdir}/lib2to3/__pycache__
873 %{py_scriptdir}/lib2to3/*.txt
874 %{py_scriptdir}/lib2to3/*.pickle
875 %{py_scriptdir}/lib2to3/*.py
876 %dir %{py_scriptdir}/lib2to3/fixes
877 %{py_scriptdir}/lib2to3/fixes/__pycache__
878 %{py_scriptdir}/lib2to3/fixes/*.py
879 %dir %{py_scriptdir}/lib2to3/pgen2
880 %{py_scriptdir}/lib2to3/pgen2/__pycache__
881 %{py_scriptdir}/lib2to3/pgen2/*.py
882
883 %files static
884 %defattr(644,root,root,755)
885 %{_libdir}/libpython%{py_abi}.a
886
887 %files examples
888 %defattr(644,root,root,755)
889 %{_examplesdir}/%{name}-%{version}
890
891 %if %{with info}
892 %files doc-info
893 %defattr(644,root,root,755)
894 %{_infodir}/*.info*
895 %endif
896
897 %if %{with tkinter}
898 %files tkinter
899 %defattr(644,root,root,755)
900 %dir %{py_scriptdir}/tkinter
901 %{py_scriptdir}/tkinter/__pycache__
902 %{py_scriptdir}/tkinter/*.py
903 %attr(755,root,root) %{py_dyndir}/_tkinter.cpython-*.so
904 %endif
This page took 0.888316 seconds and 4 git commands to generate.