]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
- garbage removed
[packages/python3.git] / python3.spec
1
2 # Conditional build:
3 %bcond_with     info                    # info pages (requires emacs)
4 %bcond_without  tkinter                 # disables tkinter module building
5 %bcond_without  tests                   # disables Python testing
6 %bcond_with     verbose_tests           # runs tests in verbose mode
7 %bcond_with     openssl097
8 #
9 # tests which will not work on 64-bit platforms
10 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
11 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
12 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
13 # tests which fail because of some unknown/unresolved reason (this list should be empty)
14 %define         broken_tests test_httpservers
15
16 %define beta            %{nil}
17
18 %define py_ver          3.0
19 %define py_prefix       %{_prefix}
20 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
21 %define py_incdir       %{_includedir}/python%{py_ver}
22 %define py_sitedir      %{py_libdir}/site-packages
23 %define py_dyndir       %{py_libdir}/lib-dynload
24
25 Summary:        Very high level scripting language with X interface
26 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
27 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
28 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
29 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
30 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
31 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
32 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
33 Name:           python30
34 Version:        %{py_ver}.1
35 Release:        0.1
36 Epoch:          1
37 License:        PSF
38 Group:          Applications
39 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
40 # Source0-md5:  7291eac6a9a7a3642e309c78b8d744e5
41 Patch1:         %{name}-pythonpath.patch
42 Patch2:         %{name}-no_ndbm.patch
43 Patch3:         %{name}-ac_fixes.patch
44 Patch4:         %{name}-lib64.patch
45 Patch5:         %{name}-noarch_to_datadir.patch
46 Patch6:         %{name}-doc_path.patch
47 Patch7:         %{name}-db4.6.patch
48 URL:            http://www.python.org/
49 BuildRequires:  autoconf
50 BuildRequires:  bluez-libs-devel
51 BuildRequires:  bzip2-devel
52 BuildRequires:  db-devel >= 4
53 %{?with_info:BuildRequires:     emacs >= 21}
54 BuildRequires:  expat-devel >= 1:1.95.7
55 BuildRequires:  file
56 BuildRequires:  gdbm-devel >= 1.8.3
57 BuildRequires:  gmp-devel >= 4.0
58 BuildRequires:  libffi-devel
59 BuildRequires:  libstdc++-devel
60 BuildRequires:  ncurses-ext-devel >= 5.2
61 %if %{with openssl097}
62 BuildRequires:  openssl-devel < 0.9.8
63 %else
64 BuildRequires:  openssl-devel >= 0.9.8
65 %endif
66 BuildRequires:  readline-devel >= 5.0
67 BuildRequires:  rpm-pythonprov
68 BuildRequires:  sed >= 4.0
69 BuildRequires:  sqlite3-devel >= 3.3.5
70 %{?with_info:BuildRequires:     tetex-makeindex}
71 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
72 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
73 BuildRequires:  zlib-devel
74 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %if %{with verbose_tests}
78 %define test_flags -v -l -x
79 %else
80 %define test_flags -l -x
81 %endif
82
83 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
84 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
85 %else
86 %define test_list %{nobuilder_tests} %{broken_tests}
87 %endif
88
89 %ifarch sparc
90 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
91 %endif
92
93 %description
94 Python is an interpreted, interactive, object-oriented programming
95 language. It incorporates modules, exceptions, dynamic typing, very
96 high level dynamic data types, and classes. Python combines remarkable
97 power with very clear syntax. It has interfaces to many system calls
98 and libraries, as well as to various window systems, and is extensible
99 in C or C++. It is also usable as an extension language for
100 applications that need a programmable interface. Finally, Python is
101 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
102 MS-DOS, Windows, Windows NT, and OS/2.
103
104 This package contains the Python binary.
105
106 %description -l de.UTF-8
107 Python ist eine interpretierte, interaktive, objektorientierte
108 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
109 Python enthält Module, Klassen, Exceptions, High-Level dynamische
110 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
111 zu vielen Systemaufrufen und Libraries, sowie verschiedene
112 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
113
114 Programmierer können neue built-in-Module für Python in C oder C++
115 schreiben. Python kann auch als Erweiterungssprache für Applikationen
116 benutzt werden, die ein programmierbares Interface brauchen. Dieses
117 Paket enthält die meisten Standard-Python-Module, und Module zum
118 Ansprechen von Tix (Tk-widget set) und RPM.
119
120 %description -l es.UTF-8
121 Python es un lenguaje de scripts interpretado orientado a objetos.
122 Contiene soporte para carga dinámica de objetos, clases, módulos y
123 excepciones.
124
125 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
126 través de código C, tornando Python fácil de usar en ambientes
127 particulares/personalizados. Este paquete Python incluye la mayoría de
128 los módulos padrón Python, junto con módulos para crear interfaces
129 para el conjunto de componentes Tix para Tk y RPM.
130
131 %description -l fr.UTF-8
132 Python est un langage de script interprété et orienté objet. Il gère
133 le chargement dynamique des objets, les classes, les modules et les
134 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
135 avec du code C est simple, ce qui rend Python facile à utiliser dans
136 des configs personnalisées.
137
138 Ce paquetage Python contient la plupart des modules Python standards,
139 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
140 et RPM.
141
142 %description -l pl.UTF-8
143 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
144 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
145 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
146 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
147 wielu wywołań systemowych i bibliotek, w tym również do różnych
148 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
149 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
150 użyty jako element aplikacji, którym potrzebny jest interpreter do
151 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
152 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
153 OS/2.
154
155 Ten pakiet zawiera binarkę Pythona.
156
157 %description -l pt_BR.UTF-8
158 Python é uma linguagem de scripts interpretada orientada a objetos.
159 Contém suporte para carga dinâmica de objetos, classes, módulos e
160 exceções. Adicionar interfaces para novos sistemas de biblioteca
161 através de código C é simples, tornando Python fácil de usar em
162 ambientes particulares/personalizados.
163
164 Este pacote Python inclui a maioria do módulos padrão Python, junto
165 com módulos para interfaceamento para o conjunto de componentes Tix
166 para Tk e RPM.
167
168 %description -l ru.UTF-8
169 Python - это интерпретируемый, объектно-ориентированный язык
170 программирования. Он поддерживает динамическую загрузку объектов,
171 классы, модули и обработку исключительных ситуаций (exceptions).
172 Простота добавления интерфейсов к новым системным библиотекам через
173 код на языке C делает Python хорошим выбором для использования в
174 специальных конфигурациях.
175
176 %description -l tr.UTF-8
177 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
178 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
179 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
180 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
181 arayüz birimlerini de içerir.
182
183 %description -l uk.UTF-8
184 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
185 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
186 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
187 нових системних бібліотек через код на мові C робить Python добрим
188 вибором для використання в спеціальних конфігураціях.
189
190 %package libs
191 Summary:        Python library
192 Summary(pl.UTF-8):      Biblioteka języka Python
193 Group:          Libraries/Python
194 # broken detection in rpm/pythondeps.sh
195 Provides:       python(abi) = %{py_ver}
196 # for compatibility with existing Ac packages
197 Provides:       python(bytecode) = %{py_ver}
198 %{!?with_info:Obsoletes:        python30-doc-info}
199
200 %description libs
201 Python shared library and very essental modules for Python binary.
202
203 %description libs -l pl.UTF-8
204 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
205 dla Pythona.
206
207 %package modules
208 Summary:        Python modules
209 Summary(pl.UTF-8):      Moduły języka Python
210 Group:          Libraries/Python
211 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
212
213 %description modules
214 Python officially distributed modules.
215
216 %description modules -l pl.UTF-8
217 Oficjalnie rozprowadzane moduły języka Python.
218
219 %package modules-sqlite
220 Summary:        Python SQLite modules
221 Summary(pl.UTF-8):      Moduły SQLite języka Python
222 Group:          Libraries/Python
223 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
224
225 %description modules-sqlite
226 Python officially distributed sqlite module.
227
228 %description modules-sqlite -l pl.UTF-8
229 Oficjalnie rozprowadzany moduł sqlite języka Python.
230
231 %package -n pydoc30
232 Summary:        Python interactive module documentation access support
233 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
234 Group:          Applications
235 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
236
237 %description -n pydoc30
238 Python interactive module documentation access support.
239
240 %description -n pydoc30 -l pl.UTF-8
241 Interaktywne korzystanie z dokumentacji modułów języka Python.
242
243 %package -n idle30
244 Summary:        IDE for Python language
245 Summary(pl.UTF-8):      IDE dla języka Python
246 Group:          Applications
247 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
248
249 %description -n idle30
250 IDE for Python language.
251
252 %description -n idle30 -l pl.UTF-8
253 IDE dla języka Python.
254
255 %package devel
256 Summary:        Libraries and header files for building python code
257 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
258 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
259 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
260 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
261 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
262 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
263 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
264 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
265 Group:          Development/Languages/Python
266 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
267 Obsoletes:      python-devel
268
269 %description devel
270 The Python interpreter is relatively easy to extend with dynamically
271 loaded extensions and to embed in other programs. This package
272 contains the header files and libraries which are needed to do both of
273 these tasks.
274
275 %description devel -l de.UTF-8
276 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
277 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
278 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
279 die für beide Aufgaben erforderlich sind.
280
281 %description devel -l es.UTF-8
282 El interpretador Python permite incluir con facilidad extensiones
283 cargadas dinámicamente. Python es también fácil de ser empotrado en
284 otros programas. Este paquete contiene los archivos de inclusión y
285 bibliotecas necesarios para estas dos tareas.
286
287 %description devel -l fr.UTF-8
288 L'interpréteur Python est relativement facile à étendre avec des
289 extensions chargées dynamiquement et à insérer dans d'autres
290 programmes. Ce paquetage contient les en-têtes et les bibliothèques
291 nécessaires à ces deux tâches.
292
293 %description devel -l pl.UTF-8
294 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
295 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
296 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
297 wszystko inne co potrzebne do tych celów.
298
299 %description devel -l pt_BR.UTF-8
300 O interpretador Python permite incluir com facilidade extensões
301 carregadas dinamicamente. Python é também fácil de ser embutido em
302 outros programas. Este pacote contém os arquivos de inclusão e
303 bibliotecas necessários para estas duas tarefas.
304
305 %description devel -l ru.UTF-8
306 Интерпретатор Python относительно легко расширяется при помощи
307 динамически загружаемых расширений и встраивается в другие программы.
308 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
309 задач.
310
311 %description devel -l tr.UTF-8
312 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
313 dosyalarını ve kitaplıkları içerir.
314
315 %description devel -l uk.UTF-8
316 Інтерпретатор Python відносно легко розширюється за допомогою
317 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
318 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
319
320 %package devel-src
321 Summary:        Python module sources
322 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
323 Group:          Development/Languages/Python
324 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
325
326 %description devel-src
327 Python module sources.
328
329 %description devel-src -l pl.UTF-8
330 Pliki źródłowe modułów Pythona.
331
332 %package devel-tools
333 Summary:        Python development tools
334 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
335 Group:          Development/Languages/Python
336 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
337
338 %description devel-tools
339 Python development tools such as profilers and debugger.
340
341 %description devel-tools -l pl.UTF-8
342 Narzędzia programistyczne języka Python takie jak profiler oraz
343 debugger.
344
345 %package static
346 Summary:        Static python library
347 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
348 Group:          Development/Languages/Python
349 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
350
351 %description static
352 Static python library.
353
354 %description static -l pl.UTF-8
355 Statyczna biblioteka Pythona.
356
357 %package doc
358 Summary:        Documentation on Python
359 Summary(de.UTF-8):      Dokumentation zu Python
360 Summary(es.UTF-8):      Documentación para Python
361 Summary(fr.UTF-8):      Documentation sur Python
362 Summary(pl.UTF-8):      Dokumentacja do Pythona
363 Summary(pt_BR.UTF-8):   Documentação para a linguagem de programação Python
364 Summary(ru.UTF-8):      Документация по языку Python
365 Summary(tr.UTF-8):      Python belgeleri
366 Summary(uk.UTF-8):      Документація по мові Python
367 Group:          Documentation
368
369 %description doc
370 This package contains documentation on the Python language and
371 interpretor as a mix of plain ASCII files and LaTeX sources.
372
373 %description doc -l de.UTF-8
374 Dieses Paket enthält Dokumentationen zu Python (Sprache und
375 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
376
377 %description doc -l es.UTF-8
378 Documentación para Python. Contiene archivos en texto y PostScript.
379
380 %description doc -l fr.UTF-8
381 Ce paquetage contient la documentation sur le langage python et sur
382 son interpréteur sous forme de fichiers ASCII et LaTeX.
383
384 %description doc -l pl.UTF-8
385 Oficjalna dokumentacja do Pythona. Zawiera przykładowe programy,
386 narzędzia i dokumentację. Strony podręcznika man znajdują się w
387 głównym pakiecie. Ten pakiet nie zawiera źródeł dokumentacji
388 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
389 i HTML.
390
391 %description doc -l pt_BR.UTF-8
392 O pacote python-doc contém documentação para a linguagem de
393 programação e para o interpretador Python. Fornecida em arquivos texto
394 e Postcript.
395
396 %description doc -l ru.UTF-8
397 Этот пакет содержит документацию по собственно языку Python и по
398 исполняющему его интерпретатору в виде набора текстовых файлов и
399 исходных текстов в формате LaTeX.
400
401 %description doc -l tr.UTF-8
402 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyaları ve
403 LaTeX kaynaklarının bir karışımı olan yorumlayıcıyı içerir.
404
405 %description doc -l uk.UTF-8
406 Цей пакет містить документацію по власне мові Python та по виконуючому
407 її інтерпретатору у вигляді набора текстових файлів та вихідних
408 текстів у форматі LaTeX.
409
410 %package doc-info
411 Summary:        Documentation on Python in texinfo format
412 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
413 Group:          Documentation
414
415 %description doc-info
416 Documentation on Python in texinfo format.
417
418 %description doc-info -l pl.UTF-8
419 Dokumentacja do Pythona w formacie texinfo.
420
421 %package tkinter
422 Summary:        Standard Python interface to the Tk GUI toolkit
423 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
424 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
425 Summary(fr.UTF-8):      Interface graphique Tk pour Python
426 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
427 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
428 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
429 Group:          Libraries/Python
430 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
431 Requires:       tcl >= 8.4.3
432 Requires:       tix >= 1:8.1.4-4
433 Requires:       tk >= 8.4.3
434
435 %description tkinter
436 Standard Python interface to the Tk GUI toolkit.
437
438 %description tkinter -l de.UTF-8
439 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
440 vielen Konfigurations-Tools genutzt.
441
442 %description tkinter -l es.UTF-8
443 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
444 herramientas de configuración.
445
446 %description tkinter -l fr.UTF-8
447 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
448 beaucoup des outils de configuration.
449
450 %description tkinter -l pl.UTF-8
451 Standardowy interfejs Pythona do biblioteki Tk.
452
453 %description tkinter -l pt_BR.UTF-8
454 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
455 muitas ferramentas de configuração.
456
457 %description tkinter -l ru.UTF-8
458 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
459
460 %description tkinter -l tr.UTF-8
461 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
462 kullanılan grafik bir arayüzdür.
463
464 %description tkinter -l uk.UTF-8
465 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
466
467 %package examples
468 Summary:        Example programs in Python
469 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
470 Group:          Development/Languages/Python
471
472 %description examples
473 Example programs in Python.
474
475 These are for Python 2.3.4, not %{version}.
476
477 %description examples -l pl.UTF-8
478 Przykładowe programy w Pythonie.
479
480 Przykłady te są dla Pythona 2.3.4, nie %{version}.
481
482 %prep
483 %setup -q -n Python-%{version}%{beta}
484 #patch1 -p1
485 %patch2 -p1
486 %patch3 -p1
487 %patch4 -p1
488 %patch5 -p1
489 #patch6 -p1
490 #patch7 -p1
491
492 %build
493 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
494 %{__autoconf}
495 CPPFLAGS="-I/usr/include/ncursesw"; export CPPFLAGS
496 %configure \
497         --with-cxx-main="%{__cxx}" \
498         --enable-shared \
499         --enable-ipv6 \
500         --with-wide-unicode \
501         --with-signal-module \
502         --with-tsc \
503         --with-threads \
504         --with-doc-strings \
505         --with-fpectl \
506         --with-system-ffi \
507         LINKCC='$(PURIFY) $(CXX)' \
508         LDSHARED='$(CC) $(CFLAGS) -shared' \
509         BLDSHARED='$(CC) $(CFLAGS) -shared' \
510         LDFLAGS="%{rpmcflags} %{rpmldflags}"
511
512 %{__make} \
513         OPT="%{rpmcflags}" 2>&1 | awk '
514 BEGIN { fail = 0; logmsg = ""; }
515 {
516         if ($0 ~ /\*\*\* WARNING:/) {
517                 fail = 1;
518                 logmsg = logmsg $0;
519         }
520         print $0;
521 }
522 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
523
524 LC_ALL=C
525 export LC_ALL
526 %if %{with tests}
527 binlibdir=`echo build/lib.*`
528 %{__make} test \
529         TESTOPTS="%{test_flags} %{test_list}" \
530         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
531 %endif
532
533 %install
534 rm -rf $RPM_BUILD_ROOT
535 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
536         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
537         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
538         $RPM_BUILD_ROOT%{_infodir} \
539         $RPM_BUILD_ROOT/etc/shrc.d
540
541 %{__make} install \
542         DESTDIR=$RPM_BUILD_ROOT
543
544 %if %{with info}
545 %{__make} -C Doc/info
546 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
547 %endif
548
549 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
550
551 mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
552 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
553 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
554 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
555
556 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
557 cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
558
559 #
560 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
561 #
562
563 # for python devel tools
564 for script in timeit profile pdb pstats; do
565     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
566 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
567
568 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
569         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
570
571 sed 's/=/ /' \
572         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
573         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
574
575 # for python modules
576 for script in smtpd webbrowser; do
577     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
578 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
579
580 sed 's/=/ /' \
581         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
582         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
583
584 # xgettext specific for Python code
585 #
586 # we will have two commands: pygettext.py (an alias) and pygettext;
587 # this way there are no import (which is impossible now) conflicts and
588 # pygettext.py is provided for compatibility
589 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
590
591 # add py_ver
592 for script in idle pydoc; do
593         mv $RPM_BUILD_ROOT%{_bindir}/${script} $RPM_BUILD_ROOT%{_bindir}/${script}%{py_ver}
594 done
595 #mv $RPM_BUILD_ROOT%{_mandir}/man1/python.1 $RPM_BUILD_ROOT%{_mandir}/man1/python%{py_ver}.1
596
597 # just to cut the noise, as they are not packaged (now)
598 # first tests
599 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
600 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
601 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
602 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
603 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
604 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
605 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
606 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
607
608 # other files
609 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
610 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
611 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
612 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
613 # already in %%doc
614 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
615 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
616
617 %clean
618 rm -rf $RPM_BUILD_ROOT
619
620 %post   libs -p /sbin/ldconfig
621 %postun libs -p /sbin/ldconfig
622
623 %post doc-info  -p      /sbin/postshell
624 -/usr/sbin/fix-info-dir -c %{_infodir}
625
626 %postun doc-info        -p      /sbin/postshell
627 -/usr/sbin/fix-info-dir -c %{_infodir}
628
629 %files
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_bindir}/python%{py_ver}
632 %attr(755,root,root) %{_bindir}/2to3
633 #%{_mandir}/man1/*
634
635 %files modules
636 %defattr(644,root,root,755)
637 /etc/shrc.d/python*-modules*
638 #exclude %{py_scriptdir}/UserDict.py[co]
639 %exclude %{py_scriptdir}/codecs.py[co]
640 %exclude %{py_scriptdir}/copyreg.py[co]
641 %exclude %{py_scriptdir}/locale.py[co]
642 %exclude %{py_scriptdir}/posixpath.py[co]
643 %exclude %{py_scriptdir}/pdb.py[co]
644 %exclude %{py_scriptdir}/profile.py[co]
645 %exclude %{py_scriptdir}/pstats.py[co]
646 %exclude %{py_scriptdir}/pydoc.py[co]
647 %exclude %{py_scriptdir}/site.py[co]
648 %exclude %{py_scriptdir}/stat.py[co]
649 %exclude %{py_scriptdir}/timeit.py[co]
650 %exclude %{py_scriptdir}/os.py[co]
651 %exclude %{py_scriptdir}/encodings/*.py[co]
652 %exclude %{py_scriptdir}/types.py[co]
653
654 %{py_scriptdir}/*.py[co]
655
656 %{py_dyndir}/*.egg-info
657
658 #
659 # list .so modules to be sure that all of them are built
660 #
661
662 # three modules below do not work on 64-bit architectures
663 # see Python README file for explanation
664 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
665 %attr(755,root,root) %{py_dyndir}/audioop.so
666 %attr(755,root,root) %{py_dyndir}/rgbimg.so
667 %attr(755,root,root) %{py_dyndir}/imageop.so
668 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
669 # platforms
670 %attr(755,root,root) %{py_dyndir}/dl.so
671 %endif
672
673 %attr(755,root,root) %{py_dyndir}/array.so
674 %attr(755,root,root) %{py_dyndir}/atexit.so
675 %attr(755,root,root) %{py_dyndir}/audioop.so
676 %attr(755,root,root) %{py_dyndir}/binascii.so
677 %attr(755,root,root) %{py_dyndir}/_bisect.so
678 #%attr(755,root,root) %{py_dyndir}/_bsddb.so
679 %attr(755,root,root) %{py_dyndir}/bz2.so
680 %attr(755,root,root) %{py_dyndir}/cmath.so
681 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
682 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
683 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
684 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
685 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
686 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
687 %attr(755,root,root) %{py_dyndir}/_collections.so
688 %attr(755,root,root) %{py_dyndir}/crypt.so
689 #%attr(755,root,root) %{py_dyndir}/cStringIO.so
690 %attr(755,root,root) %{py_dyndir}/_csv.so
691 %attr(755,root,root) %{py_dyndir}/_ctypes*.so
692 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
693 %attr(755,root,root) %{py_dyndir}/_curses.so
694 %attr(755,root,root) %{py_dyndir}/datetime.so
695 %attr(755,root,root) %{py_dyndir}/_elementtree.so
696 %attr(755,root,root) %{py_dyndir}/_functools.so
697 %attr(755,root,root) %{py_dyndir}/_hashlib.so
698 %attr(755,root,root) %{py_dyndir}/_heapq.so
699 %attr(755,root,root) %{py_dyndir}/_json.so
700 %attr(755,root,root) %{py_dyndir}/_locale.so
701 %attr(755,root,root) %{py_dyndir}/_lsprof.so
702 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
703 %attr(755,root,root) %{py_dyndir}/_multiprocessing.so
704 %attr(755,root,root) %{py_dyndir}/_pickle.so
705 %attr(755,root,root) %{py_dyndir}/_random.so
706 %{?with_openssl097:%attr(755,root,root) %{py_dyndir}/_sha*.so}
707 %attr(755,root,root) %{py_dyndir}/_socket.so
708 %attr(755,root,root) %{py_dyndir}/_ssl.so
709 %attr(755,root,root) %{py_dyndir}/_testcapi.so
710 #%attr(755,root,root) %{py_dyndir}/_weakref.so
711 %ifnarch sparc64
712 %attr(755,root,root) %{py_dyndir}/_dbm.so
713 %endif
714 %attr(755,root,root) %{py_dyndir}/fcntl.so
715 %attr(755,root,root) %{py_dyndir}/_gdbm.so
716 %attr(755,root,root) %{py_dyndir}/grp.so
717 %attr(755,root,root) %{py_dyndir}/itertools.so
718 #%attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
719 %attr(755,root,root) %{py_dyndir}/math.so
720 %attr(755,root,root) %{py_dyndir}/mmap.so
721 %attr(755,root,root) %{py_dyndir}/nis.so
722 %attr(755,root,root) %{py_dyndir}/operator.so
723 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
724 %attr(755,root,root) %{py_dyndir}/parser.so
725 %attr(755,root,root) %{py_dyndir}/pyexpat.so
726 %attr(755,root,root) %{py_dyndir}/readline.so
727 %attr(755,root,root) %{py_dyndir}/resource.so
728 %attr(755,root,root) %{py_dyndir}/select.so
729 #%attr(755,root,root) %{py_dyndir}/strop.so
730 %attr(755,root,root) %{py_dyndir}/syslog.so
731 %attr(755,root,root) %{py_dyndir}/termios.so
732 %attr(755,root,root) %{py_dyndir}/time.so
733 %attr(755,root,root) %{py_dyndir}/spwd.so
734 %attr(755,root,root) %{py_dyndir}/unicodedata.so
735 %attr(755,root,root) %{py_dyndir}/zlib.so
736
737 %dir %{py_scriptdir}/plat-*
738 %{py_scriptdir}/plat-*/*.py[co]
739
740 #%dir %{py_scriptdir}/bsddb
741 #%{py_scriptdir}/bsddb/*.py[co]
742
743 #%dir %{py_scriptdir}/compiler
744 #%{py_scriptdir}/compiler/*.py[co]
745
746 %dir %{py_scriptdir}/ctypes
747 %dir %{py_scriptdir}/ctypes/macholib
748
749 %{py_scriptdir}/ctypes/*.py[co]
750 %{py_scriptdir}/ctypes/macholib/*.py[co]
751 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
752
753 %dir %{py_scriptdir}/curses
754 %{py_scriptdir}/curses/*.py[co]
755
756 %dir %{py_scriptdir}/dbm
757 %{py_scriptdir}/dbm/*.py[co]
758
759 %dir %{py_scriptdir}/distutils
760 %dir %{py_scriptdir}/distutils/command
761 %doc %{py_scriptdir}/distutils/README
762 %{py_scriptdir}/distutils/*.py[co]
763 %{py_scriptdir}/distutils/command/*.py[co]
764 %{py_scriptdir}/distutils/command/command_template
765
766 %dir %{py_scriptdir}/email
767 %dir %{py_scriptdir}/email/mime
768 %{py_scriptdir}/email/*.py[co]
769 %{py_scriptdir}/email/mime/*.py[co]
770
771 %dir %{py_scriptdir}/html
772 %{py_scriptdir}/html/*.py[co]
773
774 %dir %{py_scriptdir}/http
775 %{py_scriptdir}/http/*.py[co]
776
777 %dir %{py_scriptdir}/json
778 %{py_scriptdir}/json/*.py[co]
779
780 %dir %{py_scriptdir}/lib2to3
781 %{py_scriptdir}/lib2to3/*.txt
782 %{py_scriptdir}/lib2to3/*.pickle
783 %{py_scriptdir}/lib2to3/*.py[co]
784 %dir %{py_scriptdir}/lib2to3/fixes
785 %{py_scriptdir}/lib2to3/fixes/*.py[co]
786 %dir %{py_scriptdir}/lib2to3/pgen2
787 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
788
789 %dir %{py_scriptdir}/logging
790 %{py_scriptdir}/logging/*.py[co]
791
792 %dir %{py_scriptdir}/multiprocessing
793 %{py_scriptdir}/multiprocessing/*.py[co]
794 %dir %{py_scriptdir}/multiprocessing/dummy
795 %{py_scriptdir}/multiprocessing/dummy/*.py[co]
796
797 %dir %{py_scriptdir}/urllib
798 %{py_scriptdir}/urllib/*.py[co]
799
800 %dir %{py_scriptdir}/wsgiref
801 %{py_scriptdir}/wsgiref/*.py[co]
802 %{py_scriptdir}/wsgiref.egg-info
803
804 %dir %{py_scriptdir}/xml
805 %dir %{py_scriptdir}/xml/dom
806 %dir %{py_scriptdir}/xml/etree
807 %dir %{py_scriptdir}/xml/parsers
808 %dir %{py_scriptdir}/xml/sax
809 %{py_scriptdir}/xml/*.py[co]
810 %{py_scriptdir}/xml/dom/*.py[co]
811 %{py_scriptdir}/xml/etree/*.py[co]
812 %{py_scriptdir}/xml/parsers/*.py[co]
813 %{py_scriptdir}/xml/sax/*.py[co]
814
815 %dir %{py_scriptdir}/xmlrpc
816 %{py_scriptdir}/xmlrpc/*.py[co]
817
818 %files modules-sqlite
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
821 %dir %{py_scriptdir}/sqlite3
822 %{py_scriptdir}/sqlite3/*.py[co]
823
824 %files libs
825 %defattr(644,root,root,755)
826 %doc LICENSE
827 %attr(755,root,root) %{_libdir}/libpython*.so.*
828
829 %dir %{py_dyndir}
830 %dir %{py_scriptdir}
831 %dir %{py_libdir}
832 %dir %{py_sitescriptdir}
833 %dir %{py_sitedir}
834
835 # shared modules required by python library
836 %attr(755,root,root) %{py_dyndir}/_struct.so
837
838 # modules required by python library
839 #%{py_scriptdir}/UserDict.py[co]
840 %{py_scriptdir}/codecs.py[co]
841 %{py_scriptdir}/copyreg.py[co]
842 %{py_scriptdir}/locale.py[co]
843 %{py_scriptdir}/posixpath.py[co]
844 %{py_scriptdir}/site.py[co]
845 %{py_scriptdir}/stat.py[co]
846 %{py_scriptdir}/os.py[co]
847 # needed by the dynamic sys.lib patch
848 %{py_scriptdir}/types.py[co]
849
850 # encodings required by python library
851 %dir %{py_scriptdir}/encodings
852 %{py_scriptdir}/encodings/*.py[co]
853
854 %files -n pydoc30
855 %defattr(644,root,root,755)
856 %attr(755,root,root) %{_bindir}/pydoc%{py_ver}
857 %{py_scriptdir}/pydoc.py[co]
858
859 %files -n idle30
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_bindir}/idle%{py_ver}
862 %dir %{py_scriptdir}/idlelib
863 %dir %{py_scriptdir}/idlelib/Icons
864 %{py_scriptdir}/idlelib/*.py[co]
865 %doc %{py_scriptdir}/idlelib/*.txt
866 %doc %{py_scriptdir}/idlelib/ChangeLog
867 %{py_scriptdir}/idlelib/Icons/*
868 %{py_scriptdir}/idlelib/*.def
869
870 %files devel
871 %defattr(644,root,root,755)
872 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
873 #%attr(755,root,root) %{_bindir}/python-config
874 %attr(755,root,root) %{_bindir}/python%{py_ver}-config
875 %attr(755,root,root) %{_libdir}/lib*.so
876 %dir %{py_incdir}
877 %{py_incdir}/*.h
878
879 %dir %{py_libdir}/config
880 %attr(755,root,root) %{py_libdir}/config/makesetup
881 %attr(755,root,root) %{py_libdir}/config/install-sh
882 %{py_libdir}/config/Makefile
883 %{py_libdir}/config/Makefile.pre.in
884 %{py_libdir}/config/Setup
885 %{py_libdir}/config/Setup.config
886 %{py_libdir}/config/Setup.local
887 %{py_libdir}/config/config.c
888 %{py_libdir}/config/config.c.in
889 %{py_libdir}/config/python.o
890
891 %files devel-src
892 %defattr(644,root,root,755)
893 %attr(-,root,root) %{py_scriptdir}/*.py
894 %{py_scriptdir}/plat-*/*.py
895 #%{py_scriptdir}/bsddb/*.py
896 %{py_scriptdir}/ctypes/*.py
897 %{py_scriptdir}/ctypes/macholib/*.py
898 #%{py_scriptdir}/compiler/*.py
899 %{py_scriptdir}/curses/*.py
900 %{py_scriptdir}/dbm/*.py
901 %{py_scriptdir}/distutils/*.py
902 %{py_scriptdir}/distutils/command/*.py
903 %{py_scriptdir}/email/*.py
904 %{py_scriptdir}/email/mime/*.py
905 %{py_scriptdir}/html/*.py
906 %{py_scriptdir}/http/*.py
907 %{py_scriptdir}/json/*.py
908 %{py_scriptdir}/lib2to3/*.py
909 %{py_scriptdir}/lib2to3/fixes/*.py
910 %{py_scriptdir}/lib2to3/pgen2/*.py
911 %{py_scriptdir}/logging/*.py
912 %{py_scriptdir}/multiprocessing/*.py
913 %{py_scriptdir}/multiprocessing/dummy/*.py
914 %{py_scriptdir}/sqlite3/*.py
915 %{py_scriptdir}/urllib/*.py
916 %{py_scriptdir}/wsgiref/*.py
917 %{py_scriptdir}/tkinter/*.py
918 %{py_scriptdir}/xml/*.py
919 %{py_scriptdir}/xml/dom/*.py
920 %{py_scriptdir}/xml/etree/*.py
921 %{py_scriptdir}/xml/parsers/*.py
922 %{py_scriptdir}/xml/sax/*.py
923 %{py_scriptdir}/xmlrpc/*.py
924 %{py_scriptdir}/encodings/*.py
925 %{py_scriptdir}/idlelib/*.py
926
927 %files devel-tools
928 %defattr(644,root,root,755)
929 %doc Lib/pdb.doc
930 /etc/shrc.d/python*-devel*
931
932 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
933
934 #%attr(755,root,root) %{py_dyndir}/_hotshot.so
935 #%dir %{py_scriptdir}/hotshot
936 #%{py_scriptdir}/hotshot/*.py[co]
937 %{py_scriptdir}/pdb.py[co]
938 %{py_scriptdir}/profile.py[co]
939 %{py_scriptdir}/pstats.py[co]
940 %{py_scriptdir}/timeit.py[co]
941
942 %files static
943 %defattr(644,root,root,755)
944 %{_libdir}/lib*.a
945
946 %files examples
947 %defattr(644,root,root,755)
948 %{_examplesdir}/%{name}-%{version}
949
950
951 #%files doc
952 #%defattr(644,root,root,755)
953 #%doc Python-Docs-%{version}%{beta}/*
954
955 %if %{with info}
956 %files doc-info
957 %defattr(644,root,root,755)
958 %{_infodir}/*.info*
959 %endif
960
961 %if %{with tkinter}
962 %files tkinter
963 %defattr(644,root,root,755)
964 %dir %{py_scriptdir}/tkinter
965 %{py_scriptdir}/tkinter/*.py[co]
966 %attr(755,root,root) %{py_dyndir}/_tkinter.so
967 %endif
This page took 0.148856 seconds and 4 git commands to generate.