]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
- updated to 3.1; release 0.1
[packages/python3.git] / python3.spec
1 #
2 # TODO:
3 # - fix tests
4 # - check unpackaged files
5
6 # Conditional build:
7 %bcond_with     info                    # info pages (requires emacs)
8 %bcond_without  tkinter                 # disables tkinter module building
9 %bcond_without  tests                   # disables Python testing
10 %bcond_with     verbose_tests           # runs tests in verbose mode
11 #
12 # tests which will not work on 64-bit platforms
13 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
14 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16 # tests which fail because of some unknown/unresolved reason (this list should be empty)
17 %define         broken_tests test_httpservers
18
19 %define beta            %{nil}
20
21 %define py_ver          3.1
22 %define py_prefix       %{_prefix}
23 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
24 %define py_incdir       %{_includedir}/python%{py_ver}
25 %define py_sitedir      %{py_libdir}/site-packages
26 %define py_dyndir       %{py_libdir}/lib-dynload
27
28 Summary:        Very high level scripting language with X interface
29 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
30 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
31 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
32 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
33 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
34 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
35 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
36 Name:           python3
37 Version:        %{py_ver}
38 Release:        0.1
39 Epoch:          1
40 License:        PSF
41 Group:          Applications
42 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
43 # Source0-md5:  f64437a24d39f1917aa1878cc70621f6
44 Patch1:         %{name}-pythonpath.patch
45 Patch2:         %{name}-no_ndbm.patch
46 Patch3:         %{name}-ac_fixes.patch
47 Patch4:         %{name}-lib64.patch
48 Patch5:         %{name}-noarch_to_datadir.patch
49 Patch6:         %{name}-cast-fix.patch
50 URL:            http://www.python.org/
51 BuildRequires:  autoconf
52 BuildRequires:  bluez-libs-devel
53 BuildRequires:  bzip2-devel
54 BuildRequires:  db-devel >= 4
55 %{?with_info:BuildRequires:     emacs >= 21}
56 BuildRequires:  expat-devel >= 1:1.95.7
57 BuildRequires:  file
58 BuildRequires:  gdbm-devel >= 1.8.3
59 BuildRequires:  gmp-devel >= 4.0
60 BuildRequires:  libffi-devel
61 BuildRequires:  libstdc++-devel
62 BuildRequires:  ncurses-ext-devel >= 5.2
63 BuildRequires:  openssl-devel >= 0.9.8
64 BuildRequires:  readline-devel >= 5.0
65 BuildRequires:  rpm-pythonprov
66 BuildRequires:  sed >= 4.0
67 BuildRequires:  sqlite3-devel >= 3.3.5
68 %{?with_info:BuildRequires:     tetex-makeindex}
69 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
70 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
71 BuildRequires:  zlib-devel
72 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         specflags_ppc   -D__ppc__=1
76 %define         specflags_ppc64 -D__ppc64__=1
77
78 %if %{with verbose_tests}
79 %define test_flags -v -l -x
80 %else
81 %define test_flags -l -x
82 %endif
83
84 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
85 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
86 %else
87 %define test_list %{nobuilder_tests} %{broken_tests}
88 %endif
89
90 %ifarch sparc
91 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
92 %endif
93
94 %description
95 Python is an interpreted, interactive, object-oriented programming
96 language. It incorporates modules, exceptions, dynamic typing, very
97 high level dynamic data types, and classes. Python combines remarkable
98 power with very clear syntax. It has interfaces to many system calls
99 and libraries, as well as to various window systems, and is extensible
100 in C or C++. It is also usable as an extension language for
101 applications that need a programmable interface. Finally, Python is
102 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
103 MS-DOS, Windows, Windows NT, and OS/2.
104
105 This package contains the Python binary.
106
107 %description -l de.UTF-8
108 Python ist eine interpretierte, interaktive, objektorientierte
109 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
110 Python enthält Module, Klassen, Exceptions, High-Level dynamische
111 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
112 zu vielen Systemaufrufen und Libraries, sowie verschiedene
113 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
114
115 Programmierer können neue built-in-Module für Python in C oder C++
116 schreiben. Python kann auch als Erweiterungssprache für Applikationen
117 benutzt werden, die ein programmierbares Interface brauchen. Dieses
118 Paket enthält die meisten Standard-Python-Module, und Module zum
119 Ansprechen von Tix (Tk-widget set) und RPM.
120
121 %description -l es.UTF-8
122 Python es un lenguaje de scripts interpretado orientado a objetos.
123 Contiene soporte para carga dinámica de objetos, clases, módulos y
124 excepciones.
125
126 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
127 través de código C, tornando Python fácil de usar en ambientes
128 particulares/personalizados. Este paquete Python incluye la mayoría de
129 los módulos padrón Python, junto con módulos para crear interfaces
130 para el conjunto de componentes Tix para Tk y RPM.
131
132 %description -l fr.UTF-8
133 Python est un langage de script interprété et orienté objet. Il gère
134 le chargement dynamique des objets, les classes, les modules et les
135 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
136 avec du code C est simple, ce qui rend Python facile à utiliser dans
137 des configs personnalisées.
138
139 Ce paquetage Python contient la plupart des modules Python standards,
140 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
141 et RPM.
142
143 %description -l pl.UTF-8
144 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
145 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
146 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
147 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
148 wielu wywołań systemowych i bibliotek, w tym również do różnych
149 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
150 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
151 użyty jako element aplikacji, którym potrzebny jest interpreter do
152 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
153 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
154 OS/2.
155
156 Ten pakiet zawiera binarkę Pythona.
157
158 %description -l pt_BR.UTF-8
159 Python é uma linguagem de scripts interpretada orientada a objetos.
160 Contém suporte para carga dinâmica de objetos, classes, módulos e
161 exceções. Adicionar interfaces para novos sistemas de biblioteca
162 através de código C é simples, tornando Python fácil de usar em
163 ambientes particulares/personalizados.
164
165 Este pacote Python inclui a maioria do módulos padrão Python, junto
166 com módulos para interfaceamento para o conjunto de componentes Tix
167 para Tk e RPM.
168
169 %description -l ru.UTF-8
170 Python - это интерпретируемый, объектно-ориентированный язык
171 программирования. Он поддерживает динамическую загрузку объектов,
172 классы, модули и обработку исключительных ситуаций (exceptions).
173 Простота добавления интерфейсов к новым системным библиотекам через
174 код на языке C делает Python хорошим выбором для использования в
175 специальных конфигурациях.
176
177 %description -l tr.UTF-8
178 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
179 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
180 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
181 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
182 arayüz birimlerini de içerir.
183
184 %description -l uk.UTF-8
185 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
186 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
187 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
188 нових системних бібліотек через код на мові C робить Python добрим
189 вибором для використання в спеціальних конфігураціях.
190
191 %package libs
192 Summary:        Python library
193 Summary(pl.UTF-8):      Biblioteka języka Python
194 Group:          Libraries/Python
195 # broken detection in rpm/pythondeps.sh
196 Provides:       python(abi) = %{py_ver}
197 # for compatibility with existing Ac packages
198 Provides:       python(bytecode) = %{py_ver}
199 %{!?with_info:Obsoletes:        python3-doc-info}
200
201 %description libs
202 Python shared library and very essental modules for Python binary.
203
204 %description libs -l pl.UTF-8
205 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
206 dla Pythona.
207
208 %package modules
209 Summary:        Python modules
210 Summary(pl.UTF-8):      Moduły języka Python
211 Group:          Libraries/Python
212 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
213
214 %description modules
215 Python officially distributed modules.
216
217 %description modules -l pl.UTF-8
218 Oficjalnie rozprowadzane moduły języka Python.
219
220 %package modules-sqlite
221 Summary:        Python SQLite modules
222 Summary(pl.UTF-8):      Moduły SQLite języka Python
223 Group:          Libraries/Python
224 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
225
226 %description modules-sqlite
227 Python officially distributed sqlite module.
228
229 %description modules-sqlite -l pl.UTF-8
230 Oficjalnie rozprowadzany moduł sqlite języka Python.
231
232 %package -n pydoc3
233 Summary:        Python interactive module documentation access support
234 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
235 Group:          Applications
236 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
237
238 %description -n pydoc3
239 Python interactive module documentation access support.
240
241 %description -n pydoc3 -l pl.UTF-8
242 Interaktywne korzystanie z dokumentacji modułów języka Python.
243
244 %package -n idle3
245 Summary:        IDE for Python language
246 Summary(pl.UTF-8):      IDE dla języka Python
247 Group:          Applications
248 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
249
250 %description -n idle3
251 IDE for Python language.
252
253 %description -n idle3 -l pl.UTF-8
254 IDE dla języka Python.
255
256 %package devel
257 Summary:        Libraries and header files for building python code
258 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
259 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
260 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
261 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
262 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
263 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
264 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
265 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
266 Group:          Development/Languages/Python
267 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
268
269 %description devel
270 The Python interpreter is relatively easy to extend with dynamically
271 loaded extensions and to embed in other programs. This package
272 contains the header files and libraries which are needed to do both of
273 these tasks.
274
275 %description devel -l de.UTF-8
276 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
277 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
278 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
279 die für beide Aufgaben erforderlich sind.
280
281 %description devel -l es.UTF-8
282 El interpretador Python permite incluir con facilidad extensiones
283 cargadas dinámicamente. Python es también fácil de ser empotrado en
284 otros programas. Este paquete contiene los archivos de inclusión y
285 bibliotecas necesarios para estas dos tareas.
286
287 %description devel -l fr.UTF-8
288 L'interpréteur Python est relativement facile à étendre avec des
289 extensions chargées dynamiquement et à insérer dans d'autres
290 programmes. Ce paquetage contient les en-têtes et les bibliothèques
291 nécessaires à ces deux tâches.
292
293 %description devel -l pl.UTF-8
294 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
295 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
296 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
297 wszystko inne co potrzebne do tych celów.
298
299 %description devel -l pt_BR.UTF-8
300 O interpretador Python permite incluir com facilidade extensões
301 carregadas dinamicamente. Python é também fácil de ser embutido em
302 outros programas. Este pacote contém os arquivos de inclusão e
303 bibliotecas necessários para estas duas tarefas.
304
305 %description devel -l ru.UTF-8
306 Интерпретатор Python относительно легко расширяется при помощи
307 динамически загружаемых расширений и встраивается в другие программы.
308 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
309 задач.
310
311 %description devel -l tr.UTF-8
312 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
313 dosyalarını ve kitaplıkları içerir.
314
315 %description devel -l uk.UTF-8
316 Інтерпретатор Python відносно легко розширюється за допомогою
317 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
318 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
319
320 %package devel-src
321 Summary:        Python module sources
322 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
323 Group:          Development/Languages/Python
324 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
325
326 %description devel-src
327 Python module sources.
328
329 %description devel-src -l pl.UTF-8
330 Pliki źródłowe modułów Pythona.
331
332 %package devel-tools
333 Summary:        Python development tools
334 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
335 Group:          Development/Languages/Python
336 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
337
338 %description devel-tools
339 Python development tools such as profilers and debugger.
340
341 %description devel-tools -l pl.UTF-8
342 Narzędzia programistyczne języka Python takie jak profiler oraz
343 debugger.
344
345 %package 2to3
346 Summary:        Automated Python 2 to 3 code translation
347 Summary(pl.UTF-8):      Automatyczne tłumaczenie kody Pythona 2 do 3
348 Group:          Development/Languages/Pythona
349
350 %description 2to3
351 2to3 is a Python program that reads Python 2.x source code and applies a series
352 of fixers to transform it into valid Python 3.x code. The standard library
353 contains a rich set of fixers that will handle almost all code. 2to3 supporting
354 library lib2to3 is, however, a flexible and generic library, so it is possible
355 to write your own fixers for 2to3. lib2to3 could also be adapted to custom
356 applications in which Python code needs to be edited automatically.
357
358 %package static
359 Summary:        Static python library
360 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
361 Group:          Development/Languages/Python
362 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
363
364 %description static
365 Static python library.
366
367 %description static -l pl.UTF-8
368 Statyczna biblioteka Pythona.
369
370 %package doc
371 Summary:        Documentation on Python
372 Summary(de.UTF-8):      Dokumentation zu Python
373 Summary(es.UTF-8):      Documentación para Python
374 Summary(fr.UTF-8):      Documentation sur Python
375 Summary(pl.UTF-8):      Dokumentacja do Pythona
376 Summary(pt_BR.UTF-8):   Documentação para a linguagem de programação Python
377 Summary(ru.UTF-8):      Документация по языку Python
378 Summary(tr.UTF-8):      Python belgeleri
379 Summary(uk.UTF-8):      Документація по мові Python
380 Group:          Documentation
381
382 %description doc
383 This package contains documentation on the Python language and
384 interpretor as a mix of plain ASCII files and LaTeX sources.
385
386 %description doc -l de.UTF-8
387 Dieses Paket enthält Dokumentationen zu Python (Sprache und
388 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
389
390 %description doc -l es.UTF-8
391 Documentación para Python. Contiene archivos en texto y PostScript.
392
393 %description doc -l fr.UTF-8
394 Ce paquetage contient la documentation sur le langage python et sur
395 son interpréteur sous forme de fichiers ASCII et LaTeX.
396
397 %description doc -l pl.UTF-8
398 Oficjalna dokumentacja do Pythona. Zawiera przykładowe programy,
399 narzędzia i dokumentację. Strony podręcznika man znajdują się w
400 głównym pakiecie. Ten pakiet nie zawiera źródeł dokumentacji
401 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
402 i HTML.
403
404 %description doc -l pt_BR.UTF-8
405 O pacote python-doc contém documentação para a linguagem de
406 programação e para o interpretador Python. Fornecida em arquivos texto
407 e Postcript.
408
409 %description doc -l ru.UTF-8
410 Этот пакет содержит документацию по собственно языку Python и по
411 исполняющему его интерпретатору в виде набора текстовых файлов и
412 исходных текстов в формате LaTeX.
413
414 %description doc -l tr.UTF-8
415 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyaları ve
416 LaTeX kaynaklarının bir karışımı olan yorumlayıcıyı içerir.
417
418 %description doc -l uk.UTF-8
419 Цей пакет містить документацію по власне мові Python та по виконуючому
420 її інтерпретатору у вигляді набора текстових файлів та вихідних
421 текстів у форматі LaTeX.
422
423 %package doc-info
424 Summary:        Documentation on Python in texinfo format
425 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
426 Group:          Documentation
427
428 %description doc-info
429 Documentation on Python in texinfo format.
430
431 %description doc-info -l pl.UTF-8
432 Dokumentacja do Pythona w formacie texinfo.
433
434 %package tkinter
435 Summary:        Standard Python interface to the Tk GUI toolkit
436 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
437 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
438 Summary(fr.UTF-8):      Interface graphique Tk pour Python
439 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
440 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
441 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
442 Group:          Libraries/Python
443 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
444 Requires:       tcl >= 8.4.3
445 Requires:       tix >= 1:8.1.4-4
446 Requires:       tk >= 8.4.3
447
448 %description tkinter
449 Standard Python interface to the Tk GUI toolkit.
450
451 %description tkinter -l de.UTF-8
452 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
453 vielen Konfigurations-Tools genutzt.
454
455 %description tkinter -l es.UTF-8
456 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
457 herramientas de configuración.
458
459 %description tkinter -l fr.UTF-8
460 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
461 beaucoup des outils de configuration.
462
463 %description tkinter -l pl.UTF-8
464 Standardowy interfejs Pythona do biblioteki Tk.
465
466 %description tkinter -l pt_BR.UTF-8
467 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
468 muitas ferramentas de configuração.
469
470 %description tkinter -l ru.UTF-8
471 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
472
473 %description tkinter -l tr.UTF-8
474 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
475 kullanılan grafik bir arayüzdür.
476
477 %description tkinter -l uk.UTF-8
478 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
479
480 %package examples
481 Summary:        Example programs in Python
482 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
483 Group:          Development/Languages/Python
484
485 %description examples
486 Example programs in Python.
487
488 These are for Python 2.3.4, not %{version}.
489
490 %description examples -l pl.UTF-8
491 Przykładowe programy w Pythonie.
492
493 Przykłady te są dla Pythona 2.3.4, nie %{version}.
494
495 %prep
496 %setup -q -n Python-%{version}%{beta}
497 %patch1 -p1
498 #%patch2 -p1
499 %patch3 -p1
500 %patch4 -p1
501 %patch5 -p1
502 %patch6 -p1
503 sed -i -e 's=@EXENAME@=%{_bindir}/python3=' Misc/python-config.in
504
505 %build
506 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
507 %{__autoconf}
508 CPPFLAGS="-I/usr/include/ncursesw"; export CPPFLAGS
509 %configure \
510         --with-cxx-main="%{__cxx}" \
511         --enable-shared \
512         --enable-ipv6 \
513         --with-dbmliborder=gdbm:bdb \
514         --with-wide-unicode \
515         --with-signal-module \
516         --with-tsc \
517         --with-threads \
518         --with-doc-strings \
519         --with-fpectl \
520         --with-system-ffi \
521         LINKCC='$(PURIFY) $(CXX)' \
522         LDSHARED='$(CC) $(CFLAGS) -shared' \
523         BLDSHARED='$(CC) $(CFLAGS) -shared' \
524         LDFLAGS="%{rpmcflags} %{rpmldflags}"
525
526 %{__make} \
527         OPT="%{rpmcflags}" 2>&1 | awk '
528 BEGIN { fail = 0; logmsg = ""; }
529 {
530         if ($0 ~ /\*\*\* WARNING:/) {
531                 fail = 1;
532                 logmsg = logmsg $0;
533         }
534         print $0;
535 }
536 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
537
538 LC_ALL=C
539 export LC_ALL
540 %if %{with tests}
541 binlibdir=`echo build/lib.*`
542 %{__make} test \
543         TESTOPTS="%{test_flags} %{test_list}" \
544         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
545 %endif
546
547 %install
548 rm -rf $RPM_BUILD_ROOT
549 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
550         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
551         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
552         $RPM_BUILD_ROOT%{_infodir} \
553         $RPM_BUILD_ROOT/etc/shrc.d
554
555 %{__make} install \
556         DESTDIR=$RPM_BUILD_ROOT
557
558 %if %{with info}
559 %{__make} -C Doc/info
560 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
561 %endif
562
563 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
564
565 mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
566 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
567 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
568
569 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
570 cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
571
572 #
573 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
574 #
575
576 # for python devel tools
577 for script in timeit profile pdb pstats; do
578     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
579 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
580
581 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
582         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
583
584 sed 's/=/ /' \
585         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
586         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
587
588 # for python modules
589 for script in smtpd webbrowser; do
590     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
591 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
592
593 sed 's/=/ /' \
594         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
595         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
596
597 # xgettext specific for Python code
598 #
599 # we will have two commands: pygettext.py (an alias) and pygettext;
600 # this way there are no import (which is impossible now) conflicts and
601 # pygettext.py is provided for compatibility
602 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
603
604 # just to cut the noise, as they are not packaged (now)
605 # first tests
606 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
607 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
608 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
609 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
610 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
611 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
612 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
613 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
614
615 # other files
616 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
617 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
618 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
619 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
620 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
621 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
622 rm -rf $RPM_BUILD_ROOT%{_bindir}/smtpd.py
623 # already in %%doc
624 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
625 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
626
627 %clean
628 rm -rf $RPM_BUILD_ROOT
629
630 %post   libs -p /sbin/ldconfig
631 %postun libs -p /sbin/ldconfig
632
633 %post doc-info  -p      /sbin/postshell
634 -/usr/sbin/fix-info-dir -c %{_infodir}
635
636 %postun doc-info        -p      /sbin/postshell
637 -/usr/sbin/fix-info-dir -c %{_infodir}
638
639 %files
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_bindir}/python%{py_ver}
642 %attr(755,root,root) %{_bindir}/python3
643 %{_mandir}/man1/python*.1*
644
645 %files modules
646 %defattr(644,root,root,755)
647 /etc/shrc.d/python*-modules*
648 %exclude %{py_scriptdir}/_abcoll.py[co]
649 %exclude %{py_scriptdir}/_weakrefset.py[co]
650 %exclude %{py_scriptdir}/abc.py[co]
651 %exclude %{py_scriptdir}/codecs.py[co]
652 %exclude %{py_scriptdir}/copyreg.py[co]
653 %exclude %{py_scriptdir}/genericpath.py[co]
654 %exclude %{py_scriptdir}/io.py[co]
655 %exclude %{py_scriptdir}/locale.py[co]
656 %exclude %{py_scriptdir}/posixpath.py[co]
657 %exclude %{py_scriptdir}/pdb.py[co]
658 %exclude %{py_scriptdir}/profile.py[co]
659 %exclude %{py_scriptdir}/pstats.py[co]
660 %exclude %{py_scriptdir}/pydoc.py[co]
661 %exclude %{py_scriptdir}/site.py[co]
662 %exclude %{py_scriptdir}/stat.py[co]
663 %exclude %{py_scriptdir}/timeit.py[co]
664 %exclude %{py_scriptdir}/os.py[co]
665 %exclude %{py_scriptdir}/encodings/*.py[co]
666 %exclude %{py_scriptdir}/types.py[co]
667
668 %{py_scriptdir}/*.py[co]
669
670 %{py_dyndir}/*.egg-info
671
672 #
673 # list .so modules to be sure that all of them are built
674 #
675
676 # modules below do not work on 64-bit architectures
677 # see Python README file for explanation
678 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
679 %attr(755,root,root) %{py_dyndir}/audioop.so
680 %endif
681
682 %attr(755,root,root) %{py_dyndir}/array.so
683 %attr(755,root,root) %{py_dyndir}/atexit.so
684 %attr(755,root,root) %{py_dyndir}/audioop.so
685 %attr(755,root,root) %{py_dyndir}/binascii.so
686 %attr(755,root,root) %{py_dyndir}/_bisect.so
687 %attr(755,root,root) %{py_dyndir}/bz2.so
688 %attr(755,root,root) %{py_dyndir}/cmath.so
689 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
690 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
691 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
692 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
693 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
694 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
695 %attr(755,root,root) %{py_dyndir}/_collections.so
696 %attr(755,root,root) %{py_dyndir}/crypt.so
697 %attr(755,root,root) %{py_dyndir}/_csv.so
698 %attr(755,root,root) %{py_dyndir}/_ctypes*.so
699 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
700 %attr(755,root,root) %{py_dyndir}/_curses.so
701 %attr(755,root,root) %{py_dyndir}/datetime.so
702 %attr(755,root,root) %{py_dyndir}/_elementtree.so
703 #%attr(755,root,root) %{py_dyndir}/_functools.so
704 %attr(755,root,root) %{py_dyndir}/_hashlib.so
705 %attr(755,root,root) %{py_dyndir}/_heapq.so
706 %attr(755,root,root) %{py_dyndir}/_json.so
707 #%attr(755,root,root) %{py_dyndir}/_locale.so
708 %attr(755,root,root) %{py_dyndir}/_lsprof.so
709 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
710 %attr(755,root,root) %{py_dyndir}/_multiprocessing.so
711 %attr(755,root,root) %{py_dyndir}/_pickle.so
712 %attr(755,root,root) %{py_dyndir}/_random.so
713 %attr(755,root,root) %{py_dyndir}/_socket.so
714 %attr(755,root,root) %{py_dyndir}/_ssl.so
715 %attr(755,root,root) %{py_dyndir}/_testcapi.so
716 %ifnarch sparc64
717 %attr(755,root,root) %{py_dyndir}/_dbm.so
718 %endif
719 %attr(755,root,root) %{py_dyndir}/fcntl.so
720 %attr(755,root,root) %{py_dyndir}/_gdbm.so
721 %attr(755,root,root) %{py_dyndir}/grp.so
722 %attr(755,root,root) %{py_dyndir}/itertools.so
723 %attr(755,root,root) %{py_dyndir}/math.so
724 %attr(755,root,root) %{py_dyndir}/mmap.so
725 %attr(755,root,root) %{py_dyndir}/nis.so
726 %attr(755,root,root) %{py_dyndir}/operator.so
727 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
728 %attr(755,root,root) %{py_dyndir}/parser.so
729 %attr(755,root,root) %{py_dyndir}/pyexpat.so
730 %attr(755,root,root) %{py_dyndir}/readline.so
731 %attr(755,root,root) %{py_dyndir}/resource.so
732 %attr(755,root,root) %{py_dyndir}/select.so
733 %attr(755,root,root) %{py_dyndir}/syslog.so
734 %attr(755,root,root) %{py_dyndir}/termios.so
735 %attr(755,root,root) %{py_dyndir}/time.so
736 %attr(755,root,root) %{py_dyndir}/spwd.so
737 %attr(755,root,root) %{py_dyndir}/unicodedata.so
738 %attr(755,root,root) %{py_dyndir}/zlib.so
739
740 %dir %{py_scriptdir}/plat-*
741 %{py_scriptdir}/plat-*/*.py[co]
742
743 %dir %{py_scriptdir}/ctypes
744 %dir %{py_scriptdir}/ctypes/macholib
745
746 %{py_scriptdir}/ctypes/*.py[co]
747 %{py_scriptdir}/ctypes/macholib/*.py[co]
748 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
749
750 %dir %{py_scriptdir}/curses
751 %{py_scriptdir}/curses/*.py[co]
752
753 %dir %{py_scriptdir}/dbm
754 %{py_scriptdir}/dbm/*.py[co]
755
756 %dir %{py_scriptdir}/distutils
757 %dir %{py_scriptdir}/distutils/command
758 %doc %{py_scriptdir}/distutils/README
759 %{py_scriptdir}/distutils/*.py[co]
760 %{py_scriptdir}/distutils/command/*.py[co]
761 %{py_scriptdir}/distutils/command/command_template
762
763 %dir %{py_scriptdir}/email
764 %dir %{py_scriptdir}/email/mime
765 %{py_scriptdir}/email/*.py[co]
766 %{py_scriptdir}/email/mime/*.py[co]
767
768 %dir %{py_scriptdir}/html
769 %{py_scriptdir}/html/*.py[co]
770
771 %dir %{py_scriptdir}/http
772 %{py_scriptdir}/http/*.py[co]
773
774 %dir %{py_scriptdir}/json
775 %{py_scriptdir}/json/*.py[co]
776
777 %dir %{py_scriptdir}/logging
778 %{py_scriptdir}/logging/*.py[co]
779
780 %dir %{py_scriptdir}/multiprocessing
781 %{py_scriptdir}/multiprocessing/*.py[co]
782 %dir %{py_scriptdir}/multiprocessing/dummy
783 %{py_scriptdir}/multiprocessing/dummy/*.py[co]
784
785 %dir %{py_scriptdir}/urllib
786 %{py_scriptdir}/urllib/*.py[co]
787
788 %dir %{py_scriptdir}/wsgiref
789 %{py_scriptdir}/wsgiref/*.py[co]
790 %{py_scriptdir}/wsgiref.egg-info
791
792 %dir %{py_scriptdir}/xml
793 %dir %{py_scriptdir}/xml/dom
794 %dir %{py_scriptdir}/xml/etree
795 %dir %{py_scriptdir}/xml/parsers
796 %dir %{py_scriptdir}/xml/sax
797 %{py_scriptdir}/xml/*.py[co]
798 %{py_scriptdir}/xml/dom/*.py[co]
799 %{py_scriptdir}/xml/etree/*.py[co]
800 %{py_scriptdir}/xml/parsers/*.py[co]
801 %{py_scriptdir}/xml/sax/*.py[co]
802
803 %dir %{py_scriptdir}/xmlrpc
804 %{py_scriptdir}/xmlrpc/*.py[co]
805
806 %files modules-sqlite
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
809 %dir %{py_scriptdir}/sqlite3
810 %{py_scriptdir}/sqlite3/*.py[co]
811
812 %files libs
813 %defattr(644,root,root,755)
814 %doc LICENSE
815 %attr(755,root,root) %{_libdir}/libpython*.so.*
816
817 %dir %{py_dyndir}
818 %dir %{py_scriptdir}
819 %dir %{py_libdir}
820 %dir %{py_sitescriptdir}
821 %dir %{py_sitedir}
822
823 # shared modules required by python library
824 %attr(755,root,root) %{py_dyndir}/_struct.so
825
826 # modules required by python library
827 %{py_scriptdir}/_abcoll.py[co]
828 %{py_scriptdir}/_weakrefset.py[co]
829 %{py_scriptdir}/abc.py[co]
830 %{py_scriptdir}/codecs.py[co]
831 %{py_scriptdir}/copyreg.py[co]
832 %{py_scriptdir}/genericpath.py[co]
833 %{py_scriptdir}/locale.py[co]
834 %{py_scriptdir}/io.py[co]
835 %{py_scriptdir}/posixpath.py[co]
836 %{py_scriptdir}/site.py[co]
837 %{py_scriptdir}/stat.py[co]
838 %{py_scriptdir}/os.py[co]
839 # needed by the dynamic sys.lib patch
840 %{py_scriptdir}/types.py[co]
841
842 # encodings required by python library
843 %dir %{py_scriptdir}/encodings
844 %{py_scriptdir}/encodings/*.py[co]
845
846 %files -n pydoc3
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_bindir}/pydoc3
849 %{py_scriptdir}/pydoc.py[co]
850
851 %files -n idle3
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_bindir}/idle3
854 %dir %{py_scriptdir}/idlelib
855 %dir %{py_scriptdir}/idlelib/Icons
856 %{py_scriptdir}/idlelib/*.py[co]
857 %doc %{py_scriptdir}/idlelib/*.txt
858 %doc %{py_scriptdir}/idlelib/ChangeLog
859 %{py_scriptdir}/idlelib/Icons/*
860 %{py_scriptdir}/idlelib/*.def
861
862 %files devel
863 %defattr(644,root,root,755)
864 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
865 %attr(755,root,root) %{_bindir}/python*-config
866 %attr(755,root,root) %{_libdir}/lib*.so
867 %dir %{py_incdir}
868 %{py_incdir}/*.h
869
870 %dir %{py_libdir}/config
871 %attr(755,root,root) %{py_libdir}/config/makesetup
872 %attr(755,root,root) %{py_libdir}/config/install-sh
873 %{py_libdir}/config/Makefile
874 %{py_libdir}/config/Makefile.pre.in
875 %{py_libdir}/config/Setup
876 %{py_libdir}/config/Setup.config
877 %{py_libdir}/config/Setup.local
878 %{py_libdir}/config/config.c
879 %{py_libdir}/config/config.c.in
880 %{py_libdir}/config/python.o
881
882 %files devel-src
883 %defattr(644,root,root,755)
884 %attr(-,root,root) %{py_scriptdir}/*.py
885 %{py_scriptdir}/plat-*/*.py
886 %{py_scriptdir}/ctypes/*.py
887 %{py_scriptdir}/ctypes/macholib/*.py
888 %{py_scriptdir}/curses/*.py
889 %{py_scriptdir}/dbm/*.py
890 %{py_scriptdir}/distutils/*.py
891 %{py_scriptdir}/distutils/command/*.py
892 %{py_scriptdir}/email/*.py
893 %{py_scriptdir}/email/mime/*.py
894 %{py_scriptdir}/html/*.py
895 %{py_scriptdir}/http/*.py
896 %{py_scriptdir}/json/*.py
897 %{py_scriptdir}/lib2to3/*.py
898 %{py_scriptdir}/lib2to3/fixes/*.py
899 %{py_scriptdir}/lib2to3/pgen2/*.py
900 %{py_scriptdir}/logging/*.py
901 %{py_scriptdir}/multiprocessing/*.py
902 %{py_scriptdir}/multiprocessing/dummy/*.py
903 %{py_scriptdir}/sqlite3/*.py
904 %{py_scriptdir}/urllib/*.py
905 %{py_scriptdir}/wsgiref/*.py
906 %{py_scriptdir}/tkinter/*.py
907 %{py_scriptdir}/xml/*.py
908 %{py_scriptdir}/xml/dom/*.py
909 %{py_scriptdir}/xml/etree/*.py
910 %{py_scriptdir}/xml/parsers/*.py
911 %{py_scriptdir}/xml/sax/*.py
912 %{py_scriptdir}/xmlrpc/*.py
913 %{py_scriptdir}/encodings/*.py
914 %{py_scriptdir}/idlelib/*.py
915
916 %files devel-tools
917 %defattr(644,root,root,755)
918 %doc Lib/pdb.doc
919 /etc/shrc.d/python*-devel*
920
921 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
922
923 %{py_scriptdir}/pdb.py[co]
924 %{py_scriptdir}/profile.py[co]
925 %{py_scriptdir}/pstats.py[co]
926 %{py_scriptdir}/timeit.py[co]
927
928 %files 2to3
929 %attr(755,root,root) %{_bindir}/2to3
930 %dir %{py_scriptdir}/lib2to3
931 %{py_scriptdir}/lib2to3/*.txt
932 %{py_scriptdir}/lib2to3/*.pickle
933 %{py_scriptdir}/lib2to3/*.py[co]
934 %dir %{py_scriptdir}/lib2to3/fixes
935 %{py_scriptdir}/lib2to3/fixes/*.py[co]
936 %dir %{py_scriptdir}/lib2to3/pgen2
937 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
938
939 %files static
940 %defattr(644,root,root,755)
941 %{_libdir}/lib*.a
942
943 %files examples
944 %defattr(644,root,root,755)
945 %{_examplesdir}/%{name}-%{version}
946
947 %if %{with info}
948 %files doc-info
949 %defattr(644,root,root,755)
950 %{_infodir}/*.info*
951 %endif
952
953 %if %{with tkinter}
954 %files tkinter
955 %defattr(644,root,root,755)
956 %dir %{py_scriptdir}/tkinter
957 %{py_scriptdir}/tkinter/*.py[co]
958 %attr(755,root,root) %{py_dyndir}/_tkinter.so
959 %endif
This page took 0.098675 seconds and 4 git commands to generate.