]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
3c05bcbd484b128b4c0288295f88d8a6610bc8f5
[packages/python3.git] / python3.spec
1 #
2 # TODO:
3 # - fix tests
4 # - check unpackaged files
5
6 # Conditional build:
7 %bcond_with     info                    # info pages (requires emacs)
8 %bcond_without  tkinter                 # disables tkinter module building
9 %bcond_without  tests                   # disables Python testing
10 %bcond_with     verbose_tests           # runs tests in verbose mode
11 #
12 # tests which will not work on 64-bit platforms
13 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
14 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
15 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
16 # tests which fail because of some unknown/unresolved reason (this list should be empty)
17 %define         broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib
18
19 %define beta            %{nil}
20
21 %define py_ver          3.1
22 %define py_prefix       %{_prefix}
23 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
24 %define py_incdir       %{_includedir}/python%{py_ver}
25 %define py_sitedir      %{py_libdir}/site-packages
26 %define py_dyndir       %{py_libdir}/lib-dynload
27
28 Summary:        Very high level scripting language with X interface
29 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
30 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
31 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
32 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
33 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
34 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
35 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
36 Name:           python3
37 Version:        %{py_ver}.1
38 Release:        1
39 Epoch:          1
40 License:        PSF
41 Group:          Applications
42 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
43 # Source0-md5:  d1ddd9f16e3c6a51c7208f33518cd674
44 Patch0:         %{name}-pythonpath.patch
45 Patch1:         %{name}-ac_fixes.patch
46 Patch2:         %{name}-lib64.patch
47 Patch3:         %{name}-noarch_to_datadir.patch
48 Patch4:         %{name}-cast-fix.patch
49 URL:            http://www.python.org/
50 BuildRequires:  autoconf
51 BuildRequires:  bluez-libs-devel
52 BuildRequires:  bzip2-devel
53 BuildRequires:  db-devel >= 4
54 %{?with_info:BuildRequires:     emacs >= 21}
55 BuildRequires:  expat-devel >= 1:1.95.7
56 BuildRequires:  file
57 BuildRequires:  gdbm-devel >= 1.8.3
58 BuildRequires:  gmp-devel >= 4.0
59 BuildRequires:  libffi-devel
60 BuildRequires:  libstdc++-devel
61 BuildRequires:  ncurses-ext-devel >= 5.2
62 BuildRequires:  openssl-devel >= 0.9.8
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-pythonprov
65 BuildRequires:  sed >= 4.0
66 BuildRequires:  sqlite3-devel >= 3.3.5
67 %{?with_info:BuildRequires:     tetex-makeindex}
68 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
69 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
70 BuildRequires:  zlib-devel
71 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         specflags_ppc   -D__ppc__=1
75 %define         specflags_ppc64 -D__ppc64__=1
76
77 %if %{with verbose_tests}
78 %define test_flags -v -l -x
79 %else
80 %define test_flags -w -l -x
81 %endif
82
83 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
84 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
85 %else
86 %define test_list %{nobuilder_tests} %{broken_tests}
87 %endif
88
89 %ifarch sparc
90 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
91 %endif
92
93 %description
94 Python is an interpreted, interactive, object-oriented programming
95 language. It incorporates modules, exceptions, dynamic typing, very
96 high level dynamic data types, and classes. Python combines remarkable
97 power with very clear syntax. It has interfaces to many system calls
98 and libraries, as well as to various window systems, and is extensible
99 in C or C++. It is also usable as an extension language for
100 applications that need a programmable interface. Finally, Python is
101 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
102 MS-DOS, Windows, Windows NT, and OS/2.
103
104 This package contains the Python binary.
105
106 %description -l de.UTF-8
107 Python ist eine interpretierte, interaktive, objektorientierte
108 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
109 Python enthält Module, Klassen, Exceptions, High-Level dynamische
110 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
111 zu vielen Systemaufrufen und Libraries, sowie verschiedene
112 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
113
114 Programmierer können neue built-in-Module für Python in C oder C++
115 schreiben. Python kann auch als Erweiterungssprache für Applikationen
116 benutzt werden, die ein programmierbares Interface brauchen. Dieses
117 Paket enthält die meisten Standard-Python-Module, und Module zum
118 Ansprechen von Tix (Tk-widget set) und RPM.
119
120 %description -l es.UTF-8
121 Python es un lenguaje de scripts interpretado orientado a objetos.
122 Contiene soporte para carga dinámica de objetos, clases, módulos y
123 excepciones.
124
125 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
126 través de código C, tornando Python fácil de usar en ambientes
127 particulares/personalizados. Este paquete Python incluye la mayoría de
128 los módulos padrón Python, junto con módulos para crear interfaces
129 para el conjunto de componentes Tix para Tk y RPM.
130
131 %description -l fr.UTF-8
132 Python est un langage de script interprété et orienté objet. Il gère
133 le chargement dynamique des objets, les classes, les modules et les
134 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
135 avec du code C est simple, ce qui rend Python facile à utiliser dans
136 des configs personnalisées.
137
138 Ce paquetage Python contient la plupart des modules Python standards,
139 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
140 et RPM.
141
142 %description -l pl.UTF-8
143 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
144 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
145 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
146 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
147 wielu wywołań systemowych i bibliotek, w tym również do różnych
148 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
149 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
150 użyty jako element aplikacji, którym potrzebny jest interpreter do
151 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
152 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
153 OS/2.
154
155 Ten pakiet zawiera binarkę Pythona.
156
157 %description -l pt_BR.UTF-8
158 Python é uma linguagem de scripts interpretada orientada a objetos.
159 Contém suporte para carga dinâmica de objetos, classes, módulos e
160 exceções. Adicionar interfaces para novos sistemas de biblioteca
161 através de código C é simples, tornando Python fácil de usar em
162 ambientes particulares/personalizados.
163
164 Este pacote Python inclui a maioria do módulos padrão Python, junto
165 com módulos para interfaceamento para o conjunto de componentes Tix
166 para Tk e RPM.
167
168 %description -l ru.UTF-8
169 Python - это интерпретируемый, объектно-ориентированный язык
170 программирования. Он поддерживает динамическую загрузку объектов,
171 классы, модули и обработку исключительных ситуаций (exceptions).
172 Простота добавления интерфейсов к новым системным библиотекам через
173 код на языке C делает Python хорошим выбором для использования в
174 специальных конфигурациях.
175
176 %description -l tr.UTF-8
177 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
178 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
179 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
180 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
181 arayüz birimlerini de içerir.
182
183 %description -l uk.UTF-8
184 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
185 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
186 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
187 нових системних бібліотек через код на мові C робить Python добрим
188 вибором для використання в спеціальних конфігураціях.
189
190 %package libs
191 Summary:        Python library
192 Summary(pl.UTF-8):      Biblioteka języka Python
193 Group:          Libraries/Python
194 # broken detection in rpm/pythondeps.sh
195 Provides:       python(abi) = %{py_ver}
196 # for compatibility with existing Ac packages
197 Provides:       python(bytecode) = %{py_ver}
198 %{!?with_info:Obsoletes:        python3-doc-info}
199
200 %description libs
201 Python shared library and very essental modules for Python binary.
202
203 %description libs -l pl.UTF-8
204 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
205 dla Pythona.
206
207 %package modules
208 Summary:        Python modules
209 Summary(pl.UTF-8):      Moduły języka Python
210 Group:          Libraries/Python
211 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
212 Obsoletes:      python3-modules-sqlite
213
214 %description modules
215 Python officially distributed modules.
216
217 %description modules -l pl.UTF-8
218 Oficjalnie rozprowadzane moduły języka Python.
219
220 %package -n pydoc3
221 Summary:        Python interactive module documentation access support
222 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
223 Group:          Applications
224 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
225
226 %description -n pydoc3
227 Python interactive module documentation access support.
228
229 %description -n pydoc3 -l pl.UTF-8
230 Interaktywne korzystanie z dokumentacji modułów języka Python.
231
232 %package -n idle3
233 Summary:        IDE for Python language
234 Summary(pl.UTF-8):      IDE dla języka Python
235 Group:          Applications
236 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
237
238 %description -n idle3
239 IDE for Python language.
240
241 %description -n idle3 -l pl.UTF-8
242 IDE dla języka Python.
243
244 %package devel
245 Summary:        Libraries and header files for building python code
246 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
247 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
248 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
249 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
250 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
251 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
252 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
253 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
254 Group:          Development/Languages/Python
255 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
256
257 %description devel
258 The Python interpreter is relatively easy to extend with dynamically
259 loaded extensions and to embed in other programs. This package
260 contains the header files and libraries which are needed to do both of
261 these tasks.
262
263 %description devel -l de.UTF-8
264 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
265 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
266 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
267 die für beide Aufgaben erforderlich sind.
268
269 %description devel -l es.UTF-8
270 El interpretador Python permite incluir con facilidad extensiones
271 cargadas dinámicamente. Python es también fácil de ser empotrado en
272 otros programas. Este paquete contiene los archivos de inclusión y
273 bibliotecas necesarios para estas dos tareas.
274
275 %description devel -l fr.UTF-8
276 L'interpréteur Python est relativement facile à étendre avec des
277 extensions chargées dynamiquement et à insérer dans d'autres
278 programmes. Ce paquetage contient les en-têtes et les bibliothèques
279 nécessaires à ces deux tâches.
280
281 %description devel -l pl.UTF-8
282 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
283 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
284 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
285 wszystko inne co potrzebne do tych celów.
286
287 %description devel -l pt_BR.UTF-8
288 O interpretador Python permite incluir com facilidade extensões
289 carregadas dinamicamente. Python é também fácil de ser embutido em
290 outros programas. Este pacote contém os arquivos de inclusão e
291 bibliotecas necessários para estas duas tarefas.
292
293 %description devel -l ru.UTF-8
294 Интерпретатор Python относительно легко расширяется при помощи
295 динамически загружаемых расширений и встраивается в другие программы.
296 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
297 задач.
298
299 %description devel -l tr.UTF-8
300 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
301 dosyalarını ve kitaplıkları içerir.
302
303 %description devel -l uk.UTF-8
304 Інтерпретатор Python відносно легко розширюється за допомогою
305 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
306 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
307
308 %package devel-src
309 Summary:        Python module sources
310 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
311 Group:          Development/Languages/Python
312 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
313
314 %description devel-src
315 Python module sources.
316
317 %description devel-src -l pl.UTF-8
318 Pliki źródłowe modułów Pythona.
319
320 %package devel-tools
321 Summary:        Python development tools
322 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
323 Group:          Development/Languages/Python
324 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
325
326 %description devel-tools
327 Python development tools such as profilers and debugger.
328
329 %description devel-tools -l pl.UTF-8
330 Narzędzia programistyczne języka Python takie jak profiler oraz
331 debugger.
332
333 %package 2to3
334 Summary:        Automated Python 2 to 3 code translation
335 Summary(pl.UTF-8):      Automatyczne tłumaczenie kody Pythona 2 do 3
336 Group:          Development/Languages/Pythona
337
338 %description 2to3
339 2to3 is a Python program that reads Python 2.x source code and applies a series
340 of fixers to transform it into valid Python 3.x code. The standard library
341 contains a rich set of fixers that will handle almost all code. 2to3 supporting
342 library lib2to3 is, however, a flexible and generic library, so it is possible
343 to write your own fixers for 2to3. lib2to3 could also be adapted to custom
344 applications in which Python code needs to be edited automatically.
345
346 %package static
347 Summary:        Static python library
348 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
349 Group:          Development/Languages/Python
350 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
351
352 %description static
353 Static python library.
354
355 %description static -l pl.UTF-8
356 Statyczna biblioteka Pythona.
357
358 %package doc
359 Summary:        Documentation on Python
360 Summary(de.UTF-8):      Dokumentation zu Python
361 Summary(es.UTF-8):      Documentación para Python
362 Summary(fr.UTF-8):      Documentation sur Python
363 Summary(pl.UTF-8):      Dokumentacja do Pythona
364 Summary(pt_BR.UTF-8):   Documentação para a linguagem de programação Python
365 Summary(ru.UTF-8):      Документация по языку Python
366 Summary(tr.UTF-8):      Python belgeleri
367 Summary(uk.UTF-8):      Документація по мові Python
368 Group:          Documentation
369
370 %description doc
371 This package contains documentation on the Python language and
372 interpretor as a mix of plain ASCII files and LaTeX sources.
373
374 %description doc -l de.UTF-8
375 Dieses Paket enthält Dokumentationen zu Python (Sprache und
376 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
377
378 %description doc -l es.UTF-8
379 Documentación para Python. Contiene archivos en texto y PostScript.
380
381 %description doc -l fr.UTF-8
382 Ce paquetage contient la documentation sur le langage python et sur
383 son interpréteur sous forme de fichiers ASCII et LaTeX.
384
385 %description doc -l pl.UTF-8
386 Oficjalna dokumentacja do Pythona. Zawiera przykładowe programy,
387 narzędzia i dokumentację. Strony podręcznika man znajdują się w
388 głównym pakiecie. Ten pakiet nie zawiera źródeł dokumentacji
389 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
390 i HTML.
391
392 %description doc -l pt_BR.UTF-8
393 O pacote python-doc contém documentação para a linguagem de
394 programação e para o interpretador Python. Fornecida em arquivos texto
395 e Postcript.
396
397 %description doc -l ru.UTF-8
398 Этот пакет содержит документацию по собственно языку Python и по
399 исполняющему его интерпретатору в виде набора текстовых файлов и
400 исходных текстов в формате LaTeX.
401
402 %description doc -l tr.UTF-8
403 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyaları ve
404 LaTeX kaynaklarının bir karışımı olan yorumlayıcıyı içerir.
405
406 %description doc -l uk.UTF-8
407 Цей пакет містить документацію по власне мові Python та по виконуючому
408 її інтерпретатору у вигляді набора текстових файлів та вихідних
409 текстів у форматі LaTeX.
410
411 %package doc-info
412 Summary:        Documentation on Python in texinfo format
413 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
414 Group:          Documentation
415
416 %description doc-info
417 Documentation on Python in texinfo format.
418
419 %description doc-info -l pl.UTF-8
420 Dokumentacja do Pythona w formacie texinfo.
421
422 %package tkinter
423 Summary:        Standard Python interface to the Tk GUI toolkit
424 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
425 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
426 Summary(fr.UTF-8):      Interface graphique Tk pour Python
427 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
428 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
429 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
430 Group:          Libraries/Python
431 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
432 Requires:       tcl >= 8.4.3
433 Requires:       tix >= 1:8.1.4-4
434 Requires:       tk >= 8.4.3
435
436 %description tkinter
437 Standard Python interface to the Tk GUI toolkit.
438
439 %description tkinter -l de.UTF-8
440 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
441 vielen Konfigurations-Tools genutzt.
442
443 %description tkinter -l es.UTF-8
444 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
445 herramientas de configuración.
446
447 %description tkinter -l fr.UTF-8
448 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
449 beaucoup des outils de configuration.
450
451 %description tkinter -l pl.UTF-8
452 Standardowy interfejs Pythona do biblioteki Tk.
453
454 %description tkinter -l pt_BR.UTF-8
455 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
456 muitas ferramentas de configuração.
457
458 %description tkinter -l ru.UTF-8
459 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
460
461 %description tkinter -l tr.UTF-8
462 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
463 kullanılan grafik bir arayüzdür.
464
465 %description tkinter -l uk.UTF-8
466 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
467
468 %package examples
469 Summary:        Example programs in Python
470 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
471 Group:          Development/Languages/Python
472
473 %description examples
474 Example programs in Python.
475
476 These are for Python 2.3.4, not %{version}.
477
478 %description examples -l pl.UTF-8
479 Przykładowe programy w Pythonie.
480
481 Przykłady te są dla Pythona 2.3.4, nie %{version}.
482
483 %prep
484 %setup -q -n Python-%{version}%{beta}
485 %patch0 -p1
486 %patch1 -p1
487 %patch2 -p1
488 %patch3 -p1
489 %patch4 -p1
490 sed -i -e 's=@EXENAME@=%{_bindir}/python3=' Misc/python-config.in
491
492 %build
493 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
494 %{__autoconf}
495 CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
496 %configure \
497         --with-cxx-main="%{__cxx}" \
498         --enable-shared \
499         --enable-ipv6 \
500         --with-dbmliborder=gdbm:bdb \
501         --with-wide-unicode \
502         --with-signal-module \
503         --with-tsc \
504         --with-threads \
505         --with-doc-strings \
506         --with-fpectl \
507         --with-system-ffi \
508         --with-computed-gotos \
509         LINKCC='$(PURIFY) $(CXX)' \
510         LDSHARED='$(CC) $(CFLAGS) -shared' \
511         BLDSHARED='$(CC) $(CFLAGS) -shared' \
512         LDFLAGS="%{rpmcflags} %{rpmldflags}"
513
514 %{__make} \
515         OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
516 BEGIN { fail = 0; logmsg = ""; }
517 {
518         if ($0 ~ /\*\*\* WARNING:/) {
519                 fail = 1;
520                 logmsg = logmsg $0;
521         }
522         print $0;
523 }
524 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
525
526 LC_ALL=C
527 export LC_ALL
528 %if %{with tests}
529 binlibdir=`echo build/lib.*`
530 %{__make} test \
531         TESTOPTS="%{test_flags} %{test_list}" \
532         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
533 %endif
534
535 %install
536 rm -rf $RPM_BUILD_ROOT
537 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
538         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
539         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
540         $RPM_BUILD_ROOT%{_infodir} \
541         $RPM_BUILD_ROOT/etc/shrc.d
542
543 %{__make} install \
544         DESTDIR=$RPM_BUILD_ROOT
545
546 %if %{with info}
547 %{__make} -C Doc/info
548 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
549 %endif
550
551 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
552
553 mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
554 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
555 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
556
557 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
558 cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
559
560 #
561 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
562 #
563
564 # for python devel tools
565 for script in timeit profile pdb pstats; do
566     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
567 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
568
569 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
570         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
571
572 sed 's/=/ /' \
573         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
574         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
575
576 # for python modules
577 for script in smtpd webbrowser; do
578     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
579 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
580
581 sed 's/=/ /' \
582         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
583         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
584
585 # xgettext specific for Python code
586 #
587 # we will have two commands: pygettext.py (an alias) and pygettext;
588 # this way there are no import (which is impossible now) conflicts and
589 # pygettext.py is provided for compatibility
590 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
591
592 # just to cut the noise, as they are not packaged (now)
593 # first tests
594 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
595 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
596 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
597 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
598 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
599 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
600 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/json/tests
601 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
602 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
603
604 # other files
605 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
606 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
607 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
608 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
609 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
610 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
611 rm -rf $RPM_BUILD_ROOT%{_bindir}/smtpd.py
612 # already in %%doc
613 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/pdb.doc
614 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
615
616 %clean
617 rm -rf $RPM_BUILD_ROOT
618
619 %post   libs -p /sbin/ldconfig
620 %postun libs -p /sbin/ldconfig
621
622 %post doc-info  -p      /sbin/postshell
623 -/usr/sbin/fix-info-dir -c %{_infodir}
624
625 %postun doc-info        -p      /sbin/postshell
626 -/usr/sbin/fix-info-dir -c %{_infodir}
627
628 %files
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_bindir}/python%{py_ver}
631 %attr(755,root,root) %{_bindir}/python3
632 %{_mandir}/man1/python*.1*
633
634 %files modules
635 %defattr(644,root,root,755)
636 /etc/shrc.d/python*-modules*
637 %exclude %{py_scriptdir}/_abcoll.py[co]
638 %exclude %{py_scriptdir}/_weakrefset.py[co]
639 %exclude %{py_scriptdir}/abc.py[co]
640 %exclude %{py_scriptdir}/codecs.py[co]
641 %exclude %{py_scriptdir}/copyreg.py[co]
642 %exclude %{py_scriptdir}/genericpath.py[co]
643 %exclude %{py_scriptdir}/io.py[co]
644 %exclude %{py_scriptdir}/locale.py[co]
645 %exclude %{py_scriptdir}/posixpath.py[co]
646 %exclude %{py_scriptdir}/pdb.py[co]
647 %exclude %{py_scriptdir}/profile.py[co]
648 %exclude %{py_scriptdir}/pstats.py[co]
649 %exclude %{py_scriptdir}/pydoc.py[co]
650 %exclude %{py_scriptdir}/site.py[co]
651 %exclude %{py_scriptdir}/stat.py[co]
652 %exclude %{py_scriptdir}/timeit.py[co]
653 %exclude %{py_scriptdir}/os.py[co]
654 %exclude %{py_scriptdir}/encodings/*.py[co]
655 %exclude %{py_scriptdir}/types.py[co]
656
657 %{py_scriptdir}/*.py[co]
658
659 %{py_dyndir}/*.egg-info
660
661 #
662 # list .so modules to be sure that all of them are built
663 #
664
665 # modules below do not work on 64-bit architectures
666 # see Python README file for explanation
667 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
668 %attr(755,root,root) %{py_dyndir}/audioop.so
669 %endif
670
671 %attr(755,root,root) %{py_dyndir}/array.so
672 %attr(755,root,root) %{py_dyndir}/atexit.so
673 %attr(755,root,root) %{py_dyndir}/audioop.so
674 %attr(755,root,root) %{py_dyndir}/binascii.so
675 %attr(755,root,root) %{py_dyndir}/_bisect.so
676 %attr(755,root,root) %{py_dyndir}/bz2.so
677 %attr(755,root,root) %{py_dyndir}/cmath.so
678 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
679 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
680 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
681 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
682 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
683 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
684 %attr(755,root,root) %{py_dyndir}/_collections.so
685 %attr(755,root,root) %{py_dyndir}/crypt.so
686 %attr(755,root,root) %{py_dyndir}/_csv.so
687 %attr(755,root,root) %{py_dyndir}/_ctypes*.so
688 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
689 %attr(755,root,root) %{py_dyndir}/_curses.so
690 %attr(755,root,root) %{py_dyndir}/datetime.so
691 %attr(755,root,root) %{py_dyndir}/_elementtree.so
692 #%attr(755,root,root) %{py_dyndir}/_functools.so
693 %attr(755,root,root) %{py_dyndir}/_hashlib.so
694 %attr(755,root,root) %{py_dyndir}/_heapq.so
695 %attr(755,root,root) %{py_dyndir}/_json.so
696 #%attr(755,root,root) %{py_dyndir}/_locale.so
697 %attr(755,root,root) %{py_dyndir}/_lsprof.so
698 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
699 %attr(755,root,root) %{py_dyndir}/_multiprocessing.so
700 %attr(755,root,root) %{py_dyndir}/_pickle.so
701 %attr(755,root,root) %{py_dyndir}/_random.so
702 %attr(755,root,root) %{py_dyndir}/_socket.so
703 %attr(755,root,root) %{py_dyndir}/_ssl.so
704 %attr(755,root,root) %{py_dyndir}/_testcapi.so
705 %ifnarch sparc64
706 %attr(755,root,root) %{py_dyndir}/_dbm.so
707 %endif
708 %attr(755,root,root) %{py_dyndir}/fcntl.so
709 %attr(755,root,root) %{py_dyndir}/_gdbm.so
710 %attr(755,root,root) %{py_dyndir}/grp.so
711 %attr(755,root,root) %{py_dyndir}/itertools.so
712 %attr(755,root,root) %{py_dyndir}/math.so
713 %attr(755,root,root) %{py_dyndir}/mmap.so
714 %attr(755,root,root) %{py_dyndir}/nis.so
715 %attr(755,root,root) %{py_dyndir}/operator.so
716 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
717 %attr(755,root,root) %{py_dyndir}/parser.so
718 %attr(755,root,root) %{py_dyndir}/pyexpat.so
719 %attr(755,root,root) %{py_dyndir}/readline.so
720 %attr(755,root,root) %{py_dyndir}/resource.so
721 %attr(755,root,root) %{py_dyndir}/select.so
722 %attr(755,root,root) %{py_dyndir}/syslog.so
723 %attr(755,root,root) %{py_dyndir}/termios.so
724 %attr(755,root,root) %{py_dyndir}/time.so
725 %attr(755,root,root) %{py_dyndir}/spwd.so
726 %attr(755,root,root) %{py_dyndir}/unicodedata.so
727 %attr(755,root,root) %{py_dyndir}/zlib.so
728
729 %dir %{py_scriptdir}/plat-*
730 %{py_scriptdir}/plat-*/*.py[co]
731
732 %dir %{py_scriptdir}/ctypes
733 %dir %{py_scriptdir}/ctypes/macholib
734
735 %{py_scriptdir}/ctypes/*.py[co]
736 %{py_scriptdir}/ctypes/macholib/*.py[co]
737 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
738
739 %dir %{py_scriptdir}/curses
740 %{py_scriptdir}/curses/*.py[co]
741
742 %dir %{py_scriptdir}/dbm
743 %{py_scriptdir}/dbm/*.py[co]
744
745 %dir %{py_scriptdir}/distutils
746 %dir %{py_scriptdir}/distutils/command
747 %doc %{py_scriptdir}/distutils/README
748 %{py_scriptdir}/distutils/*.py[co]
749 %{py_scriptdir}/distutils/command/*.py[co]
750 %{py_scriptdir}/distutils/command/command_template
751
752 %dir %{py_scriptdir}/email
753 %dir %{py_scriptdir}/email/mime
754 %{py_scriptdir}/email/*.py[co]
755 %{py_scriptdir}/email/mime/*.py[co]
756
757 %dir %{py_scriptdir}/html
758 %{py_scriptdir}/html/*.py[co]
759
760 %dir %{py_scriptdir}/http
761 %{py_scriptdir}/http/*.py[co]
762
763 %dir %{py_scriptdir}/importlib
764 %{py_scriptdir}/importlib/*.py[co]
765
766 %dir %{py_scriptdir}/json
767 %{py_scriptdir}/json/*.py[co]
768
769 %dir %{py_scriptdir}/logging
770 %{py_scriptdir}/logging/*.py[co]
771
772 %dir %{py_scriptdir}/multiprocessing
773 %{py_scriptdir}/multiprocessing/*.py[co]
774 %dir %{py_scriptdir}/multiprocessing/dummy
775 %{py_scriptdir}/multiprocessing/dummy/*.py[co]
776
777 %dir %{py_scriptdir}/urllib
778 %{py_scriptdir}/urllib/*.py[co]
779
780 %dir %{py_scriptdir}/wsgiref
781 %{py_scriptdir}/wsgiref/*.py[co]
782 %{py_scriptdir}/wsgiref.egg-info
783
784 %dir %{py_scriptdir}/xml
785 %dir %{py_scriptdir}/xml/dom
786 %dir %{py_scriptdir}/xml/etree
787 %dir %{py_scriptdir}/xml/parsers
788 %dir %{py_scriptdir}/xml/sax
789 %{py_scriptdir}/xml/*.py[co]
790 %{py_scriptdir}/xml/dom/*.py[co]
791 %{py_scriptdir}/xml/etree/*.py[co]
792 %{py_scriptdir}/xml/parsers/*.py[co]
793 %{py_scriptdir}/xml/sax/*.py[co]
794
795 %dir %{py_scriptdir}/xmlrpc
796 %{py_scriptdir}/xmlrpc/*.py[co]
797
798 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
799 %dir %{py_scriptdir}/sqlite3
800 %{py_scriptdir}/sqlite3/*.py[co]
801
802 %files libs
803 %defattr(644,root,root,755)
804 %doc LICENSE
805 %attr(755,root,root) %{_libdir}/libpython*.so.*
806
807 %dir %{py_dyndir}
808 %dir %{py_scriptdir}
809 %dir %{py_libdir}
810 %dir %{py_sitescriptdir}
811 %dir %{py_sitedir}
812
813 # shared modules required by python library
814 %attr(755,root,root) %{py_dyndir}/_struct.so
815
816 # modules required by python library
817 %{py_scriptdir}/_abcoll.py[co]
818 %{py_scriptdir}/_weakrefset.py[co]
819 %{py_scriptdir}/abc.py[co]
820 %{py_scriptdir}/codecs.py[co]
821 %{py_scriptdir}/copyreg.py[co]
822 %{py_scriptdir}/genericpath.py[co]
823 %{py_scriptdir}/locale.py[co]
824 %{py_scriptdir}/io.py[co]
825 %{py_scriptdir}/posixpath.py[co]
826 %{py_scriptdir}/site.py[co]
827 %{py_scriptdir}/stat.py[co]
828 %{py_scriptdir}/os.py[co]
829 # needed by the dynamic sys.lib patch
830 %{py_scriptdir}/types.py[co]
831
832 # encodings required by python library
833 %dir %{py_scriptdir}/encodings
834 %{py_scriptdir}/encodings/*.py[co]
835
836 %files -n pydoc3
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_bindir}/pydoc3
839 %{py_scriptdir}/pydoc.py[co]
840 %dir %{py_scriptdir}/pydoc_data
841 %{py_scriptdir}/pydoc_data/*.py[co]
842
843 %files -n idle3
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_bindir}/idle3
846 %dir %{py_scriptdir}/idlelib
847 %dir %{py_scriptdir}/idlelib/Icons
848 %{py_scriptdir}/idlelib/*.py[co]
849 %doc %{py_scriptdir}/idlelib/*.txt
850 %doc %{py_scriptdir}/idlelib/ChangeLog
851 %{py_scriptdir}/idlelib/Icons/*
852 %{py_scriptdir}/idlelib/*.def
853
854 %files devel
855 %defattr(644,root,root,755)
856 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
857 %attr(755,root,root) %{_bindir}/python*-config
858 %attr(755,root,root) %{_libdir}/lib*.so
859 %dir %{py_incdir}
860 %{py_incdir}/*.h
861 %{_pkgconfigdir}/python*.pc
862
863 %dir %{py_libdir}/config
864 %attr(755,root,root) %{py_libdir}/config/makesetup
865 %attr(755,root,root) %{py_libdir}/config/install-sh
866 %{py_libdir}/config/Makefile
867 %{py_libdir}/config/Makefile.pre.in
868 %{py_libdir}/config/Setup
869 %{py_libdir}/config/Setup.config
870 %{py_libdir}/config/Setup.local
871 %{py_libdir}/config/config.c
872 %{py_libdir}/config/config.c.in
873 %{py_libdir}/config/python.o
874
875 %files devel-src
876 %defattr(644,root,root,755)
877 %attr(-,root,root) %{py_scriptdir}/*.py
878 %{py_scriptdir}/plat-*/*.py
879 %{py_scriptdir}/ctypes/*.py
880 %{py_scriptdir}/ctypes/macholib/*.py
881 %{py_scriptdir}/curses/*.py
882 %{py_scriptdir}/dbm/*.py
883 %{py_scriptdir}/distutils/*.py
884 %{py_scriptdir}/distutils/command/*.py
885 %{py_scriptdir}/email/*.py
886 %{py_scriptdir}/email/mime/*.py
887 %{py_scriptdir}/encodings/*.py
888 %{py_scriptdir}/html/*.py
889 %{py_scriptdir}/http/*.py
890 %{py_scriptdir}/idlelib/*.py
891 %{py_scriptdir}/importlib/*.py
892 %{py_scriptdir}/json/*.py
893 %{py_scriptdir}/lib2to3/*.py
894 %{py_scriptdir}/lib2to3/fixes/*.py
895 %{py_scriptdir}/lib2to3/pgen2/*.py
896 %{py_scriptdir}/logging/*.py
897 %{py_scriptdir}/multiprocessing/*.py
898 %{py_scriptdir}/multiprocessing/dummy/*.py
899 %{py_scriptdir}/pydoc_data/*.py
900 %{py_scriptdir}/sqlite3/*.py
901 %{py_scriptdir}/tkinter/*.py
902 %{py_scriptdir}/urllib/*.py
903 %{py_scriptdir}/wsgiref/*.py
904 %{py_scriptdir}/xml/*.py
905 %{py_scriptdir}/xml/dom/*.py
906 %{py_scriptdir}/xml/etree/*.py
907 %{py_scriptdir}/xml/parsers/*.py
908 %{py_scriptdir}/xml/sax/*.py
909 %{py_scriptdir}/xmlrpc/*.py
910
911 %files devel-tools
912 %defattr(644,root,root,755)
913 %doc Lib/pdb.doc
914 /etc/shrc.d/python*-devel*
915
916 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
917
918 %{py_scriptdir}/pdb.py[co]
919 %{py_scriptdir}/profile.py[co]
920 %{py_scriptdir}/pstats.py[co]
921 %{py_scriptdir}/timeit.py[co]
922
923 %files 2to3
924 %attr(755,root,root) %{_bindir}/2to3
925 %dir %{py_scriptdir}/lib2to3
926 %{py_scriptdir}/lib2to3/*.txt
927 %{py_scriptdir}/lib2to3/*.pickle
928 %{py_scriptdir}/lib2to3/*.py[co]
929 %dir %{py_scriptdir}/lib2to3/fixes
930 %{py_scriptdir}/lib2to3/fixes/*.py[co]
931 %dir %{py_scriptdir}/lib2to3/pgen2
932 %{py_scriptdir}/lib2to3/pgen2/*.py[co]
933
934 %files static
935 %defattr(644,root,root,755)
936 %{_libdir}/lib*.a
937
938 %files examples
939 %defattr(644,root,root,755)
940 %{_examplesdir}/%{name}-%{version}
941
942 %if %{with info}
943 %files doc-info
944 %defattr(644,root,root,755)
945 %{_infodir}/*.info*
946 %endif
947
948 %if %{with tkinter}
949 %files tkinter
950 %defattr(644,root,root,755)
951 %dir %{py_scriptdir}/tkinter
952 %{py_scriptdir}/tkinter/*.py[co]
953 %attr(755,root,root) %{py_dyndir}/_tkinter.so
954 %endif
This page took 4.143431 seconds and 3 git commands to generate.